]> git.pld-linux.org Git - packages/spice-space.git/commitdiff
- updated to 0.12.6 auto/th/spice-space-0.12.6-1
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 9 Oct 2015 19:19:31 +0000 (21:19 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Fri, 9 Oct 2015 19:19:31 +0000 (21:19 +0200)
- updated am patch
- removed obsolete sh patch
- added codegen patch (don't require sources of spice protocol codegen modules)
- client from this package is discontinued, use spice-gtk based clients like virt-viewer instead

spice-am.patch
spice-codegen.patch [new file with mode: 0644]
spice-link.patch
spice-sh.patch [deleted file]
spice-space.spec

index 3fd2355fed3ee67dda8fe0ecadc406738c7c8a13..4ea4802286f0df8dcce9b12743e2975a795ac8cd 100644 (file)
@@ -1,11 +1,11 @@
---- spice-0.12.2/configure.ac.orig     2013-01-04 15:09:25.311544149 +0100
-+++ spice-0.12.2/configure.ac  2013-01-04 15:16:44.294868335 +0100
-@@ -26,7 +26,7 @@
-         [spice-devel@lists.freedesktop.org], spice)
+--- spice-0.12.6/configure.ac.orig     2015-10-06 17:09:16.000000000 +0200
++++ spice-0.12.6/configure.ac  2015-10-09 19:15:30.664763514 +0200
+@@ -30,7 +30,7 @@
  
  AC_CONFIG_MACRO_DIR([m4])
+ m4_include([spice-common/m4/spice-deps.m4])
 -AM_CONFIG_HEADER([config.h])
 +AC_CONFIG_HEADERS([config.h])
  AC_CONFIG_AUX_DIR(.)
  
- # For automake >= 1.12
+ AM_INIT_AUTOMAKE([dist-bzip2 no-dist-gzip subdir-objects])
diff --git a/spice-codegen.patch b/spice-codegen.patch
new file mode 100644 (file)
index 0000000..37d8513
--- /dev/null
@@ -0,0 +1,15 @@
+--- spice-0.12.6/spice-common/common/Makefile.am.orig  2015-08-14 10:54:53.000000000 +0200
++++ spice-0.12.6/spice-common/common/Makefile.am       2015-10-09 19:27:13.894734003 +0200
+@@ -100,12 +100,6 @@
+       $(NULL)
+ MARSHALLERS_DEPS =                                                    \
+-      $(CODE_GENERATOR_BASEDIR)/python_modules/__init__.py            \
+-      $(CODE_GENERATOR_BASEDIR)/python_modules/codegen.py             \
+-      $(CODE_GENERATOR_BASEDIR)/python_modules/demarshal.py           \
+-      $(CODE_GENERATOR_BASEDIR)/python_modules/marshal.py             \
+-      $(CODE_GENERATOR_BASEDIR)/python_modules/ptypes.py              \
+-      $(CODE_GENERATOR_BASEDIR)/python_modules/spice_parser.py        \
+       $(CODE_GENERATOR_BASEDIR)/spice_codegen.py                      \
+       $(NULL)
index 398796679c932061290b2996ae8fa601f6710247..4976965b48978eb8d58177ad8f00b3be2b24d22a 100644 (file)
@@ -1,10 +1,10 @@
---- spice-0.10.0/configure.ac.orig     2011-11-13 08:37:42.000000000 +0100
-+++ spice-0.10.0/configure.ac  2011-11-13 08:38:30.260509328 +0100
-@@ -246,6 +246,7 @@
- if test "x$enable_opengl" = "xyes"; then
-    AC_CHECK_LIB(GL, glBlendFunc, GL_LIBS="$GL_LIBS -lGL", enable_opengl=no)
-    AC_CHECK_LIB(GLU, gluSphere, GL_LIBS="$GL_LIBS -lGLU", enable_opengl=no)
-+   AC_CHECK_LIB(X11, XOpenDisplay, GL_LIBS="$GL_LIBS -lX11", have_opengl=no)
-    AC_DEFINE([USE_OPENGL], [1], [Define to build with OpenGL support])
-    AC_DEFINE([GL_GLEXT_PROTOTYPES], [], [Enable GLExt prototypes])
+--- spice-0.12.6/spice-common/m4/spice-deps.m4.orig    2015-08-14 10:54:53.000000000 +0200
++++ spice-0.12.6/spice-common/m4/spice-deps.m4 2015-10-09 19:14:14.964766691 +0200
+@@ -125,6 +125,7 @@
    if test "x$enable_opengl" = "xyes"; then
+         AC_CHECK_LIB(GL, glBlendFunc, GL_LIBS="$GL_LIBS -lGL", enable_opengl=no)
+         AC_CHECK_LIB(GLU, gluSphere, GL_LIBS="$GL_LIBS -lGLU", enable_opengl=no)
++        AC_CHECK_LIB(X11, XOpenDisplay, GL_LIBS="$GL_LIBS -lX11", have_opengl=no)
+         AC_DEFINE([USE_OPENGL], [1], [Define to build with OpenGL support])
+         AC_DEFINE([GL_GLEXT_PROTOTYPES], [], [Enable GLExt prototypes])
  
diff --git a/spice-sh.patch b/spice-sh.patch
deleted file mode 100644 (file)
index 2b7c204..0000000
+++ /dev/null
@@ -1,78 +0,0 @@
---- spice-0.12.5/configure.ac.orig     2014-05-19 14:20:53.000000000 +0200
-+++ spice-0.12.5/configure.ac  2014-05-23 19:18:10.227726292 +0200
-@@ -163,9 +163,9 @@
- AC_SUBST(LIBRT)
- if test "$red_target" = "windows"; then
--      SPICE_NONPKGCONFIG_LIBS+=" -lpthreadGC2 -lversion -lmsimg32 $LIBM"
-+      SPICE_NONPKGCONFIG_LIBS="$SPICE_NONPKGCONFIG_LIBS -lpthreadGC2 -lversion -lmsimg32 $LIBM"
- else
--      SPICE_NONPKGCONFIG_LIBS+=" -pthread $LIBM $LIBRT"
-+      SPICE_NONPKGCONFIG_LIBS="$SPICE_NONPKGCONFIG_LIBS -pthread $LIBM $LIBRT"
- fi
- dnl The client needs a yield function
-@@ -211,24 +211,24 @@
-     SMARTCARD_CFLAGS="$CAC_CARD_CFLAGS"
-     AC_SUBST(SMARTCARD_LIBS)
-     AC_SUBST(SMARTCARD_CFLAGS)
--    SPICE_REQUIRES+=" libcacard >= 0.1.2"
-+    SPICE_REQUIRES="$SPICE_REQUIRES libcacard >= 0.1.2"
- fi
- PKG_CHECK_MODULES([GLIB2], [glib-2.0 >= 2.22])
--SPICE_REQUIRES+=" glib-2.0 >= 2.22"
-+SPICE_REQUIRES="$SPICE_REQUIRES glib-2.0 >= 2.22"
- PKG_CHECK_MODULES(PIXMAN, pixman-1 >= 0.17.7)
- AC_SUBST(PIXMAN_CFLAGS)
- AC_SUBST(PIXMAN_LIBS)
--SPICE_REQUIRES+=" pixman-1 >= 0.17.7"
-+SPICE_REQUIRES="$SPICE_REQUIRES pixman-1 >= 0.17.7"
- AC_ARG_ENABLE(celt051,
-     [  --disable-celt051       Disable celt051 audio codec (enabled by default)],,
-         [enable_celt051="yes"])
- if test "x$enable_celt051" = "xyes"; then
--    PKG_CHECK_MODULES(CELT051, celt051 >= 0.5.1.1, SPICE_REQUIRES+=" celt051 >= 0.5.1.1")
-+    PKG_CHECK_MODULES(CELT051, celt051 >= 0.5.1.1, SPICE_REQUIRES="$SPICE_REQUIRES celt051 >= 0.5.1.1")
- fi
- if test ! -e client/generated_marshallers.cpp; then
-@@ -244,14 +244,14 @@
- PKG_CHECK_MODULES(SSL, openssl)
- AC_SUBST(SSL_CFLAGS)
- AC_SUBST(SSL_LIBS)
--SPICE_REQUIRES+=" openssl"
-+SPICE_REQUIRES="$SPICE_REQUIRES openssl"
- # These are commented out because the gl libraries on RHEL 5 do not have pkgconfig files
- #
- # PKG_CHECK_MODULES(GL, gl glu)
- # AC_SUBST(GL_CFLAGS)
- # AC_SUBST(GL_LIBS)
--# SPICE_REQUIRES+=" gl glu"
-+# SPICE_REQUIRES="$SPICE_REQUIRES gl glu"
- if test "x$enable_opengl" = "xyes"; then
-    AC_CHECK_LIB(GL, glBlendFunc, GL_LIBS="$GL_LIBS -lGL", enable_opengl=no)
-@@ -266,7 +266,7 @@
- AC_SUBST(GL_CFLAGS)
- AC_SUBST(GL_LIBS)
--SPICE_NONPKGCONFIG_LIBS+=" $GL_LIBS"
-+SPICE_NONPKGCONFIG_LIBS="$SPICE_NONPKGCONFIG_LIBS $GL_LIBS"
- if test "x$red_target" = "xx11" && test "x$enable_client" = "xyes" ; then
-       if test "$os_linux" = yes; then
-@@ -319,7 +319,7 @@
-   AC_DEFINE([HAVE_XINERAMA], [], [Define if we have Xinerama])
-   AC_SUBST(XINERAMA_CFLAGS)
-   AC_SUBST(XINERAMA_LIBS)
--  SPICE_REQUIRES+=" xinerama"
-+  SPICE_REQUIRES="$SPICE_REQUIRES xinerama"
- fi
- # Add parameter for (partial) static linkage of spice client.
index 5206b22b2cf5e0cab54e839f33569cdd3ab3ff84..736ed7a711e4078a1b2b1ca600331c2a9f82c67c 100644 (file)
@@ -6,36 +6,41 @@ Summary:      SPICE virtualization solution
 Summary(pl.UTF-8):     System wirtualizacji SPICE
 # real package name (spice) is already occupied
 Name:          spice-space
-Version:       0.12.5
-Release:       2
+Version:       0.12.6
+Release:       1
 License:       LGPL v2.1+
 Group:         Applications/Emulators
 Source0:       http://www.spice-space.org/download/releases/spice-%{version}.tar.bz2
-# Source0-md5: 1256286214fe402703c0a01bd3a85319
-Patch0:                spice-sh.patch
-Patch1:                spice-link.patch
-Patch2:                spice-am.patch
+# Source0-md5: 605a8c8ea80bc95076c4b3539c6dd026
+Patch0:                spice-link.patch
+Patch1:                spice-am.patch
+Patch2:                spice-codegen.patch
 URL:           http://www.spice-space.org/
 %{?with_opengl:BuildRequires:  OpenGL-devel}
 %{?with_opengl:BuildRequires:  OpenGL-GLU-devel}
 BuildRequires: alsa-lib-devel
+BuildRequires: asciidoc
 BuildRequires: autoconf >= 2.63
 BuildRequires: automake >= 1:1.11
 BuildRequires: celt051-devel >= 0.5.1.1
 BuildRequires: cyrus-sasl-devel >= 2
+BuildRequires: gcc >= 5:3.2
 BuildRequires: glib2-devel >= 1:2.22
 BuildRequires: libcacard-devel >= 0.1.2
 BuildRequires: libjpeg-devel
 BuildRequires: libstdc++-devel
 BuildRequires: libtool >= 2:2
+BuildRequires: lz4-devel
 BuildRequires: openssl-devel
 BuildRequires: opus-devel >= 0.9.14
 BuildRequires: pixman-devel >= 0.17.7
 BuildRequires: pkgconfig
 BuildRequires: python >= 2
 BuildRequires: python-pyparsing
+BuildRequires: python-six
 BuildRequires: rpmbuild(macros) >= 1.527
-BuildRequires: spice-protocol >= 0.10.1
+BuildRequires: spice-protocol >= 0.12.10
+BuildRequires: spice-protocol-codegen >= 0.12.10
 BuildRequires: xorg-lib-libX11-devel
 BuildRequires: xorg-lib-libXext-devel
 BuildRequires: xorg-lib-libXfixes-devel
@@ -70,6 +75,7 @@ Requires:     celt051 >= 0.5.1.1
 Requires:      opus >= 0.9.14
 Requires:      glib2 >= 1:2.22
 Requires:      pixman >= 0.17.7
+Obsoletes:     spice-client
 
 %description -n spice-server-libs
 SPICE server library.
@@ -130,18 +136,24 @@ Klient SPICE dla X11.
 
 %build
 %{__libtoolize}
-%{__aclocal}
+%{__aclocal} -I m4
 %{__autoconf}
 %{__autoheader}
 %{__automake}
+cd spice-common
+%{__libtoolize}
+%{__aclocal} -I m4
+%{__autoconf}
+%{__autoheader}
+%{__automake}
+cd ..
 %configure \
        --disable-silent-rules \
        --enable-client \
+       --enable-lz4 \
        %{?with_opengl:--enable-opengl} \
        --enable-smartcard
 
-# --enable-gui         BR: CEGUI-devel >= 0.6.0 < 0.7.0
-
 %{__make}
 
 %install
@@ -174,7 +186,3 @@ rm -rf $RPM_BUILD_ROOT
 %files -n spice-server-static
 %defattr(644,root,root,755)
 %{_libdir}/libspice-server.a
-
-%files -n spice-client
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/spicec
This page took 0.228453 seconds and 4 git commands to generate.