]> git.pld-linux.org Git - packages/spice-space.git/blob - spice-space.spec
9d26b152a66f340e3b1db3102970bb70973a38a4
[packages/spice-space.git] / spice-space.spec
1 #
2 # Conditional build:
3 %bcond_without  opengl  # OpenGL support
4 #
5 Summary:        SPICE virtualization solution
6 Summary(pl.UTF-8):      System wirtualizacji SPICE
7 # real package name (spice) is already occupied
8 Name:           spice-space
9 Version:        0.12.5
10 Release:        1
11 License:        LGPL v2.1+
12 Group:          Applications/Emulators
13 Source0:        http://www.spice-space.org/download/releases/spice-%{version}.tar.bz2
14 # Source0-md5:  1256286214fe402703c0a01bd3a85319
15 Patch0:         spice-sh.patch
16 Patch1:         spice-link.patch
17 Patch2:         spice-am.patch
18 URL:            http://www.spice-space.org/
19 %{?with_opengl:BuildRequires:   OpenGL-devel}
20 %{?with_opengl:BuildRequires:   OpenGL-GLU-devel}
21 BuildRequires:  alsa-lib-devel
22 BuildRequires:  autoconf >= 2.63
23 BuildRequires:  automake >= 1:1.11
24 BuildRequires:  celt051-devel >= 0.5.1.1
25 BuildRequires:  cyrus-sasl-devel >= 2
26 BuildRequires:  glib2-devel >= 1:2.22
27 BuildRequires:  libcacard-devel >= 0.1.2
28 BuildRequires:  libjpeg-devel
29 BuildRequires:  libstdc++-devel
30 BuildRequires:  libtool >= 2:2
31 BuildRequires:  openssl-devel
32 BuildRequires:  opus-devel >= 0.9.14
33 BuildRequires:  pixman-devel >= 0.17.7
34 BuildRequires:  pkgconfig
35 BuildRequires:  python >= 2
36 BuildRequires:  python-pyparsing
37 BuildRequires:  rpmbuild(macros) >= 1.527
38 BuildRequires:  spice-protocol >= 0.10.1
39 BuildRequires:  xorg-lib-libX11-devel
40 BuildRequires:  xorg-lib-libXext-devel
41 BuildRequires:  xorg-lib-libXfixes-devel
42 BuildRequires:  xorg-lib-libXinerama-devel >= 1.0
43 BuildRequires:  xorg-lib-libXrandr-devel >= 1.2
44 BuildRequires:  xorg-lib-libXrender-devel
45 BuildRequires:  zlib-devel
46 ExclusiveArch:  %{ix86} %{x8664} arm
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 Spice is an open remote computing solution, providing client access to
51 remote machine display and devices (e.g., keyboard, mouse, audio).
52 Spice achieves a user experience similar to an interaction with a
53 local machine, while trying to offload most of the intensive CPU and
54 GPU tasks to the client. Spice is suitable for both LAN and WAN usage,
55 without compromising on the user experience.
56
57 %description -l pl.UTF-8
58 Spice to rozwiązanie do zdalnych obliczeń, zapewniające dostęp
59 kliencki ekranu i urządzeń zdalnej maszyny (klawiatury, myszy,
60 dźwięku). Daje użytkownikowi wrażenie podobne do pracy lokalnej, ale
61 próbuje większość zadań wykorzystujących intensywnie CPU i GPU zrzucić
62 na klienta. Nadaje się do pracy w sieciach LAN i WAN, bez większych
63 poświęceń ze strony doznań użytkownika.
64
65 %package -n spice-server-libs
66 Summary:        SPICE server library
67 Summary(pl.UTF-8):      Biblioteka serwera SPICE
68 Group:          Libraries
69 Requires:       celt051 >= 0.5.1.1
70 Requires:       opus >= 0.9.14
71 Requires:       glib2 >= 1:2.22
72 Requires:       pixman >= 0.17.7
73
74 %description -n spice-server-libs
75 SPICE server library.
76
77 %description -n spice-server-libs -l pl.UTF-8
78 Biblioteka serwera SPICE.
79
80 %package -n spice-server-devel
81 Summary:        Header files for SPICE server library
82 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki serwera SPICE
83 Group:          Development/Libraries
84 Requires:       celt051-devel >= 0.5.1.1
85 Requires:       glib2-devel >= 1:2.22
86 Requires:       openssl-devel
87 Requires:       pixman-devel >= 0.17.7
88 Requires:       spice-server-libs = %{version}-%{release}
89
90 %description -n spice-server-devel
91 Header files for SPICE server library.
92
93 %description -n spice-server-devel -l pl.UTF-8
94 Pliki nagłówkowe biblioteki serwera SPICE.
95
96 %package -n spice-server-static
97 Summary:        Static SPICE server library
98 Summary(pl.UTF-8):      Statyczna biblioteka serwera SPICE
99 Group:          Development/Libraries
100 Requires:       spice-server-devel = %{version}-%{release}
101
102 %description -n spice-server-static
103 Static SPICE server library.
104
105 %description -n spice-server-static -l pl.UTF-8
106 Statyczna biblioteka serwera SPICE.
107
108 %package -n spice-client
109 Summary:        SPICE client for X11
110 Summary(pl.UTF-8):      Klient SPICE dla X11
111 Group:          X11/Applications
112 Requires:       celt051 >= 0.5.1.1
113 Requires:       libcacard >= 0.1.2
114 Requires:       opus >= 0.9.14
115 Requires:       pixman >= 0.17.7
116 Requires:       xorg-lib-libXrandr >= 1.2
117 Requires:       xorg-lib-libXinerama >= 1.0
118
119 %description -n spice-client
120 SPICE client for X11.
121
122 %description -n spice-client -l pl.UTF-8
123 Klient SPICE dla X11.
124
125 %prep
126 %setup -q -n spice-%{version}
127 %patch0 -p1
128 %patch1 -p1
129 %patch2 -p1
130
131 %build
132 %{__libtoolize}
133 %{__aclocal}
134 %{__autoconf}
135 %{__autoheader}
136 %{__automake}
137 %configure \
138         --disable-silent-rules \
139         --enable-client \
140         %{?with_opengl:--enable-opengl} \
141         --enable-smartcard
142
143 # --enable-gui          BR: CEGUI-devel >= 0.6.0 < 0.7.0
144
145 %{__make}
146
147 %install
148 rm -rf $RPM_BUILD_ROOT
149
150 %{__make} install \
151         DESTDIR=$RPM_BUILD_ROOT
152
153 # obsoleted by pkg-config
154 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libspice-server.la
155
156 %clean
157 rm -rf $RPM_BUILD_ROOT
158
159 %post   -n spice-server-libs -p /sbin/ldconfig
160 %postun -n spice-server-libs -p /sbin/ldconfig
161
162 %files -n spice-server-libs
163 %defattr(644,root,root,755)
164 %doc NEWS README
165 %attr(755,root,root) %{_libdir}/libspice-server.so.*.*.*
166 %attr(755,root,root) %ghost %{_libdir}/libspice-server.so.1
167
168 %files -n spice-server-devel
169 %defattr(644,root,root,755)
170 %attr(755,root,root) %{_libdir}/libspice-server.so
171 %{_includedir}/spice-server
172 %{_pkgconfigdir}/spice-server.pc
173
174 %files -n spice-server-static
175 %defattr(644,root,root,755)
176 %{_libdir}/libspice-server.a
177
178 %files -n spice-client
179 %defattr(644,root,root,755)
180 %attr(755,root,root) %{_bindir}/spicec
This page took 0.722441 seconds and 2 git commands to generate.