]> git.pld-linux.org Git - packages/spice-space.git/blob - spice-space.spec
859cd979b3f348e1a755fabc4dc982f23e3b509a
[packages/spice-space.git] / spice-space.spec
1 #
2 # Conditional build:
3 %bcond_with     slirp           # build with tunneling support (breaks qemu)
4 #
5 Summary:        SPICE virtualization solution
6 Summary(pl.UTF-8):      System wirtualizacji SPICE
7 # real package name (spice) is already occupied
8 Name:           spice-space
9 Version:        0.12.0
10 Release:        1
11 License:        LGPL v2.1+
12 Group:          Applications/Emulators
13 Source0:        http://spice-space.org/download/releases/spice-%{version}.tar.bz2
14 # Source0-md5:  12c6ea4938215f8f9f10d2925f7bec9b
15 Patch0:         spice-sh.patch
16 Patch1:         spice-link.patch
17 URL:            http://spice-space.org/
18 BuildRequires:  OpenGL-GLU-devel
19 BuildRequires:  alsa-lib-devel
20 BuildRequires:  celt051-devel >= 0.5.1.1
21 BuildRequires:  autoconf >= 2.57
22 BuildRequires:  automake
23 BuildRequires:  cyrus-sasl-devel >= 2
24 BuildRequires:  libcacard-devel >= 0.1.2
25 BuildRequires:  libjpeg-devel
26 %{?with_slirp:BuildRequires:    libslirp-devel}
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  libtool
29 BuildRequires:  openssl-devel
30 BuildRequires:  pixman-devel >= 0.17.7
31 BuildRequires:  pkgconfig
32 BuildRequires:  python
33 BuildRequires:  python-pyparsing
34 BuildRequires:  rpmbuild(macros) >= 1.527
35 BuildRequires:  spice-protocol >= 0.10.1
36 BuildRequires:  xorg-lib-libXext-devel
37 BuildRequires:  xorg-lib-libXfixes-devel
38 BuildRequires:  xorg-lib-libXinerama-devel >= 1.0
39 BuildRequires:  xorg-lib-libXrandr-devel >= 1.2
40 BuildRequires:  xorg-lib-libXrender-devel
41 BuildRequires:  zlib-devel
42 ExclusiveArch:  %{ix86} %{x8664} arm
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 Spice is an open remote computing solution, providing client access to
47 remote machine display and devices (e.g., keyboard, mouse, audio).
48 Spice achieves a user experience similar to an interaction with a
49 local machine, while trying to offload most of the intensive CPU and
50 GPU tasks to the client. Spice is suitable for both LAN and WAN usage,
51 without compromising on the user experience.
52
53 %description -l pl.UTF-8
54 Spice to rozwiązanie do zdalnych obliczeń, zapewniające dostęp
55 kliencki ekranu i urządzeń zdalnej maszyny (klawiatury, myszy,
56 dźwięku). Daje użytkownikowi wrażenie podobne do pracy lokalnej, ale
57 próbuje większość zadań wykorzystujących intensywnie CPU i GPU zrzucić
58 na klienta. Nadaje się do pracy w sieciach LAN i WAN, bez większych
59 poświęceń ze strony doznań użytkownika.
60
61 %package -n spice-server-libs
62 Summary:        SPICE server library
63 Summary(pl.UTF-8):      Biblioteka serwera SPICE
64 Group:          Libraries
65 Requires:       celt051 >= 0.5.1.1
66 Requires:       pixman >= 0.17.7
67
68 %description -n spice-server-libs
69 SPICE server library.
70
71 %description -n spice-server-libs -l pl.UTF-8
72 Biblioteka serwera SPICE.
73
74 %package -n spice-server-devel
75 Summary:        Header files for SPICE server library
76 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki serwera SPICE
77 Group:          Development/Libraries
78 Requires:       celt051-devel >= 0.5.1.1
79 %{?with_slirp:Requires: libslirp-devel}
80 Requires:       openssl-devel
81 Requires:       pixman-devel >= 0.17.7
82 Requires:       spice-server-libs = %{version}-%{release}
83
84 %description -n spice-server-devel
85 Header files for SPICE server library.
86
87 %description -n spice-server-devel -l pl.UTF-8
88 Pliki nagłówkowe biblioteki serwera SPICE.
89
90 %package -n spice-server-static
91 Summary:        Static SPICE server library
92 Summary(pl.UTF-8):      Statyczna biblioteka serwera SPICE
93 Group:          Development/Libraries
94 Requires:       spice-server-devel = %{version}-%{release}
95
96 %description -n spice-server-static
97 Static SPICE server library.
98
99 %description -n spice-server-static -l pl.UTF-8
100 Statyczna biblioteka serwera SPICE.
101
102 %package -n spice-client
103 Summary:        SPICE client for X11
104 Summary(pl.UTF-8):      Klient SPICE dla X11
105 Group:          X11/Applications
106 Requires:       celt051 >= 0.5.1.1
107 Requires:       libcacard >= 0.1.2
108 Requires:       pixman >= 0.17.7
109 Requires:       xorg-lib-libXrandr >= 1.2
110 Requires:       xorg-lib-libXinerama >= 1.0
111
112 %description -n spice-client
113 SPICE client for X11.
114
115 %description -n spice-client -l pl.UTF-8
116 Klient SPICE dla X11.
117
118 %prep
119 %setup -q -n spice-%{version}
120 %patch0 -p1
121 %patch1 -p1
122
123 %build
124 %{__libtoolize}
125 %{__aclocal}
126 %{__autoconf}
127 %{__autoheader}
128 %{__automake}
129 %configure \
130         --disable-silent-rules \
131         --enable-opengl \
132         --enable-smartcard \
133         %{?with_slirp:en}%{!?with_slirp:dis}able-tunnel
134 # --enable-gui          BR: CEGUI-devel >= 0.6.0 < 0.7.0
135
136 %{__make}
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140
141 %{__make} install \
142         DESTDIR=$RPM_BUILD_ROOT
143
144 # obsoleted by pkg-config
145 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libspice-server.la
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %post   -n spice-server-libs -p /sbin/ldconfig
151 %postun -n spice-server-libs -p /sbin/ldconfig
152
153 %files -n spice-server-libs
154 %defattr(644,root,root,755)
155 %doc NEWS README
156 %attr(755,root,root) %{_libdir}/libspice-server.so.*.*.*
157 %attr(755,root,root) %ghost %{_libdir}/libspice-server.so.1
158
159 %files -n spice-server-devel
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_libdir}/libspice-server.so
162 %{_includedir}/spice-server
163 %{_pkgconfigdir}/spice-server.pc
164
165 %files -n spice-server-static
166 %defattr(644,root,root,755)
167 %{_libdir}/libspice-server.a
168
169 %files -n spice-client
170 %defattr(644,root,root,755)
171 %attr(755,root,root) %{_bindir}/spicec
This page took 0.068765 seconds and 2 git commands to generate.