]> git.pld-linux.org Git - packages/spice-space.git/blob - spice-space.spec
- updated dependencies
[packages/spice-space.git] / spice-space.spec
1 #
2 # Conditional build:
3 %bcond_without  opengl          # OpenGL support
4 %bcond_without  static_libs     # static library
5 #
6 Summary:        SPICE virtualization solution
7 Summary(pl.UTF-8):      System wirtualizacji SPICE
8 # real package name (spice) is already occupied
9 Name:           spice-space
10 # NOTE: 0.odd.x versions are unstable
11 Version:        0.14.3
12 Release:        1
13 License:        LGPL v2.1+
14 Group:          Applications/Emulators
15 Source0:        https://www.spice-space.org/download/releases/spice-server/spice-%{version}.tar.bz2
16 # Source0-md5:  a776650f7c4dc22681d76308475a9190
17 Patch0:         spice-am.patch
18 URL:            https://www.spice-space.org/
19 %{?with_opengl:BuildRequires:   OpenGL-GLU-devel}
20 %{?with_opengl:BuildRequires:   OpenGL-devel}
21 BuildRequires:  alsa-lib-devel
22 BuildRequires:  asciidoc
23 BuildRequires:  autoconf >= 2.63
24 BuildRequires:  automake >= 1:1.11
25 BuildRequires:  celt051-devel >= 0.5.1.1
26 BuildRequires:  cyrus-sasl-devel >= 2
27 BuildRequires:  gcc >= 5:4.0
28 BuildRequires:  gdk-pixbuf2-devel >= 2.26
29 BuildRequires:  glib2-devel >= 1:2.38
30 BuildRequires:  gstreamer-devel >= 1.0
31 BuildRequires:  gstreamer-plugins-base-devel >= 1.0
32 BuildRequires:  libcacard-devel >= 2.5.1
33 BuildRequires:  libjpeg-devel
34 BuildRequires:  libstdc++-devel
35 BuildRequires:  libtool >= 2:2
36 BuildRequires:  lz4-devel >= 129
37 BuildRequires:  openssl-devel >= 1.0.0
38 BuildRequires:  opus-devel >= 1.0.0
39 BuildRequires:  orc-devel >= 0.4
40 BuildRequires:  pixman-devel >= 0.17.7
41 BuildRequires:  pkgconfig
42 BuildRequires:  python >= 2
43 BuildRequires:  python-pyparsing
44 BuildRequires:  python-six
45 BuildRequires:  rpmbuild(macros) >= 1.527
46 BuildRequires:  spice-protocol >= 0.14.0
47 BuildRequires:  xorg-lib-libX11-devel
48 BuildRequires:  xorg-lib-libXext-devel
49 BuildRequires:  xorg-lib-libXfixes-devel
50 BuildRequires:  xorg-lib-libXinerama-devel >= 1.0
51 BuildRequires:  xorg-lib-libXrandr-devel >= 1.2
52 BuildRequires:  xorg-lib-libXrender-devel
53 BuildRequires:  zlib-devel
54 ExclusiveArch:  %{ix86} %{x8664} x32 %{arm}
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %description
58 Spice is an open remote computing solution, providing client access to
59 remote machine display and devices (e.g., keyboard, mouse, audio).
60 Spice achieves a user experience similar to an interaction with a
61 local machine, while trying to offload most of the intensive CPU and
62 GPU tasks to the client. Spice is suitable for both LAN and WAN usage,
63 without compromising on the user experience.
64
65 %description -l pl.UTF-8
66 Spice to rozwiązanie do zdalnych obliczeń, zapewniające dostęp
67 kliencki ekranu i urządzeń zdalnej maszyny (klawiatury, myszy,
68 dźwięku). Daje użytkownikowi wrażenie podobne do pracy lokalnej, ale
69 próbuje większość zadań wykorzystujących intensywnie CPU i GPU zrzucić
70 na klienta. Nadaje się do pracy w sieciach LAN i WAN, bez większych
71 poświęceń ze strony doznań użytkownika.
72
73 %package -n spice-server-libs
74 Summary:        SPICE server library
75 Summary(pl.UTF-8):      Biblioteka serwera SPICE
76 Group:          Libraries
77 Requires:       celt051 >= 0.5.1.1
78 Requires:       glib2 >= 1:2.38
79 Requires:       openssl >= 1.0.0
80 Requires:       opus >= 1.0.0
81 Requires:       pixman >= 0.17.7
82 Obsoletes:      spice-client < 0.12.6
83
84 %description -n spice-server-libs
85 SPICE server library.
86
87 %description -n spice-server-libs -l pl.UTF-8
88 Biblioteka serwera SPICE.
89
90 %package -n spice-server-devel
91 Summary:        Header files for SPICE server library
92 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki serwera SPICE
93 Group:          Development/Libraries
94 Requires:       celt051-devel >= 0.5.1.1
95 Requires:       glib2-devel >= 1:2.38
96 Requires:       libcacard-devel >= 2.5.1
97 Requires:       openssl-devel >= 1.0.0
98 Requires:       pixman-devel >= 0.17.7
99 Requires:       spice-protocol >= 0.14.0
100 Requires:       spice-server-libs = %{version}-%{release}
101
102 %description -n spice-server-devel
103 Header files for SPICE server library.
104
105 %description -n spice-server-devel -l pl.UTF-8
106 Pliki nagłówkowe biblioteki serwera SPICE.
107
108 %package -n spice-server-static
109 Summary:        Static SPICE server library
110 Summary(pl.UTF-8):      Statyczna biblioteka serwera SPICE
111 Group:          Development/Libraries
112 Requires:       spice-server-devel = %{version}-%{release}
113
114 %description -n spice-server-static
115 Static SPICE server library.
116
117 %description -n spice-server-static -l pl.UTF-8
118 Statyczna biblioteka serwera SPICE.
119
120 %prep
121 %setup -q -n spice-%{version}
122 %patch0 -p1
123
124 %build
125 %{__libtoolize}
126 %{__aclocal} -I m4
127 %{__autoconf}
128 %{__autoheader}
129 %{__automake}
130 cd subprojects/spice-common
131 %{__libtoolize}
132 %{__aclocal} -I m4
133 %{__autoconf}
134 %{__autoheader}
135 %{__automake}
136 cd ../..
137 %configure \
138         --disable-silent-rules \
139         --enable-celt051 \
140         --enable-lz4 \
141         %{?with_opengl:--enable-opengl} \
142         --enable-smartcard \
143         %{?with_static_libs:--enable-static}
144
145 %{__make}
146
147 %install
148 rm -rf $RPM_BUILD_ROOT
149
150 %{__make} install \
151         DESTDIR=$RPM_BUILD_ROOT
152
153 # obsoleted by pkg-config
154 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libspice-server.la
155
156 %clean
157 rm -rf $RPM_BUILD_ROOT
158
159 %post   -n spice-server-libs -p /sbin/ldconfig
160 %postun -n spice-server-libs -p /sbin/ldconfig
161
162 %files -n spice-server-libs
163 %defattr(644,root,root,755)
164 %doc AUTHORS CHANGELOG.md README
165 %attr(755,root,root) %{_libdir}/libspice-server.so.*.*.*
166 %attr(755,root,root) %ghost %{_libdir}/libspice-server.so.1
167
168 %files -n spice-server-devel
169 %defattr(644,root,root,755)
170 %attr(755,root,root) %{_libdir}/libspice-server.so
171 %{_includedir}/spice-server
172 %{_pkgconfigdir}/spice-server.pc
173
174 %if %{with static_libs}
175 %files -n spice-server-static
176 %defattr(644,root,root,755)
177 %{_libdir}/libspice-server.a
178 %endif
This page took 0.093489 seconds and 3 git commands to generate.