]> git.pld-linux.org Git - packages/speedtest-cli.git/commitdiff
- updated to 0.3.2
authorWitold Filipczyk <witekfl@poczta.onet.pl>
Tue, 19 May 2015 13:09:13 +0000 (15:09 +0200)
committerWitold Filipczyk <witekfl@poczta.onet.pl>
Tue, 19 May 2015 13:09:13 +0000 (15:09 +0200)
- added patch (issue 138)

138.patch [new file with mode: 0644]
speedtest-cli.spec

diff --git a/138.patch b/138.patch
new file mode 100644 (file)
index 0000000..6c068b3
--- /dev/null
+++ b/138.patch
@@ -0,0 +1,24 @@
+diff --git a/speedtest_cli.py b/speedtest_cli.py
+index 2beeb35..82351b1 100755
+--- a/speedtest_cli.py
++++ b/speedtest_cli.py
+@@ -17,6 +17,7 @@
+ import os
+ import re
++import ssl
+ import sys
+ import math
+ import signal
+@@ -192,7 +193,10 @@ def catch_request(request):
+     """
+     try:
+-        uh = urlopen(request)
++        ctx = ssl.create_default_context()
++        ctx.check_hostname = False
++        ctx.verify_mode = ssl.CERT_NONE
++        uh = urlopen(request, context = ctx)
+         return uh
+     except (HTTPError, URLError, socket.error):
+         return False
index f6a8b82bbbaf6cbc78277336fa8ccb24aedf3002..e03b3e4b93dfc1772e5a7924edf61ac8c122acea 100644 (file)
@@ -1,11 +1,12 @@
 Summary:       speedtest
 Name:          speedtest-cli
-Version:       0.2.7
+Version:       0.3.2
 Release:       1
 License:       Apache
 Group:         Networking
 Source0:       http://github.com/sivel/speedtest-cli/archive/v%{version}.tar.gz
-# Source0-md5: 0466359388ab9f35bc52d3ab531816e1
+# Source0-md5: 86f8ef30a724c5ee577d91c42e17b5fb
+Patch0:                138.patch
 URL:           http://github.com/sivel/speedtest-cli
 BuildRequires: python-distribute
 BuildRequires: rpm-pythonprov
@@ -19,6 +20,7 @@ Command line interface for testing internet bandwidth using speedtest.net.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %{__python} setup.py build
This page took 0.149508 seconds and 4 git commands to generate.