]> git.pld-linux.org Git - packages/spdylay.git/blob - spdylay.spec
- updated to 1.3.2
[packages/spdylay.git] / spdylay.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform "make check"
4 %bcond_without  static_libs     # don't build static library
5
6 Summary:        SPDY C library
7 Summary(pl.UTF-8):      Biblioteka C SPDY
8 Name:           spdylay
9 Version:        1.3.2
10 Release:        1
11 License:        MIT
12 Group:          Libraries
13 #Source0Download: https://github.com/tatsuhiro-t/spdylay/releases
14 Source0:        https://github.com/tatsuhiro-t/spdylay/releases/download/v%{version}/%{name}-%{version}.tar.xz
15 # Source0-md5:  69da2cfa2ec72053d88c6ae0c1d9089c
16 URL:            http://tatsuhiro-t.github.io/spdylay/
17 %{?with_tests:BuildRequires:    CUnit >= 2.1}
18 BuildRequires:  libevent-devel >= 2.0.8
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  libxml2-devel >= 1:2.7.7
21 BuildRequires:  openssl-devel >= 1.0.1
22 BuildRequires:  pkgconfig >= 1:0.20
23 BuildRequires:  tar >= 1:1.22
24 BuildRequires:  xz
25 BuildRequires:  zlib-devel >= 1.2.3
26 Requires:       libevent >= 2.0.8
27 Requires:       libxml2 >= 1:2.7.7
28 Requires:       openssl >= 1.0.1
29 Requires:       zlib >= 1.2.3
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 This is an experimental implementation of Google's SPDY protocol in C.
34 This library provides SPDY version 2 and 3 framing layer
35 implementation. It does not perform any I/O operations. When the
36 library needs them, it calls the callback functions provided by the
37 application. It also does not include any event polling mechanism, so
38 the application can freely choose the way of handling events. This
39 library code does not depend on any particular SSL library (except for
40 example programs which depend on OpenSSL 1.0.1 or later).
41
42 %description -l pl.UTF-8
43 Ta biblioteka jest eksperymentalną implementacją protokołu SPDY
44 Google'a w C. Udostępnia implementację warstwy ramek SPDY w wersji 2 i
45 3. Nie wykonuje żadnych operacji we/wy - w razie potrzeby odwołuje się
46 do wywołań wstecznych dostarczonych przez aplikację. Nie zawiera także
47 żadnego mechanizmu typu poll - aplikacja może dowolnie wybrać metodę
48 obsługi zdarzeń. Biblioteka nie zależy od żadnej konkretnej biblioteki
49 SSL (poza programami przykładowymi, które wymagają OpenSSL >= 1.0.1).
50
51 %package devel
52 Summary:        Files needed for developing with libspdylay
53 Summary(pl.UTF-8):      Pliki niezbędne do tworzenia aplikacji z użyciem libspdylay
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56 Requires:       zlib-devel >= 1.2.3
57
58 %description devel
59 Files needed for building applications with libspdylay.
60
61 %description devel -l pl.UTF-8
62 Pliki niezbędne do tworzenia aplikacji z użyciem libspdylay.
63
64 %package static
65 Summary:        Static libspdylay library
66 Summary(pl.UTF-8):      Statyczna biblioteka libspdylay
67 Group:          Development/Libraries
68 Requires:       %{name}-devel = %{version}-%{release}
69
70 %description static
71 Static libspdylay library.
72
73 %description static -l pl.UTF-8
74 Statyczna biblioteka libspdylay.
75
76 %prep
77 %setup -q
78
79 %build
80 %configure \
81         %{!?with_static_libs:--disable-static}
82
83 %{__make}
84
85 %if %{with tests}
86 %{__make} check
87 %endif
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91
92 %{__make} install \
93         DESTDIR=$RPM_BUILD_ROOT
94
95 # obsoleted by pkg-config
96 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libspdylay.la
97 # packaged as %doc
98 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/spdylay
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %post   -p /sbin/ldconfig
104 %postun -p /sbin/ldconfig
105
106 %files
107 %defattr(644,root,root,755)
108 %doc AUTHORS COPYING ChangeLog NEWS README.rst
109 %attr(755,root,root) %{_bindir}/shrpx
110 %attr(755,root,root) %{_bindir}/spdycat
111 %attr(755,root,root) %{_bindir}/spdyd
112 %attr(755,root,root) %{_libdir}/libspdylay.so.*.*.*
113 %attr(755,root,root) %ghost %{_libdir}/libspdylay.so.7
114
115 %files devel
116 %defattr(644,root,root,755)
117 %attr(755,root,root) %{_libdir}/libspdylay.so
118 %{_includedir}/spdylay
119 %{_pkgconfigdir}/libspdylay.pc
120
121 %if %{with static_libs}
122 %files static
123 %defattr(644,root,root,755)
124 %{_libdir}/libspdylay.a
125 %endif
This page took 0.084314 seconds and 4 git commands to generate.