]> git.pld-linux.org Git - packages/sparse.git/blob - sparse.spec
7c63ea08424b51b617a8be329ac0aecaf29adb72
[packages/sparse.git] / sparse.spec
1 Summary:        Sparse - a semantic parser of source files
2 Summary(pl.UTF-8):      Sparse - analizator semantyczny plików źródłowych
3 Name:           sparse
4 Version:        0.6.3
5 Release:        2
6 License:        OSL v1.1
7 Group:          Development/Debuggers
8 Source0:        https://www.kernel.org/pub/software/devel/sparse/dist/%{name}-%{version}.tar.xz
9 # Source0-md5:  5eeca38d842b0e715e91111d7a975fb0
10 URL:            https://www.kernel.org/pub/software/devel/sparse/
11 BuildRequires:  gtk+3-devel >= 3.0
12 BuildRequires:  libxml2-devel >= 2.0
13 BuildRequires:  llvm-devel >= 3.0
14 BuildRequires:  pkgconfig
15 BuildRequires:  tar >= 1:1.22
16 BuildRequires:  xz
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Sparse is a semantic parser of source files: it's neither a compiler
21 (although it could be used as a front-end for one) nor is it a
22 preprocessor (although it contains as a part of it a preprocessing
23 phase).
24
25 It is meant to be a small - and simple - library. Scanty and meager,
26 and partly because of that easy to use. It has one mission in life:
27 create a semantic parse tree for some arbitrary user for further
28 analysis. It's not a tokenizer, nor is it some generic context-free
29 parser. In fact, context (semantics) is what it's all about - figuring
30 out not just what the grouping of tokens are, but what the _types_ are
31 that the grouping implies.
32
33 %description -l pl.UTF-8
34 Sparse to analizator semantyczny plików źródłowych - nie jest to ani
35 kompilator (choć mógłby być używany jako frontend dla niego) ani
36 preprocesor (choć zawiera jako część fazę preprocesingu).
37
38 Sparse ma być małą i prostą biblioteką. Ledwie wystarczającą i
39 niewielką, i po części dlatego łatwą w użyciu. Ma jedno zadanie:
40 utworzyć drzewo semantyczne analizy do dowolnego późniejszego
41 wykorzystania. Nie jest to tokenizer ani żaden ogólny analizator
42 bezkontekstowy. Właściwie kontekst (semantyka) to wszystko co
43 istotne - przedstawianie nie tylko czym są grupowane tokeny, ale tego,
44 czym są _typy_ obejmowane przez grupowanie.
45
46 %prep
47 %setup -q
48
49 %build
50 %{__make} \
51         CC="%{__cc}" \
52         CFLAGS="%{rpmcflags} -fpic" \
53         LDFLAGS="%{rpmldflags}" \
54         PREFIX="%{_prefix}" \
55         LIBDIR="%{_libdir}" \
56         V=1
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} install \
62         PREFIX="%{_prefix}" \
63         LIBDIR="%{_libdir}" \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc FAQ LICENSE README
72 %attr(755,root,root) %{_bindir}/c2xml
73 %attr(755,root,root) %{_bindir}/cgcc
74 %attr(755,root,root) %{_bindir}/semind
75 %attr(755,root,root) %{_bindir}/sparse
76 %attr(755,root,root) %{_bindir}/sparse-llvm
77 %attr(755,root,root) %{_bindir}/sparsec
78 %attr(755,root,root) %{_bindir}/test-inspect
79 %{_mandir}/man1/cgcc.1*
80 %{_mandir}/man1/semind.1*
81 %{_mandir}/man1/sparse.1*
This page took 0.062993 seconds and 2 git commands to generate.