]> git.pld-linux.org Git - packages/spamassassin.git/commitdiff
- up to 3.4.0 auto/th/spamassassin-3.4.0-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 12 Feb 2014 21:13:07 +0000 (22:13 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 12 Feb 2014 21:13:07 +0000 (22:13 +0100)
spamassassin-perl_5.18.patch [deleted file]
spamassassin.spec

diff --git a/spamassassin-perl_5.18.patch b/spamassassin-perl_5.18.patch
deleted file mode 100644 (file)
index 589904b..0000000
+++ /dev/null
@@ -1,113 +0,0 @@
---- Mail-SpamAssassin-3.3.2/lib/Mail/SpamAssassin/AsyncLoop.pm.orig     2011-06-06 23:59:17.000000000 +0000
-+++ Mail-SpamAssassin-3.3.2/lib/Mail/SpamAssassin/AsyncLoop.pm
-@@ -360,7 +360,14 @@ sub complete_lookups {
-     }
-     $now = time;  # capture new timestamp, after possible sleep in 'select'
--    while (my($key,$ent) = each %$pending) {
-+    # A callback routine may generate another DNS query, which may insert
-+    # an entry into the %$pending hash thus invalidating the each() context.
-+    # So, make sure that callbacks are not called while the each() context
-+    # is open, or avoid using each().  [Bug 6937]
-+    #
-+  # while (my($key,$ent) = each %$pending) {
-+    foreach my $key (keys %$pending) {
-+      my $ent = $pending->{$key};
-       my $id = $ent->{id};
-       if (defined $ent->{poll_callback}) {  # call a "poll_callback" if exists
-         # be nice, provide fresh info to a callback routine
-@@ -448,7 +455,8 @@ sub abort_remaining_lookups {
-   my $pending = $self->{pending_lookups};
-   my $foundcnt = 0;
-   my $now = time;
--  while (my($key,$ent) = each %$pending) {
-+  foreach my $key (keys %$pending) {
-+    my $ent = $pending->{$key};
-     dbg("async: aborting after %.3f s, %s: %s",
-         $now - $ent->{start_time},
-         (defined $ent->{timeout_initial} &&
---- Mail-SpamAssassin-3.3.2/lib/Mail/SpamAssassin/Conf/Parser.pm.orig   2013-06-14 14:47:39.000000000 +0000
-+++ Mail-SpamAssassin-3.3.2/lib/Mail/SpamAssassin/Conf/Parser.pm
-@@ -1248,7 +1248,7 @@ sub is_regexp_valid {
-   my $safere = $re;
-   my $mods = '';
-   local ($1,$2);
--  if ($re =~ s/^m{//) {
-+  if ($re =~ s/^m\{//) {
-     $re =~ s/}([a-z]*)$//; $mods = $1;
-   }
-   elsif ($re =~ s/^m\(//) {
---- Mail-SpamAssassin-3.3.2/lib/Mail/SpamAssassin/DnsResolver.pm.orig   2011-06-06 23:59:17.000000000 +0000
-+++ Mail-SpamAssassin-3.3.2/lib/Mail/SpamAssassin/DnsResolver.pm
-@@ -440,10 +440,16 @@ sub poll_responses {
-     { my $timer;  # collects timestamp when variable goes out of scope
-       if (!defined($timeout) || $timeout > 0)
-         { $timer = $self->{main}->time_method("poll_dns_idle") }
-+      $! = 0;
-       ($nfound, $timeleft) = select($rout=$rin, undef, undef, $timeout);
-     }
-     if (!defined $nfound || $nfound < 0) {
--      warn "dns: select failed: $!";
-+      if ($!) { warn "dns: select failed: $!\n" }
-+      else    { info("dns: select interrupted") }
-+      return;
-+    } elsif (!$nfound) {
-+      if (!defined $timeout) { warn("dns: select returned empty-handed\n") }
-+      elsif ($timeout > 0) { dbg("dns: select timed out %.3f s", $timeout) }
-       return;
-     }
---- Mail-SpamAssassin-3.3.2/lib/Mail/SpamAssassin/Message.pm.orig       2011-06-06 23:59:17.000000000 +0000
-+++ Mail-SpamAssassin-3.3.2/lib/Mail/SpamAssassin/Message.pm
-@@ -566,7 +566,7 @@ sub finish {
-   while (my $part = shift @toclean) {
-     # bug 5557: windows requires tmp file be closed before it can be rm'd
-     if (ref $part->{'raw'} eq 'GLOB') {
--      close($part->{'raw'})  or die "error closing input file: $!";
-+      close($part->{'raw'})  or warn "error closing input file: $!";
-     }
-     # bug 5858: avoid memory leak with deep MIME structure
---- Mail-SpamAssassin-3.3.2/lib/Mail/SpamAssassin/PerMsgStatus.pm.orig  2011-06-06 23:59:17.000000000 +0000
-+++ Mail-SpamAssassin-3.3.2/lib/Mail/SpamAssassin/PerMsgStatus.pm
-@@ -420,8 +420,8 @@ sub _get_autolearn_points {
-       }
-     }
--    # ignore tests with 0 score in this scoreset
--    next if ($scores->{$test} == 0);
-+    # ignore tests with 0 score (or undefined) in this scoreset
-+    next if !$scores->{$test};
-     # Go ahead and add points to the proper locations
-     if (!$self->{conf}->maybe_header_only ($test)) {
-@@ -1252,13 +1252,12 @@ sub _get_tag {
-               my $arg = (shift || ",");
-               my $line = '';
-               foreach my $test (sort @{$self->{test_names_hit}}) {
--                if (!$line) {
--                  $line .= $test . "=" . $self->{conf}->{scores}->{$test};
--                } else {
--                  $line .= $arg . $test . "=" . $self->{conf}->{scores}->{$test};
--                }
-+                my $score = $self->{conf}->{scores}->{$test};
-+                $score = '0'  if !defined $score;
-+                $line .= $arg  if $line ne '';
-+                $line .= $test . "=" . $score;
-               }
--              $line ? $line : 'none';
-+              $line ne '' ? $line : 'none';
-             },
-             PREVIEW => sub { $self->get_content_preview() },
---- Mail-SpamAssassin-3.3.2/lib/Mail/SpamAssassin/Util.pm.orig  2011-06-06 23:59:17.000000000 +0000
-+++ Mail-SpamAssassin-3.3.2/lib/Mail/SpamAssassin/Util.pm
-@@ -1582,7 +1582,7 @@ sub regexp_remove_delimiters {
-     warn "cannot remove delimiters from null regexp";
-     return undef;   # invalid
-   }
--  elsif ($re =~ s/^m{//) {              # m{foo/bar}
-+  elsif ($re =~ s/^m\{//) {             # m{foo/bar}
-     $delim = '}';
-   }
-   elsif ($re =~ s/^m\(//) {             # m(foo/bar)
index aa7fe2d94ecaa4efaaefd8cedc3e191a0e38192b..7b096b83de2e80bfb775bb7e4e887e357593c0a3 100644 (file)
 Summary:       A spam filter for email which can be invoked from mail delivery agents
 Summary(pl.UTF-8):     Filtr antyspamowy, przeznaczony dla programów dostarczających pocztę (MDA)
 Name:          spamassassin
-Version:       3.3.2
-Release:       4
+Version:       3.4.0
+Release:       1
 License:       Apache v2.0
 Group:         Applications/Mail
-Source0:       http://ftp.tpnet.pl/vol/d1/apache/spamassassin/source/%{pdir}-%{pnam}-%{version}.tar.bz2
-# Source0-md5: 253f8fcbeb6c8bfcab9d139865c1a404
+Source0:       http://ftp.ps.pl/pub/apache//spamassassin/source/%{pdir}-%{pnam}-%{version}.tar.bz2
+# Source0-md5: 46e99adc0affebbe5f3524b4834e0345
 Source1:       %{name}.sysconfig
 Source2:       %{name}-spamd.init
 Source3:       %{name}-default.rc
 Source4:       %{name}-spamc.rc
 Source5:       sa-update.sh
 Source6:       sa-update.cron
-Patch0:                %{name}-perl_5.18.patch
 URL:           http://spamassassin.apache.org/
 BuildRequires: openssl-devel >= 0.9.7d
 BuildRequires: perl(ExtUtils::MakeMaker) >= 6.16
@@ -111,6 +110,7 @@ Requires:   perl-Mail-SpamAssassin = %{version}-%{release}
 Requires:      rc-scripts
 Suggests:      perl-Apache-Test
 Suggests:      perl-IO-Socket-SSL
+Suggests:      perl-IO-Socket-IP
 Suggests:      perl-Net-Ident
 
 %description spamd
@@ -254,7 +254,6 @@ aplikacji do czytania poczty.
 
 %prep
 %setup -q -n %{pdir}-%{pnam}-%{version}
-%patch0 -p1
 
 %build
 # for spamc/configure
This page took 0.094509 seconds and 4 git commands to generate.