]> git.pld-linux.org Git - packages/spamassassin.git/blob - spamassassin.spec
ba978862ba6f8a9b54fca3f0a742fcfc98a8cc21
[packages/spamassassin.git] / spamassassin.spec
1 %include        /usr/lib/rpm/macros.perl
2 %define pdir    Mail
3 %define pnam    SpamAssassin
4 Summary:        A spam filter for email which can be invoked from mail delivery agents
5 Summary(pl):    Filtr antyspamowy, przeznaczony dla programów dostarczaj±cych pocztê (MDA)
6 Group:          Applications/Mail
7 Version:        2.31
8 Release:        5
9 Name:           spamassassin
10 License:        GPL/Artistic
11 Source0:        http://spamassassin.org/released/%{pdir}-%{pnam}-%{version}.tar.gz
12 Patch0:         spamassassin-makefile.patch
13 Patch1:         spamassassin-rc-script.patch
14 URL:            http://spamassassin.org/
15 BuildRequires:  perl >= 5.6
16 BuildRequires:  rpm-perlprov >= 3.0.3-16
17 Prereq:         /sbin/chkconfig
18 Obsoletes:      SpamAssassin
19 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _noautoreq      'perl(Razor::Agent)' 'perl(Razor::Client)'
22
23 %description
24 SpamAssassin provides you with a way to reduce if not completely
25 eliminate Unsolicited Commercial Email (SPAM) from your incoming
26 email. It can be invoked by a MDA such as sendmail or postfix, or can
27 be called from a procmail script, .forward file, etc. It uses a
28 genetic-algorithm evolved scoring system to identify messages which
29 look spammy, then adds headers to the message so they can be filtered
30 by the user's mail reading software. This distribution includes the
31 spamd/spamc components which create a server that considerably speeds
32 processing of mail.
33
34 %description -l pl
35 SpamAssassin udostêpnia Ci mo¿liwo¶æ zredukowania, je¶li nie
36 kompletnego wyeliminowania Niezamawianej Komercyjnej Poczty
37 (Unsolicited Commercial Email, spamu) z Twojej poczty. Mo¿e byæ
38 wywo³ywany z MDA, np. Sendmaila czy Postfixa, lub z pliku ~/.forward
39 itp. U¿ywa ogólnego algorytmu oceniania w celu identyfikacji
40 wiadomo¶ci, które wygl±daj± na SPAM, po czym dodaje nag³ówki do
41 wiadomo¶ci, umo¿liwiaj±c filtrowanie przez oprogramowanie u¿ytkownika.
42 Ta dystrybucja zawiera programy spamd/spamc, umo¿liwiaj±ce
43 uruchomienie serwera, co znacznie przyspieszy proces przetwarzania
44 poczty.
45
46 %package tools
47 Summary:        Miscleanous tools for SpamAssassin
48 Summary(pl):    Przeró¿ne narzêdzia zwi±zane z SpamAssassin
49 Group:          Applications/Mail
50 Obsoletes:      SpamAssassin-tools
51
52 %description tools
53 Miscleanous tools from various authors, distributed with SpamAssassin.
54 See /usr/share/doc/SpamAssassin-tools-*/.
55
56 %description tools -l pl
57 Przeró¿ne narzêdzia, dystrybuowane razem z SpamAssassin. Zobacz
58 /usr/share/doc/SpamAssassin-tools-*/.
59
60
61 %package -n perl-Mail-SpamAssassin
62 Summary:        %{pdir}::%{pnam} -- SpamAssassin e-mail filter Perl modules
63 Summary(pl):    %{pdir}::%{pnam} -- modu³y Perla filtru poczty SpamAssassin
64 Group:          Development/Languages/Perl
65
66 %description -n perl-Mail-SpamAssassin
67 Mail::SpamAssassin is a Mail::Audit plugin to identify spam using text
68 analysis and several internet-based realtime blacklists. Using its
69 rule base, it uses a wide range of heuristic tests on mail headers and
70 body text to identify ``spam'', also known as unsolicited commercial
71 email. Once identified, the mail can then be optionally tagged as spam
72 for later filtering using the user's own mail user-agent application.
73
74 %description -n perl-Mail-SpamAssassin -l pl
75 Mail::SpamAssassin jest pluginem dla Mail::Audit, s³u¿±cym do
76 identyfikacji spamu przy u¿yciu analizy zawarto¶ci i/lub internetowych
77 czarnych list. Do zidentyfikowania jako ,,spam'' stosuje szeroki
78 zakres testów heurystycznych na nag³ówkach i tre¶ci, posi³kuj±c siê
79 stworzon± wcze¶niej baz± regu³. Po zidentyfikowaniu, poczta mo¿e byæ
80 oznaczona jako spam w celu pó¼niejszego wyfiltrowania, np. przy u¿yciu
81 aplikacji do czytania poczty.
82
83
84 %prep -q
85 %setup -q -n %{pdir}-%{pnam}-%{version}
86 %patch0 -p0
87 %patch1 -p1
88
89 %build
90 %{__perl} Makefile.PL PREFIX=%{_prefix}
91 %{__make} OPTIMIZE="%{rpmcflags}" PREFIX=%{_prefix}
92 #%make test
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/mail/spamassassin,/etc/rc.d/init.d}
97
98 %{__make} install DESTDIR=$RPM_BUILD_ROOT
99
100 # shouldn't this script be called `spamd' instead?
101 install spamd/pld-rc-script.sh $RPM_BUILD_ROOT/etc/rc.d/init.d/spamassassin
102
103 rm -f spamd/{*.sh,*.conf,spam*} spamproxy/spamproxyd*
104
105 %post
106 if [ $1 = 1 ]; then
107         /sbin/chkconfig --add spamassassin
108 fi
109 if [ -f /var/lock/subsys/spamassassin ]; then
110         /etc/rc.d/init.d/spamassassin restart 1>&2
111 else
112         echo 'Run "/etc/rc.d/init.d/spamassassin start" to start the spamd daemon.'
113 fi
114
115 %preun
116 if [ $1 = 0 ]; then
117         if [ -f /var/lock/subsys/spamassassin ]; then
118                 /etc/rc.d/init.d/spamassassin stop 1>&2
119         fi
120         /sbin/chkconfig --del spamassassin
121 fi
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %files
127 %defattr(644,root,root,755)
128 %doc Changes README TODO sample-nonspam.txt sample-spam.txt spamd spamproxy
129 %attr(755,root,root) %{_bindir}/*
130 %attr(755,root,root) %{_sysconfdir}/rc.d/init.d/spamassassin
131 %config(noreplace) %{_sysconfdir}/mail/spamassassin
132 %config(noreplace) %{_datadir}/spamassassin
133 %{_mandir}/man1/*
134
135 %files tools
136 %defattr(644,root,root,755)
137 %doc sql tools masses contrib
138
139 %files -n perl-Mail-SpamAssassin
140 %defattr(644,root,root,755)
141 %{perl_sitelib}/Mail/*
142 %{perl_sitelib}/auto/Mail/*
143 %{_mandir}/man3/*
This page took 0.070938 seconds and 2 git commands to generate.