]> git.pld-linux.org Git - packages/spamassassin.git/blob - spamassassin.spec
- upgraded to 2.40
[packages/spamassassin.git] / spamassassin.spec
1 %include        /usr/lib/rpm/macros.perl
2 %define pdir    Mail
3 %define pnam    SpamAssassin
4 Summary:        A spam filter for email which can be invoked from mail delivery agents
5 Summary(pl):    Filtr antyspamowy, przeznaczony dla programów dostarczaj±cych pocztê (MDA)
6 Group:          Applications/Mail
7 Version:        2.40
8 Release:        1
9 Name:           spamassassin
10 License:        Artistic
11 Source0:        http://spamassassin.org/released/%{pdir}-%{pnam}-%{version}.tar.gz
12 Patch0:         spamassassin-rc-script.patch
13 URL:            http://spamassassin.org/
14 BuildRequires:  perl >= 5.6
15 BuildRequires:  rpm-perlprov >= 3.0.3-16
16 Prereq:         /sbin/chkconfig
17 Requires:       perl-Mail-SpamAssassin >= %{version}
18 Obsoletes:      SpamAssassin
19 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _noautoreq      'perl(Razor2::Client::Agent)' 'perl(Razor::Agent)' 'perl(Razor::Client)'
22
23 %description
24 SpamAssassin provides you with a way to reduce if not completely
25 eliminate Unsolicited Commercial Email (SPAM) from your incoming
26 email. It can be invoked by a MDA such as sendmail or postfix, or can
27 be called from a procmail script, .forward file, etc. It uses a
28 genetic-algorithm evolved scoring system to identify messages which
29 look spammy, then adds headers to the message so they can be filtered
30 by the user's mail reading software. This distribution includes the
31 spamd/spamc components which create a server that considerably speeds
32 processing of mail.
33
34 %description -l pl
35 SpamAssassin udostêpnia Ci mo¿liwo¶æ zredukowania, je¶li nie
36 kompletnego wyeliminowania Niezamawianej Komercyjnej Poczty
37 (Unsolicited Commercial Email, spamu) z Twojej poczty. Mo¿e byæ
38 wywo³ywany z MDA, np. Sendmaila czy Postfixa, lub z pliku ~/.forward
39 itp. U¿ywa ogólnego algorytmu oceniania w celu identyfikacji
40 wiadomo¶ci, które wygl±daj± na SPAM, po czym dodaje nag³ówki do
41 wiadomo¶ci, umo¿liwiaj±c filtrowanie przez oprogramowanie u¿ytkownika.
42 Ta dystrybucja zawiera programy spamd/spamc, umo¿liwiaj±ce
43 uruchomienie serwera, co znacznie przyspieszy proces przetwarzania
44 poczty.
45
46 %package tools
47 Summary:        Miscleanous tools for SpamAssassin
48 Summary(pl):    Przeró¿ne narzêdzia zwi±zane z SpamAssassin
49 Group:          Applications/Mail
50 Obsoletes:      SpamAssassin-tools
51
52 %description tools
53 Miscleanous tools from various authors, distributed with SpamAssassin.
54 See /usr/share/doc/spamassassin-tools-*/.
55
56 %description tools -l pl
57 Przeró¿ne narzêdzia, dystrybuowane razem z SpamAssassin. Zobacz
58 /usr/share/doc/spamassassin-tools-*/.
59
60 %package -n perl-Mail-SpamAssassin
61 Summary:        %{pdir}::%{pnam} -- SpamAssassin e-mail filter Perl modules
62 Summary(pl):    %{pdir}::%{pnam} -- modu³y Perla filtru poczty SpamAssassin
63 Group:          Development/Languages/Perl
64
65
66 %description -n perl-Mail-SpamAssassin
67 Mail::SpamAssassin is a Mail::Audit plugin to identify spam using text
68 analysis and several internet-based realtime blacklists. Using its
69 rule base, it uses a wide range of heuristic tests on mail headers and
70 body text to identify ``spam'', also known as unsolicited commercial
71 email. Once identified, the mail can then be optionally tagged as spam
72 for later filtering using the user's own mail user-agent application.
73
74 %description -n perl-Mail-SpamAssassin -l pl
75 Mail::SpamAssassin jest pluginem dla Mail::Audit, s³u¿±cym do
76 identyfikacji spamu przy u¿yciu analizy zawarto¶ci i/lub internetowych
77 czarnych list. Do zidentyfikowania jako ,,spam'' stosuje szeroki
78 zakres testów heurystycznych na nag³ówkach i tre¶ci, posi³kuj±c siê
79 stworzon± wcze¶niej baz± regu³. Po zidentyfikowaniu, poczta mo¿e byæ
80 oznaczona jako spam w celu pó¼niejszego wyfiltrowania, np. przy u¿yciu
81 aplikacji do czytania poczty.
82
83 %define         sa_confdir      $RPM_BUILD_ROOT%{_sysconfdir}/mail/spamassassin
84
85 %prep -q
86 %setup -q -n %{pdir}-%{pnam}-%{version}
87 %patch0 -p0
88
89 %build
90 %{__perl} Makefile.PL PREFIX=%{_prefix} SYSCONFDIR=%{_sysconfdir}
91 %{__make} OPTIMIZE="%{rpmcflags}" PREFIX=%{_prefix}
92 #%make test
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96 install -d $RPM_BUILD_ROOT{%{sa_confdir},/etc/rc.d/init.d}
97
98 %{__make} install \
99         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
100         INSTALLMAN1DIR=$RPM_BUILD_ROOT%{_prefix}/share/man/man1 \
101         INSTALLMAN3DIR=$RPM_BUILD_ROOT%{_prefix}/share/man/man3 \
102         LOCAL_RULES_DIR=$RPM_BUILD_ROOT%{_sysconfdir}/mail/spamassassin
103
104 install rules/local.cf $RPM_BUILD_ROOT%{sa_confdir}
105
106 # shouldn't this script be called `spamd' instead?
107 install spamd/pld-rc-script.sh $RPM_BUILD_ROOT/etc/rc.d/init.d/spamassassin
108
109 rm -f spamd/{*.sh,*.conf,spam*} contrib/snp.tar.gz
110
111 %post
112 if [ $1 = 1 ]; then
113         /sbin/chkconfig --add spamassassin
114 fi
115 if [ -f /var/lock/subsys/spamassassin ]; then
116         /etc/rc.d/init.d/spamassassin restart 1>&2
117 else
118         echo 'Run "/etc/rc.d/init.d/spamassassin start" to start the spamd daemon.'
119 fi
120
121 %preun
122 if [ $1 = 0 ]; then
123         if [ -f /var/lock/subsys/spamassassin ]; then
124                 /etc/rc.d/init.d/spamassassin stop 1>&2
125         fi
126         /sbin/chkconfig --del spamassassin
127 fi
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %files
133 %defattr(644,root,root,755)
134 %doc BUGS Changes COPYRIGHT INSTALL README TODO TRADEMARK
135 %doc sample-nonspam.txt sample-spam.txt spamd procmailrc.example
136 %attr(755,root,root) %{_bindir}/*
137 %attr(755,root,root) %{_sysconfdir}/rc.d/init.d/spamassassin
138 %dir %{_sysconfdir}/mail/spamassassin
139 %config(noreplace) %{_sysconfdir}/mail/spamassassin/*
140 %dir %{_datadir}/spamassassin
141 %config(noreplace) %{_datadir}/spamassassin/*
142 %{_mandir}/man1/*
143
144 %files tools
145 %defattr(644,root,root,755)
146 %doc sql tools masses contrib
147
148 %files -n perl-Mail-SpamAssassin
149 %defattr(644,root,root,755)
150 %{perl_sitelib}/Mail/*
151 %{_mandir}/man3/*
This page took 0.042734 seconds and 3 git commands to generate.