]> git.pld-linux.org Git - packages/spamassassin.git/blob - spamassassin.spec
- merged version 3.0.2 from HEAD
[packages/spamassassin.git] / spamassassin.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Mail
7 %define         pnam    SpamAssassin
8 Summary:        A spam filter for email which can be invoked from mail delivery agents
9 Summary(pl):    Filtr antyspamowy, przeznaczony dla programów dostarczaj±cych pocztê (MDA)
10 Name:           spamassassin
11 Version:        3.0.2
12 Release:        2
13 License:        Apache Software License v2
14 Group:          Applications/Mail
15 Source0:        http://www.apache.org/dist/spamassassin/%{pdir}-%{pnam}-%{version}.tar.bz2
16 # Source0-md5:  b373bc48c4f50b70cb784f40d88868bf
17 Source1:        %{name}.sysconfig
18 Source2:        %{name}-spamd.init
19 Patch0:         %{name}-utf8_mode.patch
20 URL:            http://spamassassin.apache.org/
21 BuildRequires:  openssl-devel >= 0.9.6m
22 BuildRequires:  perl-devel >= 1:5.6.1
23 BuildRequires:  perl-Digest-SHA1 >= 2.10
24 BuildRequires:  perl-HTML-Parser >= 3
25 %if %{with tests}
26 # are these really needed?
27 BuildRequires:  perl-MailTools
28 BuildRequires:  perl-MIME-Base64
29 BuildRequires:  perl-MIME-tools
30 %endif
31 BuildRequires:  rpm-perlprov >= 4.0.2-112.1
32 Requires:       perl-Mail-SpamAssassin >= %{version}
33 Obsoletes:      SpamAssassin
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         _noautoreq      'perl(Razor2::Client::Agent)' 'perl(Razor::Agent)' 'perl(Razor::Client)' 'perl(DBI)'
37
38 %description
39 SpamAssassin provides you with a way to reduce if not completely
40 eliminate Unsolicited Commercial Email (SPAM) from your incoming
41 email. It can be invoked by a MDA such as sendmail or postfix, or can
42 be called from a procmail script, .forward file, etc. It uses a
43 genetic-algorithm evolved scoring system to identify messages which
44 look spammy, then adds headers to the message so they can be filtered
45 by the user's mail reading software. This distribution includes the
46 spamd/spamc components which create a server that considerably speeds
47 processing of mail.
48
49 %description -l pl
50 SpamAssassin daje mo¿liwo¶æ zredukowania, je¶li nie kompletnego
51 wyeliminowania niezamawianej komercyjnej poczty (Unsolicited
52 Commercial Email, spamu) z poczty. Mo¿e byæ wywo³ywany z MDA, np.
53 Sendmaila czy Postfiksa, lub z pliku ~/.forward itp. U¿ywa ogólnego
54 algorytmu oceniania w celu identyfikacji wiadomo¶ci, które wygl±daj±
55 na SPAM, po czym dodaje nag³ówki do wiadomo¶ci, umo¿liwiaj±c
56 filtrowanie przez oprogramowanie u¿ytkownika. Ta dystrybucja zawiera
57 programy spamd/spamc, umo¿liwiaj±ce uruchomienie serwera, co znacznie
58 przyspieszy proces przetwarzania poczty.
59
60 %package tools
61 Summary:        Miscleanous tools for SpamAssassin
62 Summary(pl):    Przeró¿ne narzêdzia zwi±zane z SpamAssassin
63 Group:          Applications/Mail
64 Obsoletes:      SpamAssassin-tools
65
66 %description tools
67 Miscleanous tools from various authors, distributed with SpamAssassin.
68 See /usr/share/doc/spamassassin-tools-*/.
69
70 %description tools -l pl
71 Przeró¿ne narzêdzia, dystrybuowane razem ze SpamAssassinem. Wiêcej
72 informacji w /usr/share/doc/spamassassin-tools-*/.
73
74 %package spamd
75 Summary:        spamd - daemonized version of spamassassin
76 Summary(pl):    spamd - spamassassin w postaci demona
77 Group:          Applications/Mail
78 PreReq:         rc-scripts
79 Requires(post,preun):   /sbin/chkconfig
80
81 %description spamd
82 The purpose of this program is to provide a daemonized version of the
83 spamassassin executable. The goal is improving throughput performance
84 for automated mail checking.
85
86 This is intended to be used alongside "spamc", a fast, low-overhead C
87 client program.
88
89 %description spamd -l pl
90 Spamd jest "demoniczn±" wersj± spamassassina. Jego zadaniem jest
91 poprawa wydajno¶ci automatycznego sprawdzania poczty.
92
93 Spamd powinien byæ u¿ywany wespó³ ze "spamc", który jest szybkim i
94 wydajnym programem klienckim.
95
96 %package spamc
97 Summary:        spamc - client for spamd
98 Summary(pl):    spamc - klient dla spamd
99 Group:          Applications/Mail
100
101 %description spamc
102 Spamc is the client half of the spamc/spamd pair. It should be used in
103 place of "spamassassin" in scripts to process mail. It will read the
104 mail from STDIN, and spool it to its connection to spamd, then read
105 the result back and print it to STDOUT. Spamc has extremely low
106 overhead in loading, so it should be much faster to load than the
107 whole spamassassin program.
108
109 %description spamc -l pl
110 Spamc powinien byæ u¿ywany zamiast "spamassassina" w skryptach
111 przetwarzaj±cych pocztê. Zczytuje pocztê ze STDIN, kolejkuje j± a
112 nastêpnie przekazuje spamdowi, odczytuje wynik i podaje go na STDOUT.
113 Spamc stara siê nie obci±¿aæ zbytnio procesora podczas ³adowania,
114 dziêki czemu powinien dzia³aæ szybciej ni¿ sam spamassassin.
115
116 %package -n perl-Mail-SpamAssassin
117 Summary:        Mail::SpamAssassin - SpamAssassin e-mail filter libraries
118 Summary(pl):    Mail::SpamAssassin - biblioteki filtra poczty SpamAssassin
119 Group:          Development/Languages/Perl
120 Requires:       perl-HTML-Parser >= 3
121 Requires:       perl-Cache-DB_File >= 0.2
122
123 %description -n perl-Mail-SpamAssassin
124 Mail::SpamAssassin is a Mail::Audit plugin to identify spam using text
125 analysis and several internet-based realtime blacklists. Using its
126 rule base, it uses a wide range of heuristic tests on mail headers and
127 body text to identify ``spam'', also known as unsolicited commercial
128 email. Once identified, the mail can then be optionally tagged as spam
129 for later filtering using the user's own mail user-agent application.
130
131 %description -n perl-Mail-SpamAssassin -l pl
132 Mail::SpamAssassin jest pluginem dla Mail::Audit, s³u¿±cym do
133 identyfikacji spamu przy u¿yciu analizy zawarto¶ci i/lub internetowych
134 czarnych list. Do zidentyfikowania jako ,,spam'' stosuje szeroki
135 zakres testów heurystycznych na nag³ówkach i tre¶ci, posi³kuj±c siê
136 stworzon± wcze¶niej baz± regu³. Po zidentyfikowaniu, poczta mo¿e byæ
137 oznaczona jako spam w celu pó¼niejszego wyfiltrowania, np. przy u¿yciu
138 aplikacji do czytania poczty.
139
140 %prep
141 %setup -q -n %{pdir}-%{pnam}-%{version}
142 %patch0 -p1
143
144 %build
145 echo "postmaster@localhost" | \
146 %{__perl} Makefile.PL \
147         INSTALLDIRS=site \
148         PREFIX=%{_prefix} \
149         SYSCONFDIR=%{_sysconfdir} \
150         ENABLE_SSL=yes \
151         RUN_NET_TESTS=0 \
152         PERL_BIN=%{__perl}
153 %{__make} \
154         CC="%{__cc}" \
155         OPTIMIZE="%{rpmcflags}"
156
157 %{?with_tests:%{__make} test}
158
159 %install
160 rm -rf $RPM_BUILD_ROOT
161 install -d $RPM_BUILD_ROOT{/etc/{sysconfig,rc.d/init.d},%{_sysconfdir}/mail/spamassassin}
162
163 %{__make} install \
164         DESTDIR=$RPM_BUILD_ROOT
165
166 install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/spamassassin
167
168 # shouldn't this script be called `spamd' instead?
169 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/spamassassin
170
171 rm -f spamd/{*.sh,*.conf,spam*} contrib/snp.tar.gz
172
173 %clean
174 rm -rf $RPM_BUILD_ROOT
175
176 %post spamd
177 /sbin/chkconfig --add spamassassin
178 if [ -f /var/lock/subsys/spamd ]; then
179         /etc/rc.d/init.d/spamassassin restart 1>&2
180 else
181         echo 'Run "/etc/rc.d/init.d/spamassassin start" to start the spamd daemon.'
182 fi
183
184 %preun spamd
185 if [ "$1" = "0" ]; then
186         if [ -f /var/lock/subsys/spamd ]; then
187                 /etc/rc.d/init.d/spamassassin stop 1>&2
188         fi
189         /sbin/chkconfig --del spamassassin
190 fi
191
192 %files
193 %defattr(644,root,root,755)
194 %doc BUGS CREDITS Changes INSTALL README STATUS TRADEMARK UPGRADE USAGE
195 %doc procmailrc.example sample*.txt
196 %attr(755,root,root) %{_bindir}/sa-learn
197 %attr(755,root,root) %{_bindir}/spamassassin
198 %{_mandir}/man1/sa-learn*
199 %{_mandir}/man1/spamassassin*
200
201 %files tools
202 %defattr(644,root,root,755)
203 %doc sql tools masses contrib
204
205 %files spamd
206 %defattr(644,root,root,755)
207 %doc spamd/README*
208 %attr(754,root,root) /etc/rc.d/init.d/spamassassin
209 %attr(600,root,root) %config(noreplace) /etc/sysconfig/spamassassin
210 %attr(755,root,root) %{_bindir}/spamd
211 %{_mandir}/man1/spamd*
212
213 %files spamc
214 %defattr(644,root,root,755)
215 %attr(755,root,root) %{_bindir}/spamc
216 %{_mandir}/man1/spamc*
217
218 %files -n perl-Mail-SpamAssassin
219 %defattr(644,root,root,755)
220 %doc sample-nonspam.txt sample-spam.txt
221 %dir %{_sysconfdir}/mail/spamassassin
222 %config(noreplace) %{_sysconfdir}/mail/spamassassin/*
223 %dir %{_datadir}/spamassassin
224 %config(noreplace) %{_datadir}/spamassassin/*
225 %{perl_sitelib}/Mail/*
226 %{_mandir}/man3/*
This page took 0.083941 seconds and 3 git commands to generate.