]> git.pld-linux.org Git - packages/sox.git/commitdiff
- updated to 12.17
authorbszx <bszx@pld-linux.org>
Sat, 21 Oct 2000 16:39:09 +0000 (16:39 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    sox-12.15-space.patch -> 1.2
    sox-makefile.patch -> 1.1
    sox-paths.patch -> 1.2
    sox-play.patch -> 1.2

sox-12.15-space.patch [deleted file]
sox-makefile.patch [new file with mode: 0644]
sox-paths.patch
sox-play.patch

diff --git a/sox-12.15-space.patch b/sox-12.15-space.patch
deleted file mode 100644 (file)
index 86b9c4e..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
---- sox-12.15/play.orig        Wed Jan 20 11:50:22 1999
-+++ sox-12.15/play     Wed Jan 20 11:50:32 1999
-@@ -117,6 +117,6 @@
- #    fi
-     # Best to always use highest quality output for sound.
--    sox $volume $fopts $filename -t ossdsp -w -s /dev/dsp $effects
-+    sox $volume $fopts "$filename" -t ossdsp -w -s /dev/dsp $effects
-   fi
- fi
---- sox-12.15/rec.orig Wed Jan 20 11:50:25 1999
-+++ sox-12.15/rec      Wed Jan 20 11:50:40 1999
-@@ -114,6 +114,6 @@
- #      mixer $volume
- #    fi
--    sox $volume -t ossdsp /dev/dsp $fopts $filename $effects
-+    sox $volume -t ossdsp /dev/dsp $fopts "$filename" $effects
-   fi
- fi
diff --git a/sox-makefile.patch b/sox-makefile.patch
new file mode 100644 (file)
index 0000000..365002c
--- /dev/null
@@ -0,0 +1,12 @@
+--- sox-12.17/Makefile.in.old  Fri Sep  1 19:10:24 2000
++++ sox-12.17/Makefile.in      Sat Oct 21 13:30:47 2000
+@@ -95,8 +95,7 @@
+       $(srcdir)/mkinstalldirs $(BINDIR)
+       $(INSTALL) -c -m 755 $(srcdir)/play $(BINDIR)
+       $(INSTALL) -c -m 644 $(srcdir)/play.1 $(MANDIR)/man1
+-      ln -s $(BINDIR)/play $(BINDIR)/rec
+-      ln -s $(MANDIR)/man1/play.1 $(MANDIR)/man1/rec.1
++      ln -s play $(BINDIR)/rec
+ install-lib: libst.a
+       $(srcdir)/mkinstalldirs $(LIBDIR)/man1
index a9434e9a3162c8b871a2b2380147d70bb3fd1406..fc436339175d3f6dee25cc6dc746207d2b42b126 100644 (file)
@@ -9,14 +9,14 @@
  export PATH
  
  help()
---- sox-12.15/play.orig        Mon Nov 23 17:08:31 1998
-+++ sox-12.15/play     Mon Nov 23 17:08:49 1998
-@@ -28,7 +28,7 @@
+--- sox-12.15/play.orig        Sat Oct 21 12:32:37 2000
++++ sox-12.15/play     Sat Oct 21 12:34:45 2000
+@@ -14,7 +14,7 @@
  
- # Set up path to sox so that it can find it if user's path doesn't already
+ # Set up path so that it can find Sox if user's path doesn't already
  # include it.
 -PATH=$PATH:/usr/local/bin
 +PATH=$PATH:/usr/bin
- export PATH
+ program_name=`basename $0`
+ program_version="2.0"
  
- help()
index 32ad180e7ec503342371353453f311f0eac364ba..5a3f402bc8c262e0a08a93d9e5fc5be1ba7739a7 100644 (file)
@@ -1,44 +1,38 @@
---- sox-12.15/play.mike        Thu Apr  1 17:37:18 1999
-+++ sox-12.15/play     Thu Apr  1 17:40:00 1999
-@@ -49,7 +49,7 @@
- fi
- while [ $# -ne 0 ] # loop over arguments
--do case $1 in
-+do case "$1" in
-    avg|band|chorus|copy|cut|echo|echos|flanger|highp|lowp|map|mask|phaser|pick|pred|rate|resample|reverb|reverse|split|stat|vibro)
-      effects="$@"
-      break
-@@ -91,32 +91,6 @@
-    shift
+--- sox-12.17/play.orig        Sat Oct 21 12:39:28 2000
++++ sox-12.17/play     Sat Oct 21 12:44:00 2000
+@@ -156,31 +156,10 @@
+     shift
  done
  
 -arch=`uname -s`
--
--if [ "$arch" = "SunOS" ]; then
--
--  case `arch -k` in
--    sun4|sun4c|sun4d)
--      # Use below for older Sun audio hardware
--      sox $volume $fopts $filename -t sunau -U -c 1 /dev/audio $effects
--      ;;
--
--    *)
--      # Use below for newer Sun audio hardware that supports stereo linear
--      sox $volume $fopts $filename -t sunau -w -s /dev/audio $effects
--      ;;
--
--  esac
--
--else
--  if [ "$arch" = "Linux" ]; then
--
--# Possible way to set volume
--#    if [ "$volume" != "" ] ; then
--#      mixer $volume
--#    fi
+-case $arch in
+-  SunOS)
+-    case `uname -r` in
+-        # Solaris software can auto-detect hardware capabilities.
+-        5.*)
+-          arch_defines="-t sunau"
+-          ;;
+-      # For SunOS default to signed words.  Some hardware can only play u-law and would need
+-      # to be changed here.
+-      *)
+-          arch_defines="-t sunau -w -s"
+-          ;;
+-    esac
+-    if [ -z "$device" ]; then
+-      device="/dev/audio"
+-    fi
+-    ;;
+-  Linux|FreeBSD)
+-    arch_defines="-t ossdsp"
+-    if [ -z "$device" ]; then
+-      device="/dev/dsp"
+-    fi
+-    ;;
+-esac
++arch_defines="-t ossdsp"
++if [ -z "$device" ]; then
++    device="/dev/dsp"
++fi
  
-     # Best to always use highest quality output for sound.
-     sox $volume $fopts "$filename" -t ossdsp -w -s /dev/dsp $effects
--  fi
--fi
+ # If name is "rec" then record else assume user is wanting to play
+ # a sound file.
This page took 0.031363 seconds and 4 git commands to generate.