]> git.pld-linux.org Git - packages/source-highlight.git/commitdiff
force c++14 standard to fix build with gcc 11
authorJan Palus <atler@pld-linux.org>
Mon, 9 Aug 2021 18:48:33 +0000 (20:48 +0200)
committerJan Palus <atler@pld-linux.org>
Mon, 9 Aug 2021 18:48:33 +0000 (20:48 +0200)
gcc 11 defaults to c++17 which breaks build due to dynamic throw clauses
still used in source-highlight. use c++14 instead which gcc 9 defaulted
to at the time last version was released.

source-highlight.spec

index 8207200744f8a4e4c592e47149951b21618d028f..049a4e8f2cce4666f35943471c161c68250b43fb 100644 (file)
@@ -89,6 +89,7 @@ source-highlight.
 %patch0 -p1
 
 %build
+export CXXFLAGS="%{rpmcxxflags} -std=c++14"
 %configure \
        --with-boost-libdir=%{_libdir}
 %{__make}
This page took 0.03915 seconds and 4 git commands to generate.