]> git.pld-linux.org Git - packages/simplescreenrecorder.git/blob - simplescreenrecorder.spec
e22b2cb7f3ca6443f04e98317d0f81ed8b775bf6
[packages/simplescreenrecorder.git] / simplescreenrecorder.spec
1 %ifarch %{ix86} %{x8664} x32
2 %define         with_gl         1
3 %endif
4
5 %define         qtver   5.7
6 Summary:        Screen recorder for Linux
7 Summary(pl.UTF-8):      Nagrywarka ekranu dla Linuksa
8 Name:           simplescreenrecorder
9 Version:        0.4.4
10 Release:        1
11 License:        GPL v3
12 Group:          Applications
13 Source0:        https://github.com/MaartenBaert/ssr/archive/%{version}/ssr-%{version}.tar.gz
14 # Source0-md5:  6360ff633bcb88b0c221d56fd52b7dac
15 URL:            http://www.maartenbaert.be/simplescreenrecorder/
16 BuildRequires:  Mesa-libGL-devel
17 BuildRequires:  Mesa-libGLU-devel
18 BuildRequires:  Qt5Core-devel >= %{qtver}
19 BuildRequires:  Qt5Gui-devel >= %{qtver}
20 BuildRequires:  Qt5Widgets-devel >= %{qtver}
21 BuildRequires:  Qt5X11Extras-devel >= %{qtver}
22 BuildRequires:  alsa-lib-devel
23 BuildRequires:  cmake >= 3.1
24 BuildRequires:  ffmpeg-devel
25 BuildRequires:  jack-audio-connection-kit-devel
26 BuildRequires:  libv4l-devel
27 BuildRequires:  pulseaudio-devel
28 BuildRequires:  qt5-build >= %{qtver}
29 BuildRequires:  qt5-linguist >= %{qtver}
30 BuildRequires:  rpmbuild(macros) >= 1.742
31 BuildRequires:  xorg-lib-libX11-devel
32 BuildRequires:  xorg-lib-libXext-devel
33 BuildRequires:  xorg-lib-libXfixes-devel
34 BuildRequires:  xorg-lib-libXi-devel
35 Requires:       Qt5Core >= %{qtver}
36 Requires:       Qt5Gui >= %{qtver}
37 Requires:       Qt5Gui-platform-xcb
38 Requires:       Qt5Widgets >= %{qtver}
39 Requires:       Qt5X11Extras >= %{qtver}
40 %if %{with gl}
41 Suggests:       %{name}-glinject = %{version}-%{release}
42 %endif
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 SimpleScreenRecorder is a screen recorder for Linux. Despite the name,
47 this program is actually quite complex. It's 'simple' in the sense
48 that it's easier to use than ffmpeg/avconv or VLC :).
49
50 %package glinject
51 Summary:        SimpleScreenRecorder - wrapper library for recording OpenGL
52 Group:          Applications
53
54 %description glinject
55 A wrapper library and a script to inject screen recording calls into
56 OpenGL applications, for use with the SimpleScreenRecorder.
57
58 %prep
59 %setup -q -n ssr-%{version}
60
61 %build
62 %cmake \
63         -DLRELEASE=/usr/bin/lrelease-qt5 \
64         %{cmake_on_off gl WITH_GLINJECT} \
65         %{cmake_on_off gl WITH_OPENGL_RECORDING} \
66         -DWITH_JACK=ON \
67         -DWITH_PULSEAUDIO=ON \
68         -DWITH_QT5=ON
69
70 %{__make}
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %{__make} install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 %find_lang %{name} --with-qm
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files -f %{name}.lang
84 %defattr(644,root,root,755)
85 %doc AUTHORS.md CHANGELOG.md README.md *.txt
86 %attr(755,root,root) %{_bindir}/simplescreenrecorder
87 %dir %{_datadir}/simplescreenrecorder
88 %{_datadir}/simplescreenrecorder/output-profiles
89 %dir %{_datadir}/simplescreenrecorder/translations
90 %{_mandir}/man1/simplescreenrecorder.1*
91 %{_iconsdir}/*/*/apps/simplescreenrecorder*.png
92 %{_iconsdir}/hicolor/scalable/apps/simplescreenrecorder*.svg
93 %{_desktopdir}/simplescreenrecorder.desktop
94 %{_datadir}/metainfo/simplescreenrecorder.metainfo.xml
95
96 %if %{with gl}
97 %files glinject
98 %defattr(644,root,root,755)
99 %attr(755,root,root) %{_bindir}/ssr-glinject
100 %attr(755,root,root) %{_libdir}/libssr-glinject.so
101 %{_mandir}/man1/ssr-glinject.1*
102 %endif
This page took 0.109593 seconds and 2 git commands to generate.