]> git.pld-linux.org Git - packages/shotwell.git/blob - shotwell.spec
d106fd0f3643eda3832d95b48dba94641849ecd1
[packages/shotwell.git] / shotwell.spec
1 #
2 # Conditional build:
3 %bcond_with     unity   # Ubuntu Unity integration
4 #
5 Summary:        Photo manager for GNOME
6 Summary(pl.UTF-8):      Zarządca zdjęć dla GNOME
7 Name:           shotwell
8 Version:        0.24.5
9 Release:        2
10 License:        LGPL v2+ and CC-BY-SA
11 Group:          X11/Applications
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/shotwell/0.24/%{name}-%{version}.tar.xz
13 # Source0-md5:  17e4f81947a2824b00789cfb05512bb8
14 Patch0:         %{name}-link.patch
15 Patch1:         %{name}-gitversion.patch
16 URL:            https://wiki.gnome.org/Apps/Shotwell
17 BuildRequires:  appstream-glib-devel
18 BuildRequires:  atk-devel
19 BuildRequires:  autoconf >= 2.69
20 BuildRequires:  automake >= 1:1.11
21 BuildRequires:  gettext-tools >= 0.19.7
22 BuildRequires:  gexiv2-devel >= 0.4.90
23 BuildRequires:  glib2-devel >= 1:2.32.0
24 BuildRequires:  gnome-doc-utils
25 BuildRequires:  gstreamer-devel >= 1.0.0
26 BuildRequires:  gstreamer-plugins-base-devel >= 1.0.0
27 BuildRequires:  gtk+3-devel >= 3.12.2
28 BuildRequires:  gtk-webkit4-devel
29 BuildRequires:  json-glib-devel >= 0.6.16
30 BuildRequires:  libexif-devel >= 1:0.6.16
31 BuildRequires:  libgee-devel >= 0.8.5
32 BuildRequires:  libgphoto2-devel >= 2.5.0
33 BuildRequires:  libraw-devel >= 0.14.7-2
34 BuildRequires:  libsoup-devel >= 2.26.0
35 BuildRequires:  libtool >= 2:2.2
36 %{?with_unity:BuildRequires:    libunity-devel}
37 BuildRequires:  libxml2-devel >= 1:2.6.32
38 BuildRequires:  pkgconfig >= 1:0.22
39 BuildRequires:  rest-devel >= 0.7
40 BuildRequires:  rpmbuild(macros) >= 1.311
41 BuildRequires:  sqlite3-devel >= 3.5.9
42 BuildRequires:  udev-glib-devel >= 1:145
43 BuildRequires:  vala >= 2:0.28.0
44 BuildRequires:  vala-gexiv2 >= 0.4.90
45 BuildRequires:  vala-libgee >= 0.8.5
46 BuildRequires:  yelp-tools
47 Requires(post,postun):  desktop-file-utils
48 Requires(post,postun):  glib2 >= 1:2.32.0
49 Requires(post,postun):  gtk-update-icon-cache
50 Requires(post,postun):  hicolor-icon-theme
51 Requires:       glib2 >= 1:2.32.0
52 Requires:       gtk+3 >= 3.12.2
53 Requires:       gtk-webkit4
54 Requires:       hicolor-icon-theme
55 Requires:       libexif >= 1:0.6.16
56 Requires:       libgphoto2 >= 2.5.0
57 Requires:       libraw >= 0.14.7-2
58 Requires:       libsoup >= 2.26.0
59 Requires:       libxml2 >= 1:2.6.32
60 Requires:       sqlite3 >= 3.5.9
61 Requires:       udev-glib >= 1:145
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 %description
65 Shotwell is a digital photo organizer designed for the GNOME desktop
66 environment. It allows you to import photos from disk or camera,
67 organize them in various ways, view them in full-window or fullscreen
68 mode, and export them to share with others.
69
70 %description -l pl.UTF-8
71 Shotwell to organizator zdjęć cyfrowych, zaprojektowany dla środowiska
72 graficznego GNOME. Pozwala importować zdjęcia z dysku lub aparatu,
73 organizować je na różne sposoby, przeglądać w trybie okienkowym lub
74 pełnoekranowym oraz eksportować, aby podzielić się nimi z innymi.
75
76 %prep
77 %setup -q
78 %patch0 -p1
79 %patch1 -p1
80
81 # force rebuild without _GITVERSION
82 %{__rm} src/Resources.c
83
84 %build
85 %{__libtoolize}
86 %{__aclocal} -I m4
87 %{__autoconf}
88 %{__autoheader}
89 %{__automake}
90 %configure \
91         --disable-schemas-compile \
92         --disable-silent-rules \
93         %{?with_unity:--enable-unity-support}
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 %{__make} install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
103 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/builtin/*.la
104
105 %find_lang shotwell --with-gnome
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %post
111 %update_icon_cache hicolor
112 %update_desktop_database
113 %glib_compile_schemas
114
115 %postun
116 %update_icon_cache hicolor
117 %update_desktop_database_postun
118 %glib_compile_schemas
119
120 %files -f shotwell.lang
121 %defattr(644,root,root,755)
122 %doc AUTHORS COPYING NEWS README THANKS
123 %attr(755,root,root) %{_bindir}/shotwell
124 %attr(755,root,root) %{_libdir}/libshotwell-plugin-common.so*
125 %{_desktopdir}/%{name}-viewer.desktop
126 %{_desktopdir}/%{name}.desktop
127 %dir %{_libdir}/%{name}
128 %attr(755,root,root) %{_libdir}/shotwell/shotwell-settings-migrator
129 %attr(755,root,root) %{_libdir}/shotwell/shotwell-video-thumbnailer
130 %{_datadir}/appdata/shotwell.appdata.xml
131 %{_datadir}/%{name}
132 %{_datadir}/glib-2.0/schemas/org.yorba.shotwell.gschema.xml
133 %{_datadir}/glib-2.0/schemas/org.yorba.shotwell-extras.gschema.xml
134 %dir %{_libdir}/%{name}/plugins
135 %dir %{_libdir}/%{name}/plugins/builtin
136 %attr(755,root,root) %{_libdir}/%{name}/plugins/builtin/*.so
137 %{_iconsdir}/hicolor/*x*/apps/shotwell.png
138 %{_iconsdir}/hicolor/symbolic/apps/shotwell-symbolic.svg
139 %{_mandir}/man1/shotwell.1*
This page took 0.063336 seconds and 2 git commands to generate.