]> git.pld-linux.org Git - packages/shotwell.git/blob - shotwell.spec
Update to 0.26.1
[packages/shotwell.git] / shotwell.spec
1 #
2 # Conditional build:
3 %bcond_with     unity   # Ubuntu Unity integration
4 #
5 Summary:        Photo manager for GNOME
6 Summary(pl.UTF-8):      Zarządca zdjęć dla GNOME
7 Name:           shotwell
8 Version:        0.26.1
9 Release:        1
10 License:        LGPL v2+ and CC-BY-SA
11 Group:          X11/Applications
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/shotwell/0.26/%{name}-%{version}.tar.xz
13 # Source0-md5:  1e9cb403756f789a78df6f9fa1e972fa
14 Patch0:         %{name}-link.patch
15 Patch1:         %{name}-gitversion.patch
16 URL:            https://wiki.gnome.org/Apps/Shotwell
17 BuildRequires:  appstream-glib-devel
18 BuildRequires:  atk-devel
19 BuildRequires:  autoconf >= 2.69
20 BuildRequires:  automake >= 1:1.11
21 BuildRequires:  cairo-devel
22 BuildRequires:  gcr-ui-devel
23 BuildRequires:  gdk-pixbuf2-devel
24 BuildRequires:  gettext-tools >= 0.19.7
25 BuildRequires:  gexiv2-devel >= 0.10.4
26 BuildRequires:  glib2-devel >= 1:2.40.0
27 BuildRequires:  gnome-doc-utils
28 BuildRequires:  gstreamer-devel >= 1.0.0
29 BuildRequires:  gstreamer-plugins-base-devel >= 1.0.0
30 BuildRequires:  gtk+3-devel >= 3.14.0
31 BuildRequires:  gtk-webkit4-devel
32 BuildRequires:  json-glib-devel >= 0.6.16
33 BuildRequires:  libexif-devel >= 1:0.6.16
34 BuildRequires:  libgdata-devel
35 BuildRequires:  libgee-devel >= 0.8.5
36 BuildRequires:  libgphoto2-devel >= 2.5.0
37 BuildRequires:  libraw-devel >= 0.14.7-2
38 BuildRequires:  libsoup-devel >= 2.26.0
39 BuildRequires:  libtool >= 2:2.2
40 %{?with_unity:BuildRequires:    libunity-devel}
41 BuildRequires:  libxml2-devel >= 1:2.6.32
42 BuildRequires:  pkgconfig >= 1:0.22
43 BuildRequires:  rest-devel >= 0.7
44 BuildRequires:  rpmbuild(macros) >= 1.311
45 BuildRequires:  sqlite3-devel >= 3.5.9
46 BuildRequires:  udev-glib-devel >= 1:145
47 BuildRequires:  vala >= 2:0.28.0
48 BuildRequires:  vala-gexiv2 >= 0.4.90
49 BuildRequires:  vala-libgee >= 0.8.5
50 BuildRequires:  yelp-tools
51 Requires(post,postun):  desktop-file-utils
52 Requires(post,postun):  glib2 >= 1:2.32.0
53 Requires(post,postun):  gtk-update-icon-cache
54 Requires(post,postun):  hicolor-icon-theme
55 Requires:       gexiv2 >= 0.10.4
56 Requires:       glib2 >= 1:2.40.0
57 Requires:       gtk+3 >= 3.14.0
58 Requires:       gtk-webkit4
59 Requires:       hicolor-icon-theme
60 Requires:       libexif >= 1:0.6.16
61 Requires:       libgphoto2 >= 2.5.0
62 Requires:       libraw >= 0.14.7-2
63 Requires:       libsoup >= 2.26.0
64 Requires:       libxml2 >= 1:2.6.32
65 Requires:       sqlite3 >= 3.5.9
66 Requires:       udev-glib >= 1:145
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %description
70 Shotwell is a digital photo organizer designed for the GNOME desktop
71 environment. It allows you to import photos from disk or camera,
72 organize them in various ways, view them in full-window or fullscreen
73 mode, and export them to share with others.
74
75 %description -l pl.UTF-8
76 Shotwell to organizator zdjęć cyfrowych, zaprojektowany dla środowiska
77 graficznego GNOME. Pozwala importować zdjęcia z dysku lub aparatu,
78 organizować je na różne sposoby, przeglądać w trybie okienkowym lub
79 pełnoekranowym oraz eksportować, aby podzielić się nimi z innymi.
80
81 %prep
82 %setup -q
83 %patch0 -p1
84 %patch1 -p1
85
86 # force rebuild without _GITVERSION
87 %{__rm} src/Resources.c
88
89 %build
90 %{__libtoolize}
91 %{__aclocal} -I m4
92 %{__autoconf}
93 %{__autoheader}
94 %{__automake}
95 %configure \
96         --disable-schemas-compile \
97         --disable-silent-rules \
98         %{?with_unity:--enable-unity-support}
99 %{__make}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 %{__make} install \
105         DESTDIR=$RPM_BUILD_ROOT
106
107 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
108 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins/builtin/*.la
109
110 %find_lang shotwell --with-gnome
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post
116 %update_icon_cache hicolor
117 %update_desktop_database
118 %glib_compile_schemas
119
120 %postun
121 %update_icon_cache hicolor
122 %update_desktop_database_postun
123 %glib_compile_schemas
124
125 %files -f shotwell.lang
126 %defattr(644,root,root,755)
127 %doc AUTHORS COPYING NEWS README THANKS
128 %attr(755,root,root) %{_bindir}/shotwell
129 %attr(755,root,root) %{_libdir}/libshotwell-authenticator.so*
130 %attr(755,root,root) %{_libdir}/libshotwell-plugin-common.so*
131 %{_desktopdir}/%{name}-viewer.desktop
132 %{_desktopdir}/%{name}.desktop
133 %dir %{_libdir}/%{name}
134 %attr(755,root,root) %{_libdir}/shotwell/shotwell-settings-migrator
135 %attr(755,root,root) %{_libdir}/shotwell/shotwell-video-thumbnailer
136 %{_datadir}/appdata/shotwell.appdata.xml
137 %{_datadir}/glib-2.0/schemas/org.yorba.shotwell.gschema.xml
138 %{_datadir}/glib-2.0/schemas/org.yorba.shotwell-extras.gschema.xml
139 %dir %{_libdir}/%{name}/plugins
140 %dir %{_libdir}/%{name}/plugins/builtin
141 %attr(755,root,root) %{_libdir}/%{name}/plugins/builtin/*.so
142 %{_iconsdir}/hicolor/*x*/apps/shotwell.png
143 %{_iconsdir}/hicolor/symbolic/apps/shotwell-symbolic.svg
144 %{_mandir}/man1/shotwell.1*
This page took 0.074503 seconds and 3 git commands to generate.