]> git.pld-linux.org Git - packages/setup.git/commitdiff
- bugfixes, unexpanding, more aliases from PLD services
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 25 Nov 2007 16:24:26 +0000 (16:24 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    setup-iana-etc.patch -> 1.1

setup-iana-etc.patch [new file with mode: 0644]

diff --git a/setup-iana-etc.patch b/setup-iana-etc.patch
new file mode 100644 (file)
index 0000000..4a7d6d7
--- /dev/null
@@ -0,0 +1,82 @@
+--- setup-2.4.11/iana-etc-2.20/services.gawk.orig      2006-11-14 21:26:22.000000000 +0100
++++ setup-2.4.11/iana-etc-2.20/services.gawk   2007-11-25 17:06:06.113293195 +0100
+@@ -16,7 +16,7 @@
+     while (getline <"port-aliases") {
+       sub(/#.*/, "")
+       if (/^[ \t]*$/) { continue }
+-      alias_list[$1] = substr($0, index($0, $2))
++      alias_list[$1] = substr($0, index(substr($0, length($1)), $2)+length($1)-1)
+     }
+ }
+ function aliases(n) {
+@@ -43,6 +43,8 @@
+     if (length(protocols[0]) == 0) {
+       protocols[0] = "/tcp"
+       protocols[1] = "/udp"
++    } else if (1 in protocols) {
++      delete protocols[1]
+     }
+     for (i = start; i <= end; i++) {
+       for (p in protocols) {
+--- setup-2.4.11/iana-etc-2.20/Makefile.orig   2006-11-14 18:53:41.000000000 +0100
++++ setup-2.4.11/iana-etc-2.20/Makefile        2007-11-25 15:16:05.825164209 +0100
+@@ -65,10 +65,10 @@
+ protocols: protocol-numbers protocols.gawk
+       $(AWK) --re-interval -f protocols.gawk -v strip=$(STRIP) \
+-          protocol-numbers > protocols
++          protocol-numbers | unexpand -a > protocols
+ services: port-numbers services.gawk
+-      $(AWK) -f services.gawk -v strip=$(STRIP) port-numbers > services
++      $(AWK) -f services.gawk -v strip=$(STRIP) port-numbers | unexpand -a > services
+ dist: clean
+       rm -vrf ../iana-etc-`cat VERSION`
+--- setup-2.4.11/iana-etc-2.20/port-aliases.orig       2006-11-14 17:01:10.000000000 +0100
++++ setup-2.4.11/iana-etc-2.20/port-aliases    2007-11-25 15:59:09.044373483 +0100
+@@ -12,3 +12,44 @@
+ nicname whois
++# PLD additions
++discard sink null
++systat users
++qotd quote
++chargen ttytst source
++smtp mail
++time timserver
++rlp resource
++name nameserver
++http www www-http
++kerberos krb5 kerberos5
++hostname hostnames
++iso-tsap tsap
++cso csnet-ns cso-ns
++pop2 postoffice pop pop-2
++pop3 pop-3
++sunrpc portmapper
++auth tap
++nntp untp
++imap imap2
++snmptrap snmp-trap
++z39.50 z3950 wais
++biff comsat
++who whod
++shell cmd
++printer spooler
++utime unixtime
++router route routed
++courier rpc
++conference chat
++netnews readnews
++uucp uucpd
++kshell krcmd
++new-rwho new-who
++rmonitor rmonitord
++nntps snntp
++kerberos-iv kerberos4
++telnets stelnet
++postgresql postgres
++jms irrd
++sane-port sane
This page took 0.065438 seconds and 4 git commands to generate.