]> git.pld-linux.org Git - packages/serf.git/blob - serf.spec
a7e780e2a2f695de33e9a297083d5d40defc4ca0
[packages/serf.git] / serf.spec
1 #
2 # Conditional build:
3 %bcond_without  kerberos5       # GSSAPI support
4 %bcond_with     tests           # perform "scons check" (uses localhost network, fails on apr side when IPV6 is enabled and localhost resolves only to IPV4 addresses)
5 #
6 Summary:        A high-performance asynchronous HTTP client library
7 Summary(pl.UTF-8):      Wysokowydajna biblioteka asynchronicznego klienta HTTP
8 Name:           serf
9 Version:        1.3.9
10 Release:        1
11 License:        Apache v2.0
12 Group:          Libraries
13 Source0:        https://www.apache.org/dist/serf/%{name}-%{version}.tar.bz2
14 # Source0-md5:  370a6340ff20366ab088012cd13f2b57
15 Patch0:         %{name}-scons.patch
16 URL:            https://serf.apache.org/
17 BuildRequires:  apr-devel
18 BuildRequires:  apr-util-devel
19 %{?with_kerberos5:BuildRequires:        heimdal-devel}
20 BuildRequires:  openssl-devel >= 0.9.7d
21 BuildRequires:  scons >= 2.3.0
22 BuildRequires:  zlib-devel
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 The serf library is a C-based HTTP client library built upon the
27 Apache Portable Runtime (APR) library. It multiplexes connections,
28 running the read/write communication asynchronously. Memory copies and
29 transformations are kept to a minimum to provide high performance
30 operation.
31
32 %description -l pl.UTF-8
33 Biblioteka serf to napisana w C biblioteka klienta HTTP stworzona w
34 oparciu o bibliotekę Apache Portable Runtime (APR). Obsługuje
35 połączenia naprzemiennie, wywołując asynchronicznie komunikację
36 odczyt-zapis. Kopiowanie i transformacje w pamięci są ograniczone do
37 minimum w celu zapewnienia wydajnego działania.
38
39 %package devel
40 Summary:        Header files for serf
41 Summary(pl.UTF-8):      Pliki nagłówkowe serf
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       apr-devel
45 Requires:       apr-util-devel
46 %{?with_kerberos5:Requires:     heimdal-devel}
47 Requires:       openssl-devel >= 0.9.7d
48
49 %description devel
50 C header files for the serf library.
51
52 %description devel -l pl.UTF-8
53 Pliki nagłówkowe dla biblioteki serf.
54
55 %package static
56 Summary:        Static libraries for serf
57 Summary(pl.UTF-8):      Biblioteki statyczne serf
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{version}-%{release}
60
61 %description static
62 Static serf libraries.
63
64 %description static -l pl.UTF-8
65 Statyczne biblioteki serf.
66
67 %prep
68 %setup -q
69 %patch0 -p1
70
71 %build
72 %scons \
73         PREFIX=%{_prefix} \
74         LIBDIR=%{_libdir} \
75         GSSAPI=/usr
76
77 %if %{with tests}
78 %scons check
79 %endif
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 %scons install \
85         PREFIX=%{_prefix} \
86         LIBDIR=%{_libdir} \
87         --install-sandbox=$RPM_BUILD_ROOT
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post   -p /sbin/ldconfig
93 %postun -p /sbin/ldconfig
94
95 %files
96 %defattr(644,root,root,755)
97 %doc CHANGES NOTICE README
98 %attr(755,root,root) %{_libdir}/libserf-1.so.*.*.*
99 %attr(755,root,root) %ghost %{_libdir}/libserf-1.so.1
100
101 %files devel
102 %defattr(644,root,root,755)
103 %attr(755,root,root) %{_libdir}/libserf-1.so
104 %{_includedir}/serf-1
105 %{_pkgconfigdir}/serf-1.pc
106
107 %files static
108 %defattr(644,root,root,755)
109 %{_libdir}/libserf-1.a
This page took 0.077682 seconds and 2 git commands to generate.