]> git.pld-linux.org Git - packages/seamonkey.git/blob - seamonkey.spec
- updated files when building with system xulrunner (enigmail not supported; mail...
[packages/seamonkey.git] / seamonkey.spec
1 #
2 # Conditional build:
3 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
4 %bcond_without  gnomeui         # disable gnomeui support
5 %bcond_without  gnome           # disable gnomeui (alias)
6 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
7 %bcond_without  lightning       # disable Sunbird/Lightning calendar
8 %bcond_with     xulrunner       # build with system xulrunner (incomplete? enigmail not supported)
9 %bcond_with     tests           # enable tests (whatever they check)
10 %bcond_without  kerberos        # disable krb5 support
11
12 %if %{without gnome}
13 %undefine       with_gnomeui
14 %endif
15
16 %define         enigmail_ver    1.5.1
17 %define         nspr_ver        4.9.3
18 %define         nss_ver         3.14.1
19 %define         xulrunner_ver   19.0
20
21 %if %{without xulrunner}
22 # The actual sqlite version (see RHBZ#480989):
23 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
24 %endif
25
26 Summary:        SeaMonkey Community Edition - web browser
27 Summary(es.UTF-8):      Navegador de Internet SeaMonkey Community Edition
28 Summary(pl.UTF-8):      SeaMonkey Community Edition - przeglądarka WWW
29 Summary(pt_BR.UTF-8):   Navegador SeaMonkey Community Edition
30 Name:           seamonkey
31 Version:        2.16
32 Release:        1
33 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
34 Group:          X11/Applications/Networking
35 Source0:        http://ftp.mozilla.org/pub/mozilla.org/seamonkey/releases/%{version}/source/%{name}-%{version}.source.tar.bz2
36 # Source0-md5:  29e360eae42d7a9cca7f25c1ad44f1d5
37 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
38 # Source1-md5:  3e71f84ed2c11471282412ebe4f5eb2d
39 Source4:        %{name}.desktop
40 Source5:        %{name}-composer.desktop
41 Source6:        %{name}-chat.desktop
42 Source7:        %{name}-mail.desktop
43 Source8:        %{name}-venkman.desktop
44 Source9:        %{name}.sh
45 Patch1:         %{name}-pld-branding.patch
46 Patch2:         %{name}-agent.patch
47 Patch3:         %{name}-glueload-fix.patch
48 Patch4:         system-mozldap.patch
49 Patch5:         makefile.patch
50 Patch6:         system-cairo.patch
51 # Edit patch below and restore --system-site-packages when system virtualenv gets 1.7 upgrade
52 Patch7:         %{name}-system-virtualenv.patch
53 Patch8:         %{name}-gyp-slashism.patch
54 Patch9:         %{name}-system-xulrunner.patch
55 URL:            http://www.seamonkey-project.org/
56 BuildRequires:  GConf2-devel >= 1.2.1
57 BuildRequires:  OpenGL-devel
58 BuildRequires:  alsa-lib-devel
59 BuildRequires:  automake
60 BuildRequires:  bzip2-devel
61 BuildRequires:  cairo-devel >= 1.10.2-5
62 BuildRequires:  dbus-glib-devel >= 0.60
63 BuildRequires:  freetype-devel >= 1:2.1.8
64 BuildRequires:  glib2-devel >= 1:2.18
65 BuildRequires:  gtk+2-devel >= 2:2.10
66 %{?with_kerberos:BuildRequires: heimdal-devel >= 0.7.1}
67 BuildRequires:  hunspell-devel
68 BuildRequires:  libIDL-devel >= 0.8.0
69 BuildRequires:  libdnet-devel
70 BuildRequires:  libevent-devel >= 1.4.7
71 # standalone libffi 3.0.9 or gcc's from 4.5(?)+
72 BuildRequires:  libffi-devel >= 6:3.0.9
73 %{?with_gnomeui:BuildRequires:  libgnome-devel >= 2.0}
74 %{?with_gnomeui:BuildRequires:  libgnome-keyring-devel}
75 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
76 BuildRequires:  libiw-devel
77 # requires libjpeg-turbo implementing at least libjpeg 6b API
78 BuildRequires:  libjpeg-devel >= 6b
79 BuildRequires:  libjpeg-turbo-devel
80 BuildRequires:  libnotify-devel >= 0.4
81 BuildRequires:  libpng(APNG)-devel >= 0.10
82 BuildRequires:  libpng-devel >= 1.4.1
83 BuildRequires:  libstdc++-devel
84 BuildRequires:  libvpx-devel >= 1.0.0
85 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
86 BuildRequires:  nss-devel >= 1:%{nss_ver}
87 BuildRequires:  pango-devel >= 1:1.14.0
88 BuildRequires:  perl-base >= 1:5.6
89 BuildRequires:  perl-modules >= 5.004
90 BuildRequires:  pkgconfig
91 BuildRequires:  python >= 1:2.5
92 BuildRequires:  python-modules
93 BuildRequires:  python-virtualenv
94 BuildRequires:  rpm >= 4.4.9-56
95 BuildRequires:  rpmbuild(macros) >= 1.601
96 BuildRequires:  sed >= 4.0
97 BuildRequires:  sqlite3-devel >= 3.7.10
98 BuildRequires:  startup-notification-devel >= 0.8
99 BuildRequires:  xorg-lib-libXScrnSaver-devel
100 BuildRequires:  xorg-lib-libXext-devel
101 BuildRequires:  xorg-lib-libXinerama-devel
102 BuildRequires:  xorg-lib-libXt-devel
103 %if %{with xulrunner}
104 BuildRequires:  xulrunner-devel >= 2:%{xulrunner_ver}
105 %endif
106 BuildRequires:  yasm
107 BuildRequires:  zip
108 BuildRequires:  zlib-devel >= 1.2.3
109 Requires(post): mktemp >= 1.5-18
110 Requires:       desktop-file-utils
111 Requires:       hicolor-icon-theme
112 %if %{with xulrunner}
113 %requires_eq_to xulrunner xulrunner-devel
114 %else
115 Requires:       browser-plugins >= 2.0
116 Requires:       cairo >= 1.10.2-5
117 Requires:       dbus-glib >= 0.60
118 Requires:       gtk+2 >= 2:2.18
119 Requires:       libjpeg-turbo
120 Requires:       libpng >= 1.4.1
121 Requires:       libpng(APNG) >= 0.10
122 Requires:       myspell-common
123 Requires:       nspr >= 1:%{nspr_ver}
124 Requires:       nss >= 1:%{nss_ver}
125 Requires:       pango >= 1:1.14.0
126 Requires:       sqlite3 >= %{sqlite_build_version}
127 Requires:       startup-notification >= 0.8
128 %endif
129 Provides:       seamonkey-embedded = %{version}-%{release}
130 Provides:       wwwbrowser
131 Obsoletes:      light
132 Obsoletes:      mozilla
133 Obsoletes:      mozilla-gnomevfs
134 Obsoletes:      seamonkey-calendar
135 Obsoletes:      seamonkey-libs
136 Obsoletes:      seamonkey-mailnews
137 Obsoletes:      seamonkey-gnomevfs
138 Conflicts:      seamonkey-lang-resources < %{version}
139 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
140
141 %define         topdir          %{_builddir}/%{name}-%{version}
142 %define         objdir          %{topdir}/obj-%{_target_cpu}
143
144 %define         filterout_cpp   -D_FORTIFY_SOURCE=[0-9]+
145
146 # don't satisfy other packages
147 %define         _noautoprovfiles        %{_libdir}/%{name}
148 # and as we don't provide them, don't require either
149 %define         _noautoreq      libmozjs.so libxpcom.so libxul.so libjemalloc.so %{!?with_xulrunner:libmozalloc.so}
150 %define         _noautoreqdep   libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpistub.so
151
152 %description
153 SeaMonkey Community Edition is an open-source web browser, designed
154 for standards compliance, performance and portability.
155
156 %description -l es.UTF-8
157 SeaMonkey Community Edition es un navegador de Internet que se basa en
158 una versión inicial de Netscape Communicator.
159
160 %description -l pl.UTF-8
161 SeaMonkey Community Edition jest potężną graficzną przeglądarką WWW,
162 która jest następcą Mozilli, która następnie była następczynią
163 Netscape Communikatora.
164
165 %description -l pt_BR.UTF-8
166 O SeaMonkey Community Edition é um web browser baseado numa versão
167 inicial do Netscape Communicator.
168
169 %description -l ru.UTF-8
170 SeaMonkey Community Edition - полнофункциональный web-browser с
171 открытыми исходными текстами, разработанный для максимального
172 соотвествия стандартам, максмимальной переносимости и скорости работы
173
174 %package addon-lightning
175 Summary:        An integrated calendar for SeaMonkey
176 Summary(pl.UTF-8):      Zintegrowany kalendarz dla SeaMonkey
177 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
178 Group:          Applications/Networking
179 Requires:       %{name} = %{version}-%{release}
180
181 %description addon-lightning
182 Lightning is an calendar extension to Icedove email client.
183
184 %description addon-lightning -l pl.UTF-8
185 Lightning to rozszerzenie do klienta poczty Icedove dodające
186 funkcjonalność kalendarza.
187
188 %package addon-enigmail
189 Summary:        Enigmail %{enigmail_ver} - PGP/GPG support for SeaMonkey Community Edition
190 Summary(pl.UTF-8):      Enigmail %{enigmail_ver} - obsługa PGP/GPG dla SeaMonkey Community Edition
191 Group:          X11/Applications/Networking
192 Requires(post,postun):  %{name} = %{version}-%{release}
193 Requires:       %{name} = %{version}-%{release}
194 Requires:       gnupg >= 1.4.2.2
195
196 %description addon-enigmail
197 Enigmail is an extension to the mail client of SeaMonkey / Mozilla /
198 Netscape and Mozilla Thunderbird which allows users to access the
199 authentication and encryption features provided by GnuPG.
200
201 %description addon-enigmail -l pl.UTF-8
202 Enigmail jest rozszerzeniem dla klienta pocztowego SeaMonkey, Mozilla
203 i Mozilla Thunderdbird pozwalającym użytkownikowi korzystać z
204 funkcjonalności GnuPG.
205
206 %package chat
207 Summary:        SeaMonkey Community Edition Chat - integrated IRC client
208 Summary(pl.UTF-8):      SeaMonkey Community Edition Chat - zintegrowany klient IRC-a
209 Group:          X11/Applications/Networking
210 Requires(post,postun):  %{name} = %{version}-%{release}
211 Requires:       %{name} = %{version}-%{release}
212 Obsoletes:      mozilla-chat
213
214 %description chat
215 SeaMonkey Community Edition Chat - IRC client that is integrated with
216 the SeaMonkey Community Edition web browser.
217
218 %description chat -l pl.UTF-8
219 SeaMonkey Community Edition Chat - klient IRC-a zintegrowany z
220 przeglądarką SeaMonkey Community Edition.
221
222 %package js-debugger
223 Summary:        JavaScript debugger for use with SeaMonkey Community Edition
224 Summary(pl.UTF-8):      Odpluskwiacz JavaScriptu do używania z SeaMonkey Community Edition
225 Group:          X11/Applications/Networking
226 Requires(post,postun):  %{name} = %{version}-%{release}
227 Requires:       %{name} = %{version}-%{release}
228 Obsoletes:      mozilla-js-debugger
229
230 %description js-debugger
231 JavaScript debugger for use with SeaMonkey Community Edition.
232
233 %description js-debugger -l pl.UTF-8
234 Odpluskwiacz JavaScriptu do używania z SeaMonkey Community Edition.
235
236 %package dom-inspector
237 Summary:        A tool for inspecting the DOM of pages in SeaMonkey Community Edition
238 Summary(pl.UTF-8):      Narzędzie do oglądania DOM stron w SeaMonkey Community Edition
239 Group:          X11/Applications/Networking
240 Requires(post,postun):  %{name} = %{version}-%{release}
241 Requires:       %{name} = %{version}-%{release}
242 Obsoletes:      mozilla-dom-inspector
243
244 %description dom-inspector
245 This is a tool that allows you to inspect the DOM for web pages in
246 SeaMonkey Community Edition. This is of great use to people who are
247 doing SeaMonkey Community Edition chrome development or web page
248 development.
249
250 %description dom-inspector -l pl.UTF-8
251 To narzędzie pozwala na oglądanie DOM dla stron WWW w SeaMonkey
252 Community Edition. Jest bardzo przydatne dla ludzi rozwijających
253 chrome w SeaMonkey Community Edition lub tworzących strony WWW.
254
255 %prep
256 %setup -qc
257 cd comm-release
258 tar -C mailnews/extensions -zxf %{SOURCE1}
259 %patch1 -p1
260 %patch2 -p1
261 %patch3 -p1
262 %patch4 -p1
263 %patch5 -p1
264 %patch6 -p1
265 %patch7 -p2
266 %patch8 -p1
267 %patch9 -p2
268
269 %build
270 cd comm-release
271 %if %{with xulrunner}
272 if [ "$(grep -E '^[0-9]+\.' mozilla/config/milestone.txt)" != "%{xulrunner_ver}" ]; then
273         echo >&2
274         echo >&2 "Xulrunner version %{xulrunner_ver} does not match mozilla/config/milestone.txt!"
275         echo >&2
276         exit 1
277 fi
278 %endif
279
280 cp -f %{_datadir}/automake/config.* build/autoconf
281 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
282 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
283 cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
284
285 cat << EOF > .mozconfig
286 mk_add_options MOZ_OBJDIR=%{objdir}
287
288 export CFLAGS="%{rpmcflags}"
289 export CXXFLAGS="%{rpmcflags}"
290
291 %if %{with crashreporter}
292 export MOZ_DEBUG_SYMBOLS=1
293 %endif
294
295 # Options for 'configure' (same as command-line options).
296 ac_add_options --prefix=%{_prefix}
297 ac_add_options --exec-prefix=%{_exec_prefix}
298 ac_add_options --bindir=%{_bindir}
299 ac_add_options --sbindir=%{_sbindir}
300 ac_add_options --sysconfdir=%{_sysconfdir}
301 ac_add_options --datadir=%{_datadir}
302 ac_add_options --includedir=%{_includedir}
303 ac_add_options --libdir=%{_libdir}
304 ac_add_options --libexecdir=%{_libexecdir}
305 ac_add_options --localstatedir=%{_localstatedir}
306 ac_add_options --sharedstatedir=%{_sharedstatedir}
307 ac_add_options --mandir=%{_mandir}
308 ac_add_options --infodir=%{_infodir}
309 ac_add_options --disable-elf-hack
310 %if %{?debug:1}0
311 ac_add_options --disable-optimize
312 ac_add_options --enable-debug
313 ac_add_options --enable-debug-modules
314 ac_add_options --enable-debugger-info-modules
315 ac_add_options --enable-crash-on-assert
316 %else
317 ac_add_options --disable-debug
318 ac_add_options --disable-debug-modules
319 ac_add_options --disable-logging
320 ac_add_options --enable-optimize="%{rpmcflags} -Os"
321 %endif
322 ac_add_options --disable-strip
323 ac_add_options --disable-strip-libs
324 %if %{with tests}
325 ac_add_options --enable-tests
326 %else
327 ac_add_options --disable-tests
328 %endif
329 ac_add_options --enable-gio
330 %if %{with gnomeui}
331 ac_add_options --enable-gnomeui
332 %else
333 ac_add_options --disable-gnomeui
334 %endif
335 ac_add_options --disable-gnomevfs
336 %if %{with ldap}
337 ac_add_options --enable-ldap
338 ac_add_options --with-system-ldap
339 %else
340 ac_add_options --disable-ldap
341 %endif
342 %if %{with crashreporter}
343 ac_add_options --enable-crashreporter
344 %else
345 ac_add_options --disable-crashreporter
346 %endif
347 ac_add_options --disable-xterm-updates
348 ac_add_options --enable-postscript
349 %if %{with lightning}
350 ac_add_options --enable-calendar
351 %else
352 ac_add_options --disable-calendar
353 %endif
354 ac_add_options --disable-installer
355 ac_add_options --disable-javaxpcom
356 ac_add_options --disable-updater
357 ac_add_options --enable-crypto
358 ac_add_options --enable-libxul
359 ac_add_options --enable-pango
360 ac_add_options --enable-shared-js
361 ac_add_options --enable-startup-notification
362 ac_add_options --enable-system-cairo
363 ac_add_options --enable-system-hunspell
364 ac_add_options --enable-system-sqlite
365 ac_add_options --enable-application=suite
366 ac_add_options --with-distribution-id=org.pld-linux
367 %if %{with xulrunner}
368 ac_add_options --with-system-libxul
369 ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
370 %endif
371 ac_add_options --with-pthreads
372 ac_add_options --with-system-bz2
373 ac_add_options --with-system-ffi
374 ac_add_options --with-system-jpeg
375 ac_add_options --with-system-libevent
376 ac_add_options --with-system-libvpx
377 ac_add_options --with-system-nspr
378 ac_add_options --with-system-nss
379 ac_add_options --with-system-png
380 ac_add_options --with-system-zlib
381 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
382 EOF
383
384 %{__make} -j1 -f client.mk build \
385         STRIP="/bin/true" \
386         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
387         installdir=%{_libdir}/%{name} \
388         XLIBS="-lX11 -lXt" \
389         CC="%{__cc}" \
390         CXX="%{__cxx}"
391
392 %if %{with crashreporter}
393 # create debuginfo for crash-stats.mozilla.com
394 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
395 %endif
396
397 %if %{with enigmail}
398 cd mailnews/extensions/enigmail
399 ./makemake -r -o %{objdir}
400 %{__make} -C %{objdir}/mailnews/extensions/enigmail \
401         STRIP="/bin/true" \
402         CC="%{__cc}" \
403         CXX="%{__cxx}"
404
405 %{__make} -C %{objdir}/mailnews/extensions/enigmail xpi \
406         STRIP="/bin/true" \
407         CC="%{__cc}" \
408         CXX="%{__cxx}"
409 %endif
410
411 %install
412 rm -rf $RPM_BUILD_ROOT
413 cd comm-release
414 install -d \
415         $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
416         $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}} \
417         $RPM_BUILD_ROOT%{_datadir}/%{name} \
418         $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins
419
420 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins
421
422 cd %{objdir}
423 %{__make} -C suite/installer stage-package \
424         DESTDIR=$RPM_BUILD_ROOT \
425         installdir=%{_libdir}/%{name} \
426         PKG_SKIP_STRIP=1
427
428 cp -a mozilla/dist/seamonkey/* $RPM_BUILD_ROOT%{_libdir}/%{name}/
429
430 %if %{with xulrunner}
431 # >= 5.0 seems to require this
432 ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
433 %endif
434
435 # Enable crash reporter for Thunderbird application
436 %if %{with crashreporter}
437 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
438
439 # Add debuginfo for crash-stats.mozilla.com
440 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
441 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
442 %endif
443
444 # copy manually lightning files, somewhy they are not installed by make
445 cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
446         mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
447         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
448                 
449 # move arch independant ones to datadir
450 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
451 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
452 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
453 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
454 %if %{without xulrunner}
455 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs.js $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs.js
456 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
457 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
458 %endif
459
460 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
461 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
462 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
463 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
464 %if %{without xulrunner}
465 ln -s ../../share/%{name}/greprefs.js $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs.js
466 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
467 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
468 %endif
469
470 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/* \
471         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/
472
473 # dir for arch independant extensions besides arch dependant extensions
474 # see mozilla/xpcom/build/nsXULAppAPI.h
475 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
476 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
477  
478 %if %{without xulrunner}
479 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
480 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
481 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
482 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
483 %endif
484
485 sed 's,@LIBDIR@,%{_libdir},' %{SOURCE9} > $RPM_BUILD_ROOT%{_bindir}/seamonkey
486 chmod a+rx $RPM_BUILD_ROOT%{_bindir}/seamonkey
487
488 install %{SOURCE4} %{SOURCE5} %{SOURCE6} %{SOURCE7} %{SOURCE8} \
489         $RPM_BUILD_ROOT%{_desktopdir}
490
491 cp -p %{topdir}/comm-release/suite/branding/nightly/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
492
493 # files created by seamonkey -register
494 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
495 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
496
497 cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
498 #!/bin/sh
499 umask 022
500 rm -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
501
502 # it attempts to touch files in $HOME/.mozilla
503 # beware if you run this with sudo!!!
504 export HOME=$(mktemp -d)
505 # also TMPDIR could be pointing to sudo user's homedir
506 unset TMPDIR TMP || :
507
508 %{_libdir}/%{name}/seamonkey -register
509
510 rm -rf $HOME
511 EOF
512 chmod 755 $RPM_BUILD_ROOT%{_libdir}/%{name}/register
513
514 %if %{with enigmail}
515 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
516 install -d $ext_dir/{chrome,components,defaults/preferences,modules}
517 cd mozilla/dist/bin
518 cp -rfLp chrome/enigmail.jar $ext_dir/chrome
519 cp -rfLp components/enig* $ext_dir/components
520 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
521 cp -rfLp modules/{commonFuncs,enigmailCommon,keyManagement,pipeConsole,subprocess}.jsm $ext_dir/modules
522 cp -rfLp modules/{subprocess_worker_unix,subprocess_worker_win}.js $ext_dir/modules
523 cd -
524 cp -p %{topdir}/comm-release/mailnews/extensions/enigmail/package/install.rdf $ext_dir
525 cp -p %{topdir}/comm-release/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
526 %endif
527
528 # never package these. always remove
529 # nss
530 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
531 # nspr
532 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
533 # mozldap
534 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
535 # testpilot quiz
536 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/tbtestpilot@labs.mozilla.com.xpi
537
538 %clean
539 rm -rf $RPM_BUILD_ROOT
540
541 %post
542 %{_libdir}/%{name}/register || :
543 %update_browser_plugins
544 %update_desktop_database
545
546 %postun
547 if [ "$1" = 0 ]; then
548         %update_browser_plugins
549 fi
550
551 %files
552 %defattr(644,root,root,755)
553 %attr(755,root,root) %{_bindir}/seamonkey
554
555 # browser plugins v2
556 %{_browserpluginsconfdir}/browsers.d/%{name}.*
557 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
558
559 %dir %{_libdir}/%{name}
560 %if %{without xulrunner}
561 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
562 %attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
563 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
564 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
565 %endif
566
567 %{_libdir}/%{name}/blocklist.xml
568 %attr(755,root,root) %{_libdir}/%{name}/register
569
570 %if %{with crashreporter}
571 %{_libdir}/%{name}/crashreporter
572 %{_libdir}/%{name}/crashreporter-override.ini
573 %{_libdir}/%{name}/crashreporter.ini
574 %{_libdir}/%{name}/Throbber-small.gif
575 %endif
576
577 # config?
578 %{_libdir}/%{name}/application.ini
579 %{_libdir}/%{name}/chrome.manifest
580
581 %dir %{_libdir}/%{name}/components
582
583 %{_libdir}/%{name}/components/Aitc.js
584 %{_libdir}/%{name}/components/FeedConverter.js
585 %{_libdir}/%{name}/components/FeedWriter.js
586 %{_libdir}/%{name}/components/Weave.js
587 %{_libdir}/%{name}/components/WebContentConverter.js
588 %{_libdir}/%{name}/components/nsAbout.js
589 %{_libdir}/%{name}/components/nsBrowserContentHandler.js
590 %{_libdir}/%{name}/components/nsComposerCmdLineHandler.js
591 %{_libdir}/%{name}/components/nsSessionStartup.js
592 %{_libdir}/%{name}/components/nsSessionStore.js
593 %{_libdir}/%{name}/components/nsSetDefault.js
594 %{_libdir}/%{name}/components/nsSidebar.js
595 %{_libdir}/%{name}/components/nsSuiteDownloadManagerUI.js
596 %{_libdir}/%{name}/components/nsSuiteGlue.js
597 %{_libdir}/%{name}/components/nsTypeAheadFind.js
598 %{_libdir}/%{name}/components/smileApplication.js
599
600 %{_libdir}/%{name}/components/browser.xpt
601 %{_libdir}/%{name}/components/components.manifest
602 %{_libdir}/%{name}/components/interfaces.manifest
603
604 %attr(755,root,root) %{_libdir}/%{name}/components/libsuite.so
605
606 %if %{without xulrunner}
607 %{_libdir}/%{name}/dependentlibs.list
608 %{_libdir}/%{name}/platform.ini
609 %{_libdir}/%{name}/components/AlarmsManager.js
610 %{_libdir}/%{name}/components/AppsService.js
611 %{_libdir}/%{name}/components/BrowserElementParent.js
612 %{_libdir}/%{name}/components/ColorAnalyzer.js
613 %{_libdir}/%{name}/components/ContactManager.js
614 %{_libdir}/%{name}/components/ConsoleAPI.js
615 %{_libdir}/%{name}/components/FeedProcessor.js
616 %{_libdir}/%{name}/components/GPSDGeolocationProvider.js
617 %{_libdir}/%{name}/components/NetworkGeolocationProvider.js
618 %{_libdir}/%{name}/components/PermissionSettings.js
619 %{_libdir}/%{name}/components/PlacesCategoriesStarter.js
620 %{_libdir}/%{name}/components/SettingsManager.js
621 %{_libdir}/%{name}/components/SiteSpecificUserAgent.js
622 %{_libdir}/%{name}/components/TCPSocket.js
623 %{_libdir}/%{name}/components/TCPSocketParentIntermediary.js
624 %{_libdir}/%{name}/components/TelemetryPing.js
625 %{_libdir}/%{name}/components/Webapps.js
626 %{_libdir}/%{name}/components/addonManager.js
627 %{_libdir}/%{name}/components/amContentHandler.js
628 %{_libdir}/%{name}/components/amWebInstallListener.js
629 %{_libdir}/%{name}/components/contentAreaDropListener.js
630 %{_libdir}/%{name}/components/contentSecurityPolicy.js
631 %{_libdir}/%{name}/components/crypto-SDR.js
632 %{_libdir}/%{name}/components/glautocomp.js
633 %{_libdir}/%{name}/components/jsconsole-clhandler.js
634 %{_libdir}/%{name}/components/jsmimeemitter.js
635 %{_libdir}/%{name}/components/mdn-service.js
636 %{_libdir}/%{name}/components/messageWakeupService.js
637 %{_libdir}/%{name}/components/msgAsyncPrompter.js
638 %{_libdir}/%{name}/components/newMailNotificationService.js
639 %{_libdir}/%{name}/components/newsblog.js
640 %{_libdir}/%{name}/components/nsAbAutoCompleteMyDomain.js
641 %{_libdir}/%{name}/components/nsAbAutoCompleteSearch.js
642 %{_libdir}/%{name}/components/nsAbLDAPAttributeMap.js
643 %{_libdir}/%{name}/components/nsBadCertHandler.js
644 %{_libdir}/%{name}/components/nsBlocklistService.js
645 %{_libdir}/%{name}/components/nsContentDispatchChooser.js
646 %{_libdir}/%{name}/components/nsContentPrefService.js
647 %{_libdir}/%{name}/components/nsDOMIdentity.js
648 %{_libdir}/%{name}/components/nsDefaultCLH.js
649 %{_libdir}/%{name}/components/nsFilePicker.js
650 %{_libdir}/%{name}/components/nsFormAutoComplete.js
651 %{_libdir}/%{name}/components/nsFormHistory.js
652 %{_libdir}/%{name}/components/nsHandlerService.js
653 %{_libdir}/%{name}/components/nsHelperAppDlg.js
654 %{_libdir}/%{name}/components/nsIDService.js
655 %{_libdir}/%{name}/components/nsINIProcessor.js
656 %{_libdir}/%{name}/components/nsInputListAutoComplete.js
657 %{_libdir}/%{name}/components/nsLDAPProtocolHandler.js
658 %{_libdir}/%{name}/components/nsLivemarkService.js
659 %{_libdir}/%{name}/components/nsLoginInfo.js
660 %{_libdir}/%{name}/components/nsLoginManager.js
661 %{_libdir}/%{name}/components/nsLoginManagerPrompter.js
662 %{_libdir}/%{name}/components/nsMailNewsCommandLineHandler.js
663 %{_libdir}/%{name}/components/nsMsgTraitService.js
664 %{_libdir}/%{name}/components/nsPlacesAutoComplete.js
665 %{_libdir}/%{name}/components/nsPlacesExpiration.js
666 %{_libdir}/%{name}/components/nsPrompter.js
667 %{_libdir}/%{name}/components/nsSMTPProtocolHandler.js
668 %{_libdir}/%{name}/components/nsSearchService.js
669 %{_libdir}/%{name}/components/nsSearchSuggestions.js
670 %{_libdir}/%{name}/components/nsTaggingService.js
671 %{_libdir}/%{name}/components/nsUpdateTimerManager.js
672 %{_libdir}/%{name}/components/nsUrlClassifierHashCompleter.js
673 %{_libdir}/%{name}/components/nsUrlClassifierLib.js
674 %{_libdir}/%{name}/components/nsUrlClassifierListManager.js
675 %{_libdir}/%{name}/components/nsURLFormatter.js
676 %{_libdir}/%{name}/components/nsWebHandlerApp.js
677 %{_libdir}/%{name}/components/offlineStartup.js
678 %{_libdir}/%{name}/components/smime-service.js
679 %{_libdir}/%{name}/components/storage-Legacy.js
680 %{_libdir}/%{name}/components/storage-mozStorage.js
681 %{_libdir}/%{name}/components/txEXSLTRegExFunctions.js
682
683 %{_libdir}/%{name}/components/mail.xpt
684
685 %attr(755,root,root) %{_libdir}/%{name}/components/libdbusservice.so
686 %attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so
687 %attr(755,root,root) %{_libdir}/%{name}/run-mozilla.sh
688 %attr(755,root,root) %{_libdir}/%{name}/seamonkey-bin
689 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
690 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
691 %endif
692
693 %attr(755,root,root) %{_libdir}/%{name}/seamonkey
694 %dir %{_libdir}/%{name}/plugins
695
696 # symlinks
697 %{_libdir}/%{name}/chrome
698 %{_libdir}/%{name}/defaults
699 %{_libdir}/%{name}/modules
700 %{_libdir}/%{name}/searchplugins
701 %if %{with xulrunner}
702 %{_libdir}/%{name}/xulrunner
703 %else
704 %{_libdir}/%{name}/dictionaries
705 %{_libdir}/%{name}/hyphenation
706 %{_libdir}/%{name}/greprefs.js
707 %{_libdir}/%{name}/res
708 %endif
709
710 %dir %{_datadir}/%{name}
711 %{_datadir}/%{name}/chrome
712 %{_datadir}/%{name}/defaults
713 %{_datadir}/%{name}/modules
714 %if %{with enigmail}
715 %exclude %{_datadir}/%{name}/modules/commonFuncs.jsm
716 %exclude %{_datadir}/%{name}/modules/enigmailCommon.jsm
717 %exclude %{_datadir}/%{name}/modules/keyManagement.jsm
718 %exclude %{_datadir}/%{name}/modules/pipeConsole.jsm
719 %exclude %{_datadir}/%{name}/modules/subprocess.jsm
720 %exclude %{_datadir}/%{name}/modules/subprocess_worker_unix.js
721 %exclude %{_datadir}/%{name}/modules/subprocess_worker_win.js
722 %endif
723 %{_datadir}/%{name}/searchplugins
724 %if %{without xulrunner}
725 %{_datadir}/%{name}/greprefs.js
726 %{_datadir}/%{name}/res
727 %endif
728
729 %dir %{_datadir}/%{name}/extensions
730 %dir %{_libdir}/%{name}/extensions
731 # the signature of the default theme
732 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}.xpi
733 %{_libdir}/%{name}/extensions/modern@themes.mozilla.org.xpi
734
735 # files created by seamonkey -register
736 %ghost %{_libdir}/%{name}/components/compreg.dat
737 %ghost %{_libdir}/%{name}/components/xpti.dat
738
739 %if %{without xulrunner}
740 %{_libdir}/%{name}/isp
741 %dir %{_datadir}/%{name}/isp
742 %{_datadir}/%{name}/isp/Bogofilter.sfd
743 %{_datadir}/%{name}/isp/DSPAM.sfd
744 %{_datadir}/%{name}/isp/POPFile.sfd
745 %{_datadir}/%{name}/isp/SpamAssassin.sfd
746 %{_datadir}/%{name}/isp/SpamPal.sfd
747 %{_datadir}/%{name}/isp/movemail.rdf
748 %{_datadir}/%{name}/isp/rss.rdf
749 %endif
750
751 %{_pixmapsdir}/seamonkey.png
752 %{_desktopdir}/%{name}.desktop
753 %{_desktopdir}/%{name}-composer.desktop
754 %{_desktopdir}/%{name}-mail.desktop
755
756 %if %{with lightning}
757 %files addon-lightning
758 %defattr(644,root,root,755)
759 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
760 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
761 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
762 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
763 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
764 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
765 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
766 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
767 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
768 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
769 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
770 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
771 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
772 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
773 %{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
774 %endif
775
776 %if %{with enigmail}
777 %files addon-enigmail
778 %defattr(644,root,root,755)
779 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
780 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
781 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
782 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
783 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
784 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
785 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
786 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
787 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules
788 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.jsm
789 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.js
790 %endif
791
792 %files chat
793 %defattr(644,root,root,755)
794 %{_libdir}/%{name}/extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}.xpi
795 %{_desktopdir}/%{name}-chat.desktop
796
797 %files js-debugger
798 %defattr(644,root,root,755)
799 %{_libdir}/%{name}/extensions/{f13b157f-b174-47e7-a34d-4815ddfdfeb8}.xpi
800 %{_desktopdir}/%{name}-venkman.desktop
801
802 %files dom-inspector
803 %defattr(644,root,root,755)
804 %{_libdir}/%{name}/extensions/inspector@mozilla.org.xpi
This page took 0.097555 seconds and 4 git commands to generate.