]> git.pld-linux.org Git - packages/seamonkey.git/blob - seamonkey.spec
- removed non-existant and wrong options
[packages/seamonkey.git] / seamonkey.spec
1 #
2 # Conditional build:
3 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
4 %bcond_without  gnomeui         # disable gnomeui support
5 %bcond_without  gnome           # disable gnomeui (alias)
6 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
7 %bcond_without  lightning       # disable Sunbird/Lightning calendar
8 %bcond_with     xulrunner       # build with system xulrunner
9 %bcond_with     tests           # enable tests (whatever they check)
10 %bcond_without  kerberos        # disable krb5 support
11
12 %if %{without gnome}
13 %undefine       with_gnomeui
14 %endif
15
16 %define         enigmail_ver    1.4.1
17 %define         nspr_ver        4.9
18 %define         nss_ver         3.13.3
19 %define         xulrunner_ver   12.0
20
21 %if %{without xulrunner}
22 # The actual sqlite version (see RHBZ#480989):
23 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
24 %endif
25
26 Summary:        SeaMonkey Community Edition - web browser
27 Summary(es.UTF-8):      Navegador de Internet SeaMonkey Community Edition
28 Summary(pl.UTF-8):      SeaMonkey Community Edition - przeglądarka WWW
29 Summary(pt_BR.UTF-8):   Navegador SeaMonkey Community Edition
30 Name:           seamonkey
31 Version:        2.9.1
32 Release:        0.1
33 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
34 Group:          X11/Applications/Networking
35 Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/seamonkey/releases/%{version}/source/%{name}-%{version}.source.tar.bz2
36 # Source0-md5:  8dd18d93a6570c3c9f3873bb177ccc6b
37 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
38 # Source1-md5:  0eba75fbcf8f0bb32d538df102fbb8e9
39 Source2:        %{name}.desktop
40 Source3:        %{name}-composer.desktop
41 Source4:        %{name}-chat.desktop
42 Source5:        %{name}-mail.desktop
43 Source6:        %{name}-venkman.desktop
44 Source7:        %{name}.sh
45 Patch0:         %{name}-pld-homepage.patch
46 Patch1:         %{name}-agent.patch
47 Patch2:         %{name}-glueload-fix.patch
48 Patch3:         system-mozldap.patch
49 Patch4:         makefile.patch
50 Patch5:         system-cairo.patch
51 URL:            http://www.seamonkey-project.org/
52 BuildRequires:  GConf2-devel >= 1.2.1
53 BuildRequires:  OpenGL-devel
54 BuildRequires:  alsa-lib-devel
55 BuildRequires:  automake
56 BuildRequires:  bzip2-devel
57 BuildRequires:  cairo-devel >= 1.10.2-5
58 BuildRequires:  dbus-glib-devel >= 0.60
59 BuildRequires:  freetype-devel >= 1:2.1.8
60 BuildRequires:  glib2-devel >= 1:2.18
61 BuildRequires:  gtk+2-devel >= 2:2.10
62 %{?with_kerberos:BuildRequires: heimdal-devel >= 0.7.1}
63 BuildRequires:  hunspell-devel
64 BuildRequires:  libIDL-devel >= 0.8.0
65 BuildRequires:  libdnet-devel
66 BuildRequires:  libevent-devel >= 1.4.7
67 # standalone libffi 3.0.9 or gcc's from 4.5(?)+
68 BuildRequires:  libffi-devel >= 6:3.0.9
69 %{?with_gnomeui:BuildRequires:  libgnome-devel >= 2.0}
70 %{?with_gnomeui:BuildRequires:  libgnome-keyring-devel}
71 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
72 BuildRequires:  libiw-devel
73 BuildRequires:  libjpeg-devel >= 6b
74 BuildRequires:  libnotify-devel >= 0.4
75 BuildRequires:  libpng(APNG)-devel >= 0.10
76 BuildRequires:  libpng-devel >= 1.4.1
77 BuildRequires:  libstdc++-devel
78 BuildRequires:  libvpx-devel
79 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
80 BuildRequires:  nss-devel >= 1:%{nss_ver}
81 BuildRequires:  pango-devel >= 1:1.14.0
82 BuildRequires:  perl-base >= 1:5.6
83 BuildRequires:  perl-modules >= 5.004
84 BuildRequires:  pkgconfig
85 BuildRequires:  python >= 1:2.5
86 BuildRequires:  python-modules
87 BuildRequires:  rpm >= 4.4.9-56
88 BuildRequires:  rpmbuild(macros) >= 1.601
89 BuildRequires:  sed >= 4.0
90 BuildRequires:  sqlite3-devel >= 3.7.10
91 BuildRequires:  startup-notification-devel >= 0.8
92 BuildRequires:  xorg-lib-libXScrnSaver-devel
93 BuildRequires:  xorg-lib-libXext-devel
94 BuildRequires:  xorg-lib-libXinerama-devel
95 BuildRequires:  xorg-lib-libXt-devel
96 %if %{with xulrunner}
97 BuildRequires:  xulrunner-devel >= 2:%{xulrunner_ver}
98 %endif
99 BuildRequires:  yasm
100 BuildRequires:  zip
101 BuildRequires:  zlib-devel >= 1.2.3
102 Requires(post): mktemp >= 1.5-18
103 Requires:       desktop-file-utils
104 Requires:       hicolor-icon-theme
105 %if %{with xulrunner}
106 %requires_eq_to xulrunner xulrunner-devel
107 %else
108 Requires:       browser-plugins >= 2.0
109 Requires:       cairo >= 1.10.2-5
110 Requires:       dbus-glib >= 0.60
111 Requires:       gtk+2 >= 2:2.18
112 Requires:       libpng >= 1.4.1
113 Requires:       libpng(APNG) >= 0.10
114 Requires:       myspell-common
115 Requires:       nspr >= 1:%{nspr_ver}
116 Requires:       nss >= 1:%{nss_ver}
117 Requires:       pango >= 1:1.14.0
118 Requires:       sqlite3 >= %{sqlite_build_version}
119 Requires:       startup-notification >= 0.8
120 %endif
121 Provides:       seamonkey-embedded = %{version}-%{release}
122 Provides:       wwwbrowser
123 Obsoletes:      light
124 Obsoletes:      mozilla
125 Obsoletes:      seamonkey-calendar
126 Obsoletes:      seamonkey-libs
127 Obsoletes:      seamonkey-mailnews
128 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
129
130 %define         topdir          %{_builddir}/%{name}-%{version}
131 %define         objdir          %{topdir}/obj-%{_target_cpu}
132
133 %define         filterout_cpp   -D_FORTIFY_SOURCE=[0-9]+
134
135 # don't satisfy other packages
136 %define         _noautoprovfiles        %{_libdir}/%{name}
137 # and as we don't provide them, don't require either
138 %define         _noautoreq      libmozjs.so libxpcom.so libxul.so libjemalloc.so %{!?with_xulrunner:libmozalloc.so}
139 %define         _noautoreqdep   libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpistub.so
140
141 %description
142 SeaMonkey Community Edition is an open-source web browser, designed
143 for standards compliance, performance and portability.
144
145 %description -l es.UTF-8
146 SeaMonkey Community Edition es un navegador de Internet que se basa en
147 una versión inicial de Netscape Communicator.
148
149 %description -l pl.UTF-8
150 SeaMonkey Community Edition jest potężną graficzną przeglądarką WWW,
151 która jest następcą Mozilli, która następnie była następczynią
152 Netscape Communikatora.
153
154 %description -l pt_BR.UTF-8
155 O SeaMonkey Community Edition é um web browser baseado numa versão
156 inicial do Netscape Communicator.
157
158 %description -l ru.UTF-8
159 SeaMonkey Community Edition - полнофункциональный web-browser с
160 открытыми исходными текстами, разработанный для максимального
161 соотвествия стандартам, максмимальной переносимости и скорости работы
162
163 %package addon-lightning
164 Summary:        An integrated calendar for SeaMonkey
165 Summary(pl.UTF-8):      Zintegrowany kalendarz dla SeaMonkey
166 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
167 Group:          Applications/Networking
168 Requires:       %{name} = %{version}-%{release}
169
170 %description addon-lightning
171 Lightning is an calendar extension to Icedove email client.
172
173 %description addon-lightning -l pl.UTF-8
174 Lightning to rozszerzenie do klienta poczty Icedove dodające
175 funkcjonalność kalendarza.
176
177 %package addon-enigmail
178 Summary:        Enigmail %{enigmail_ver} - PGP/GPG support for SeaMonkey Community Edition
179 Summary(pl.UTF-8):      Enigmail %{enigmail_ver} - obsługa PGP/GPG dla SeaMonkey Community Edition
180 Group:          X11/Applications/Networking
181 Requires(post,postun):  %{name} = %{version}-%{release}
182 Requires:       %{name} = %{version}-%{release}
183 Requires:       gnupg >= 1.4.2.2
184
185 %description addon-enigmail
186 Enigmail is an extension to the mail client of SeaMonkey / Mozilla /
187 Netscape and Mozilla Thunderbird which allows users to access the
188 authentication and encryption features provided by GnuPG.
189
190 %description addon-enigmail -l pl.UTF-8
191 Enigmail jest rozszerzeniem dla klienta pocztowego SeaMonkey, Mozilla
192 i Mozilla Thunderdbird pozwalającym użytkownikowi korzystać z
193 funkcjonalności GnuPG.
194
195 %package chat
196 Summary:        SeaMonkey Community Edition Chat - integrated IRC client
197 Summary(pl.UTF-8):      SeaMonkey Community Edition Chat - zintegrowany klient IRC-a
198 Group:          X11/Applications/Networking
199 Requires(post,postun):  %{name} = %{version}-%{release}
200 Requires:       %{name} = %{version}-%{release}
201 Obsoletes:      mozilla-chat
202
203 %description chat
204 SeaMonkey Community Edition Chat - IRC client that is integrated with
205 the SeaMonkey Community Edition web browser.
206
207 %description chat -l pl.UTF-8
208 SeaMonkey Community Edition Chat - klient IRC-a zintegrowany z
209 przeglądarką SeaMonkey Community Edition.
210
211 %package js-debugger
212 Summary:        JavaScript debugger for use with SeaMonkey Community Edition
213 Summary(pl.UTF-8):      Odpluskwiacz JavaScriptu do używania z SeaMonkey Community Edition
214 Group:          X11/Applications/Networking
215 Requires(post,postun):  %{name} = %{version}-%{release}
216 Requires:       %{name} = %{version}-%{release}
217 Obsoletes:      mozilla-js-debugger
218
219 %description js-debugger
220 JavaScript debugger for use with SeaMonkey Community Edition.
221
222 %description js-debugger -l pl.UTF-8
223 Odpluskwiacz JavaScriptu do używania z SeaMonkey Community Edition.
224
225 %package dom-inspector
226 Summary:        A tool for inspecting the DOM of pages in SeaMonkey Community Edition
227 Summary(pl.UTF-8):      Narzędzie do oglądania DOM stron w SeaMonkey Community Edition
228 Group:          X11/Applications/Networking
229 Requires(post,postun):  %{name} = %{version}-%{release}
230 Requires:       %{name} = %{version}-%{release}
231 Obsoletes:      mozilla-dom-inspector
232
233 %description dom-inspector
234 This is a tool that allows you to inspect the DOM for web pages in
235 SeaMonkey Community Edition. This is of great use to people who are
236 doing SeaMonkey Community Edition chrome development or web page
237 development.
238
239 %description dom-inspector -l pl.UTF-8
240 To narzędzie pozwala na oglądanie DOM dla stron WWW w SeaMonkey
241 Community Edition. Jest bardzo przydatne dla ludzi rozwijających
242 chrome w SeaMonkey Community Edition lub tworzących strony WWW.
243
244 %prep
245 %setup -qc
246 cd comm-release
247 tar -C mailnews/extensions -zxf %{SOURCE1}
248 #patch0 -p1
249 %patch1 -p1
250 %patch2 -p1
251 %patch3 -p1
252 %patch4 -p1
253 %patch5 -p1
254
255 %build
256 cd comm-release
257 %if %{with xulrunner}
258 if [ "$(grep -E '^[0-9]+\.' mozilla/config/milestone.txt)" != "%{xulrunner_ver}" ]; then
259         echo >&2
260         echo >&2 "Xulrunner version %{xulrunner_ver} does not match mozilla/config/milestone.txt!"
261         echo >&2
262         exit 1
263 fi
264 %endif
265
266 cp -f %{_datadir}/automake/config.* build/autoconf
267 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
268 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
269 cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
270
271 cat << EOF > .mozconfig
272 mk_add_options MOZ_OBJDIR=%{objdir}
273
274 export CFLAGS="%{rpmcflags}"
275 export CXXFLAGS="%{rpmcflags}"
276
277 %if %{with crashreporter}
278 export MOZ_DEBUG_SYMBOLS=1
279 %endif
280
281 # Options for 'configure' (same as command-line options).
282 ac_add_options --prefix=%{_prefix}
283 ac_add_options --exec-prefix=%{_exec_prefix}
284 ac_add_options --bindir=%{_bindir}
285 ac_add_options --sbindir=%{_sbindir}
286 ac_add_options --sysconfdir=%{_sysconfdir}
287 ac_add_options --datadir=%{_datadir}
288 ac_add_options --includedir=%{_includedir}
289 ac_add_options --libdir=%{_libdir}
290 ac_add_options --libexecdir=%{_libexecdir}
291 ac_add_options --localstatedir=%{_localstatedir}
292 ac_add_options --sharedstatedir=%{_sharedstatedir}
293 ac_add_options --mandir=%{_mandir}
294 ac_add_options --infodir=%{_infodir}
295 ac_add_options --disable-elf-hack
296 %if %{?debug:1}0
297 ac_add_options --disable-optimize
298 ac_add_options --enable-debug
299 ac_add_options --enable-debug-modules
300 ac_add_options --enable-debugger-info-modules
301 ac_add_options --enable-crash-on-assert
302 %else
303 ac_add_options --disable-debug
304 ac_add_options --disable-debug-modules
305 ac_add_options --disable-logging
306 ac_add_options --enable-optimize="%{rpmcflags} -Os"
307 %endif
308 ac_add_options --disable-strip
309 ac_add_options --disable-strip-libs
310 %if %{with tests}
311 ac_add_options --enable-tests
312 %else
313 ac_add_options --disable-tests
314 %endif
315 ac_add_options --enable-gio
316 %if %{with gnomeui}
317 ac_add_options --enable-gnomeui
318 %else
319 ac_add_options --disable-gnomeui
320 %endif
321 ac_add_options --disable-gnomevfs
322 %if %{with ldap}
323 ac_add_options --enable-ldap
324 ac_add_options --with-system-ldap
325 %else
326 ac_add_options --disable-ldap
327 %endif
328 %if %{with crashreporter}
329 ac_add_options --enable-crashreporter
330 %else
331 ac_add_options --disable-crashreporter
332 %endif
333 ac_add_options --disable-xterm-updates
334 ac_add_options --enable-postscript
335 %if %{with lightning}
336 ac_add_options --enable-calendar
337 %else
338 ac_add_options --disable-calendar
339 %endif
340 ac_add_options --disable-installer
341 ac_add_options --disable-javaxpcom
342 ac_add_options --disable-updater
343 ac_add_options --enable-crypto
344 ac_add_options --enable-libxul
345 ac_add_options --enable-pango
346 ac_add_options --enable-shared-js
347 ac_add_options --enable-startup-notification
348 ac_add_options --enable-system-cairo
349 ac_add_options --enable-system-hunspell
350 ac_add_options --enable-system-sqlite
351 ac_add_options --enable-application=suite
352 ac_add_options --with-distribution-id=org.pld-linux
353 %if %{with xulrunner}
354 ac_add_options --with-system-libxul
355 ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
356 %endif
357 ac_add_options --with-pthreads
358 ac_add_options --with-system-bz2
359 ac_add_options --with-system-ffi
360 ac_add_options --with-system-jpeg
361 ac_add_options --with-system-libevent
362 ac_add_options --with-system-libvpx
363 ac_add_options --with-system-nspr
364 ac_add_options --with-system-nss
365 ac_add_options --with-system-png
366 ac_add_options --with-system-zlib
367 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
368 EOF
369
370 %{__make} -j1 -f client.mk build \
371         STRIP="/bin/true" \
372         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
373         installdir=%{_libdir}/%{name} \
374         CC="%{__cc}" \
375         CXX="%{__cxx}"
376
377 %if %{with crashreporter}
378 # create debuginfo for crash-stats.mozilla.com
379 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
380 %endif
381
382 %if %{with enigmail}
383 cd mailnews/extensions/enigmail
384 ./makemake -r -o %{objdir}
385 %{__make} -C %{objdir}/mailnews/extensions/enigmail \
386         STRIP="/bin/true" \
387         CC="%{__cc}" \
388         CXX="%{__cxx}"
389 %endif
390
391 %install
392 rm -rf $RPM_BUILD_ROOT
393 cd comm-release
394 install -d \
395         $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
396         $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}} \
397         $RPM_BUILD_ROOT%{_datadir}/%{name} \
398         $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins
399
400 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins
401
402 cd %{objdir}
403 %{__make} -C suite/installer stage-package \
404         DESTDIR=$RPM_BUILD_ROOT \
405         installdir=%{_libdir}/%{name} \
406         PKG_SKIP_STRIP=1
407
408 cp -a mozilla/dist/seamonkey/* $RPM_BUILD_ROOT%{_libdir}/%{name}/
409
410 %if %{with xulrunner}
411 # >= 5.0 seems to require this
412 ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
413 %endif
414
415 # Enable crash reporter for Thunderbird application
416 %if %{with crashreporter}
417 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
418
419 # Add debuginfo for crash-stats.mozilla.com
420 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
421 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
422 %endif
423
424 # copy manually lightning files, somewhy they are not installed by make
425 cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
426         mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
427         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
428                 
429 # move arch independant ones to datadir
430 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
431 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
432 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
433 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
434 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
435 %if %{without xulrunner}
436 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs.js $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs.js
437 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
438 %endif
439
440 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
441 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
442 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
443 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
444 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
445 %if %{without xulrunner}
446 ln -s ../../share/%{name}/greprefs.js $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs.js
447 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
448 %endif
449
450 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/* \
451         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/
452
453 # dir for arch independant extensions besides arch dependant extensions
454 # see mozilla/xpcom/build/nsXULAppAPI.h
455 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
456 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
457  
458 %if %{without xulrunner}
459 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
460 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
461 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
462 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
463 %endif
464
465 sed 's,@LIBDIR@,%{_libdir},' %{SOURCE7} > $RPM_BUILD_ROOT%{_bindir}/seamonkey
466 chmod a+rx $RPM_BUILD_ROOT%{_bindir}/seamonkey
467
468 install %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6} \
469         $RPM_BUILD_ROOT%{_desktopdir}
470
471 cp -p %{topdir}/comm-release/suite/branding/nightly/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
472
473 # files created by seamonkey -register
474 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
475 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
476
477 cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
478 #!/bin/sh
479 umask 022
480 rm -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
481
482 # it attempts to touch files in $HOME/.mozilla
483 # beware if you run this with sudo!!!
484 export HOME=$(mktemp -d)
485 # also TMPDIR could be pointing to sudo user's homedir
486 unset TMPDIR TMP || :
487
488 %{_libdir}/%{name}/seamonkey -register
489
490 rm -rf $HOME
491 EOF
492 chmod 755 $RPM_BUILD_ROOT%{_libdir}/%{name}/register
493
494 %if %{with enigmail}
495 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
496 install -d $ext_dir/{chrome,components,defaults/preferences}
497 cd mozilla/dist/bin
498 #cp -rfLp chrome/enigmail.jar $ext_dir/chrome
499 #cp -rfLp chrome/enigmime.jar $ext_dir/chrome
500 cp -rfLp components/enig* $ext_dir/components
501 cp -rfLp components/libenigmime.so $ext_dir/components
502 cp -rfLp components/libipc.so $ext_dir/components
503 cp -rfLp components/ipc.xpt $ext_dir/components
504 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
505 cd -
506 cp -p %{topdir}/comm-release/mailnews/extensions/enigmail/package/install.rdf $ext_dir
507 cp -p %{topdir}/comm-release/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
508 %endif
509
510 # never package these. always remove
511 # nss
512 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
513 # nspr
514 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
515 # mozldap
516 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
517 # testpilot quiz
518 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/tbtestpilot@labs.mozilla.com.xpi
519
520 %clean
521 rm -rf $RPM_BUILD_ROOT
522
523 %post
524 %{_libdir}/%{name}/register || :
525 %update_browser_plugins
526 %update_desktop_database
527
528 %postun
529 if [ "$1" = 0 ]; then
530         %update_browser_plugins
531 fi
532
533 %files
534 %defattr(644,root,root,755)
535 %attr(755,root,root) %{_bindir}/seamonkey
536
537 # browser plugins v2
538 %{_browserpluginsconfdir}/browsers.d/%{name}.*
539 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
540
541 %dir %{_libdir}/%{name}
542 %if %{without xulrunner}
543 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
544 %attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
545 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
546 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
547 %endif
548
549 %{_libdir}/%{name}/blocklist.xml
550 %attr(755,root,root) %{_libdir}/%{name}/register
551
552 %if %{with crashreporter}
553 %{_libdir}/%{name}/crashreporter
554 %{_libdir}/%{name}/crashreporter-override.ini
555 %{_libdir}/%{name}/crashreporter.ini
556 %{_libdir}/%{name}/Throbber-small.gif
557 %endif
558
559 # config?
560 %{_libdir}/%{name}/application.ini
561 %{_libdir}/%{name}/chrome.manifest
562
563 %dir %{_libdir}/%{name}/components
564
565 %{_libdir}/%{name}/components/FeedConverter.js
566 %{_libdir}/%{name}/components/FeedWriter.js
567 %{_libdir}/%{name}/components/Weave.js
568 %{_libdir}/%{name}/components/WebContentConverter.js
569 %{_libdir}/%{name}/components/browser.xpt
570 %{_libdir}/%{name}/components/nsBrowserContentHandler.js
571 %{_libdir}/%{name}/components/nsSessionStartup.js
572 %{_libdir}/%{name}/components/nsSessionStore.js
573 %{_libdir}/%{name}/components/nsSidebar.js
574
575 %{_libdir}/%{name}/components/components.manifest
576 %{_libdir}/%{name}/components/interfaces.manifest
577
578 %if %{without xulrunner}
579 %{_libdir}/%{name}/platform.ini
580 %{_libdir}/%{name}/components/ConsoleAPI.js
581 %{_libdir}/%{name}/components/FeedProcessor.js
582 %{_libdir}/%{name}/components/GPSDGeolocationProvider.js
583 %{_libdir}/%{name}/components/NetworkGeolocationProvider.js
584 %{_libdir}/%{name}/components/PlacesCategoriesStarter.js
585 %{_libdir}/%{name}/components/TelemetryPing.js
586 %{_libdir}/%{name}/components/addonManager.js
587 %{_libdir}/%{name}/components/amContentHandler.js
588 %{_libdir}/%{name}/components/amWebInstallListener.js
589 %{_libdir}/%{name}/components/contentAreaDropListener.js
590 %{_libdir}/%{name}/components/contentSecurityPolicy.js
591 %{_libdir}/%{name}/components/crypto-SDR.js
592 %{_libdir}/%{name}/components/jsconsole-clhandler.js
593 %{_libdir}/%{name}/components/nsBadCertHandler.js
594 %{_libdir}/%{name}/components/nsBlocklistService.js
595 %{_libdir}/%{name}/components/nsContentDispatchChooser.js
596 %{_libdir}/%{name}/components/nsContentPrefService.js
597 %{_libdir}/%{name}/components/nsDefaultCLH.js
598 %{_libdir}/%{name}/components/nsFilePicker.js
599 %{_libdir}/%{name}/components/nsFormAutoComplete.js
600 %{_libdir}/%{name}/components/nsFormHistory.js
601 %{_libdir}/%{name}/components/nsHandlerService.js
602 %{_libdir}/%{name}/components/nsHelperAppDlg.js
603 %{_libdir}/%{name}/components/nsINIProcessor.js
604 %{_libdir}/%{name}/components/nsInputListAutoComplete.js
605 %{_libdir}/%{name}/components/nsLivemarkService.js
606 %{_libdir}/%{name}/components/nsLoginInfo.js
607 %{_libdir}/%{name}/components/nsLoginManager.js
608 %{_libdir}/%{name}/components/nsLoginManagerPrompter.js
609 %{_libdir}/%{name}/components/nsPlacesAutoComplete.js
610 %{_libdir}/%{name}/components/nsPlacesExpiration.js
611 %{_libdir}/%{name}/components/nsPrompter.js
612 %{_libdir}/%{name}/components/nsProxyAutoConfig.js
613 %{_libdir}/%{name}/components/nsSearchService.js
614 %{_libdir}/%{name}/components/nsSearchSuggestions.js
615 %{_libdir}/%{name}/components/nsTaggingService.js
616 %{_libdir}/%{name}/components/nsURLFormatter.js
617 %{_libdir}/%{name}/components/nsUpdateTimerManager.js
618 %{_libdir}/%{name}/components/nsWebHandlerApp.js
619 %{_libdir}/%{name}/components/storage-Legacy.js
620 %{_libdir}/%{name}/components/storage-mozStorage.js
621 %{_libdir}/%{name}/components/txEXSLTRegExFunctions.js
622 %endif
623
624 %{_libdir}/%{name}/components/nsAbout.js
625 %{_libdir}/%{name}/components/nsAboutCertError.js
626 %{_libdir}/%{name}/components/nsAboutData.js
627 %{_libdir}/%{name}/components/nsAboutFeeds.js
628 %{_libdir}/%{name}/components/nsAboutLife.js
629 %{_libdir}/%{name}/components/nsAboutRights.js
630 %{_libdir}/%{name}/components/nsAboutSessionRestore.js
631 %{_libdir}/%{name}/components/nsAboutSyncTabs.js
632 %{_libdir}/%{name}/components/nsComposerCmdLineHandler.js
633 %{_libdir}/%{name}/components/nsSuiteDownloadManagerUI.js
634 %{_libdir}/%{name}/components/nsSuiteGlue.js
635 %{_libdir}/%{name}/components/nsTypeAheadFind.js
636 %{_libdir}/%{name}/components/smileApplication.js
637
638 %if %{without xulrunner}
639 %attr(755,root,root) %{_libdir}/%{name}/components/libdbusservice.so
640 %endif
641
642 %if %{without xulrunner}
643 %attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so
644 %endif
645
646 %attr(755,root,root) %{_libdir}/%{name}/components/libsuite.so
647
648 %attr(755,root,root) %{_libdir}/%{name}/seamonkey
649 %dir %{_libdir}/%{name}/plugins
650 %if %{without xulrunner}
651 %attr(755,root,root) %{_libdir}/%{name}/run-mozilla.sh
652 %attr(755,root,root) %{_libdir}/%{name}/seamonkey-bin
653 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
654 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
655 %endif
656
657 # symlinks
658 %{_libdir}/%{name}/chrome
659 %{_libdir}/%{name}/defaults
660 %{_libdir}/%{name}/modules
661 %{_libdir}/%{name}/searchplugins
662 %if %{with xulrunner}
663 %{_libdir}/%{name}/xulrunner
664 %else
665 %{_libdir}/%{name}/dictionaries
666 %{_libdir}/%{name}/hyphenation
667 %{_libdir}/%{name}/greprefs.js
668 %{_libdir}/%{name}/res
669 %endif
670
671 %dir %{_datadir}/%{name}
672 %{_datadir}/%{name}/chrome
673 %{_datadir}/%{name}/defaults
674 %{_datadir}/%{name}/modules
675 %{_datadir}/%{name}/searchplugins
676 %if %{without xulrunner}
677 %{_datadir}/%{name}/greprefs.js
678 %{_datadir}/%{name}/res
679 %endif
680
681 %dir %{_datadir}/%{name}/extensions
682 %dir %{_libdir}/%{name}/extensions
683 # the signature of the default theme
684 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}.xpi
685 %{_libdir}/%{name}/extensions/modern@themes.mozilla.org.xpi
686
687 # files created by seamonkey -register
688 %ghost %{_libdir}/%{name}/components/compreg.dat
689 %ghost %{_libdir}/%{name}/components/xpti.dat
690
691 %{_libdir}/%{name}/components/glautocomp.js
692 %{_libdir}/%{name}/components/jsmimeemitter.js
693 %{_libdir}/%{name}/components/mail.xpt
694 %{_libdir}/%{name}/components/mdn-service.js
695 %{_libdir}/%{name}/components/msgAsyncPrompter.js
696 %{_libdir}/%{name}/components/newsblog.js
697 %{_libdir}/%{name}/components/nsAbAutoCompleteMyDomain.js
698 %{_libdir}/%{name}/components/nsAbAutoCompleteSearch.js
699 %{_libdir}/%{name}/components/nsAbLDAPAttributeMap.js
700 %{_libdir}/%{name}/components/nsLDAPProtocolHandler.js
701 %{_libdir}/%{name}/components/nsMailNewsCommandLineHandler.js
702 %{_libdir}/%{name}/components/nsMsgTraitService.js
703 %{_libdir}/%{name}/components/nsSMTPProtocolHandler.js
704 %{_libdir}/%{name}/components/offlineStartup.js
705 %{_libdir}/%{name}/components/smime-service.js
706
707 %{_libdir}/%{name}/isp
708 %dir %{_datadir}/%{name}/isp
709 %{_datadir}/%{name}/isp/Bogofilter.sfd
710 %{_datadir}/%{name}/isp/DSPAM.sfd
711 %{_datadir}/%{name}/isp/POPFile.sfd
712 %{_datadir}/%{name}/isp/SpamAssassin.sfd
713 %{_datadir}/%{name}/isp/SpamPal.sfd
714 %{_datadir}/%{name}/isp/movemail.rdf
715 %{_datadir}/%{name}/isp/rss.rdf
716
717 %{_pixmapsdir}/seamonkey.png
718 %{_desktopdir}/%{name}.desktop
719 %{_desktopdir}/%{name}-composer.desktop
720 %{_desktopdir}/%{name}-mail.desktop
721
722 %if %{with lightning}
723 %files addon-lightning
724 %defattr(644,root,root,755)
725 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
726 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
727 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
728 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
729 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
730 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
731 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
732 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
733 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
734 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
735 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
736 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
737 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
738 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
739 %{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
740 %endif
741
742 %if %{with enigmail}
743 %files addon-enigmail
744 %defattr(644,root,root,755)
745 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
746 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
747 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
748 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
749 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
750 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
751 %attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
752 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
753 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
754 %endif
755
756 %files chat
757 %defattr(644,root,root,755)
758 %{_libdir}/%{name}/extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}.xpi
759 %{_desktopdir}/%{name}-chat.desktop
760
761 %files js-debugger
762 %defattr(644,root,root,755)
763 %{_libdir}/%{name}/extensions/{f13b157f-b174-47e7-a34d-4815ddfdfeb8}.xpi
764 %{_desktopdir}/%{name}-venkman.desktop
765
766 %files dom-inspector
767 %defattr(644,root,root,755)
768 %{_libdir}/%{name}/extensions/inspector@mozilla.org.xpi
This page took 0.127513 seconds and 4 git commands to generate.