]> git.pld-linux.org Git - packages/seamonkey.git/blob - seamonkey.spec
- updated to 2.26.1
[packages/seamonkey.git] / seamonkey.spec
1 #
2 # Conditional build:
3 %bcond_with     gtk3            # GTK+ 3.x instead of 2.x
4 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
5 %bcond_without  lightning       # disable Sunbird/Lightning calendar
6 %bcond_without  kerberos        # disable krb5 support
7 %bcond_with     xulrunner       # build with system xulrunner (incomplete?)
8 %bcond_with     crashreporter   # report crashes to crash-stats.mozilla.com
9 %bcond_with     tests           # enable tests (whatever they check)
10
11 %define         nspr_ver        4.10.3
12 %define         nss_ver         3.16
13 %define         xulrunner_ver   29.0
14
15 %if %{without xulrunner}
16 # The actual sqlite version (see RHBZ#480989):
17 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
18 %endif
19
20 Summary:        SeaMonkey Community Edition - web browser
21 Summary(es.UTF-8):      Navegador de Internet SeaMonkey Community Edition
22 Summary(pl.UTF-8):      SeaMonkey Community Edition - przeglądarka WWW
23 Summary(pt_BR.UTF-8):   Navegador SeaMonkey Community Edition
24 Name:           seamonkey
25 Version:        2.26.1
26 Release:        1
27 License:        MPL v2.0
28 Group:          X11/Applications/Networking
29 Source0:        http://ftp.mozilla.org/pub/mozilla.org/seamonkey/releases/%{version}/source/%{name}-%{version}.source.tar.bz2
30 # Source0-md5:  4bfa46b370b4d211eef56b90277a9517
31 Source4:        %{name}.desktop
32 Source5:        %{name}-composer.desktop
33 Source6:        %{name}-chat.desktop
34 Source7:        %{name}-mail.desktop
35 Source8:        %{name}-venkman.desktop
36 Source9:        %{name}.sh
37 Patch1:         %{name}-pld-branding.patch
38 Patch2:         %{name}-agent.patch
39 Patch3:         %{name}-enable-addons.patch
40 Patch4:         system-mozldap.patch
41 Patch5:         makefile.patch
42 Patch6:         %{name}-pixman.patch
43 # Edit patch below and restore --system-site-packages when system virtualenv gets 1.7 upgrade
44 Patch7:         %{name}-system-virtualenv.patch
45 Patch9:         %{name}-system-xulrunner.patch
46 URL:            http://www.seamonkey-project.org/
47 BuildRequires:  GConf2-devel >= 1.2.1
48 BuildRequires:  OpenGL-devel
49 BuildRequires:  alsa-lib-devel
50 BuildRequires:  automake
51 BuildRequires:  bzip2-devel
52 BuildRequires:  cairo-devel >= 1.10.2-5
53 BuildRequires:  dbus-glib-devel >= 0.60
54 BuildRequires:  freetype-devel >= 1:2.1.8
55 BuildRequires:  glib2-devel >= 1:2.20
56 %{!?with_gtk3:BuildRequires:    gtk+2-devel >= 2:2.18}
57 %{?with_gtk3:BuildRequires:     gtk+3-devel >= 3.0.0}
58 %{?with_kerberos:BuildRequires: heimdal-devel >= 0.7.1}
59 BuildRequires:  hunspell-devel
60 BuildRequires:  libIDL-devel >= 0.8.0
61 BuildRequires:  libdnet-devel
62 BuildRequires:  libevent-devel >= 1.4.7
63 # standalone libffi 3.0.9 or gcc's from 4.5(?)+
64 BuildRequires:  libffi-devel >= 6:3.0.9
65 BuildRequires:  libicu-devel >= 50.1
66 # requires libjpeg-turbo implementing at least libjpeg 6b API
67 BuildRequires:  libjpeg-devel >= 6b
68 BuildRequires:  libjpeg-turbo-devel
69 BuildRequires:  libnotify-devel >= 0.4
70 BuildRequires:  libpng(APNG)-devel >= 0.10
71 BuildRequires:  libpng-devel >= 2:1.6.7
72 BuildRequires:  libstdc++-devel
73 BuildRequires:  libvpx-devel >= 1.3.0
74 BuildRequires:  mozldap-devel
75 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
76 BuildRequires:  nss-devel >= 1:%{nss_ver}
77 BuildRequires:  pango-devel >= 1:1.14.0
78 BuildRequires:  perl-base >= 1:5.6
79 BuildRequires:  perl-modules >= 5.004
80 BuildRequires:  pkgconfig
81 BuildRequires:  python >= 1:2.5
82 BuildRequires:  python-modules
83 BuildRequires:  python-virtualenv
84 BuildRequires:  rpm >= 4.4.9-56
85 BuildRequires:  rpmbuild(macros) >= 1.601
86 BuildRequires:  sed >= 4.0
87 BuildRequires:  sqlite3-devel >= 3.8.2
88 BuildRequires:  startup-notification-devel >= 0.8
89 BuildRequires:  xorg-lib-libX11-devel
90 BuildRequires:  xorg-lib-libXScrnSaver-devel
91 BuildRequires:  xorg-lib-libXext-devel
92 BuildRequires:  xorg-lib-libXinerama-devel
93 BuildRequires:  xorg-lib-libXt-devel
94 %if %{with xulrunner}
95 BuildRequires:  xulrunner-devel >= 2:%{xulrunner_ver}
96 BuildRequires:  xulrunner-devel < 2:30
97 %endif
98 BuildRequires:  yasm
99 BuildRequires:  zip
100 BuildRequires:  zlib-devel >= 1.2.3
101 Requires(post): mktemp >= 1.5-18
102 Requires:       desktop-file-utils
103 Requires:       hicolor-icon-theme
104 %if %{with xulrunner}
105 %requires_eq_to xulrunner xulrunner-devel
106 %else
107 Requires:       browser-plugins >= 2.0
108 Requires:       cairo >= 1.10.2-5
109 Requires:       dbus-glib >= 0.60
110 Requires:       glib2 >= 1:2.20
111 %{!?with_gtk3:Requires: gtk+2 >= 2:2.18}
112 %{?with_gtk3:Requires:  gtk+3 >= 3.0.0}
113 Requires:       libjpeg-turbo
114 Requires:       libpng >= 2:1.6.7
115 Requires:       libpng(APNG) >= 0.10
116 Requires:       libvpx >= 1.3.0
117 Requires:       myspell-common
118 Requires:       nspr >= 1:%{nspr_ver}
119 Requires:       nss >= 1:%{nss_ver}
120 Requires:       pango >= 1:1.14.0
121 Requires:       sqlite3 >= %{sqlite_build_version}
122 Requires:       startup-notification >= 0.8
123 %endif
124 Provides:       seamonkey-embedded = %{version}-%{release}
125 Provides:       wwwbrowser
126 Obsoletes:      light
127 Obsoletes:      mozilla
128 Obsoletes:      mozilla-gnomevfs
129 Obsoletes:      seamonkey-calendar
130 Obsoletes:      seamonkey-libs
131 Obsoletes:      seamonkey-mailnews
132 Obsoletes:      seamonkey-gnomevfs
133 Conflicts:      seamonkey-lang-resources < %{version}
134 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
135
136 %define         topdir          %{_builddir}/%{name}-%{version}
137 %define         objdir          %{topdir}/obj-%{_target_cpu}
138
139 %define         filterout_cpp   -D_FORTIFY_SOURCE=[0-9]+
140
141 # don't satisfy other packages
142 %define         _noautoprovfiles        %{_libdir}/%{name}
143 # and as we don't provide them, don't require either
144 %define         _noautoreq      libmozjs.so libxpcom.so libxul.so libjemalloc.so %{!?with_xulrunner:libmozalloc.so}
145 %define         _noautoreqdep   libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpistub.so
146
147 %description
148 SeaMonkey Community Edition is an open-source web browser, designed
149 for standards compliance, performance and portability.
150
151 %description -l es.UTF-8
152 SeaMonkey Community Edition es un navegador de Internet que se basa en
153 una versión inicial de Netscape Communicator.
154
155 %description -l pl.UTF-8
156 SeaMonkey Community Edition jest potężną graficzną przeglądarką WWW,
157 która jest następcą Mozilli, która następnie była następczynią
158 Netscape Communikatora.
159
160 %description -l pt_BR.UTF-8
161 O SeaMonkey Community Edition é um web browser baseado numa versão
162 inicial do Netscape Communicator.
163
164 %description -l ru.UTF-8
165 SeaMonkey Community Edition - полнофункциональный web-browser с
166 открытыми исходными текстами, разработанный для максимального
167 соотвествия стандартам, максмимальной переносимости и скорости работы
168
169 %package addon-lightning
170 Summary:        An integrated calendar for SeaMonkey
171 Summary(pl.UTF-8):      Zintegrowany kalendarz dla SeaMonkey
172 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
173 Group:          Applications/Networking
174 Requires:       %{name} = %{version}-%{release}
175
176 %description addon-lightning
177 Lightning is an calendar extension to Icedove email client.
178
179 %description addon-lightning -l pl.UTF-8
180 Lightning to rozszerzenie do klienta poczty Icedove dodające
181 funkcjonalność kalendarza.
182
183 %package chat
184 Summary:        SeaMonkey Community Edition Chat - integrated IRC client
185 Summary(pl.UTF-8):      SeaMonkey Community Edition Chat - zintegrowany klient IRC-a
186 Group:          X11/Applications/Networking
187 Requires(post,postun):  %{name} = %{version}-%{release}
188 Requires:       %{name} = %{version}-%{release}
189 Obsoletes:      mozilla-chat
190
191 %description chat
192 SeaMonkey Community Edition Chat - IRC client that is integrated with
193 the SeaMonkey Community Edition web browser.
194
195 %description chat -l pl.UTF-8
196 SeaMonkey Community Edition Chat - klient IRC-a zintegrowany z
197 przeglądarką SeaMonkey Community Edition.
198
199 %package js-debugger
200 Summary:        JavaScript debugger for use with SeaMonkey Community Edition
201 Summary(pl.UTF-8):      Odpluskwiacz JavaScriptu do używania z SeaMonkey Community Edition
202 Group:          X11/Applications/Networking
203 Requires(post,postun):  %{name} = %{version}-%{release}
204 Requires:       %{name} = %{version}-%{release}
205 Obsoletes:      mozilla-js-debugger
206
207 %description js-debugger
208 JavaScript debugger for use with SeaMonkey Community Edition.
209
210 %description js-debugger -l pl.UTF-8
211 Odpluskwiacz JavaScriptu do używania z SeaMonkey Community Edition.
212
213 %package dom-inspector
214 Summary:        A tool for inspecting the DOM of pages in SeaMonkey Community Edition
215 Summary(pl.UTF-8):      Narzędzie do oglądania DOM stron w SeaMonkey Community Edition
216 Group:          X11/Applications/Networking
217 Requires(post,postun):  %{name} = %{version}-%{release}
218 Requires:       %{name} = %{version}-%{release}
219 Obsoletes:      mozilla-dom-inspector
220
221 %description dom-inspector
222 This is a tool that allows you to inspect the DOM for web pages in
223 SeaMonkey Community Edition. This is of great use to people who are
224 doing SeaMonkey Community Edition chrome development or web page
225 development.
226
227 %description dom-inspector -l pl.UTF-8
228 To narzędzie pozwala na oglądanie DOM dla stron WWW w SeaMonkey
229 Community Edition. Jest bardzo przydatne dla ludzi rozwijających
230 chrome w SeaMonkey Community Edition lub tworzących strony WWW.
231
232 %prep
233 %setup -qc
234 cd comm-release
235 %patch1 -p1
236 %patch2 -p1
237 %patch3 -p2
238 %patch4 -p1
239 %patch5 -p1
240 %patch6 -p1
241 %patch7 -p1
242 %patch9 -p2
243
244 %build
245 cd comm-release
246 %if %{with xulrunner}
247 if [ "$(grep -E '^[0-9]+\.' mozilla/config/milestone.txt)" != "%{xulrunner_ver}" ]; then
248         echo >&2
249         echo >&2 "Xulrunner version %{xulrunner_ver} does not match mozilla/config/milestone.txt!"
250         echo >&2
251         exit 1
252 fi
253 %endif
254
255 cp -f %{_datadir}/automake/config.* build/autoconf
256 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
257 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
258 cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
259
260 cat << EOF > .mozconfig
261 mk_add_options MOZ_OBJDIR=%{objdir}
262
263 export CFLAGS="%{rpmcflags}"
264 export CXXFLAGS="%{rpmcflags}"
265
266 %if %{with crashreporter}
267 export MOZ_DEBUG_SYMBOLS=1
268 %endif
269
270 # Options for 'configure' (same as command-line options).
271 ac_add_options --prefix=%{_prefix}
272 ac_add_options --exec-prefix=%{_exec_prefix}
273 ac_add_options --bindir=%{_bindir}
274 ac_add_options --sbindir=%{_sbindir}
275 ac_add_options --sysconfdir=%{_sysconfdir}
276 ac_add_options --datadir=%{_datadir}
277 ac_add_options --includedir=%{_includedir}
278 ac_add_options --libdir=%{_libdir}
279 ac_add_options --libexecdir=%{_libexecdir}
280 ac_add_options --localstatedir=%{_localstatedir}
281 ac_add_options --sharedstatedir=%{_sharedstatedir}
282 ac_add_options --mandir=%{_mandir}
283 ac_add_options --infodir=%{_infodir}
284 %if %{?debug:1}0
285 ac_add_options --disable-optimize
286 ac_add_options --enable-debug
287 ac_add_options --enable-debug-modules
288 ac_add_options --enable-debugger-info-modules
289 ac_add_options --enable-crash-on-assert
290 %else
291 ac_add_options --disable-debug
292 ac_add_options --disable-debug-modules
293 ac_add_options --disable-logging
294 ac_add_options --enable-optimize="%{rpmcflags} -Os"
295 %endif
296 ac_add_options --disable-strip
297 ac_add_options --disable-strip-libs
298 %if %{with tests}
299 ac_add_options --enable-tests
300 %else
301 ac_add_options --disable-tests
302 %endif
303 %if %{with lightning}
304 ac_add_options --enable-calendar
305 %else
306 ac_add_options --disable-calendar
307 %endif
308 %if %{with crashreporter}
309 ac_add_options --enable-crashreporter
310 %else
311 ac_add_options --disable-crashreporter
312 %endif
313 ac_add_options --disable-elf-dynstr-gc
314 ac_add_options --disable-gnomeui
315 ac_add_options --disable-gnomevfs
316 ac_add_options --disable-installer
317 ac_add_options --disable-javaxpcom
318 ac_add_options --disable-updater
319 ac_add_options --disable-xterm-updates
320 ac_add_options --enable-application=suite
321 ac_add_options --enable-crypto
322 ac_add_options --enable-default-toolkit=%{?with_gtk3:cairo-gtk3}%{!?with_gtk3:cairo-gtk2}
323 ac_add_options --enable-gio
324 %if %{with ldap}
325 ac_add_options --enable-ldap
326 ac_add_options --with-system-ldap
327 %else
328 ac_add_options --disable-ldap
329 %endif
330 ac_add_options --enable-libxul
331 ac_add_options --enable-pango
332 ac_add_options --enable-postscript
333 ac_add_options --enable-shared-js
334 ac_add_options --enable-startup-notification
335 ac_add_options --enable-system-cairo
336 ac_add_options --enable-system-hunspell
337 ac_add_options --enable-system-sqlite
338 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
339 ac_add_options --with-distribution-id=org.pld-linux
340 %if %{with xulrunner}
341 ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
342 ac_add_options --with-system-libxul
343 %endif
344 ac_add_options --with-pthreads
345 ac_add_options --with-system-bz2
346 ac_add_options --with-system-ffi
347 ac_add_options --with-system-jpeg
348 ac_add_options --with-system-libevent
349 ac_add_options --with-system-libvpx
350 ac_add_options --with-system-nspr
351 ac_add_options --with-system-nss
352 ac_add_options --with-system-png
353 ac_add_options --with-system-zlib
354 EOF
355
356 %{__make} -j1 -f client.mk build \
357         STRIP="/bin/true" \
358         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
359         installdir=%{_libdir}/%{name} \
360         XLIBS="-lX11 -lXt" \
361         CC="%{__cc}" \
362         CXX="%{__cxx}"
363
364 %if %{with crashreporter}
365 # create debuginfo for crash-stats.mozilla.com
366 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
367 %endif
368
369 %install
370 rm -rf $RPM_BUILD_ROOT
371 cd comm-release
372 install -d \
373         $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
374         $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}} \
375         $RPM_BUILD_ROOT%{_datadir}/%{name} \
376         $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins
377
378 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins
379
380 cd %{objdir}
381 cwd=`pwd`
382 %{__make} -C suite/installer stage-package \
383         LD_LIBRARY_PATH=$cwd/mozilla/dist/lib \
384         DESTDIR=$RPM_BUILD_ROOT \
385         installdir=%{_libdir}/%{name} \
386         PKG_SKIP_STRIP=1
387
388 cp -a mozilla/dist/seamonkey/* $RPM_BUILD_ROOT%{_libdir}/%{name}/
389
390 %if %{with xulrunner}
391 # >= 5.0 seems to require this
392 ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
393 %endif
394
395 # Enable crash reporter for Thunderbird application
396 %if %{with crashreporter}
397 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
398
399 # Add debuginfo for crash-stats.mozilla.com
400 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
401 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
402 %endif
403
404 # copy manually lightning files, somewhy they are not installed by make
405 cp -a mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
406         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
407
408 # move arch independant ones to datadir
409 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
410 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
411 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
412
413 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
414 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
415 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
416
417 %if %{without xulrunner}
418 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
419 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
420 %endif
421
422 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/* \
423         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/
424
425 # dir for arch independant extensions besides arch dependant extensions
426 # see mozilla/xpcom/build/nsXULAppAPI.h
427 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
428 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
429  
430 %if %{without xulrunner}
431 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
432 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
433 %endif
434
435 sed 's,@LIBDIR@,%{_libdir},' %{SOURCE9} > $RPM_BUILD_ROOT%{_bindir}/seamonkey
436 chmod a+rx $RPM_BUILD_ROOT%{_bindir}/seamonkey
437
438 install %{SOURCE4} %{SOURCE5} %{SOURCE6} %{SOURCE7} %{SOURCE8} \
439         $RPM_BUILD_ROOT%{_desktopdir}
440
441 cp -p %{topdir}/comm-release/suite/branding/nightly/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
442
443 # files created by seamonkey -register
444 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
445 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
446
447 cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
448 #!/bin/sh
449 umask 022
450 rm -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
451
452 # it attempts to touch files in $HOME/.mozilla
453 # beware if you run this with sudo!!!
454 export HOME=$(mktemp -d)
455 # also TMPDIR could be pointing to sudo user's homedir
456 unset TMPDIR TMP || :
457
458 %{_libdir}/%{name}/seamonkey -register
459
460 rm -rf $HOME
461 EOF
462 chmod 755 $RPM_BUILD_ROOT%{_libdir}/%{name}/register
463
464 %if %{without xulrunner}
465 # never package these. always remove
466 # mozldap
467 %{__sed} -i '/lib\(ldap\|ldif\|prldap\)60.so/d' $RPM_BUILD_ROOT%{_libdir}/%{name}/dependentlibs.list
468 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap}60.so
469 %endif
470
471 %clean
472 rm -rf $RPM_BUILD_ROOT
473
474 %post
475 %{_libdir}/%{name}/register || :
476 %update_browser_plugins
477 %update_desktop_database
478
479 %postun
480 if [ "$1" = 0 ]; then
481         %update_browser_plugins
482 fi
483
484 %files
485 %defattr(644,root,root,755)
486 %attr(755,root,root) %{_bindir}/seamonkey
487
488 # browser plugins v2
489 %{_browserpluginsconfdir}/browsers.d/%{name}.*
490 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
491
492 %dir %{_libdir}/%{name}
493 %if %{without xulrunner}
494 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
495 %attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
496 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
497 %endif
498
499 %{_libdir}/%{name}/blocklist.xml
500 %{_libdir}/%{name}/omni.ja
501 %attr(755,root,root) %{_libdir}/%{name}/register
502
503 %if %{with crashreporter}
504 %{_libdir}/%{name}/crashreporter
505 %{_libdir}/%{name}/crashreporter-override.ini
506 %{_libdir}/%{name}/crashreporter.ini
507 %{_libdir}/%{name}/Throbber-small.gif
508 %endif
509
510 # config?
511 %{_libdir}/%{name}/application.ini
512 %{_libdir}/%{name}/chrome.manifest
513
514 %dir %{_libdir}/%{name}/components
515 %{_libdir}/%{name}/components/components.manifest
516 %attr(755,root,root) %{_libdir}/%{name}/components/libsuite.so
517
518 %if %{without xulrunner}
519 %{_libdir}/%{name}/dependentlibs.list
520 %{_libdir}/%{name}/platform.ini
521 %attr(755,root,root) %{_libdir}/%{name}/components/libdbusservice.so
522 %attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so
523 %attr(755,root,root) %{_libdir}/%{name}/run-mozilla.sh
524 %attr(755,root,root) %{_libdir}/%{name}/seamonkey-bin
525 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
526 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
527 %endif
528
529 %attr(755,root,root) %{_libdir}/%{name}/seamonkey
530 %dir %{_libdir}/%{name}/plugins
531
532 # symlinks
533 %{_libdir}/%{name}/chrome
534 %{_libdir}/%{name}/defaults
535 %{_libdir}/%{name}/searchplugins
536 %if %{with xulrunner}
537 %{_libdir}/%{name}/xulrunner
538 %else
539 %{_libdir}/%{name}/dictionaries
540 %endif
541
542 %dir %{_datadir}/%{name}
543 %{_datadir}/%{name}/chrome
544 %{_datadir}/%{name}/defaults
545 %{_datadir}/%{name}/searchplugins
546
547 %dir %{_datadir}/%{name}/extensions
548 %dir %{_libdir}/%{name}/extensions
549 # the signature of the default theme
550 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}.xpi
551 %{_libdir}/%{name}/extensions/modern@themes.mozilla.org.xpi
552
553 # files created by seamonkey -register
554 %ghost %{_libdir}/%{name}/components/compreg.dat
555 %ghost %{_libdir}/%{name}/components/xpti.dat
556
557 %if %{without xulrunner}
558 %{_libdir}/%{name}/isp
559 %dir %{_datadir}/%{name}/isp
560 %{_datadir}/%{name}/isp/Bogofilter.sfd
561 %{_datadir}/%{name}/isp/DSPAM.sfd
562 %{_datadir}/%{name}/isp/POPFile.sfd
563 %{_datadir}/%{name}/isp/SpamAssassin.sfd
564 %{_datadir}/%{name}/isp/SpamPal.sfd
565 %{_datadir}/%{name}/isp/movemail.rdf
566 %{_datadir}/%{name}/isp/rss.rdf
567 %endif
568
569 %{_pixmapsdir}/seamonkey.png
570 %{_desktopdir}/%{name}.desktop
571 %{_desktopdir}/%{name}-composer.desktop
572 %{_desktopdir}/%{name}-mail.desktop
573
574 %if %{with lightning}
575 %files addon-lightning
576 %defattr(644,root,root,755)
577 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
578 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
579 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
580 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
581 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
582 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
583 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
584 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
585 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
586 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
587 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
588 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
589 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
590 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
591 %endif
592
593 %files chat
594 %defattr(644,root,root,755)
595 %{_libdir}/%{name}/extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}.xpi
596 %{_desktopdir}/%{name}-chat.desktop
597
598 %files js-debugger
599 %defattr(644,root,root,755)
600 %{_libdir}/%{name}/extensions/{f13b157f-b174-47e7-a34d-4815ddfdfeb8}.xpi
601 %{_desktopdir}/%{name}-venkman.desktop
602
603 %files dom-inspector
604 %defattr(644,root,root,755)
605 %{_libdir}/%{name}/extensions/inspector@mozilla.org.xpi
This page took 0.439123 seconds and 4 git commands to generate.