]> git.pld-linux.org Git - packages/seamonkey.git/blob - seamonkey.spec
- up to 2.15.2
[packages/seamonkey.git] / seamonkey.spec
1 #
2 # Conditional build:
3 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
4 %bcond_without  gnomeui         # disable gnomeui support
5 %bcond_without  gnome           # disable gnomeui (alias)
6 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
7 %bcond_without  lightning       # disable Sunbird/Lightning calendar
8 %bcond_with     xulrunner       # build with system xulrunner
9 %bcond_with     tests           # enable tests (whatever they check)
10 %bcond_without  kerberos        # disable krb5 support
11
12 %if %{without gnome}
13 %undefine       with_gnomeui
14 %endif
15
16 %define         enigmail_ver    1.5.1
17 %define         nspr_ver        4.9.3
18 %define         nss_ver         3.14.1
19 %define         xulrunner_ver   18.0.2
20
21 %if %{without xulrunner}
22 # The actual sqlite version (see RHBZ#480989):
23 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
24 %endif
25
26 Summary:        SeaMonkey Community Edition - web browser
27 Summary(es.UTF-8):      Navegador de Internet SeaMonkey Community Edition
28 Summary(pl.UTF-8):      SeaMonkey Community Edition - przeglądarka WWW
29 Summary(pt_BR.UTF-8):   Navegador SeaMonkey Community Edition
30 Name:           seamonkey
31 Version:        2.15.2
32 Release:        1
33 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
34 Group:          X11/Applications/Networking
35 Source0:        http://ftp.mozilla.org/pub/mozilla.org/seamonkey/releases/%{version}/source/%{name}-%{version}.source.tar.bz2
36 # Source0-md5:  1938c5a9673e94e9f5c809f5dbfe8d29
37 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
38 # Source1-md5:  3e71f84ed2c11471282412ebe4f5eb2d
39 Source4:        %{name}.desktop
40 Source5:        %{name}-composer.desktop
41 Source6:        %{name}-chat.desktop
42 Source7:        %{name}-mail.desktop
43 Source8:        %{name}-venkman.desktop
44 Source9:        %{name}.sh
45 Patch1:         %{name}-pld-branding.patch
46 Patch2:         %{name}-agent.patch
47 Patch3:         %{name}-glueload-fix.patch
48 Patch4:         system-mozldap.patch
49 Patch5:         makefile.patch
50 Patch6:         system-cairo.patch
51 # Edit patch below and restore --system-site-packages when system virtualenv gets 1.7 upgrade
52 Patch7:         %{name}-system-virtualenv.patch
53 Patch8:         %{name}-gyp-slashism.patch
54 Patch9:         %{name}-system-xulrunner.patch
55 URL:            http://www.seamonkey-project.org/
56 BuildRequires:  GConf2-devel >= 1.2.1
57 BuildRequires:  OpenGL-devel
58 BuildRequires:  alsa-lib-devel
59 BuildRequires:  automake
60 BuildRequires:  bzip2-devel
61 BuildRequires:  cairo-devel >= 1.10.2-5
62 BuildRequires:  dbus-glib-devel >= 0.60
63 BuildRequires:  freetype-devel >= 1:2.1.8
64 BuildRequires:  glib2-devel >= 1:2.18
65 BuildRequires:  gtk+2-devel >= 2:2.10
66 %{?with_kerberos:BuildRequires: heimdal-devel >= 0.7.1}
67 BuildRequires:  hunspell-devel
68 BuildRequires:  libIDL-devel >= 0.8.0
69 BuildRequires:  libdnet-devel
70 BuildRequires:  libevent-devel >= 1.4.7
71 # standalone libffi 3.0.9 or gcc's from 4.5(?)+
72 BuildRequires:  libffi-devel >= 6:3.0.9
73 %{?with_gnomeui:BuildRequires:  libgnome-devel >= 2.0}
74 %{?with_gnomeui:BuildRequires:  libgnome-keyring-devel}
75 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
76 BuildRequires:  libiw-devel
77 # requires libjpeg-turbo implementing at least libjpeg 6b API
78 BuildRequires:  libjpeg-devel >= 6b
79 BuildRequires:  libjpeg-turbo-devel
80 BuildRequires:  libnotify-devel >= 0.4
81 BuildRequires:  libpng(APNG)-devel >= 0.10
82 BuildRequires:  libpng-devel >= 1.4.1
83 BuildRequires:  libstdc++-devel
84 BuildRequires:  libvpx-devel >= 1.0.0
85 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
86 BuildRequires:  nss-devel >= 1:%{nss_ver}
87 BuildRequires:  pango-devel >= 1:1.14.0
88 BuildRequires:  perl-base >= 1:5.6
89 BuildRequires:  perl-modules >= 5.004
90 BuildRequires:  pkgconfig
91 BuildRequires:  python >= 1:2.5
92 BuildRequires:  python-modules
93 BuildRequires:  python-virtualenv
94 BuildRequires:  rpm >= 4.4.9-56
95 BuildRequires:  rpmbuild(macros) >= 1.601
96 BuildRequires:  sed >= 4.0
97 BuildRequires:  sqlite3-devel >= 3.7.10
98 BuildRequires:  startup-notification-devel >= 0.8
99 BuildRequires:  xorg-lib-libXScrnSaver-devel
100 BuildRequires:  xorg-lib-libXext-devel
101 BuildRequires:  xorg-lib-libXinerama-devel
102 BuildRequires:  xorg-lib-libXt-devel
103 %if %{with xulrunner}
104 BuildRequires:  xulrunner-devel >= 2:%{xulrunner_ver}
105 BuildRequires:  xulrunner-devel < 2:19
106 %endif
107 BuildRequires:  yasm
108 BuildRequires:  zip
109 BuildRequires:  zlib-devel >= 1.2.3
110 Requires(post): mktemp >= 1.5-18
111 Requires:       desktop-file-utils
112 Requires:       hicolor-icon-theme
113 %if %{with xulrunner}
114 %requires_eq_to xulrunner xulrunner-devel
115 %else
116 Requires:       browser-plugins >= 2.0
117 Requires:       cairo >= 1.10.2-5
118 Requires:       dbus-glib >= 0.60
119 Requires:       gtk+2 >= 2:2.18
120 Requires:       libjpeg-turbo
121 Requires:       libpng >= 1.4.1
122 Requires:       libpng(APNG) >= 0.10
123 Requires:       myspell-common
124 Requires:       nspr >= 1:%{nspr_ver}
125 Requires:       nss >= 1:%{nss_ver}
126 Requires:       pango >= 1:1.14.0
127 Requires:       sqlite3 >= %{sqlite_build_version}
128 Requires:       startup-notification >= 0.8
129 %endif
130 Provides:       seamonkey-embedded = %{version}-%{release}
131 Provides:       wwwbrowser
132 Obsoletes:      light
133 Obsoletes:      mozilla
134 Obsoletes:      mozilla-gnomevfs
135 Obsoletes:      seamonkey-calendar
136 Obsoletes:      seamonkey-libs
137 Obsoletes:      seamonkey-mailnews
138 Obsoletes:      seamonkey-gnomevfs
139 Conflicts:      seamonkey-lang-resources < %{version}
140 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
141
142 %define         topdir          %{_builddir}/%{name}-%{version}
143 %define         objdir          %{topdir}/obj-%{_target_cpu}
144
145 %define         filterout_cpp   -D_FORTIFY_SOURCE=[0-9]+
146
147 # don't satisfy other packages
148 %define         _noautoprovfiles        %{_libdir}/%{name}
149 # and as we don't provide them, don't require either
150 %define         _noautoreq      libmozjs.so libxpcom.so libxul.so libjemalloc.so %{!?with_xulrunner:libmozalloc.so}
151 %define         _noautoreqdep   libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpistub.so
152
153 %description
154 SeaMonkey Community Edition is an open-source web browser, designed
155 for standards compliance, performance and portability.
156
157 %description -l es.UTF-8
158 SeaMonkey Community Edition es un navegador de Internet que se basa en
159 una versión inicial de Netscape Communicator.
160
161 %description -l pl.UTF-8
162 SeaMonkey Community Edition jest potężną graficzną przeglądarką WWW,
163 która jest następcą Mozilli, która następnie była następczynią
164 Netscape Communikatora.
165
166 %description -l pt_BR.UTF-8
167 O SeaMonkey Community Edition é um web browser baseado numa versão
168 inicial do Netscape Communicator.
169
170 %description -l ru.UTF-8
171 SeaMonkey Community Edition - полнофункциональный web-browser с
172 открытыми исходными текстами, разработанный для максимального
173 соотвествия стандартам, максмимальной переносимости и скорости работы
174
175 %package addon-lightning
176 Summary:        An integrated calendar for SeaMonkey
177 Summary(pl.UTF-8):      Zintegrowany kalendarz dla SeaMonkey
178 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
179 Group:          Applications/Networking
180 Requires:       %{name} = %{version}-%{release}
181
182 %description addon-lightning
183 Lightning is an calendar extension to Icedove email client.
184
185 %description addon-lightning -l pl.UTF-8
186 Lightning to rozszerzenie do klienta poczty Icedove dodające
187 funkcjonalność kalendarza.
188
189 %package addon-enigmail
190 Summary:        Enigmail %{enigmail_ver} - PGP/GPG support for SeaMonkey Community Edition
191 Summary(pl.UTF-8):      Enigmail %{enigmail_ver} - obsługa PGP/GPG dla SeaMonkey Community Edition
192 Group:          X11/Applications/Networking
193 Requires(post,postun):  %{name} = %{version}-%{release}
194 Requires:       %{name} = %{version}-%{release}
195 Requires:       gnupg >= 1.4.2.2
196
197 %description addon-enigmail
198 Enigmail is an extension to the mail client of SeaMonkey / Mozilla /
199 Netscape and Mozilla Thunderbird which allows users to access the
200 authentication and encryption features provided by GnuPG.
201
202 %description addon-enigmail -l pl.UTF-8
203 Enigmail jest rozszerzeniem dla klienta pocztowego SeaMonkey, Mozilla
204 i Mozilla Thunderdbird pozwalającym użytkownikowi korzystać z
205 funkcjonalności GnuPG.
206
207 %package chat
208 Summary:        SeaMonkey Community Edition Chat - integrated IRC client
209 Summary(pl.UTF-8):      SeaMonkey Community Edition Chat - zintegrowany klient IRC-a
210 Group:          X11/Applications/Networking
211 Requires(post,postun):  %{name} = %{version}-%{release}
212 Requires:       %{name} = %{version}-%{release}
213 Obsoletes:      mozilla-chat
214
215 %description chat
216 SeaMonkey Community Edition Chat - IRC client that is integrated with
217 the SeaMonkey Community Edition web browser.
218
219 %description chat -l pl.UTF-8
220 SeaMonkey Community Edition Chat - klient IRC-a zintegrowany z
221 przeglądarką SeaMonkey Community Edition.
222
223 %package js-debugger
224 Summary:        JavaScript debugger for use with SeaMonkey Community Edition
225 Summary(pl.UTF-8):      Odpluskwiacz JavaScriptu do używania z SeaMonkey Community Edition
226 Group:          X11/Applications/Networking
227 Requires(post,postun):  %{name} = %{version}-%{release}
228 Requires:       %{name} = %{version}-%{release}
229 Obsoletes:      mozilla-js-debugger
230
231 %description js-debugger
232 JavaScript debugger for use with SeaMonkey Community Edition.
233
234 %description js-debugger -l pl.UTF-8
235 Odpluskwiacz JavaScriptu do używania z SeaMonkey Community Edition.
236
237 %package dom-inspector
238 Summary:        A tool for inspecting the DOM of pages in SeaMonkey Community Edition
239 Summary(pl.UTF-8):      Narzędzie do oglądania DOM stron w SeaMonkey Community Edition
240 Group:          X11/Applications/Networking
241 Requires(post,postun):  %{name} = %{version}-%{release}
242 Requires:       %{name} = %{version}-%{release}
243 Obsoletes:      mozilla-dom-inspector
244
245 %description dom-inspector
246 This is a tool that allows you to inspect the DOM for web pages in
247 SeaMonkey Community Edition. This is of great use to people who are
248 doing SeaMonkey Community Edition chrome development or web page
249 development.
250
251 %description dom-inspector -l pl.UTF-8
252 To narzędzie pozwala na oglądanie DOM dla stron WWW w SeaMonkey
253 Community Edition. Jest bardzo przydatne dla ludzi rozwijających
254 chrome w SeaMonkey Community Edition lub tworzących strony WWW.
255
256 %prep
257 %setup -qc
258 cd comm-release
259 tar -C mailnews/extensions -zxf %{SOURCE1}
260 %patch1 -p1
261 %patch2 -p1
262 %patch3 -p1
263 %patch4 -p1
264 %patch5 -p1
265 %patch6 -p1
266 %patch7 -p1
267 %patch8 -p1
268 %patch9 -p2
269
270 %build
271 cd comm-release
272 %if %{with xulrunner}
273 if [ "$(grep -E '^[0-9]+\.' mozilla/config/milestone.txt)" != "%{xulrunner_ver}" ]; then
274         echo >&2
275         echo >&2 "Xulrunner version %{xulrunner_ver} does not match mozilla/config/milestone.txt!"
276         echo >&2
277         exit 1
278 fi
279 %endif
280
281 cp -f %{_datadir}/automake/config.* build/autoconf
282 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
283 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
284 cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
285
286 cat << EOF > .mozconfig
287 mk_add_options MOZ_OBJDIR=%{objdir}
288
289 export CFLAGS="%{rpmcflags}"
290 export CXXFLAGS="%{rpmcflags}"
291
292 %if %{with crashreporter}
293 export MOZ_DEBUG_SYMBOLS=1
294 %endif
295
296 # Options for 'configure' (same as command-line options).
297 ac_add_options --prefix=%{_prefix}
298 ac_add_options --exec-prefix=%{_exec_prefix}
299 ac_add_options --bindir=%{_bindir}
300 ac_add_options --sbindir=%{_sbindir}
301 ac_add_options --sysconfdir=%{_sysconfdir}
302 ac_add_options --datadir=%{_datadir}
303 ac_add_options --includedir=%{_includedir}
304 ac_add_options --libdir=%{_libdir}
305 ac_add_options --libexecdir=%{_libexecdir}
306 ac_add_options --localstatedir=%{_localstatedir}
307 ac_add_options --sharedstatedir=%{_sharedstatedir}
308 ac_add_options --mandir=%{_mandir}
309 ac_add_options --infodir=%{_infodir}
310 ac_add_options --disable-elf-hack
311 %if %{?debug:1}0
312 ac_add_options --disable-optimize
313 ac_add_options --enable-debug
314 ac_add_options --enable-debug-modules
315 ac_add_options --enable-debugger-info-modules
316 ac_add_options --enable-crash-on-assert
317 %else
318 ac_add_options --disable-debug
319 ac_add_options --disable-debug-modules
320 ac_add_options --disable-logging
321 ac_add_options --enable-optimize="%{rpmcflags} -Os"
322 %endif
323 ac_add_options --disable-strip
324 ac_add_options --disable-strip-libs
325 %if %{with tests}
326 ac_add_options --enable-tests
327 %else
328 ac_add_options --disable-tests
329 %endif
330 ac_add_options --enable-gio
331 %if %{with gnomeui}
332 ac_add_options --enable-gnomeui
333 %else
334 ac_add_options --disable-gnomeui
335 %endif
336 ac_add_options --disable-gnomevfs
337 %if %{with ldap}
338 ac_add_options --enable-ldap
339 ac_add_options --with-system-ldap
340 %else
341 ac_add_options --disable-ldap
342 %endif
343 %if %{with crashreporter}
344 ac_add_options --enable-crashreporter
345 %else
346 ac_add_options --disable-crashreporter
347 %endif
348 ac_add_options --disable-xterm-updates
349 ac_add_options --enable-postscript
350 %if %{with lightning}
351 ac_add_options --enable-calendar
352 %else
353 ac_add_options --disable-calendar
354 %endif
355 ac_add_options --disable-installer
356 ac_add_options --disable-javaxpcom
357 ac_add_options --disable-updater
358 ac_add_options --enable-crypto
359 ac_add_options --enable-libxul
360 ac_add_options --enable-pango
361 ac_add_options --enable-shared-js
362 ac_add_options --enable-startup-notification
363 ac_add_options --enable-system-cairo
364 ac_add_options --enable-system-hunspell
365 ac_add_options --enable-system-sqlite
366 ac_add_options --enable-application=suite
367 ac_add_options --with-distribution-id=org.pld-linux
368 %if %{with xulrunner}
369 ac_add_options --with-system-libxul
370 ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
371 %endif
372 ac_add_options --with-pthreads
373 ac_add_options --with-system-bz2
374 ac_add_options --with-system-ffi
375 ac_add_options --with-system-jpeg
376 ac_add_options --with-system-libevent
377 ac_add_options --with-system-libvpx
378 ac_add_options --with-system-nspr
379 ac_add_options --with-system-nss
380 ac_add_options --with-system-png
381 ac_add_options --with-system-zlib
382 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
383 EOF
384
385 %{__make} -j1 -f client.mk build \
386         STRIP="/bin/true" \
387         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
388         installdir=%{_libdir}/%{name} \
389         XLIBS="-lX11 -lXt" \
390         CC="%{__cc}" \
391         CXX="%{__cxx}"
392
393 %if %{with crashreporter}
394 # create debuginfo for crash-stats.mozilla.com
395 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
396 %endif
397
398 %if %{with enigmail}
399 cd mailnews/extensions/enigmail
400 ./makemake -r -o %{objdir}
401 %{__make} -C %{objdir}/mailnews/extensions/enigmail \
402         STRIP="/bin/true" \
403         CC="%{__cc}" \
404         CXX="%{__cxx}"
405
406 %{__make} -C %{objdir}/mailnews/extensions/enigmail xpi \
407         STRIP="/bin/true" \
408         CC="%{__cc}" \
409         CXX="%{__cxx}"
410 %endif
411
412 %install
413 rm -rf $RPM_BUILD_ROOT
414 cd comm-release
415 install -d \
416         $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
417         $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}} \
418         $RPM_BUILD_ROOT%{_datadir}/%{name} \
419         $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins
420
421 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins
422
423 cd %{objdir}
424 %{__make} -C suite/installer stage-package \
425         DESTDIR=$RPM_BUILD_ROOT \
426         installdir=%{_libdir}/%{name} \
427         PKG_SKIP_STRIP=1
428
429 cp -a mozilla/dist/seamonkey/* $RPM_BUILD_ROOT%{_libdir}/%{name}/
430
431 %if %{with xulrunner}
432 # >= 5.0 seems to require this
433 ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
434 %endif
435
436 # Enable crash reporter for Thunderbird application
437 %if %{with crashreporter}
438 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
439
440 # Add debuginfo for crash-stats.mozilla.com
441 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
442 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
443 %endif
444
445 # copy manually lightning files, somewhy they are not installed by make
446 cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
447         mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
448         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
449                 
450 # move arch independant ones to datadir
451 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
452 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
453 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
454 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
455 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
456 %if %{without xulrunner}
457 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs.js $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs.js
458 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
459 %endif
460
461 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
462 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
463 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
464 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
465 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
466 %if %{without xulrunner}
467 ln -s ../../share/%{name}/greprefs.js $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs.js
468 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
469 %endif
470
471 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/* \
472         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/
473
474 # dir for arch independant extensions besides arch dependant extensions
475 # see mozilla/xpcom/build/nsXULAppAPI.h
476 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
477 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
478  
479 %if %{without xulrunner}
480 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
481 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
482 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
483 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
484 %endif
485
486 sed 's,@LIBDIR@,%{_libdir},' %{SOURCE9} > $RPM_BUILD_ROOT%{_bindir}/seamonkey
487 chmod a+rx $RPM_BUILD_ROOT%{_bindir}/seamonkey
488
489 install %{SOURCE4} %{SOURCE5} %{SOURCE6} %{SOURCE7} %{SOURCE8} \
490         $RPM_BUILD_ROOT%{_desktopdir}
491
492 cp -p %{topdir}/comm-release/suite/branding/nightly/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
493
494 # files created by seamonkey -register
495 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
496 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
497
498 cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
499 #!/bin/sh
500 umask 022
501 rm -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
502
503 # it attempts to touch files in $HOME/.mozilla
504 # beware if you run this with sudo!!!
505 export HOME=$(mktemp -d)
506 # also TMPDIR could be pointing to sudo user's homedir
507 unset TMPDIR TMP || :
508
509 %{_libdir}/%{name}/seamonkey -register
510
511 rm -rf $HOME
512 EOF
513 chmod 755 $RPM_BUILD_ROOT%{_libdir}/%{name}/register
514
515 %if %{with enigmail}
516 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
517 install -d $ext_dir/{chrome,components,defaults/preferences,modules}
518 cd mozilla/dist/bin
519 cp -rfLp chrome/enigmail.jar $ext_dir/chrome
520 cp -rfLp components/enig* $ext_dir/components
521 cp -rfLp components/libenigmime.so $ext_dir/components
522 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
523 cp -rfLp modules/{commonFuncs,enigmailCommon,keyManagement,pipeConsole,subprocess}.jsm $ext_dir/modules
524 cp -rfLp modules/{subprocess_worker_unix,subprocess_worker_win}.js $ext_dir/modules
525 cd -
526 cp -p %{topdir}/comm-release/mailnews/extensions/enigmail/package/install.rdf $ext_dir
527 cp -p %{topdir}/comm-release/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
528 %endif
529
530 # never package these. always remove
531 # nss
532 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
533 # nspr
534 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
535 # mozldap
536 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
537 # testpilot quiz
538 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/tbtestpilot@labs.mozilla.com.xpi
539
540 %clean
541 rm -rf $RPM_BUILD_ROOT
542
543 %post
544 %{_libdir}/%{name}/register || :
545 %update_browser_plugins
546 %update_desktop_database
547
548 %postun
549 if [ "$1" = 0 ]; then
550         %update_browser_plugins
551 fi
552
553 %files
554 %defattr(644,root,root,755)
555 %attr(755,root,root) %{_bindir}/seamonkey
556
557 # browser plugins v2
558 %{_browserpluginsconfdir}/browsers.d/%{name}.*
559 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
560
561 %dir %{_libdir}/%{name}
562 %if %{without xulrunner}
563 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
564 %attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
565 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
566 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
567 %endif
568
569 %{_libdir}/%{name}/blocklist.xml
570 %attr(755,root,root) %{_libdir}/%{name}/register
571
572 %if %{with crashreporter}
573 %{_libdir}/%{name}/crashreporter
574 %{_libdir}/%{name}/crashreporter-override.ini
575 %{_libdir}/%{name}/crashreporter.ini
576 %{_libdir}/%{name}/Throbber-small.gif
577 %endif
578
579 # config?
580 %{_libdir}/%{name}/application.ini
581 %{_libdir}/%{name}/chrome.manifest
582
583 %dir %{_libdir}/%{name}/components
584
585 %{_libdir}/%{name}/components/Aitc.js
586 %{_libdir}/%{name}/components/AlarmsManager.js
587 %{_libdir}/%{name}/components/AppsService.js
588 %{_libdir}/%{name}/components/BrowserElementParent.js
589 %{_libdir}/%{name}/components/ColorAnalyzer.js
590 %{_libdir}/%{name}/components/ContactManager.js
591 %{_libdir}/%{name}/components/FeedConverter.js
592 %{_libdir}/%{name}/components/FeedWriter.js
593 %{_libdir}/%{name}/components/SettingsManager.js
594 %{_libdir}/%{name}/components/SiteSpecificUserAgent.js
595 %{_libdir}/%{name}/components/TCPSocket.js
596 %{_libdir}/%{name}/components/TCPSocketParentIntermediary.js
597 %{_libdir}/%{name}/components/Weave.js
598 %{_libdir}/%{name}/components/Webapps.js
599 %{_libdir}/%{name}/components/WebContentConverter.js
600 %{_libdir}/%{name}/components/messageWakeupService.js
601 %{_libdir}/%{name}/components/newMailNotificationService.js
602 %{_libdir}/%{name}/components/nsAbout.js
603 %{_libdir}/%{name}/components/nsBrowserContentHandler.js
604 %{_libdir}/%{name}/components/nsComposerCmdLineHandler.js
605 %{_libdir}/%{name}/components/nsDOMIdentity.js
606 %{_libdir}/%{name}/components/nsIDService.js
607 %{_libdir}/%{name}/components/nsSessionStartup.js
608 %{_libdir}/%{name}/components/nsSessionStore.js
609 %{_libdir}/%{name}/components/nsSetDefault.js
610 %{_libdir}/%{name}/components/nsSidebar.js
611 %{_libdir}/%{name}/components/nsSuiteDownloadManagerUI.js
612 %{_libdir}/%{name}/components/nsSuiteGlue.js
613 %{_libdir}/%{name}/components/nsTypeAheadFind.js
614 %{_libdir}/%{name}/components/nsUrlClassifierHashCompleter.js
615 %{_libdir}/%{name}/components/nsUrlClassifierLib.js
616 %{_libdir}/%{name}/components/nsUrlClassifierListManager.js
617 %{_libdir}/%{name}/components/smileApplication.js
618
619 %{_libdir}/%{name}/components/browser.xpt
620 %{_libdir}/%{name}/components/components.manifest
621 %{_libdir}/%{name}/components/interfaces.manifest
622
623 %attr(755,root,root) %{_libdir}/%{name}/components/libsuite.so
624
625 %if %{without xulrunner}
626 %{_libdir}/%{name}/dependentlibs.list
627 %{_libdir}/%{name}/platform.ini
628 %{_libdir}/%{name}/components/ConsoleAPI.js
629 %{_libdir}/%{name}/components/FeedProcessor.js
630 %{_libdir}/%{name}/components/GPSDGeolocationProvider.js
631 %{_libdir}/%{name}/components/NetworkGeolocationProvider.js
632 %{_libdir}/%{name}/components/PlacesCategoriesStarter.js
633 %{_libdir}/%{name}/components/TelemetryPing.js
634 %{_libdir}/%{name}/components/addonManager.js
635 %{_libdir}/%{name}/components/amContentHandler.js
636 %{_libdir}/%{name}/components/amWebInstallListener.js
637 %{_libdir}/%{name}/components/contentAreaDropListener.js
638 %{_libdir}/%{name}/components/contentSecurityPolicy.js
639 %{_libdir}/%{name}/components/crypto-SDR.js
640 %{_libdir}/%{name}/components/jsconsole-clhandler.js
641 %{_libdir}/%{name}/components/nsBadCertHandler.js
642 %{_libdir}/%{name}/components/nsBlocklistService.js
643 %{_libdir}/%{name}/components/nsContentDispatchChooser.js
644 %{_libdir}/%{name}/components/nsContentPrefService.js
645 %{_libdir}/%{name}/components/nsDefaultCLH.js
646 %{_libdir}/%{name}/components/nsFilePicker.js
647 %{_libdir}/%{name}/components/nsFormAutoComplete.js
648 %{_libdir}/%{name}/components/nsFormHistory.js
649 %{_libdir}/%{name}/components/nsHandlerService.js
650 %{_libdir}/%{name}/components/nsHelperAppDlg.js
651 %{_libdir}/%{name}/components/nsINIProcessor.js
652 %{_libdir}/%{name}/components/nsInputListAutoComplete.js
653 %{_libdir}/%{name}/components/nsLivemarkService.js
654 %{_libdir}/%{name}/components/nsLoginInfo.js
655 %{_libdir}/%{name}/components/nsLoginManager.js
656 %{_libdir}/%{name}/components/nsLoginManagerPrompter.js
657 %{_libdir}/%{name}/components/nsPlacesAutoComplete.js
658 %{_libdir}/%{name}/components/nsPlacesExpiration.js
659 %{_libdir}/%{name}/components/nsPrompter.js
660 %{_libdir}/%{name}/components/nsSearchService.js
661 %{_libdir}/%{name}/components/nsSearchSuggestions.js
662 %{_libdir}/%{name}/components/nsTaggingService.js
663 %{_libdir}/%{name}/components/nsUpdateTimerManager.js
664 %{_libdir}/%{name}/components/nsURLFormatter.js
665 %{_libdir}/%{name}/components/nsWebHandlerApp.js
666 %{_libdir}/%{name}/components/storage-Legacy.js
667 %{_libdir}/%{name}/components/storage-mozStorage.js
668 %{_libdir}/%{name}/components/txEXSLTRegExFunctions.js
669 %attr(755,root,root) %{_libdir}/%{name}/components/libdbusservice.so
670 %attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so
671 %attr(755,root,root) %{_libdir}/%{name}/run-mozilla.sh
672 %attr(755,root,root) %{_libdir}/%{name}/seamonkey-bin
673 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
674 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
675 %endif
676
677 %attr(755,root,root) %{_libdir}/%{name}/seamonkey
678 %dir %{_libdir}/%{name}/plugins
679
680 # symlinks
681 %{_libdir}/%{name}/chrome
682 %{_libdir}/%{name}/defaults
683 %{_libdir}/%{name}/modules
684 %{_libdir}/%{name}/searchplugins
685 %if %{with xulrunner}
686 %{_libdir}/%{name}/xulrunner
687 %else
688 %{_libdir}/%{name}/dictionaries
689 %{_libdir}/%{name}/hyphenation
690 %{_libdir}/%{name}/greprefs.js
691 %{_libdir}/%{name}/res
692 %endif
693
694 %dir %{_datadir}/%{name}
695 %{_datadir}/%{name}/chrome
696 %{_datadir}/%{name}/defaults
697 %{_datadir}/%{name}/modules
698 %if %{with enigmail}
699 %exclude %{_datadir}/%{name}/modules/commonFuncs.jsm
700 %exclude %{_datadir}/%{name}/modules/enigmailCommon.jsm
701 %exclude %{_datadir}/%{name}/modules/keyManagement.jsm
702 %exclude %{_datadir}/%{name}/modules/pipeConsole.jsm
703 %exclude %{_datadir}/%{name}/modules/subprocess.jsm
704 %exclude %{_datadir}/%{name}/modules/subprocess_worker_unix.js
705 %exclude %{_datadir}/%{name}/modules/subprocess_worker_win.js
706 %endif
707 %{_datadir}/%{name}/searchplugins
708 %if %{without xulrunner}
709 %{_datadir}/%{name}/greprefs.js
710 %{_datadir}/%{name}/res
711 %endif
712
713 %dir %{_datadir}/%{name}/extensions
714 %dir %{_libdir}/%{name}/extensions
715 # the signature of the default theme
716 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}.xpi
717 %{_libdir}/%{name}/extensions/modern@themes.mozilla.org.xpi
718
719 # files created by seamonkey -register
720 %ghost %{_libdir}/%{name}/components/compreg.dat
721 %ghost %{_libdir}/%{name}/components/xpti.dat
722
723 %{_libdir}/%{name}/components/glautocomp.js
724 %{_libdir}/%{name}/components/jsmimeemitter.js
725 %{_libdir}/%{name}/components/mail.xpt
726 %{_libdir}/%{name}/components/mdn-service.js
727 %{_libdir}/%{name}/components/msgAsyncPrompter.js
728 %{_libdir}/%{name}/components/newsblog.js
729 %{_libdir}/%{name}/components/nsAbAutoCompleteMyDomain.js
730 %{_libdir}/%{name}/components/nsAbAutoCompleteSearch.js
731 %{_libdir}/%{name}/components/nsAbLDAPAttributeMap.js
732 %{_libdir}/%{name}/components/nsLDAPProtocolHandler.js
733 %{_libdir}/%{name}/components/nsMailNewsCommandLineHandler.js
734 %{_libdir}/%{name}/components/nsMsgTraitService.js
735 %{_libdir}/%{name}/components/nsSMTPProtocolHandler.js
736 %{_libdir}/%{name}/components/offlineStartup.js
737 %{_libdir}/%{name}/components/smime-service.js
738
739 %{_libdir}/%{name}/isp
740 %dir %{_datadir}/%{name}/isp
741 %{_datadir}/%{name}/isp/Bogofilter.sfd
742 %{_datadir}/%{name}/isp/DSPAM.sfd
743 %{_datadir}/%{name}/isp/POPFile.sfd
744 %{_datadir}/%{name}/isp/SpamAssassin.sfd
745 %{_datadir}/%{name}/isp/SpamPal.sfd
746 %{_datadir}/%{name}/isp/movemail.rdf
747 %{_datadir}/%{name}/isp/rss.rdf
748
749 %{_pixmapsdir}/seamonkey.png
750 %{_desktopdir}/%{name}.desktop
751 %{_desktopdir}/%{name}-composer.desktop
752 %{_desktopdir}/%{name}-mail.desktop
753
754 %if %{with lightning}
755 %files addon-lightning
756 %defattr(644,root,root,755)
757 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
758 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
759 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
760 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
761 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
762 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
763 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
764 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
765 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
766 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
767 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
768 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
769 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
770 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
771 %{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
772 %endif
773
774 %if %{with enigmail}
775 %files addon-enigmail
776 %defattr(644,root,root,755)
777 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
778 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
779 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
780 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
781 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
782 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
783 %attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
784 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
785 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
786 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules
787 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.jsm
788 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.js
789 %endif
790
791 %files chat
792 %defattr(644,root,root,755)
793 %{_libdir}/%{name}/extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}.xpi
794 %{_desktopdir}/%{name}-chat.desktop
795
796 %files js-debugger
797 %defattr(644,root,root,755)
798 %{_libdir}/%{name}/extensions/{f13b157f-b174-47e7-a34d-4815ddfdfeb8}.xpi
799 %{_desktopdir}/%{name}-venkman.desktop
800
801 %files dom-inspector
802 %defattr(644,root,root,755)
803 %{_libdir}/%{name}/extensions/inspector@mozilla.org.xpi
This page took 0.107051 seconds and 4 git commands to generate.