]> git.pld-linux.org Git - packages/seamonkey.git/blob - seamonkey.spec
- libvpx >= 1.0.0 is required
[packages/seamonkey.git] / seamonkey.spec
1 #
2 # Conditional build:
3 %bcond_without  enigmail        # don't build enigmail - GPG/PGP support
4 %bcond_without  gnomeui         # disable gnomeui support
5 %bcond_without  gnome           # disable gnomeui (alias)
6 %bcond_without  ldap            # disable e-mail address lookups in LDAP directories
7 %bcond_without  lightning       # disable Sunbird/Lightning calendar
8 %bcond_with     xulrunner       # build with system xulrunner
9 %bcond_with     tests           # enable tests (whatever they check)
10 %bcond_without  kerberos        # disable krb5 support
11
12 %if %{without gnome}
13 %undefine       with_gnomeui
14 %endif
15
16 %define         enigmail_ver    1.4.1
17 %define         nspr_ver        4.9
18 %define         nss_ver         3.13.3
19 %define         xulrunner_ver   12.0
20
21 %if %{without xulrunner}
22 # The actual sqlite version (see RHBZ#480989):
23 %define         sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
24 %endif
25
26 Summary:        SeaMonkey Community Edition - web browser
27 Summary(es.UTF-8):      Navegador de Internet SeaMonkey Community Edition
28 Summary(pl.UTF-8):      SeaMonkey Community Edition - przeglądarka WWW
29 Summary(pt_BR.UTF-8):   Navegador SeaMonkey Community Edition
30 Name:           seamonkey
31 Version:        2.9.1
32 Release:        1
33 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
34 Group:          X11/Applications/Networking
35 Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/seamonkey/releases/%{version}/source/%{name}-%{version}.source.tar.bz2
36 # Source0-md5:  8dd18d93a6570c3c9f3873bb177ccc6b
37 Source1:        http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
38 # Source1-md5:  0eba75fbcf8f0bb32d538df102fbb8e9
39 Source2:        %{name}.desktop
40 Source3:        %{name}-composer.desktop
41 Source4:        %{name}-chat.desktop
42 Source5:        %{name}-mail.desktop
43 Source6:        %{name}-venkman.desktop
44 Source7:        %{name}.sh
45 Patch0:         %{name}-pld-homepage.patch
46 Patch1:         %{name}-agent.patch
47 Patch2:         %{name}-glueload-fix.patch
48 Patch3:         system-mozldap.patch
49 Patch4:         makefile.patch
50 Patch5:         system-cairo.patch
51 URL:            http://www.seamonkey-project.org/
52 BuildRequires:  GConf2-devel >= 1.2.1
53 BuildRequires:  OpenGL-devel
54 BuildRequires:  alsa-lib-devel
55 BuildRequires:  automake
56 BuildRequires:  bzip2-devel
57 BuildRequires:  cairo-devel >= 1.10.2-5
58 BuildRequires:  dbus-glib-devel >= 0.60
59 BuildRequires:  freetype-devel >= 1:2.1.8
60 BuildRequires:  glib2-devel >= 1:2.18
61 BuildRequires:  gtk+2-devel >= 2:2.10
62 %{?with_kerberos:BuildRequires: heimdal-devel >= 0.7.1}
63 BuildRequires:  hunspell-devel
64 BuildRequires:  libIDL-devel >= 0.8.0
65 BuildRequires:  libdnet-devel
66 BuildRequires:  libevent-devel >= 1.4.7
67 # standalone libffi 3.0.9 or gcc's from 4.5(?)+
68 BuildRequires:  libffi-devel >= 6:3.0.9
69 %{?with_gnomeui:BuildRequires:  libgnome-devel >= 2.0}
70 %{?with_gnomeui:BuildRequires:  libgnome-keyring-devel}
71 %{?with_gnomeui:BuildRequires:  libgnomeui-devel >= 2.2.0}
72 BuildRequires:  libiw-devel
73 BuildRequires:  libjpeg-devel >= 6b
74 BuildRequires:  libnotify-devel >= 0.4
75 BuildRequires:  libpng(APNG)-devel >= 0.10
76 BuildRequires:  libpng-devel >= 1.4.1
77 BuildRequires:  libstdc++-devel
78 BuildRequires:  libvpx-devel >= 1.0.0
79 BuildRequires:  nspr-devel >= 1:%{nspr_ver}
80 BuildRequires:  nss-devel >= 1:%{nss_ver}
81 BuildRequires:  pango-devel >= 1:1.14.0
82 BuildRequires:  perl-base >= 1:5.6
83 BuildRequires:  perl-modules >= 5.004
84 BuildRequires:  pkgconfig
85 BuildRequires:  python >= 1:2.5
86 BuildRequires:  python-modules
87 BuildRequires:  rpm >= 4.4.9-56
88 BuildRequires:  rpmbuild(macros) >= 1.601
89 BuildRequires:  sed >= 4.0
90 BuildRequires:  sqlite3-devel >= 3.7.10
91 BuildRequires:  startup-notification-devel >= 0.8
92 BuildRequires:  xorg-lib-libXScrnSaver-devel
93 BuildRequires:  xorg-lib-libXext-devel
94 BuildRequires:  xorg-lib-libXinerama-devel
95 BuildRequires:  xorg-lib-libXt-devel
96 %if %{with xulrunner}
97 BuildRequires:  xulrunner-devel >= 2:%{xulrunner_ver}
98 %endif
99 BuildRequires:  yasm
100 BuildRequires:  zip
101 BuildRequires:  zlib-devel >= 1.2.3
102 Requires(post): mktemp >= 1.5-18
103 Requires:       desktop-file-utils
104 Requires:       hicolor-icon-theme
105 %if %{with xulrunner}
106 %requires_eq_to xulrunner xulrunner-devel
107 %else
108 Requires:       browser-plugins >= 2.0
109 Requires:       cairo >= 1.10.2-5
110 Requires:       dbus-glib >= 0.60
111 Requires:       gtk+2 >= 2:2.18
112 Requires:       libpng >= 1.4.1
113 Requires:       libpng(APNG) >= 0.10
114 Requires:       myspell-common
115 Requires:       nspr >= 1:%{nspr_ver}
116 Requires:       nss >= 1:%{nss_ver}
117 Requires:       pango >= 1:1.14.0
118 Requires:       sqlite3 >= %{sqlite_build_version}
119 Requires:       startup-notification >= 0.8
120 %endif
121 Provides:       seamonkey-embedded = %{version}-%{release}
122 Provides:       wwwbrowser
123 Obsoletes:      light
124 Obsoletes:      mozilla
125 Obsoletes:      mozilla-gnomevfs
126 Obsoletes:      seamonkey-calendar
127 Obsoletes:      seamonkey-libs
128 Obsoletes:      seamonkey-mailnews
129 Obsoletes:      seamonkey-gnomevfs
130 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
131
132 %define         topdir          %{_builddir}/%{name}-%{version}
133 %define         objdir          %{topdir}/obj-%{_target_cpu}
134
135 %define         filterout_cpp   -D_FORTIFY_SOURCE=[0-9]+
136
137 # don't satisfy other packages
138 %define         _noautoprovfiles        %{_libdir}/%{name}
139 # and as we don't provide them, don't require either
140 %define         _noautoreq      libmozjs.so libxpcom.so libxul.so libjemalloc.so %{!?with_xulrunner:libmozalloc.so}
141 %define         _noautoreqdep   libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpistub.so
142
143 %description
144 SeaMonkey Community Edition is an open-source web browser, designed
145 for standards compliance, performance and portability.
146
147 %description -l es.UTF-8
148 SeaMonkey Community Edition es un navegador de Internet que se basa en
149 una versión inicial de Netscape Communicator.
150
151 %description -l pl.UTF-8
152 SeaMonkey Community Edition jest potężną graficzną przeglądarką WWW,
153 która jest następcą Mozilli, która następnie była następczynią
154 Netscape Communikatora.
155
156 %description -l pt_BR.UTF-8
157 O SeaMonkey Community Edition é um web browser baseado numa versão
158 inicial do Netscape Communicator.
159
160 %description -l ru.UTF-8
161 SeaMonkey Community Edition - полнофункциональный web-browser с
162 открытыми исходными текстами, разработанный для максимального
163 соотвествия стандартам, максмимальной переносимости и скорости работы
164
165 %package addon-lightning
166 Summary:        An integrated calendar for SeaMonkey
167 Summary(pl.UTF-8):      Zintegrowany kalendarz dla SeaMonkey
168 License:        MPL 1.1 or GPL v2+ or LGPL v2.1+
169 Group:          Applications/Networking
170 Requires:       %{name} = %{version}-%{release}
171
172 %description addon-lightning
173 Lightning is an calendar extension to Icedove email client.
174
175 %description addon-lightning -l pl.UTF-8
176 Lightning to rozszerzenie do klienta poczty Icedove dodające
177 funkcjonalność kalendarza.
178
179 %package addon-enigmail
180 Summary:        Enigmail %{enigmail_ver} - PGP/GPG support for SeaMonkey Community Edition
181 Summary(pl.UTF-8):      Enigmail %{enigmail_ver} - obsługa PGP/GPG dla SeaMonkey Community Edition
182 Group:          X11/Applications/Networking
183 Requires(post,postun):  %{name} = %{version}-%{release}
184 Requires:       %{name} = %{version}-%{release}
185 Requires:       gnupg >= 1.4.2.2
186
187 %description addon-enigmail
188 Enigmail is an extension to the mail client of SeaMonkey / Mozilla /
189 Netscape and Mozilla Thunderbird which allows users to access the
190 authentication and encryption features provided by GnuPG.
191
192 %description addon-enigmail -l pl.UTF-8
193 Enigmail jest rozszerzeniem dla klienta pocztowego SeaMonkey, Mozilla
194 i Mozilla Thunderdbird pozwalającym użytkownikowi korzystać z
195 funkcjonalności GnuPG.
196
197 %package chat
198 Summary:        SeaMonkey Community Edition Chat - integrated IRC client
199 Summary(pl.UTF-8):      SeaMonkey Community Edition Chat - zintegrowany klient IRC-a
200 Group:          X11/Applications/Networking
201 Requires(post,postun):  %{name} = %{version}-%{release}
202 Requires:       %{name} = %{version}-%{release}
203 Obsoletes:      mozilla-chat
204
205 %description chat
206 SeaMonkey Community Edition Chat - IRC client that is integrated with
207 the SeaMonkey Community Edition web browser.
208
209 %description chat -l pl.UTF-8
210 SeaMonkey Community Edition Chat - klient IRC-a zintegrowany z
211 przeglądarką SeaMonkey Community Edition.
212
213 %package js-debugger
214 Summary:        JavaScript debugger for use with SeaMonkey Community Edition
215 Summary(pl.UTF-8):      Odpluskwiacz JavaScriptu do używania z SeaMonkey Community Edition
216 Group:          X11/Applications/Networking
217 Requires(post,postun):  %{name} = %{version}-%{release}
218 Requires:       %{name} = %{version}-%{release}
219 Obsoletes:      mozilla-js-debugger
220
221 %description js-debugger
222 JavaScript debugger for use with SeaMonkey Community Edition.
223
224 %description js-debugger -l pl.UTF-8
225 Odpluskwiacz JavaScriptu do używania z SeaMonkey Community Edition.
226
227 %package dom-inspector
228 Summary:        A tool for inspecting the DOM of pages in SeaMonkey Community Edition
229 Summary(pl.UTF-8):      Narzędzie do oglądania DOM stron w SeaMonkey Community Edition
230 Group:          X11/Applications/Networking
231 Requires(post,postun):  %{name} = %{version}-%{release}
232 Requires:       %{name} = %{version}-%{release}
233 Obsoletes:      mozilla-dom-inspector
234
235 %description dom-inspector
236 This is a tool that allows you to inspect the DOM for web pages in
237 SeaMonkey Community Edition. This is of great use to people who are
238 doing SeaMonkey Community Edition chrome development or web page
239 development.
240
241 %description dom-inspector -l pl.UTF-8
242 To narzędzie pozwala na oglądanie DOM dla stron WWW w SeaMonkey
243 Community Edition. Jest bardzo przydatne dla ludzi rozwijających
244 chrome w SeaMonkey Community Edition lub tworzących strony WWW.
245
246 %prep
247 %setup -qc
248 cd comm-release
249 tar -C mailnews/extensions -zxf %{SOURCE1}
250 #patch0 -p1
251 %patch1 -p1
252 %patch2 -p1
253 %patch3 -p1
254 %patch4 -p1
255 %patch5 -p1
256
257 %build
258 cd comm-release
259 %if %{with xulrunner}
260 if [ "$(grep -E '^[0-9]+\.' mozilla/config/milestone.txt)" != "%{xulrunner_ver}" ]; then
261         echo >&2
262         echo >&2 "Xulrunner version %{xulrunner_ver} does not match mozilla/config/milestone.txt!"
263         echo >&2
264         exit 1
265 fi
266 %endif
267
268 cp -f %{_datadir}/automake/config.* build/autoconf
269 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
270 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
271 cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
272
273 cat << EOF > .mozconfig
274 mk_add_options MOZ_OBJDIR=%{objdir}
275
276 export CFLAGS="%{rpmcflags}"
277 export CXXFLAGS="%{rpmcflags}"
278
279 %if %{with crashreporter}
280 export MOZ_DEBUG_SYMBOLS=1
281 %endif
282
283 # Options for 'configure' (same as command-line options).
284 ac_add_options --prefix=%{_prefix}
285 ac_add_options --exec-prefix=%{_exec_prefix}
286 ac_add_options --bindir=%{_bindir}
287 ac_add_options --sbindir=%{_sbindir}
288 ac_add_options --sysconfdir=%{_sysconfdir}
289 ac_add_options --datadir=%{_datadir}
290 ac_add_options --includedir=%{_includedir}
291 ac_add_options --libdir=%{_libdir}
292 ac_add_options --libexecdir=%{_libexecdir}
293 ac_add_options --localstatedir=%{_localstatedir}
294 ac_add_options --sharedstatedir=%{_sharedstatedir}
295 ac_add_options --mandir=%{_mandir}
296 ac_add_options --infodir=%{_infodir}
297 ac_add_options --disable-elf-hack
298 %if %{?debug:1}0
299 ac_add_options --disable-optimize
300 ac_add_options --enable-debug
301 ac_add_options --enable-debug-modules
302 ac_add_options --enable-debugger-info-modules
303 ac_add_options --enable-crash-on-assert
304 %else
305 ac_add_options --disable-debug
306 ac_add_options --disable-debug-modules
307 ac_add_options --disable-logging
308 ac_add_options --enable-optimize="%{rpmcflags} -Os"
309 %endif
310 ac_add_options --disable-strip
311 ac_add_options --disable-strip-libs
312 %if %{with tests}
313 ac_add_options --enable-tests
314 %else
315 ac_add_options --disable-tests
316 %endif
317 ac_add_options --enable-gio
318 %if %{with gnomeui}
319 ac_add_options --enable-gnomeui
320 %else
321 ac_add_options --disable-gnomeui
322 %endif
323 ac_add_options --disable-gnomevfs
324 %if %{with ldap}
325 ac_add_options --enable-ldap
326 ac_add_options --with-system-ldap
327 %else
328 ac_add_options --disable-ldap
329 %endif
330 %if %{with crashreporter}
331 ac_add_options --enable-crashreporter
332 %else
333 ac_add_options --disable-crashreporter
334 %endif
335 ac_add_options --disable-xterm-updates
336 ac_add_options --enable-postscript
337 %if %{with lightning}
338 ac_add_options --enable-calendar
339 %else
340 ac_add_options --disable-calendar
341 %endif
342 ac_add_options --disable-installer
343 ac_add_options --disable-javaxpcom
344 ac_add_options --disable-updater
345 ac_add_options --enable-crypto
346 ac_add_options --enable-libxul
347 ac_add_options --enable-pango
348 ac_add_options --enable-shared-js
349 ac_add_options --enable-startup-notification
350 ac_add_options --enable-system-cairo
351 ac_add_options --enable-system-hunspell
352 ac_add_options --enable-system-sqlite
353 ac_add_options --enable-application=suite
354 ac_add_options --with-distribution-id=org.pld-linux
355 %if %{with xulrunner}
356 ac_add_options --with-system-libxul
357 ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
358 %endif
359 ac_add_options --with-pthreads
360 ac_add_options --with-system-bz2
361 ac_add_options --with-system-ffi
362 ac_add_options --with-system-jpeg
363 ac_add_options --with-system-libevent
364 ac_add_options --with-system-libvpx
365 ac_add_options --with-system-nspr
366 ac_add_options --with-system-nss
367 ac_add_options --with-system-png
368 ac_add_options --with-system-zlib
369 ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
370 EOF
371
372 %{__make} -j1 -f client.mk build \
373         STRIP="/bin/true" \
374         MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
375         installdir=%{_libdir}/%{name} \
376         CC="%{__cc}" \
377         CXX="%{__cxx}"
378
379 %if %{with crashreporter}
380 # create debuginfo for crash-stats.mozilla.com
381 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
382 %endif
383
384 %if %{with enigmail}
385 cd mailnews/extensions/enigmail
386 ./makemake -r -o %{objdir}
387 %{__make} -C %{objdir}/mailnews/extensions/enigmail \
388         STRIP="/bin/true" \
389         CC="%{__cc}" \
390         CXX="%{__cxx}"
391 %endif
392
393 %install
394 rm -rf $RPM_BUILD_ROOT
395 cd comm-release
396 install -d \
397         $RPM_BUILD_ROOT{%{_bindir},%{_libdir}} \
398         $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}} \
399         $RPM_BUILD_ROOT%{_datadir}/%{name} \
400         $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins
401
402 %browser_plugins_add_browser %{name} -p %{_libdir}/%{name}/plugins
403
404 cd %{objdir}
405 %{__make} -C suite/installer stage-package \
406         DESTDIR=$RPM_BUILD_ROOT \
407         installdir=%{_libdir}/%{name} \
408         PKG_SKIP_STRIP=1
409
410 cp -a mozilla/dist/seamonkey/* $RPM_BUILD_ROOT%{_libdir}/%{name}/
411
412 %if %{with xulrunner}
413 # >= 5.0 seems to require this
414 ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
415 %endif
416
417 # Enable crash reporter for Thunderbird application
418 %if %{with crashreporter}
419 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
420
421 # Add debuginfo for crash-stats.mozilla.com
422 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
423 cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
424 %endif
425
426 # copy manually lightning files, somewhy they are not installed by make
427 cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
428         mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
429         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
430                 
431 # move arch independant ones to datadir
432 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
433 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
434 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
435 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
436 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
437 %if %{without xulrunner}
438 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs.js $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs.js
439 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
440 %endif
441
442 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
443 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
444 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
445 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
446 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
447 %if %{without xulrunner}
448 ln -s ../../share/%{name}/greprefs.js $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs.js
449 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
450 %endif
451
452 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/* \
453         $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/
454
455 # dir for arch independant extensions besides arch dependant extensions
456 # see mozilla/xpcom/build/nsXULAppAPI.h
457 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
458 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
459  
460 %if %{without xulrunner}
461 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
462 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
463 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
464 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
465 %endif
466
467 sed 's,@LIBDIR@,%{_libdir},' %{SOURCE7} > $RPM_BUILD_ROOT%{_bindir}/seamonkey
468 chmod a+rx $RPM_BUILD_ROOT%{_bindir}/seamonkey
469
470 install %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6} \
471         $RPM_BUILD_ROOT%{_desktopdir}
472
473 cp -p %{topdir}/comm-release/suite/branding/nightly/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
474
475 # files created by seamonkey -register
476 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
477 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
478
479 cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
480 #!/bin/sh
481 umask 022
482 rm -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
483
484 # it attempts to touch files in $HOME/.mozilla
485 # beware if you run this with sudo!!!
486 export HOME=$(mktemp -d)
487 # also TMPDIR could be pointing to sudo user's homedir
488 unset TMPDIR TMP || :
489
490 %{_libdir}/%{name}/seamonkey -register
491
492 rm -rf $HOME
493 EOF
494 chmod 755 $RPM_BUILD_ROOT%{_libdir}/%{name}/register
495
496 %if %{with enigmail}
497 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
498 install -d $ext_dir/{chrome,components,defaults/preferences}
499 cd mozilla/dist/bin
500 #cp -rfLp chrome/enigmail.jar $ext_dir/chrome
501 #cp -rfLp chrome/enigmime.jar $ext_dir/chrome
502 cp -rfLp components/enig* $ext_dir/components
503 cp -rfLp components/libenigmime.so $ext_dir/components
504 cp -rfLp components/libipc.so $ext_dir/components
505 cp -rfLp components/ipc.xpt $ext_dir/components
506 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
507 cd -
508 cp -p %{topdir}/comm-release/mailnews/extensions/enigmail/package/install.rdf $ext_dir
509 cp -p %{topdir}/comm-release/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
510 %endif
511
512 # never package these. always remove
513 # nss
514 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
515 # nspr
516 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
517 # mozldap
518 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
519 # testpilot quiz
520 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/tbtestpilot@labs.mozilla.com.xpi
521
522 %clean
523 rm -rf $RPM_BUILD_ROOT
524
525 %post
526 %{_libdir}/%{name}/register || :
527 %update_browser_plugins
528 %update_desktop_database
529
530 %postun
531 if [ "$1" = 0 ]; then
532         %update_browser_plugins
533 fi
534
535 %files
536 %defattr(644,root,root,755)
537 %attr(755,root,root) %{_bindir}/seamonkey
538
539 # browser plugins v2
540 %{_browserpluginsconfdir}/browsers.d/%{name}.*
541 %config(noreplace) %verify(not md5 mtime size) %{_browserpluginsconfdir}/blacklist.d/%{name}.*.blacklist
542
543 %dir %{_libdir}/%{name}
544 %if %{without xulrunner}
545 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
546 %attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
547 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
548 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
549 %endif
550
551 %{_libdir}/%{name}/blocklist.xml
552 %attr(755,root,root) %{_libdir}/%{name}/register
553
554 %if %{with crashreporter}
555 %{_libdir}/%{name}/crashreporter
556 %{_libdir}/%{name}/crashreporter-override.ini
557 %{_libdir}/%{name}/crashreporter.ini
558 %{_libdir}/%{name}/Throbber-small.gif
559 %endif
560
561 # config?
562 %{_libdir}/%{name}/application.ini
563 %{_libdir}/%{name}/chrome.manifest
564
565 %dir %{_libdir}/%{name}/components
566
567 %{_libdir}/%{name}/components/FeedConverter.js
568 %{_libdir}/%{name}/components/FeedWriter.js
569 %{_libdir}/%{name}/components/Weave.js
570 %{_libdir}/%{name}/components/WebContentConverter.js
571 %{_libdir}/%{name}/components/browser.xpt
572 %{_libdir}/%{name}/components/nsBrowserContentHandler.js
573 %{_libdir}/%{name}/components/nsSessionStartup.js
574 %{_libdir}/%{name}/components/nsSessionStore.js
575 %{_libdir}/%{name}/components/nsSidebar.js
576
577 %{_libdir}/%{name}/components/components.manifest
578 %{_libdir}/%{name}/components/interfaces.manifest
579
580 %if %{without xulrunner}
581 %{_libdir}/%{name}/platform.ini
582 %{_libdir}/%{name}/components/ConsoleAPI.js
583 %{_libdir}/%{name}/components/FeedProcessor.js
584 %{_libdir}/%{name}/components/GPSDGeolocationProvider.js
585 %{_libdir}/%{name}/components/NetworkGeolocationProvider.js
586 %{_libdir}/%{name}/components/PlacesCategoriesStarter.js
587 %{_libdir}/%{name}/components/TelemetryPing.js
588 %{_libdir}/%{name}/components/addonManager.js
589 %{_libdir}/%{name}/components/amContentHandler.js
590 %{_libdir}/%{name}/components/amWebInstallListener.js
591 %{_libdir}/%{name}/components/contentAreaDropListener.js
592 %{_libdir}/%{name}/components/contentSecurityPolicy.js
593 %{_libdir}/%{name}/components/crypto-SDR.js
594 %{_libdir}/%{name}/components/jsconsole-clhandler.js
595 %{_libdir}/%{name}/components/nsBadCertHandler.js
596 %{_libdir}/%{name}/components/nsBlocklistService.js
597 %{_libdir}/%{name}/components/nsContentDispatchChooser.js
598 %{_libdir}/%{name}/components/nsContentPrefService.js
599 %{_libdir}/%{name}/components/nsDefaultCLH.js
600 %{_libdir}/%{name}/components/nsFilePicker.js
601 %{_libdir}/%{name}/components/nsFormAutoComplete.js
602 %{_libdir}/%{name}/components/nsFormHistory.js
603 %{_libdir}/%{name}/components/nsHandlerService.js
604 %{_libdir}/%{name}/components/nsHelperAppDlg.js
605 %{_libdir}/%{name}/components/nsINIProcessor.js
606 %{_libdir}/%{name}/components/nsInputListAutoComplete.js
607 %{_libdir}/%{name}/components/nsLivemarkService.js
608 %{_libdir}/%{name}/components/nsLoginInfo.js
609 %{_libdir}/%{name}/components/nsLoginManager.js
610 %{_libdir}/%{name}/components/nsLoginManagerPrompter.js
611 %{_libdir}/%{name}/components/nsPlacesAutoComplete.js
612 %{_libdir}/%{name}/components/nsPlacesExpiration.js
613 %{_libdir}/%{name}/components/nsPrompter.js
614 %{_libdir}/%{name}/components/nsProxyAutoConfig.js
615 %{_libdir}/%{name}/components/nsSearchService.js
616 %{_libdir}/%{name}/components/nsSearchSuggestions.js
617 %{_libdir}/%{name}/components/nsTaggingService.js
618 %{_libdir}/%{name}/components/nsURLFormatter.js
619 %{_libdir}/%{name}/components/nsUpdateTimerManager.js
620 %{_libdir}/%{name}/components/nsWebHandlerApp.js
621 %{_libdir}/%{name}/components/storage-Legacy.js
622 %{_libdir}/%{name}/components/storage-mozStorage.js
623 %{_libdir}/%{name}/components/txEXSLTRegExFunctions.js
624 %endif
625
626 %{_libdir}/%{name}/components/nsAbout.js
627 %{_libdir}/%{name}/components/nsAboutCertError.js
628 %{_libdir}/%{name}/components/nsAboutData.js
629 %{_libdir}/%{name}/components/nsAboutFeeds.js
630 %{_libdir}/%{name}/components/nsAboutLife.js
631 %{_libdir}/%{name}/components/nsAboutRights.js
632 %{_libdir}/%{name}/components/nsAboutSessionRestore.js
633 %{_libdir}/%{name}/components/nsAboutSyncTabs.js
634 %{_libdir}/%{name}/components/nsComposerCmdLineHandler.js
635 %{_libdir}/%{name}/components/nsSuiteDownloadManagerUI.js
636 %{_libdir}/%{name}/components/nsSuiteGlue.js
637 %{_libdir}/%{name}/components/nsTypeAheadFind.js
638 %{_libdir}/%{name}/components/smileApplication.js
639
640 %if %{without xulrunner}
641 %attr(755,root,root) %{_libdir}/%{name}/components/libdbusservice.so
642 %endif
643
644 %if %{without xulrunner}
645 %attr(755,root,root) %{_libdir}/%{name}/components/libmozgnome.so
646 %endif
647
648 %attr(755,root,root) %{_libdir}/%{name}/components/libsuite.so
649
650 %attr(755,root,root) %{_libdir}/%{name}/seamonkey
651 %dir %{_libdir}/%{name}/plugins
652 %if %{without xulrunner}
653 %attr(755,root,root) %{_libdir}/%{name}/run-mozilla.sh
654 %attr(755,root,root) %{_libdir}/%{name}/seamonkey-bin
655 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
656 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
657 %endif
658
659 # symlinks
660 %{_libdir}/%{name}/chrome
661 %{_libdir}/%{name}/defaults
662 %{_libdir}/%{name}/modules
663 %{_libdir}/%{name}/searchplugins
664 %if %{with xulrunner}
665 %{_libdir}/%{name}/xulrunner
666 %else
667 %{_libdir}/%{name}/dictionaries
668 %{_libdir}/%{name}/hyphenation
669 %{_libdir}/%{name}/greprefs.js
670 %{_libdir}/%{name}/res
671 %endif
672
673 %dir %{_datadir}/%{name}
674 %{_datadir}/%{name}/chrome
675 %{_datadir}/%{name}/defaults
676 %{_datadir}/%{name}/modules
677 %{_datadir}/%{name}/searchplugins
678 %if %{without xulrunner}
679 %{_datadir}/%{name}/greprefs.js
680 %{_datadir}/%{name}/res
681 %endif
682
683 %dir %{_datadir}/%{name}/extensions
684 %dir %{_libdir}/%{name}/extensions
685 # the signature of the default theme
686 %{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}.xpi
687 %{_libdir}/%{name}/extensions/modern@themes.mozilla.org.xpi
688
689 # files created by seamonkey -register
690 %ghost %{_libdir}/%{name}/components/compreg.dat
691 %ghost %{_libdir}/%{name}/components/xpti.dat
692
693 %{_libdir}/%{name}/components/glautocomp.js
694 %{_libdir}/%{name}/components/jsmimeemitter.js
695 %{_libdir}/%{name}/components/mail.xpt
696 %{_libdir}/%{name}/components/mdn-service.js
697 %{_libdir}/%{name}/components/msgAsyncPrompter.js
698 %{_libdir}/%{name}/components/newsblog.js
699 %{_libdir}/%{name}/components/nsAbAutoCompleteMyDomain.js
700 %{_libdir}/%{name}/components/nsAbAutoCompleteSearch.js
701 %{_libdir}/%{name}/components/nsAbLDAPAttributeMap.js
702 %{_libdir}/%{name}/components/nsLDAPProtocolHandler.js
703 %{_libdir}/%{name}/components/nsMailNewsCommandLineHandler.js
704 %{_libdir}/%{name}/components/nsMsgTraitService.js
705 %{_libdir}/%{name}/components/nsSMTPProtocolHandler.js
706 %{_libdir}/%{name}/components/offlineStartup.js
707 %{_libdir}/%{name}/components/smime-service.js
708
709 %{_libdir}/%{name}/isp
710 %dir %{_datadir}/%{name}/isp
711 %{_datadir}/%{name}/isp/Bogofilter.sfd
712 %{_datadir}/%{name}/isp/DSPAM.sfd
713 %{_datadir}/%{name}/isp/POPFile.sfd
714 %{_datadir}/%{name}/isp/SpamAssassin.sfd
715 %{_datadir}/%{name}/isp/SpamPal.sfd
716 %{_datadir}/%{name}/isp/movemail.rdf
717 %{_datadir}/%{name}/isp/rss.rdf
718
719 %{_pixmapsdir}/seamonkey.png
720 %{_desktopdir}/%{name}.desktop
721 %{_desktopdir}/%{name}-composer.desktop
722 %{_desktopdir}/%{name}-mail.desktop
723
724 %if %{with lightning}
725 %files addon-lightning
726 %defattr(644,root,root,755)
727 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
728 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
729 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
730 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
731 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
732 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
733 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
734 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
735 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
736 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
737 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
738 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
739 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
740 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
741 %{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
742 %endif
743
744 %if %{with enigmail}
745 %files addon-enigmail
746 %defattr(644,root,root,755)
747 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
748 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
749 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
750 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
751 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
752 %dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
753 %attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
754 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
755 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
756 %endif
757
758 %files chat
759 %defattr(644,root,root,755)
760 %{_libdir}/%{name}/extensions/{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}.xpi
761 %{_desktopdir}/%{name}-chat.desktop
762
763 %files js-debugger
764 %defattr(644,root,root,755)
765 %{_libdir}/%{name}/extensions/{f13b157f-b174-47e7-a34d-4815ddfdfeb8}.xpi
766 %{_desktopdir}/%{name}-venkman.desktop
767
768 %files dom-inspector
769 %defattr(644,root,root,755)
770 %{_libdir}/%{name}/extensions/inspector@mozilla.org.xpi
This page took 0.100224 seconds and 4 git commands to generate.