]> git.pld-linux.org Git - packages/seafile.git/blob - seafile.spec
cleanup BR
[packages/seafile.git] / seafile.spec
1 # NOTE:
2 # using -server tag because 5.1.2..5.1.2-server differ
3 # http://manual.seafile.com/build_seafile/server.html
4 # TODO
5 # - fix python to install sitescriptdir: %{py_sitedir}/seafile
6
7 Summary:        File syncing and sharing software with file encryption and group sharing
8 Name:           seafile
9 Version:        5.1.2
10 Release:        1
11 License:        GPL v2
12 Group:          Applications/Networking
13 Source0:        https://github.com/haiwen/seafile/archive/v%{version}-server/%{name}-%{version}.tar.gz
14 # Source0-md5:  5fa7f0403aa168088c42498018f72422
15 Patch0:         codegen.patch
16 URL:            http://seafile.com/
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  pkgconfig
20 BuildRequires:  ccnet-devel = %{version}
21 BuildRequires:  curl-devel
22 BuildRequires:  glib2-devel
23 BuildRequires:  intltool
24 BuildRequires:  jansson-devel
25 BuildRequires:  libevent-devel
26 BuildRequires:  libfuse-devel >= 2.7.3
27 BuildRequires:  libtool
28 BuildRequires:  libuuid-devel
29 BuildRequires:  openssl-devel
30 BuildRequires:  python-devel
31 BuildRequires:  rpm-pythonprov
32 BuildRequires:  rpmbuild(macros) >= 1.714
33 BuildRequires:  vala
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Seafile is a next-generation open source cloud storage system with
38 advanced support for file syncing, privacy protection and teamwork.
39
40 Seafile allows users to create groups with file syncing, wiki, and
41 discussion to enable easy collaboration around documents within a
42 team.
43
44 %package devel
45 Summary:        Development files for %{name}
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       glib2-devel
48
49 %description devel
50 The %{name}-devel package contains libraries and header files for
51 developing applications that use %{name}.
52
53 %prep
54 %setup -qn %{name}-%{version}-server
55 %patch0 -p1
56
57 # bogus destdir?
58 sed -i -e 's/(DESTDIR)//' lib/libseafile.pc.in
59
60 %build
61 %{__glib_gettextize}
62 %{__intltoolize} --automake
63 %{__libtoolize}
64 %{__aclocal} -I m4
65 %{__autoheader}
66 %{__automake} --gnu
67 %{__autoconf}
68 %configure \
69         --disable-static
70
71 %{__make}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 %{__make} install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 %py_postclean
79
80 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libseafile.la
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %post   -p /sbin/ldconfig
86 %postun -p /sbin/ldconfig
87
88 %files
89 %defattr(644,root,root,755)
90 %doc README.markdown LICENSE.txt
91 %attr(755,root,root) %{_libdir}/libseafile.so.*.*.*
92 %ghost %{_libdir}/libseafile.so.0
93 %attr(755,root,root) %{_bindir}/seaf-cli
94 %attr(755,root,root) %{_bindir}/seaf-daemon
95 %{_mandir}/man1/seaf-cli.1*
96 %{_mandir}/man1/seaf-daemon.1*
97 %dir %{py_sitedir}/seafile
98 %{py_sitedir}/seafile/*.py[co]
99 %dir %{py_sitedir}/seaserv
100 %{py_sitedir}/seaserv/*.py[co]
101
102 %files devel
103 %defattr(644,root,root,755)
104 %{_includedir}/seafile
105 %{_libdir}/libseafile.so
106 %{_pkgconfigdir}/libseafile.pc
This page took 0.064133 seconds and 3 git commands to generate.