]> git.pld-linux.org Git - packages/seafile.git/blob - seafile.spec
- up to 6.2.5
[packages/seafile.git] / seafile.spec
1 # NOTE:
2 # using -server tag because 5.1.2..5.1.2-server differ
3 # http://manual.seafile.com/build_seafile/server.html
4 # explanation of the tags:
5 # http://manual.seafile.com/deploy/#for-those-that-want-to-package-seafile-server
6 # TODO
7 # - fix python to install sitescriptdir: %{py_sitedir}/seafile
8
9 Summary:        File syncing and sharing software with file encryption and group sharing
10 Name:           seafile
11 Version:        6.2.5
12 Release:        1
13 License:        GPL v2
14 Group:          Applications/Networking
15 Source0:        https://github.com/haiwen/seafile/archive/v%{version}.tar.gz
16 # Source0-md5:  220790c24a8cb1ff88bacc03e4e87976
17 Patch0:         codegen.patch
18 URL:            http://seafile.com/
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  pkgconfig
22 BuildRequires:  ccnet-devel
23 BuildRequires:  curl-devel
24 BuildRequires:  glib2-devel
25 BuildRequires:  intltool
26 BuildRequires:  jansson-devel
27 BuildRequires:  libevent-devel
28 BuildRequires:  libfuse-devel >= 2.7.3
29 # for bin/searpc-codegen
30 BuildRequires:  libsearpc
31 BuildRequires:  libtool
32 BuildRequires:  libuuid-devel
33 BuildRequires:  openssl-devel
34 BuildRequires:  python-devel
35 BuildRequires:  rpm-pythonprov
36 BuildRequires:  rpmbuild(macros) >= 1.714
37 BuildRequires:  vala
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Seafile is a next-generation open source cloud storage system with
42 advanced support for file syncing, privacy protection and teamwork.
43
44 Seafile allows users to create groups with file syncing, wiki, and
45 discussion to enable easy collaboration around documents within a
46 team.
47
48 %package devel
49 Summary:        Development files for %{name}
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       glib2-devel
52
53 %description devel
54 The %{name}-devel package contains libraries and header files for
55 developing applications that use %{name}.
56
57 %prep
58 %setup -q
59 %patch0 -p1
60
61 # bogus destdir?
62 sed -i -e 's/(DESTDIR)//' lib/libseafile.pc.in
63
64 %build
65 %{__glib_gettextize}
66 %{__intltoolize} --automake
67 %{__libtoolize}
68 %{__aclocal} -I m4
69 %{__autoheader}
70 %{__automake} --gnu
71 %{__autoconf}
72 %configure \
73         --disable-static
74
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79 %{__make} install \
80         DESTDIR=$RPM_BUILD_ROOT
81
82 %py_postclean
83
84 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libseafile.la
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %post   -p /sbin/ldconfig
90 %postun -p /sbin/ldconfig
91
92 %files
93 %defattr(644,root,root,755)
94 %doc README.markdown LICENSE.txt
95 %attr(755,root,root) %{_libdir}/libseafile.so.*.*.*
96 %ghost %{_libdir}/libseafile.so.0
97 %attr(755,root,root) %{_bindir}/seaf-cli
98 %attr(755,root,root) %{_bindir}/seaf-daemon
99 %{_mandir}/man1/seaf-cli.1*
100 %{_mandir}/man1/seaf-daemon.1*
101 %dir %{py_sitedir}/seafile
102 %{py_sitedir}/seafile/*.py[co]
103
104 %files devel
105 %defattr(644,root,root,755)
106 %{_includedir}/seafile
107 %{_libdir}/libseafile.so
108 %{_pkgconfigdir}/libseafile.pc
This page took 0.332446 seconds and 3 git commands to generate.