]> git.pld-linux.org Git - packages/scummvm.git/blob - scummvm.spec
- allow cracked games to run
[packages/scummvm.git] / scummvm.spec
1 %define         version_tools   0.7.0
2 Summary:        SCUMM graphic adventure game interpreter
3 Summary(pl):    Interpreter przygodówek opartych na SCUMM
4 Name:           scummvm
5 Version:        0.7.1
6 Release:        1
7 License:        GPL
8 Group:          X11/Applications/Games
9 Source0:        http://dl.sourceforge.net/scummvm/%{name}-%{version}.tar.bz2
10 # Source0-md5:  a935499011c59441fcce8322ea1c4f1d
11 Source1:        http://dl.sourceforge.net/scummvm/%{name}-tools-%{version_tools}.tar.bz2
12 # Source1-md5:  eeebbd4e309a8564dd911d5c26fed2f0
13 Source2:        %{name}.desktop
14 Source3:        %{name}.png
15 Patch0:         %{name}-asm.patch
16 URL:            http://scummvm.sourceforge.net/
17 BuildRequires:  SDL-devel >= 1.2.2
18 BuildRequires:  libmad-devel
19 BuildRequires:  libvorbis-devel
20 BuildRequires:  mpeg2dec-devel
21 %ifarch %{ix86}
22 BuildRequires:  nasm
23 %endif
24 BuildRequires:  sed >= 4.0
25 BuildRequires:  zlib-devel
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 ScummVM is a collection of interpreters, capable of emulating several
30 adventure game engines. ScummVM mainly supports games created using
31 SCUMM (Script Creation Utility for Maniac Mansion), used in various
32 LucasArts games such as Monkey Island, Day of the Tentacle, and
33 others.
34
35 ScummVM also contains interpreters for several non-SCUMM games.
36 Currently these are Beneath a Steel Sky, Broken Sword 1 & 2, Flight of
37 the Amazon Queen and Simon the Sorcerer 1 & 2.
38
39 At this time ScummVM should be considered beta software, and is still
40 under heavy development. Be aware that whilst we attempt to make sure
41 that many games can be completed with few major bugs, crashes can
42 happen.
43
44 %description -l pl
45 ScummVM jest zbiorem interpreterów zdolnych do emulacji kilku silników
46 gier przygodowych. ScummVM g³ównie wspiera gry stworzone z u¿yciem
47 silnika SCUMM (Script Creation Utility for Maniac Mansion), u¿ywanego
48 przez takie tytu³y stworzone przez Lucas Arts jak Monkey Island, Day
49 of the Tentacle.
50
51 ScummVM potrafi równie¿ interpretowaæ kilka gier nie opartych na
52 SCUMM. W chwili obecnej s± to Beneath a Steel Sky, Broken Sword 1 i 2,
53 Flight of the Amazon Queen oraz Simon the Sorcerer 1 i 2.
54
55 ScummVM jest ca³y czas intensywnie rozwijany i powinien byæ traktowany
56 jako program w stanie beta. Wiele gier powinno daæ siê skoñczyæ bez
57 wiêkszych b³êdów, nale¿y byæ jednak ¶wiadomym, ¿e program mo¿e siê
58 czasem wysypaæ.
59
60 %package tools
61 Summary:        ScummVM tools
62 Summary(pl):    Narzêdzia zwi±zane ze ScummVM
63 Group:          X11/Applications/Games
64
65 %description tools
66 Collection of various tools that may be useful to use in conjunction
67 with ScummVM.
68
69 %description tools -l pl
70 Zestaw narzêdzi mog±cych byæ u¿ytecznymi w po³±czeniu ze ScummVM.
71
72 %prep
73 %setup -q -a 1
74 %patch0 -p1
75
76 sed -i -e 's:(name "/lib" name ".so"):("%{_libdir}/lib" name ".so"):' base/plugins.cpp
77
78 %build
79 ./configure \
80         --disable-debug \
81 %ifnarch %{ix86}
82         --disable-nasm \
83 %endif
84         --enable-kyra \
85         --enable-plugins
86
87 %{__make} \
88         CXX="%{__cxx}" \
89         CXXFLAGS="%{rpmcflags} -DDYNAMIC_MODULES -fpic" \
90         LDFLAGS="%{rpmldflags}"
91
92 cd %{name}-tools-%{version_tools}
93 %{__make} \
94         CC="%{__cc}" \
95         CFLAGS="%{rpmcflags}" \
96         LDFLAGS="%{rpmldflags}"
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man6,%{_pixmapsdir},%{_desktopdir},%{_libdir}}
101
102 install scummvm $RPM_BUILD_ROOT%{_bindir}
103 install scummvm.6 $RPM_BUILD_ROOT%{_mandir}/man6
104
105 for i in kyra queen scumm sky sword{1,2} simon
106 do
107         install $i/lib$i.so $RPM_BUILD_ROOT%{_libdir}
108 done
109
110 cd %{name}-tools-%{version_tools}
111 install compress_san    $RPM_BUILD_ROOT%{_bindir}
112 install convbdf         $RPM_BUILD_ROOT%{_bindir}
113 install dekyra          $RPM_BUILD_ROOT%{_bindir}
114 install descumm         $RPM_BUILD_ROOT%{_bindir}
115 install desword2        $RPM_BUILD_ROOT%{_bindir}
116 install extract         $RPM_BUILD_ROOT%{_bindir}/extract-scummvm
117 install kyra_unpak      $RPM_BUILD_ROOT%{_bindir}
118 install loom_tg16_extract       $RPM_BUILD_ROOT%{_bindir}
119 install mm_nes_extract  $RPM_BUILD_ROOT%{_bindir}
120 install queenrebuild    $RPM_BUILD_ROOT%{_bindir}
121 install rescumm         $RPM_BUILD_ROOT%{_bindir}
122 install saga2mp3        $RPM_BUILD_ROOT%{_bindir}
123 install simon1decr      $RPM_BUILD_ROOT%{_bindir}
124 install simon2mp3       $RPM_BUILD_ROOT%{_bindir}
125 install sword1mp3       $RPM_BUILD_ROOT%{_bindir}
126 install sword2mp3       $RPM_BUILD_ROOT%{_bindir}
127 cd -
128
129 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
130 install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %files
136 %defattr(644,root,root,755)
137 %doc NEWS README TODO
138 %attr(755,root,root) %{_bindir}/scummvm
139 %attr(755,root,root) %{_libdir}/*
140 %{_mandir}/man6/*
141 %{_pixmapsdir}/*
142 %{_desktopdir}/*
143
144 %files tools
145 %defattr(644,root,root,755)
146 %doc %{name}-tools-%{version_tools}/README
147 %attr(755,root,root) %{_bindir}/*
148 %exclude %{_bindir}/scummvm
This page took 0.042969 seconds and 4 git commands to generate.