]> git.pld-linux.org Git - packages/scummvm.git/blob - scummvm.spec
- rel 2
[packages/scummvm.git] / scummvm.spec
1 # TODO:
2 #  - include gui/themes/modern* and teach scummvm to search
3 #    for it in some system paths, not current dir
4 #
5 %define         version_tools   0.9.0
6 Summary:        SCUMM graphic adventure game interpreter
7 Summary(pl):    Interpreter przygodówek opartych na SCUMM
8 Name:           scummvm
9 Version:        0.9.0
10 Release:        2
11 License:        GPL
12 Group:          X11/Applications/Games
13 Source0:        http://dl.sourceforge.net/scummvm/%{name}-%{version}.tar.bz2
14 # Source0-md5:  5eede9c97d1883f80770a3e211419783
15 Source1:        http://dl.sourceforge.net/scummvm/%{name}-tools-%{version_tools}.tar.bz2
16 # Source1-md5:  c8164fa1cca90b1c3bff1c8949d875a3
17 Source2:        %{name}.desktop
18 Source3:        %{name}.png
19 URL:            http://scummvm.sourceforge.net/
20 BuildRequires:  SDL-devel >= 1.2.2
21 %ifarch %{ix86} %{x8664}
22 BuildRequires:  fluidsynth-devel
23 %endif
24 BuildRequires:  libmad-devel
25 BuildRequires:  libvorbis-devel
26 BuildRequires:  mpeg2dec-devel
27 %ifarch %{ix86}
28 BuildRequires:  nasm
29 %endif
30 BuildRequires:  sed >= 4.0
31 BuildRequires:  zlib-devel
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 ScummVM is a collection of interpreters, capable of emulating several
36 adventure game engines. ScummVM mainly supports games created using
37 SCUMM (Script Creation Utility for Maniac Mansion), used in various
38 LucasArts games such as Monkey Island, Day of the Tentacle, and
39 others.
40
41 ScummVM also contains interpreters for several non-SCUMM games.
42 Currently these are Beneath a Steel Sky, Broken Sword 1 & 2, Flight of
43 the Amazon Queen and Simon the Sorcerer 1 & 2.
44
45 At this time ScummVM should be considered beta software, and is still
46 under heavy development. Be aware that whilst we attempt to make sure
47 that many games can be completed with few major bugs, crashes can
48 happen.
49
50 %description -l pl
51 ScummVM jest zbiorem interpreterów zdolnych do emulacji kilku silników
52 gier przygodowych. ScummVM g³ównie wspiera gry stworzone z u¿yciem
53 silnika SCUMM (Script Creation Utility for Maniac Mansion), u¿ywanego
54 przez takie tytu³y stworzone przez Lucas Arts jak Monkey Island, Day
55 of the Tentacle.
56
57 ScummVM potrafi równie¿ interpretowaæ kilka gier nie opartych na
58 SCUMM. W chwili obecnej s± to Beneath a Steel Sky, Broken Sword 1 i 2,
59 Flight of the Amazon Queen oraz Simon the Sorcerer 1 i 2.
60
61 ScummVM jest ca³y czas intensywnie rozwijany i powinien byæ traktowany
62 jako program w stanie beta. Wiele gier powinno daæ siê skoñczyæ bez
63 wiêkszych b³êdów, nale¿y byæ jednak ¶wiadomym, ¿e program mo¿e siê
64 czasem wysypaæ.
65
66 %package tools
67 Summary:        ScummVM tools
68 Summary(pl):    Narzêdzia zwi±zane ze ScummVM
69 Group:          X11/Applications/Games
70
71 %description tools
72 Collection of various tools that may be useful to use in conjunction
73 with ScummVM.
74
75 %description tools -l pl
76 Zestaw narzêdzi mog±cych byæ u¿ytecznymi w po³±czeniu ze ScummVM.
77
78 %prep
79 %setup -q -a 1
80
81 sed -i -e 's:"plugins/":"%{_libdir}/scummvm/":' base/plugins.cpp
82
83 %build
84 ./configure \
85         --disable-debug \
86 %ifnarch %{ix86}
87         --disable-nasm \
88 %endif
89         --enable-lure \
90         --enable-cine \
91         --enable-plugins
92
93 %{__make} \
94         CXX="%{__cxx}" \
95         CXXFLAGS="%{rpmcflags} -DDYNAMIC_MODULES -fpic" \
96         LDFLAGS="%{rpmldflags}"
97
98 cd tools-%{version_tools}
99 %{__make} \
100         CC="%{__cc}" \
101         CFLAGS="%{rpmcflags}" \
102         LDFLAGS="%{rpmldflags}"
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man6,%{_pixmapsdir},%{_desktopdir},%{_libdir}/scummvm}
107
108 install scummvm $RPM_BUILD_ROOT%{_bindir}
109 #install scummvm.6 $RPM_BUILD_ROOT%{_mandir}/man6
110
111 install plugins/lib*.so $RPM_BUILD_ROOT%{_libdir}/scummvm
112
113 cd tools-%{version_tools}
114 install compress_kyra           $RPM_BUILD_ROOT%{_bindir}
115 install compress_queen          $RPM_BUILD_ROOT%{_bindir}
116 install compress_saga           $RPM_BUILD_ROOT%{_bindir}
117 install compress_scumm_bun      $RPM_BUILD_ROOT%{_bindir}
118 install compress_scumm_san      $RPM_BUILD_ROOT%{_bindir}
119 install compress_scumm_sou      $RPM_BUILD_ROOT%{_bindir}
120 install compress_simon          $RPM_BUILD_ROOT%{_bindir}
121 install compress_sword1         $RPM_BUILD_ROOT%{_bindir}
122 install compress_sword2         $RPM_BUILD_ROOT%{_bindir}
123 install dekyra                  $RPM_BUILD_ROOT%{_bindir}
124 install descumm                 $RPM_BUILD_ROOT%{_bindir}
125 install desword2                $RPM_BUILD_ROOT%{_bindir}
126 install encode_dxa              $RPM_BUILD_ROOT%{_bindir}
127 install extract_kyra            $RPM_BUILD_ROOT%{_bindir}
128 install extract_loom_tg16       $RPM_BUILD_ROOT%{_bindir}
129 install extract_mm_c64          $RPM_BUILD_ROOT%{_bindir}
130 install extract_mm_nes          $RPM_BUILD_ROOT%{_bindir}
131 install extract_scumm_mac       $RPM_BUILD_ROOT%{_bindir}
132 install extract_simon1_amiga    $RPM_BUILD_ROOT%{_bindir}
133 install extract_zak_c64         $RPM_BUILD_ROOT%{_bindir}
134 cd -
135
136 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
137 install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %files
143 %defattr(644,root,root,755)
144 %doc AUTHORS NEWS README TODO
145 %attr(755,root,root) %{_bindir}/scummvm
146 %{_libdir}/scummvm
147 #%{_mandir}/man6/*
148 %{_pixmapsdir}/*
149 %{_desktopdir}/*
150
151 %files tools
152 %defattr(644,root,root,755)
153 %doc tools-%{version_tools}/README
154 %attr(755,root,root) %{_bindir}/*
155 %exclude %{_bindir}/scummvm
This page took 0.082137 seconds and 4 git commands to generate.