]> git.pld-linux.org Git - packages/scummvm.git/blob - scummvm.spec
- 0.9.0
[packages/scummvm.git] / scummvm.spec
1 # TODO:
2 #  - include gui/themes/modern* and teach scummvm to search
3 #    for it in some system paths, not current dir
4 #
5 %define         version_tools   0.9.0
6 Summary:        SCUMM graphic adventure game interpreter
7 Summary(pl):    Interpreter przygodówek opartych na SCUMM
8 Name:           scummvm
9 Version:        0.9.0
10 Release:        1
11 License:        GPL
12 Group:          X11/Applications/Games
13 Source0:        http://dl.sourceforge.net/scummvm/%{name}-%{version}.tar.bz2
14 # Source0-md5:  5eede9c97d1883f80770a3e211419783
15 Source1:        http://dl.sourceforge.net/scummvm/%{name}-tools-%{version_tools}.tar.bz2
16 # Source1-md5:  c8164fa1cca90b1c3bff1c8949d875a3
17 Source2:        %{name}.desktop
18 Source3:        %{name}.png
19 URL:            http://scummvm.sourceforge.net/
20 BuildRequires:  SDL-devel >= 1.2.2
21 BuildRequires:  fluidsynth-devel
22 BuildRequires:  libmad-devel
23 BuildRequires:  libvorbis-devel
24 BuildRequires:  mpeg2dec-devel
25 %ifarch %{ix86}
26 BuildRequires:  nasm
27 %endif
28 BuildRequires:  sed >= 4.0
29 BuildRequires:  zlib-devel
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 ScummVM is a collection of interpreters, capable of emulating several
34 adventure game engines. ScummVM mainly supports games created using
35 SCUMM (Script Creation Utility for Maniac Mansion), used in various
36 LucasArts games such as Monkey Island, Day of the Tentacle, and
37 others.
38
39 ScummVM also contains interpreters for several non-SCUMM games.
40 Currently these are Beneath a Steel Sky, Broken Sword 1 & 2, Flight of
41 the Amazon Queen and Simon the Sorcerer 1 & 2.
42
43 At this time ScummVM should be considered beta software, and is still
44 under heavy development. Be aware that whilst we attempt to make sure
45 that many games can be completed with few major bugs, crashes can
46 happen.
47
48 %description -l pl
49 ScummVM jest zbiorem interpreterów zdolnych do emulacji kilku silników
50 gier przygodowych. ScummVM g³ównie wspiera gry stworzone z u¿yciem
51 silnika SCUMM (Script Creation Utility for Maniac Mansion), u¿ywanego
52 przez takie tytu³y stworzone przez Lucas Arts jak Monkey Island, Day
53 of the Tentacle.
54
55 ScummVM potrafi równie¿ interpretowaæ kilka gier nie opartych na
56 SCUMM. W chwili obecnej s± to Beneath a Steel Sky, Broken Sword 1 i 2,
57 Flight of the Amazon Queen oraz Simon the Sorcerer 1 i 2.
58
59 ScummVM jest ca³y czas intensywnie rozwijany i powinien byæ traktowany
60 jako program w stanie beta. Wiele gier powinno daæ siê skoñczyæ bez
61 wiêkszych b³êdów, nale¿y byæ jednak ¶wiadomym, ¿e program mo¿e siê
62 czasem wysypaæ.
63
64 %package tools
65 Summary:        ScummVM tools
66 Summary(pl):    Narzêdzia zwi±zane ze ScummVM
67 Group:          X11/Applications/Games
68
69 %description tools
70 Collection of various tools that may be useful to use in conjunction
71 with ScummVM.
72
73 %description tools -l pl
74 Zestaw narzêdzi mog±cych byæ u¿ytecznymi w po³±czeniu ze ScummVM.
75
76 %prep
77 %setup -q -a 1
78
79 sed -i -e 's:"plugins/":"%{_libdir}/scummvm/":' base/plugins.cpp
80
81 %build
82 ./configure \
83         --disable-debug \
84 %ifnarch %{ix86}
85         --disable-nasm \
86 %endif
87         --enable-lure \
88         --enable-cine \
89         --enable-plugins
90
91 %{__make} \
92         CXX="%{__cxx}" \
93         CXXFLAGS="%{rpmcflags} -DDYNAMIC_MODULES -fpic" \
94         LDFLAGS="%{rpmldflags}"
95
96 cd tools-%{version_tools}
97 %{__make} \
98         CC="%{__cc}" \
99         CFLAGS="%{rpmcflags}" \
100         LDFLAGS="%{rpmldflags}"
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man6,%{_pixmapsdir},%{_desktopdir},%{_libdir}/scummvm}
105
106 install scummvm $RPM_BUILD_ROOT%{_bindir}
107 #install scummvm.6 $RPM_BUILD_ROOT%{_mandir}/man6
108
109 install plugins/lib*.so $RPM_BUILD_ROOT%{_libdir}/scummvm
110
111 cd tools-%{version_tools}
112 install compress_kyra           $RPM_BUILD_ROOT%{_bindir}
113 install compress_queen          $RPM_BUILD_ROOT%{_bindir}
114 install compress_saga           $RPM_BUILD_ROOT%{_bindir}
115 install compress_scumm_bun      $RPM_BUILD_ROOT%{_bindir}
116 install compress_scumm_san      $RPM_BUILD_ROOT%{_bindir}
117 install compress_scumm_sou      $RPM_BUILD_ROOT%{_bindir}
118 install compress_simon          $RPM_BUILD_ROOT%{_bindir}
119 install compress_sword1         $RPM_BUILD_ROOT%{_bindir}
120 install compress_sword2         $RPM_BUILD_ROOT%{_bindir}
121 install dekyra                  $RPM_BUILD_ROOT%{_bindir}
122 install descumm                 $RPM_BUILD_ROOT%{_bindir}
123 install desword2                $RPM_BUILD_ROOT%{_bindir}
124 install encode_dxa              $RPM_BUILD_ROOT%{_bindir}
125 install extract_kyra            $RPM_BUILD_ROOT%{_bindir}
126 install extract_loom_tg16       $RPM_BUILD_ROOT%{_bindir}
127 install extract_mm_c64          $RPM_BUILD_ROOT%{_bindir}
128 install extract_mm_nes          $RPM_BUILD_ROOT%{_bindir}
129 install extract_scumm_mac       $RPM_BUILD_ROOT%{_bindir}
130 install extract_simon1_amiga    $RPM_BUILD_ROOT%{_bindir}
131 install extract_zak_c64         $RPM_BUILD_ROOT%{_bindir}
132 cd -
133
134 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
135 install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %files
141 %defattr(644,root,root,755)
142 %doc AUTHORS NEWS README TODO
143 %attr(755,root,root) %{_bindir}/scummvm
144 %{_libdir}/scummvm
145 #%{_mandir}/man6/*
146 %{_pixmapsdir}/*
147 %{_desktopdir}/*
148
149 %files tools
150 %defattr(644,root,root,755)
151 %doc tools-%{version_tools}/README
152 %attr(755,root,root) %{_bindir}/*
153 %exclude %{_bindir}/scummvm
This page took 0.088044 seconds and 4 git commands to generate.