]> git.pld-linux.org Git - packages/sblim-sfcb.git/commitdiff
- fix building with gcc 10+, fix files, rebuild with openssl 3.0.0, rel 5 master auto/th/sblim-sfcb-1.4.9-5
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 13 Oct 2021 19:42:24 +0000 (21:42 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 13 Oct 2021 19:42:24 +0000 (21:42 +0200)
gcc10.patch [new file with mode: 0644]
sblim-sfcb.spec

diff --git a/gcc10.patch b/gcc10.patch
new file mode 100644 (file)
index 0000000..71b13ea
--- /dev/null
@@ -0,0 +1,92 @@
+diff -ur sblim-sfcb-1.4.9/control.c sblim-sfcb-1.4.9-gcc10/control.c
+--- sblim-sfcb-1.4.9/control.c 2021-10-13 21:37:49.873825576 +0200
++++ sblim-sfcb-1.4.9-gcc10/control.c   2021-10-13 21:36:53.004046593 +0200
+@@ -79,6 +79,7 @@
+ int             httpProcIdX;
+ long            httpReqHandlerTimeout;
+  
++const char      * sfcBrokerStart;
+ /**
+  * Kindly null terminate, always, even if might overwrite
+  * the last char of the truncated string. 
+diff -ur sblim-sfcb-1.4.9/control.h sblim-sfcb-1.4.9-gcc10/control.h
+--- sblim-sfcb-1.4.9/control.h 2014-11-25 02:43:10.000000000 +0100
++++ sblim-sfcb-1.4.9-gcc10/control.h   2021-10-13 21:36:42.564087988 +0200
+@@ -28,7 +28,7 @@
+ int             getControlULong(char *id, unsigned long *val);
+ int             getControlNum(char *id, long *val);
+ int             getControlBool(char *id, int *val);
+-const char      * sfcBrokerStart;
++extern const char      * sfcBrokerStart;
+ #endif
+ /* MODELINES */
+diff -ur sblim-sfcb-1.4.9/default.reg sblim-sfcb-1.4.9-gcc10/default.reg
+--- sblim-sfcb-1.4.9/default.reg       2014-11-25 03:06:53.000000000 +0100
++++ sblim-sfcb-1.4.9-gcc10/default.reg 2021-10-13 21:37:07.817321652 +0200
+@@ -20,12 +20,12 @@
+    unload: never
+    namespace: root/interop
+ #
+-#[$ProfileProvider$]
+-#   provider: ProfileProvider
+-#   location: sfcProfileProvider
+-#   type: method
+-#   unload: never
+-#   namespace: root/interop
++[$ProfileProvider$]
++   provider: ProfileProvider
++   location: sfcProfileProvider
++   type: method
++   unload: never
++   namespace: root/interop
+ #
+ [$QualifierProvider$]
+    provider: QualifierProvider
+diff -ur sblim-sfcb-1.4.9/providerMgr.c sblim-sfcb-1.4.9-gcc10/providerMgr.c
+--- sblim-sfcb-1.4.9/providerMgr.c     2014-11-25 02:43:12.000000000 +0100
++++ sblim-sfcb-1.4.9-gcc10/providerMgr.c       2021-10-13 21:35:30.974379261 +0200
+@@ -53,6 +53,8 @@
+ #define SFCB_ASM(x)
+ #endif
++sigset_t mask, old_mask;
++
+ static pthread_mutex_t resultsocketMutex = PTHREAD_MUTEX_INITIALIZER;
+ extern CMPIBroker *Broker;
+diff -ur sblim-sfcb-1.4.9/providerMgr.h sblim-sfcb-1.4.9-gcc10/providerMgr.h
+--- sblim-sfcb-1.4.9/providerMgr.h     2014-11-25 02:43:12.000000000 +0100
++++ sblim-sfcb-1.4.9-gcc10/providerMgr.h       2021-10-13 21:34:41.104590547 +0200
+@@ -398,7 +398,7 @@
+ BinResponseHdr *invokeProvider(BinRequestContext * ctx);
+ void            freeResponseHeaders(BinResponseHdr ** resp,
+                                     BinRequestContext * ctx);
+-sigset_t mask, old_mask;
++extern sigset_t mask, old_mask;
+ #endif
+ /* MODELINES */
+diff -ur sblim-sfcb-1.4.9/trace.c sblim-sfcb-1.4.9-gcc10/trace.c
+--- sblim-sfcb-1.4.9/trace.c   2014-11-25 02:43:17.000000000 +0100
++++ sblim-sfcb-1.4.9-gcc10/trace.c     2021-10-13 21:33:31.551564675 +0200
+@@ -52,6 +52,7 @@
+ int             providerProcess = 0;
+ int             idleThreadId = 0;
+ int             terminating = 0;
++int             colorTrace;
+ int             _sfcb_debug = 0;
+ unsigned long   _sfcb_trace_mask = 0;
+diff -ur sblim-sfcb-1.4.9/trace.h sblim-sfcb-1.4.9-gcc10/trace.h
+--- sblim-sfcb-1.4.9/trace.h   2021-10-13 21:37:49.873825576 +0200
++++ sblim-sfcb-1.4.9-gcc10/trace.h     2021-10-13 21:33:28.871576855 +0200
+@@ -131,7 +131,7 @@
+ #define CYAN            6
+ #define WHITE           7
+ void            changeTextColor(int reset);
+-int             colorTrace;
++extern int             colorTrace;
+ #define MAX_MSG_SIZE 1024       /* max length of trace message */
index efb43c31334aab9391851c386868c4dabc438cfc..bcdb12fd48a4e651164472e343776c4d88c01c50 100644 (file)
@@ -3,7 +3,7 @@ Summary:        Small Footprint CIM Broker
 Summary(pl.UTF-8):     Lekki broker CIM
 Name:          sblim-sfcb
 Version:       1.4.9
-Release:       4
+Release:       5
 License:       Eclipse Public License v1.0
 Group:         Libraries
 Source0:       http://downloads.sourceforge.net/sblim/%{name}-%{version}.tar.bz2
@@ -11,6 +11,7 @@ Source0:      http://downloads.sourceforge.net/sblim/%{name}-%{version}.tar.bz2
 Patch0:                %{name}-fix.patch
 Patch1:                am.patch
 Patch2:                %{name}-dont-inline.patch
+Patch3:                gcc10.patch
 URL:           http://sblim.sourceforge.net/
 BuildRequires: curl-devel >= 7.11.1
 BuildRequires: libstdc++-devel
@@ -62,6 +63,7 @@ systemami.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %build
 %{__libtoolize}
@@ -163,7 +165,7 @@ fi
 %dir /var/lib/sfcb/stage
 %config %verify(not md5 mtime size) /var/lib/sfcb/stage/default.reg
 %dir /var/lib/sfcb/stage/mofs
-%config %verify(not md5 mtime size) %dir /var/lib/sfcb/stage/mofs/indication.mof
+%config %verify(not md5 mtime size) /var/lib/sfcb/stage/mofs/indication.mof
 %dir /var/lib/sfcb/stage/mofs/root
 %dir /var/lib/sfcb/stage/mofs/root/interop
 %config %verify(not md5 mtime size) /var/lib/sfcb/stage/mofs/root/interop/*.mof
This page took 0.108972 seconds and 4 git commands to generate.