]> git.pld-linux.org Git - packages/sbcl.git/blob - sbcl.spec
06f56c64697e83a8a58276cc96defec9e8168bdc
[packages/sbcl.git] / sbcl.spec
1 #
2 # Conditional build:
3 %bcond_without  doc             # build without documentation
4 %bcond_with     clisp           # build using clisp instead of sbcl
5 #
6 # To build with an unpackaged Common Lisp implementation,
7 # pass --define bootstrap_cl /path/to/lisp/binary to builder.
8 #
9 Summary:        The Steel Bank Common Lisp development environment
10 Summary(pl.UTF-8):      Środowisko programowania Steel Bank Common Lisp
11 Name:           sbcl
12 Version:        1.0.16
13 Release:        1
14 License:        MIT
15 Group:          Development/Languages
16 Source0:        http://dl.sourceforge.net/sbcl/%{name}-%{version}-source.tar.bz2
17 # Source0-md5:  7256bed59a34b0a3efef540711bd3786
18 Patch0:         %{name}-home.patch
19 Patch1:         %{name}-threads.patch
20 URL:            http://sbcl.sourceforge.net/
21 %if %{undefined bootstrap_cl}
22 %if %{with clisp}
23 BuildRequires:  clisp
24 %else
25 BuildRequires:  sbcl
26 %endif
27 %endif
28 %if %{with doc}
29 BuildRequires:  tetex-dvips
30 BuildRequires:  texinfo-texi2dvi
31 %endif
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Steel Bank Common Lisp (SBCL) is a Open Source development environment
36 for Common Lisp based on CMUCL. It includes an integrated native compiler,
37 interpreter, and debugger.
38
39 %description -l pl.UTF-8
40 Steel Bank Common Lisp (SBCL) to środowisko programistyczne Open
41 Source dla Common Lispa oparte na CMUCL. Zawiera zintegrowany natywny
42 kompilator, interpreter i debugger.
43
44 %package doc-info
45 Summary:        The Steel Bank Common Lisp documentation (info)
46 Summary(pl.UTF-8):      Dokumentacja Steel Bank Common Lisp (info)
47 Group:          Development/Languages
48
49 %description doc-info
50 Documentation of Steel Bank Common Lisp (SBCL) in info format.
51
52 %description doc-info -l pl.UTF-8
53 Dokumentacja Steel Bank Common Lisp (SBCL) w formacie info.
54
55 %package doc-html
56 Summary:        The Steel Bank Common Lisp documentation (HTML)
57 Summary(pl.UTF-8):      Dokumentacja Steel Bank Common Lisp (HTML)
58 Group:          Development/Languages
59
60 %description doc-html
61 Documentation of Steel Bank Common Lisp (SBCL) in HTML format.
62
63 %description doc-html -l pl.UTF-8
64 Dokumentacja Steel Bank Common Lisp (SBCL) w formacie HTML.
65
66 %package doc-pdf
67 Summary:        The Steel Bank Common Lisp documentation (PDF)
68 Summary(pl.UTF-8):      Dokumentacja Steel Bank Common Lisp (PDF)
69 Group:          Development/Languages
70
71 %description doc-pdf
72 Documentation of Steel Bank Common Lisp (SBCL) in PDF format.
73
74 %description doc-pdf -l pl.UTF-8
75 Dokumentacja Steel Bank Common Lisp (SBCL) w formacie PDF.
76
77 %prep
78 %setup -q
79 %patch0 -p1
80 %ifarch %{ix86} %{x8664}
81 %patch1 -p1
82 %endif
83
84 %if %{undefined bootstrap_cl}
85 %if %{with clisp}
86 %define bootstrap_cl "clisp"
87 %else
88 %define bootstrap_cl "sbcl --disable-debugger"
89 %endif
90 %endif
91
92 %build
93 GNUMAKE="make"
94 CFLAGS="%{rpmcflags}"
95 CC="%{__cc}"
96 export GNUMAKE CC CFLAGS
97 ./make.sh %{bootstrap_cl}
98 %if %{with doc}
99 make -C doc/manual
100 %endif
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104 mkdir -p $RPM_BUILD_ROOT%{_bindir} $RPM_BUILD_ROOT%{_libdir} \
105     $RPM_BUILD_ROOT%{_mandir} $RPM_BUILD_ROOT%{_infodir} \
106     $RPM_BUILD_ROOT/etc/env.d
107 env -u SBCL_HOME INSTALL_ROOT=`pwd`/_install %{_buildshell} ./install.sh
108 mv _install/lib/sbcl $RPM_BUILD_ROOT%{_libdir}/%{name}
109 mv _install/bin/sbcl $RPM_BUILD_ROOT%{_bindir}/%{name}
110 mv _install/share/man/* $RPM_BUILD_ROOT%{_mandir}
111 %if %{with doc}
112 mv _install/share/info/*.info* $RPM_BUILD_ROOT%{_infodir}
113 %endif
114
115 echo SBCL_HOME=%{_libdir}/%{name} > $RPM_BUILD_ROOT/etc/env.d/SBCL_HOME
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post
121 %env_update
122
123 %postun
124 %env_update
125
126 %if %{with doc}
127 %post doc-info  -p      /sbin/postshell
128 -/usr/sbin/fix-info-dir -c %{_infodir}
129
130 %postun doc-info
131 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
132 %endif
133
134 %files
135 %defattr(644,root,root,755)
136 %doc _install/share/doc/sbcl/[A-Z]*
137 %attr (755,root,root) %{_bindir}/%{name}
138 %{_libdir}/%{name}
139 %{_mandir}/man1/*
140 %config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/*
141
142 %if %{with doc}
143 %files doc-info
144 %defattr(644,root,root,755)
145 %{_infodir}/*.info*
146
147 %files doc-html
148 %defattr(644,root,root,755)
149 %doc _install/share/doc/sbcl/html/*
150
151 %files doc-pdf
152 %defattr(644,root,root,755)
153 %doc _install/share/doc/sbcl/*.pdf
154 %endif
This page took 0.119043 seconds and 2 git commands to generate.