]> git.pld-linux.org Git - packages/sbcl.git/blame - sbcl.spec
- updated to 1.1.6
[packages/sbcl.git] / sbcl.spec
CommitLineData
8e4ff5ca 1#
2# Conditional build:
3%bcond_without doc # build without documentation
4%bcond_with clisp # build using clisp instead of sbcl
5#
e22d414a 6# To build with an unpackaged Common Lisp implementation,
7# pass --define bootstrap_cl /path/to/lisp/binary to builder.
8#
6114c569 9Summary: The Steel Bank Common Lisp development environment
18060869 10Summary(pl.UTF-8): Środowisko programowania Steel Bank Common Lisp
6114c569 11Name: sbcl
c7dd8c2f
JR
12Version: 1.1.6
13Release: 0.1
6114c569 14License: MIT
15Group: Development/Languages
c7dd8c2f
JR
16Source0: http://download.sourceforge.net/sbcl/%{name}-%{version}-source.tar.bz2
17# Source0-md5: 5daeabb9eaf7197006c4402bfc552d72
18Source10: http://download.sourceforge.net/sbcl/sbcl-1.0.58-x86-linux-binary.tar.bz2
19# Source10-md5: 28104cfb0ee2ac67000c77b9518377e8
20Source11: http://download.sourceforge.net/sbcl/sbcl-1.0.58-x86-64-linux-binary.tar.bz2
21# Source11-md5: 3d02edfdc851904d1d8dafeec20d1d06
e6c34555 22Patch1: %{name}-threads.patch
185e16eb 23URL: http://sbcl.sourceforge.net/
c7dd8c2f 24%{?with_clisp:BuildRequires: clisp}
8e4ff5ca 25%if %{with doc}
26BuildRequires: tetex-dvips
27BuildRequires: texinfo-texi2dvi
28%endif
6114c569 29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32Steel Bank Common Lisp (SBCL) is a Open Source development environment
33for Common Lisp based on CMUCL. It includes an integrated native compiler,
34interpreter, and debugger.
35
e072deaa
JR
36%description -l pl.UTF-8
37Steel Bank Common Lisp (SBCL) to środowisko programistyczne Open
b68b5ff6
JB
38Source dla Common Lispa oparte na CMUCL. Zawiera zintegrowany natywny
39kompilator, interpreter i debugger.
6114c569 40
33b06ddc 41%package doc-info
42Summary: The Steel Bank Common Lisp documentation (info)
18060869 43Summary(pl.UTF-8): Dokumentacja Steel Bank Common Lisp (info)
33b06ddc 44Group: Development/Languages
45
46%description doc-info
47Documentation of Steel Bank Common Lisp (SBCL) in info format.
48
e072deaa 49%description doc-info -l pl.UTF-8
33b06ddc 50Dokumentacja Steel Bank Common Lisp (SBCL) w formacie info.
51
52%package doc-html
53Summary: The Steel Bank Common Lisp documentation (HTML)
18060869 54Summary(pl.UTF-8): Dokumentacja Steel Bank Common Lisp (HTML)
33b06ddc 55Group: Development/Languages
56
57%description doc-html
58Documentation of Steel Bank Common Lisp (SBCL) in HTML format.
59
e072deaa 60%description doc-html -l pl.UTF-8
33b06ddc 61Dokumentacja Steel Bank Common Lisp (SBCL) w formacie HTML.
62
63%package doc-pdf
64Summary: The Steel Bank Common Lisp documentation (PDF)
18060869 65Summary(pl.UTF-8): Dokumentacja Steel Bank Common Lisp (PDF)
33b06ddc 66Group: Development/Languages
67
68%description doc-pdf
69Documentation of Steel Bank Common Lisp (SBCL) in PDF format.
70
e072deaa 71%description doc-pdf -l pl.UTF-8
33b06ddc 72Dokumentacja Steel Bank Common Lisp (SBCL) w formacie PDF.
73
6114c569 74%prep
c7dd8c2f
JR
75%ifarch %{ix86}
76%setup -q -a 10
77%endif
78%ifarch %{x8664}
79%setup -q -a 11
80%endif
e6c34555 81%ifarch %{ix86} %{x8664}
82%patch1 -p1
83%endif
6114c569 84
c7dd8c2f
JR
85mkdir sbcl-bootstrap
86cd sbcl-*-linux
87INSTALL_ROOT=`pwd`/../sbcl-bootstrap sh ./install.sh
88cd -
89
90# clean.sh is so stupid it removed sbcl-bootstrap contents
91%{__mv} clean.sh clean.sh.orig
92echo "#!/bin/sh" >clean.sh
93chmod 755 clean.sh
94
8e4ff5ca 95%if %{with clisp}
96%define bootstrap_cl "clisp"
e22d414a 97%endif
8e4ff5ca 98
6114c569 99%build
100GNUMAKE="make"
101CFLAGS="%{rpmcflags}"
102CC="%{__cc}"
103export GNUMAKE CC CFLAGS
c7dd8c2f
JR
104export SBCL_HOME=`pwd`/sbcl-bootstrap/lib/sbcl
105export PATH=`pwd`/sbcl-bootstrap/bin:${PATH}
106./make.sh \
107 --prefix=%{_prefix} \
108 %{?bootstrap_cl}
109
8e4ff5ca 110%if %{with doc}
33b06ddc 111make -C doc/manual
8e4ff5ca 112%endif
6114c569 113
114%install
115rm -rf $RPM_BUILD_ROOT
c7dd8c2f
JR
116install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_mandir},%{_infodir}} \
117 $RPM_BUILD_ROOT/etc/env.d
118
e22d414a 119env -u SBCL_HOME INSTALL_ROOT=`pwd`/_install %{_buildshell} ./install.sh
c7dd8c2f
JR
120
121%{__mv} _install/lib/sbcl $RPM_BUILD_ROOT%{_libdir}/%{name}
122%{__mv} _install/bin/sbcl $RPM_BUILD_ROOT%{_bindir}/%{name}
123%{__mv} _install/share/man/* $RPM_BUILD_ROOT%{_mandir}
e22d414a 124%if %{with doc}
c7dd8c2f 125%{__mv} _install/share/info/*.info* $RPM_BUILD_ROOT%{_infodir}
e22d414a 126%endif
127
128echo SBCL_HOME=%{_libdir}/%{name} > $RPM_BUILD_ROOT/etc/env.d/SBCL_HOME
6114c569 129
130%clean
131rm -rf $RPM_BUILD_ROOT
132
e22d414a 133%post
134%env_update
135
136%postun
137%env_update
138
139%if %{with doc}
c7dd8c2f 140%post doc-info -p /sbin/postshell
17eb1cbb 141-/usr/sbin/fix-info-dir -c %{_infodir}
33b06ddc 142
143%postun doc-info
33b06ddc 144[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
e22d414a 145%endif
33b06ddc 146
6114c569 147%files
148%defattr(644,root,root,755)
e22d414a 149%doc _install/share/doc/sbcl/[A-Z]*
150%attr (755,root,root) %{_bindir}/%{name}
151%{_libdir}/%{name}
6114c569 152%{_mandir}/man1/*
e22d414a 153%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/*
33b06ddc 154
8e4ff5ca 155%if %{with doc}
33b06ddc 156%files doc-info
157%defattr(644,root,root,755)
158%{_infodir}/*.info*
159
160%files doc-html
161%defattr(644,root,root,755)
c7dd8c2f 162%doc _install/share/doc/sbcl/*.html
33b06ddc 163
164%files doc-pdf
165%defattr(644,root,root,755)
e22d414a 166%doc _install/share/doc/sbcl/*.pdf
8e4ff5ca 167%endif
This page took 0.7513 seconds and 4 git commands to generate.