]> git.pld-linux.org Git - packages/sawfish.git/blob - sawfish.spec
perl -pi -e "s/^gettextize --copy --force/\%%\{__gettextize\}/"
[packages/sawfish.git] / sawfish.spec
1 Summary:        A highly configurable and extensible X11 window manager
2 Summary(pl):    Window Manad¿er dla X11 o du¿ych mo¿liwo¶ciach konfiguracyjnych i skalowalno¶ci
3 Name:           sawfish
4 Version:        1.0.1
5 Release:        6
6 Epoch:          1
7 License:        GPL
8 Group:          X11/Window Managers
9 Source0:        http://prdownloads.sourceforge.net/sawmill/%{name}-%{version}.tar.gz
10 Patch0:         %{name}-info.patch
11 Patch1:         %{name}-no_version.patch
12 Patch2:         %{name}-no_libnsl.spec
13 Patch3:         %{name}-make.patch
14 Patch4:         %{name}-windowmenu.patch
15 Patch5:         %{name}-nautilus.patch
16 Patch6:         %{name}-ac25x.patch
17 URL:            http://sawmill.sourceforge.net/
18 Icon:           sawfish.xpm
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  esound-devel
22 BuildRequires:  control-center-devel
23 BuildRequires:  gettext-devel
24 BuildRequires:  librep-devel
25 BuildRequires:  gnome-libs-devel
26 BuildRequires:  gtk+-devel >= 1.2.0
27 BuildRequires:  imlib-devel >= 1.8.2
28 BuildRequires:  libjpeg-devel
29 BuildRequires:  libpng >= 1.0.8
30 BuildRequires:  librep-devel >= 0.14
31 BuildRequires:  libtiff-devel
32 BuildRequires:  libtool
33 BuildRequires:  libungif-devel
34 BuildRequires:  ncurses-devel
35 BuildRequires:  readline-devel
36 BuildRequires:  rep-gtk >= 0.14-3
37 BuildRequires:  rep-gtk-gnome >= 0.14-3
38 BuildRequires:  rep-gtk-libglade >= 0.14-3
39 BuildRequires:  texinfo
40 %define         repexecdir      %(rep-config --execdir || echo "Install_librep-devel_and_rebuild_this_package")
41 Requires:       rep-gtk >= 0.14-3
42 Requires:       rep-gtk-gnome >= 0.14.3
43 Requires:       %{repexecdir}
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45 Obsoletes:      sawmill
46 Obsoletes:      sawmill-gnome
47 Obsoletes:      sawmill-themer
48
49 %define         _prefix         /usr/X11R6
50 %define         _libexecdir     %{_libdir}
51 %define         _wmpropsdir     %{_datadir}/wm-properties
52
53 %description
54 This is an extensible window manager using a LISP-based scripting
55 language--all window decorations are configurable, the basic idea is
56 to have as much user-interface policy as possible controlled through
57 the Lisp language. All configuration may be performed through a GTK
58 interface; sawfish is mostly-GNOME compliant.
59
60 %description -l pl
61 Window manad¿er o du¿ych mo¿liwo¶ciach rozszerzania, u¿ywaj±cy
62 bazowanego na LISP-ie jêzyka skryptowego, dziêki czemu wszystkie
63 dodatki do okien s± configurowalne. Ogóln± ide± jest, aby daæ jak
64 najwiêksz± kontrolê w rêce u¿ytkownika poprzez graficzny interfejs
65 dziêki w³a¶nie LISP-owi. Sawfish jest najbardziej zgodny z GNOME-m.
66
67 %package gnome
68 Summary:        GNOME support for sawfish
69 Summary(pl):    Support GNOME'a dla sawfisha
70 Group:          X11/Window Managers
71 Requires:       %{name} = %{version}
72 Requires:       rep-gtk-gnome >= 0.14-3
73 Requires:       rep-gtk-libglade >= 0.14-3
74
75 %description gnome
76 Optional GNOME support for sawfish. Includes a wm-entries spec, and a
77 control center applet.
78
79 %description gnome -l pl
80 Opcjonalny support GNOME'a dla sawfisha. Zawiera aplet dla
81 control-center oraz wm-entries spec.
82
83 %package themer
84 Summary:        GUI for creating sawfish themes
85 Summary(pl):    GUI do tworzenia tematów dla sawfisha
86 Group:          X11/Window Managers
87 Requires:       %{name} = %{version}
88
89 %description themer
90 Optional theme builder for sawfish. Allows static window themes to be
91 created/edited in a graphical environment.
92
93 %description themer -l pl
94 Opcjonalna aplikacja do tworzenia tematów dla sawfisha. Pozwala na
95 tworzenie/modyfikacjê statycznych tematów w ¶rodowisku graficznym.
96
97 %prep
98 %setup -q
99 %patch0 -p1
100 %patch1 -p1
101 %patch2 -p1
102 %patch3 -p1
103 %patch4 -p1
104 %patch5 -p1
105 %patch6 -p1
106
107 %build
108 %{__gettextize}
109 %{__libtoolize}
110 aclocal
111 %{__autoconf}
112 automake -a -c || :
113 %configure \
114         --disable-static \
115         --enable-capplet \
116         --enable-themer \
117         --enable-gnome-widgets \
118         --with-readline \
119         --with-esd \
120         --with-audiofile \
121         --with-gnu-ld
122 %{__make} host_type=%{_host}
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126 install -d $RPM_BUILD_ROOT%{_wmpropsdir}
127
128 %{__make} install \
129         DESTDIR=$RPM_BUILD_ROOT \
130         G_MENU_DIR=%{_applnkdir}/Settings/GNOME \
131         host_type=%{_host}
132
133 install Sawfish.desktop $RPM_BUILD_ROOT%{_wmpropsdir}
134
135 gzip -9nf README NEWS FAQ TODO
136
137 %find_lang %{name}
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %post
143 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
144
145 %postun
146 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
147
148 %files -f %{name}.lang
149 %defattr(644,root,root,755)
150 %doc *.gz
151 %attr(755,root,root) %{_bindir}/sawfish
152 %attr(755,root,root) %{_bindir}/sawfish-client
153 %attr(755,root,root) %{_bindir}/sawfish-ui
154 %dir %{_datadir}/sawfish
155 %{_datadir}/sawfish/[^t]*
156 %{_datadir}/sawfish/themes
157
158 %{_pixmapsdir}/*
159
160 %dir %{_libexecdir}/sawfish
161 %dir %{_libexecdir}/sawfish/%{_host}
162 %attr(755,root,root) %{_libexecdir}/sawfish/%{_host}/*.so
163 %attr(755,root,root) %{_libexecdir}/sawfish/%{_host}/*.la
164 %attr(755,root,root) %{_libexecdir}/sawfish/%{_host}/gtk-style
165 %attr(755,root,root) %{_libexecdir}/sawfish/%{_host}/sawfish-menu
166 %attr(755,root,root) %{_libexecdir}/sawfish/%{_host}/sawfish-about
167 %dir %{_libexecdir}/sawfish/%{_host}/sawfish
168 %dir %{_libexecdir}/sawfish/%{_host}/sawfish/wm
169 %dir %{_libexecdir}/sawfish/%{_host}/sawfish/wm/util
170 %attr(755,root,root) %{_libexecdir}/sawfish/%{_host}/sawfish/wm/util/*.so
171 %attr(755,root,root) %{_libexecdir}/sawfish/%{_host}/sawfish/wm/util/*.la
172 %{_libexecdir}/sawfish/%{_host}/DOC
173
174 %dir %{repexecdir}/sawfish
175 %attr(755,root,root) %{repexecdir}/sawfish/*.so
176 %attr(755,root,root) %{repexecdir}/sawfish/*.la
177
178 %{_infodir}/sawfish*
179
180 %files gnome
181 %defattr(644,root,root,755)
182 %attr(755,root,root) %{_bindir}/sawfish-capplet
183 %{_datadir}/control-center/Sawfish
184 %{_wmpropsdir}/Sawfish.desktop
185
186 %files themer
187 %defattr(644,root,root,755)
188 %attr(755,root,root) %{_bindir}/sawfish-themer
189 %{_datadir}/sawfish/themer.glade
This page took 0.114353 seconds and 3 git commands to generate.