]> git.pld-linux.org Git - packages/sanlock.git/commitdiff
- updated to 3.8.0 auto/th/sanlock-3.8.0-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 8 Feb 2020 22:18:09 +0000 (23:18 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 8 Feb 2020 22:18:09 +0000 (23:18 +0100)
- updated init-pld patch
- removed obsolete link patch

sanlock-init-pld.patch
sanlock-link.patch [deleted file]
sanlock.spec

index b8f20856331cc5f5b824f4b399f014b880017887..af310a431e07d96c6e45f690d1603feeb18e5700 100644 (file)
@@ -1,14 +1,14 @@
---- sanlock-2.5/init.d/sanlock.orig    2012-09-30 10:16:54.308331928 +0200
-+++ sanlock-2.5/init.d/sanlock 2012-09-30 10:51:21.691622171 +0200
+--- sanlock-3.8.0/init.d/sanlock.orig  2020-02-08 22:16:26.415493120 +0100
++++ sanlock-3.8.0/init.d/sanlock       2020-02-08 22:25:28.369223771 +0100
 @@ -32,95 +32,86 @@
  [ -f /etc/sysconfig/$prog ] && . /etc/sysconfig/$prog
  
  start() {
 -      [ -x $exec ] || exit 5
 -
--      if [ ! -d /var/run/$prog ]; then
--              install -d -o $SANLOCKUSER -g $SANLOCKUSER -m 775 /var/run/$prog
--              [ -x /sbin/restorecon ] && restorecon /var/run/$prog
+-      if [ ! -d /run/$prog ]; then
+-              install -d -o $SANLOCKUSER -g $SANLOCKUSER -m 775 /run/$prog
+-              [ -x /sbin/restorecon ] && restorecon /run/$prog
 +      # Check if the service is already running?
 +      if [ -f /var/lock/subsys/sanlock ]; then
 +              msg_already_running "sanlock"
  esac
 -exit $?
 +exit $retval
---- sanlock-3.2.4/init.d/wdmd.orig     2015-09-10 17:23:16.258102320 +0200
-+++ sanlock-3.2.4/init.d/wdmd  2015-09-10 17:31:02.341416003 +0200
-@@ -42,114 +42,105 @@
+--- sanlock-3.8.0/init.d/wdmd.orig     2020-02-08 22:16:26.418826435 +0100
++++ sanlock-3.8.0/init.d/wdmd  2020-02-08 22:32:56.383463337 +0100
+@@ -42,114 +42,103 @@
        retval=$?
  
        if [ $retval -ne 0 ]; then
  }
  
  start() {
+-      watchdog_check
+-
+-      [ -x $exec ] || exit 5
+-
+-      if [ ! -d /run/$prog ]; then
+-              install -d -g $WDMDGROUP -m 775 /run/$prog
+-              [ -x /sbin/restorecon ] && restorecon /run/$prog
 +      # Check if the service is already running?
 +      if [ -f $lockfile ]; then
 +              msg_already_running "wdmd"
 +              return
-+      fi
-+ 
-       watchdog_check
-       [ -x $exec ] || exit 5
+       fi
  
--      if [ ! -d /var/run/$prog ]; then
--              install -d -g $WDMDGROUP -m 775 /var/run/$prog
--              [ -x /sbin/restorecon ] && restorecon /var/run/$prog
--      fi
--
 -      echo -n $"Starting $prog: "
++      watchdog_check
++
 +      msg_starting "wdmd"
        daemon $prog $WDMDOPTS
        retval=$?
  esac
 -exit $?
 +exit $retval
---- sanlock-3.2.4/init.d/fence_sanlockd.orig   2015-06-19 18:26:03.000000000 +0200
-+++ sanlock-3.2.4/init.d/fence_sanlockd        2015-09-10 20:58:46.917559578 +0200
+--- sanlock-3.8.0/init.d/fence_sanlockd.orig   2019-06-12 21:07:38.000000000 +0200
++++ sanlock-3.8.0/init.d/fence_sanlockd        2020-02-08 22:34:27.129638389 +0100
 @@ -33,42 +33,35 @@
  [ -f /etc/sysconfig/$prog ] && . /etc/sysconfig/$prog
  
  start() {
 -      [ -x $exec ] || exit 5
--
 +      # Check if the service is already running?
 +      if [ -f /var/lock/subsys/sanlock ]; then
 +              msg_already_running "sanlock"
 +              return
 +      fi
-+ 
        # start wdmd and sanlock daemons if they aren't running
 +      /etc/rc.d/init.d/wdmd status >/dev/null 2>&1 || /etc/rc.d/init.d/wdmd start
 +      /etc/rc.d/init.d/sanlock status >/dev/null 2>&1 || /etc/rc.d/init.d/sanlock start
 -
 -      service sanlock status > /dev/null 2>&1 || service sanlock start
 -
--      [ ! -d /var/run/$prog ] && install -d -m 775 /var/run/$prog
+-      [ ! -d /run/$prog ] && install -d -m 775 /run/$prog
 -
--      [ ! -d /var/run/$agent ] && install -d -m 775 /var/run/$agent
+-      [ ! -d /run/$agent ] && install -d -m 775 /run/$agent
 -
 -      [ -n "$(which restorecon)" ] && \
 -              [ -x "$(which restorecon)" ] && \
--              restorecon /var/run/$prog
+-              restorecon /run/$prog
 -
 -      [ -n "$(which restorecon)" ] && \
 -              [ -x "$(which restorecon)" ] && \
--              restorecon /var/run/$agent
+-              restorecon /run/$agent
 -
 -      echo -n $"Starting $prog: "
 +      msg_starting "$prog"
diff --git a/sanlock-link.patch b/sanlock-link.patch
deleted file mode 100644 (file)
index 3d657a8..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- sanlock-2.0/src/Makefile.orig      2012-03-02 22:13:24.000000000 +0100
-+++ sanlock-2.0/src/Makefile   2012-03-06 20:11:32.466180099 +0100
-@@ -84,7 +84,7 @@
- all: $(LIBSO_ENTIRE_TARGET) $(LIBSO_CLIENT_TARGET) $(CMD_TARGET)
- $(LIBSO_ENTIRE_TARGET): $(LIB_ENTIRE_SOURCE)
--      $(CC) $(CFLAGS) $(LIB_ENTIRE_LDFLAGS) -shared -fPIC -o $@ -Wl,-soname=$(LIB_ENTIRE_TARGET).so.$(SOMAJOR) $^
-+      $(CC) $(CFLAGS) $(LIB_ENTIRE_LDFLAGS) -shared -fPIC -o $@ -Wl,-soname=$(LIB_ENTIRE_TARGET).so.$(SOMAJOR) $^ -lblkid -laio -lrt
-       ln -sf $(LIBSO_ENTIRE_TARGET) $(LIB_ENTIRE_TARGET).so
-       ln -sf $(LIBSO_ENTIRE_TARGET) $(LIB_ENTIRE_TARGET).so.$(SOMAJOR)
index 5c8825842b404fd3d9baf43119a415cca2a20aaa..cfc1b2a97352ab19357afcf1d8bb2af8de470315 100644 (file)
@@ -1,14 +1,13 @@
 Summary:       Shared storage lock manager
 Summary(pl.UTF-8):     Zarządca blokad dla współdzielonego składowania danych
 Name:          sanlock
-Version:       3.6.0
+Version:       3.8.0
 Release:       1
 License:       LGPL v2+ (libsanlock_client, libwdmd), GPL v2 (libsanlock, utilities)
 Group:         Networking
-Source0:       http://releases.pagure.org/sanlock/%{name}-%{version}.tar.gz
-# Source0-md5: 6544fb7b180f4340c568ca6bd40c97c6
-Patch0:                %{name}-link.patch
-Patch1:                %{name}-init-pld.patch
+Source0:       https://releases.pagure.org/sanlock/%{name}-%{version}.tar.gz
+# Source0-md5: 37975c995300f740fa9d42bc9ae94c75
+Patch0:                %{name}-init-pld.patch
 URL:           https://pagure.io/sanlock
 BuildRequires: gcc >= 5:3.4
 BuildRequires: libaio-devel
@@ -111,7 +110,6 @@ Wiązanie Pythona do biblioteki sanlock.
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
 
 %build
 export CFLAGS="%{rpmcflags}"
This page took 0.03364 seconds and 4 git commands to generate.