]> git.pld-linux.org Git - packages/samba.git/commitdiff
- reverting last change: removing new macros from %p{re,ost}{,un}
authorsaq <saq@pld-linux.org>
Thu, 26 Jul 2001 05:42:23 +0000 (05:42 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    samba.spec -> 1.66

samba.spec

index 4890611b5c26c86be2f14913847b445c820debe6..88989e32d3a715f7986fe574907fb119b7a8b34c 100644 (file)
@@ -242,16 +242,32 @@ rm -f docs/faq/*.{sgml,txt}
 rm -f docs/htmldocs/*.[0-9].html
 
 %post
-NAME=smb; DESC="Samba daemons"; %chkconfig_add
+/sbin/chkconfig --add smb
+if [ -r /var/lock/subsys/smb ]; then
+       /etc/rc.d/init.d/smb restart >&2
+else
+       echo "Run \"/etc/rc.d/init.d/smb start\" to start Samba daemons."
+fi
 
 %preun
-NAME=smb; %chkconfig_del
+if [ "$1" = "0" ]; then
+       if [ -r /var/lock/subsys/smb ]; then
+               /etc/rc.d/init.d/smb stop >&2
+       fi
+       /sbin/chkconfig --del smb
+fi
 
 %post -n swat
-%rc_inetd_post
+if [ -f /var/lock/subsys/rc-inetd ]; then
+       /etc/rc.d/init.d/rc-inetd reload 1>&2
+else
+       echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start inet sever" 1>&2
+fi
 
 %postun -n swat
-%rc_inetd_postun
+if [ -f /var/lock/subsys/rc-inetd ]; then
+       /etc/rc.d/init.d/rc-inetd reload
+fi
 
 %triggerpostun -- samba < 1.9.18p7
 if [ "$1" != "0" ]; then
This page took 0.029789 seconds and 4 git commands to generate.