]> git.pld-linux.org Git - packages/samba.git/blob - samba.spec
drobne poprawki
[packages/samba.git] / samba.spec
1 Summary:        SMB client and server
2 Summary(pl):    Klient i serwer SMB
3 Name:           samba
4 Version:        2.0.4b
5 Release:        1
6 Copyright:      GPL
7 Group:          Networking/Daemons
8 Group(pl):      Sieciowe/Serwery
9 Source0:        ftp://samba.anu.edu.au/pub/samba/%{name}-%{version}.tar.gz
10 Source1:        samba.PLD.tar.bz2
11 Patch0:         samba-glibc2.1.patch
12 Patch1:         samba-config.patch
13 Patch2:         samba-cap.patch
14 Prereq:         /sbin/chkconfig 
15 Requires:       pam >= 0.66 
16 BuildPrereq:    ncurses-devel
17 BuildPrereq:    readline-devel
18 BuildPrereq:    pam-devel
19 BuildRoot:      /tmp/%{name}-%{version}-root
20
21 %description
22 Samba provides an SMB server which can be used to provide
23 network services to SMB (sometimes called "Lan Manager")
24 clients, including various versions of MS Windows, OS/2,
25 and other Linux machines. Samba also provides some SMB
26 clients, which complement the built-in SMB filesystem
27 in Linux. Samba uses NetBIOS over TCP/IP (NetBT) protocols
28 and does NOT need NetBEUI (Microsoft Raw NetBIOS frame)
29 protocol.
30
31 This release is known as the "Locking Update" and has full
32 support for Opportunistic File Locking. In addition this update
33 includes native support for Microsoft encrypted passwords,
34 improved browse list and WINS database management.
35
36 Please refer to the WHATSNEW.txt document for fixup information.
37 This binary release includes encrypted password support.
38 Please read the smb.conf file and ENCRYPTION.txt in the
39 docs directory for implementation details.
40
41 %description -l pl
42 Samba udostêpnia serwer SMB, który mo¿e byæ u¿yty w celu dostarczenia
43 us³ug sieciowych (potocznie zwanych "Lan Manager"), dla klientów takich
44 jak MS Windows, OS/2 a tak¿e maszyn linuxowych.  W pakiecie znajduje siê
45 równie¿ oprogramowanie klienckie. Samba u¿ywa protoko³u NetBIOS po TCP/IP
46 (NetBT) i nie wymaga protoko³u NetBEUI. Ta wersja ma pe³ne wsparcie dla
47 blokowania plików, a tak¿e wsparcie dla kodowania hase³ w standardzie
48 MS i zarzadzania baz± WINS.
49
50 UWAGA: w przeciwieñstwie do wersji 2.0.2 aktualnie samba pozbawiona jest
51 mozliwo¶ci kontrolowania domeny NT.
52
53 %package -n swat
54 Summary:        Samba Web Administration Tool
55 Summary(pl):    Narzêdzie administracyjne serwisu Samba
56 Group:          Networking/Admin
57 Group(pl):      Sieciowe/Administracyjne
58 Requires:       %{name}
59
60 %description -n swat
61 swat allows a Samba administrator to configure the complex smb.conf
62 file via a Web browser. In addition, a swat configuration page has
63 help links to all the configurable options in the smb.conf file
64 allowing an administrator to easily look up the effects of any change.
65
66 swat is run from inetd
67
68 %description -n swat -l pl
69 swat pozwala na kompleksow± konfiguracjê smb.conf przy pomocy przegl±darki
70 internetowej.
71
72 %prep
73 %setup -q -a1
74 %patch0 -p1
75 %patch1 -p1
76 %patch2 -p1
77
78 %build
79 cd source
80 autoconf
81 LDFLAGS="-s" export LDFLAGS \
82 %configure \
83         --prefix=/usr \
84         --sysconfdir=/etc/samba \
85         --sbindir=%{_sbindir} \
86         --bindir=%{_bindir} \
87         --with-privatedir=/etc/samba \
88         --libdir=/etc/samba \
89         --localstatedir=/var \
90         --with-swatdir=%{_datadir}/swat \
91         --with-smbmount \
92         --with-smbwrapper \
93         --with-quotas \
94         --with-syslog \
95         --with-automount
96         
97 make all smbwrapper bin/smbrun bin/debug2html
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101
102 install -d $RPM_BUILD_ROOT/etc/samba/codepages/src \
103         $RPM_BUILD_ROOT/etc/{logrotate.d,pam.d,sysconfig} \
104         $RPM_BUILD_ROOT/etc/rc.d/init.d \
105         $RPM_BUILD_ROOT/home/samba \
106         $RPM_BUILD_ROOT/lib/security \
107         $RPM_BUILD_ROOT/usr/{bin,man/man{1,5,7,8},sbin} \
108         $RPM_BUILD_ROOT/var/{lock,log,spool}/samba \
109         $RPM_BUILD_ROOT%{_datadir}/swat/{include,images,help}
110
111 ( cd source;
112 make install \
113         prefix=$RPM_BUILD_ROOT/usr \
114         BASEDIR=$RPM_BUILD_ROOT/usr \
115         BINDIR=$RPM_BUILD_ROOT%{_bindir} \
116         SBINDIR=$RPM_BUILD_ROOT%{_sbindir} \
117         LIBDIR=$RPM_BUILD_ROOT/etc/samba \
118         PRIVATEDIR=$RPM_BUILD_ROOT/etc/samba \
119         SWATDIR=$RPM_BUILD_ROOT%{_datadir}/swat \
120         VARDIR=$RPM_BUILD_ROOT/var
121 )
122
123 install  source/codepages/codepage_def.* \
124         $RPM_BUILD_ROOT/etc/samba/codepages/src
125
126 install  packaging/PLD/smb.conf         $RPM_BUILD_ROOT/etc/samba
127 install  packaging/PLD/smbusers         $RPM_BUILD_ROOT/etc/samba
128 install  packaging/PLD/smbprint         $RPM_BUILD_ROOT%{_bindir}
129 install  packaging/PLD/smbadduser       $RPM_BUILD_ROOT%{_bindir}
130 install  packaging/PLD/findsmb          $RPM_BUILD_ROOT%{_bindir}
131 install  packaging/PLD/smb.init         $RPM_BUILD_ROOT/etc/rc.d/init.d/smb
132 install  packaging/PLD/samba.pam        $RPM_BUILD_ROOT/etc/pam.d/samba
133 install  packaging/PLD/samba.log        $RPM_BUILD_ROOT/etc/logrotate.d/samba
134
135 install -s source/bin/*.so      $RPM_BUILD_ROOT/lib/security
136 install -s source/bin/{smbsh,smbrun,debug2html} $RPM_BUILD_ROOT%{_bindir}
137
138 touch $RPM_BUILD_ROOT/var/lock/samba/{STATUS..LCK,wins.dat,browse.dat}
139
140 echo 127.0.0.1 localhost > $RPM_BUILD_ROOT/etc/samba/lmhosts
141
142 echo "NICELEVEL=+5" > $RPM_BUILD_ROOT/etc/sysconfig/samba
143
144 for i in 437 737 850 852 861 866 932 949 950 936; do
145 $RPM_BUILD_ROOT%{_bindir}/make_smbcodepage c $i \
146 $RPM_BUILD_ROOT/etc/samba/codepages/src/codepage_def.$i \
147 $RPM_BUILD_ROOT/etc/samba/codepages/codepage.$i; done
148
149 gzip -9fn $RPM_BUILD_ROOT%{_mandir}/man[1578]/* \
150         README Manifest WHATSNEW.txt Roadmap docs/*.reg swat/README
151
152 %post
153 /sbin/chkconfig --add smb
154 if test -r /var/run/smb.pid; then
155         /etc/rc.d/init.d/smb stop >&2
156         /etc/rc.d/init.d/smb start >&2
157 else
158         echo "Run \"/etc/rc.d/init.d/smb start\" to start samba daemons."
159 fi
160
161 %preun
162 if [ "$1" = "0" ]; then
163         /etc/rc.d/init.d/smb stop >&2
164         /sbin/chkconfig --del smb
165 fi
166
167 %clean
168 rm -rf $RPM_BUILD_ROOT
169
170 %files
171 %defattr(644,root,root,755)
172 %doc README.gz Manifest.gz WHATSNEW.txt.gz
173 %doc Roadmap.gz docs/faq/*.html docs/*.reg.gz 
174
175 %attr(755,root,root) %{_bindir}/*
176 %attr(755,root,root) %{_sbindir}/nmbd
177 %attr(755,root,root) %{_sbindir}/smbd
178
179 %dir /etc/samba
180 %config(noreplace) %verify(not size mtime md5) /etc/samba/smb.conf
181 %attr(600,root,root) %config(noreplace) %verify(not size mtime md5) /etc/samba/smbusers
182 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/samba/lmhosts
183
184 %attr(750,root,root) /etc/rc.d/init.d/smb
185 %attr(640,root,root) %config %verify(not size mtime md5) /etc/sysconfig/samba
186 %attr(640,root,root) /etc/logrotate.d/samba
187 %attr(640,root,root) /etc/pam.d/samba
188
189 %attr(755,root,root) /lib/security/*.so
190
191 %{_mandir}/man[157]/*
192 %{_mandir}/man8/nmbd.8.gz
193 %{_mandir}/man8/smbd.8.gz
194 %{_mandir}/man8/smbmnt.8.gz
195 %{_mandir}/man8/smbmount.8.gz
196 %{_mandir}/man8/smbpasswd.8.gz
197 %{_mandir}/man8/smbumount.8.gz
198
199 %dir /home/samba
200 /etc/samba/codepages
201
202 %dir /var/lock/samba
203 %ghost /var/lock/samba/*
204
205 %attr(0750,root,root) %dir /var/log/samba
206 %attr(1777,root,root) %dir /var/spool/samba
207
208 %files -n swat
209 %defattr(644,root,root,755)
210 %doc swat/README.gz
211 %attr(755,root,root) %{_sbindir}/swat
212 %{_datadir}/swat
213 %{_mandir}/man8/swat.8.gz
214
215 %changelog
216 * Wed Apr 28 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
217   [2.0.3-2]
218 - added BuildPrereq rules,
219 - standarized %post{un} - now samba service is restarted automatically on   
220   upgrade and downed on uninstall).
221
222 * Wed Apr 14 1999 Artur Frysiak <wiget@pld.org.pl>
223 - Changed group to Networking/Daemons
224 - Changed name of source1
225 - Added swat subpackage
226 - Used %configure macro
227 - Correct one typo in configure args
228 - Added --with-syslog and --with-automount to configure
229 - Added /etc/sysconfig/samba (allow set nice level of [sn]mbd )
230 - Removed %config from /etc/rc.d/init.d/smb
231 - Removed manuly install man and swat ( make install do it)
232 - Install smbrun and debug2html
233 - Fixed lmhosts files
234 - Added noreplace to config files
235 - Added %ghost macro to state files 
236
237 * Sun Mar 28 1999 Ziemek Borowski <zmb@ziembor.waw.pl>
238   [2.0.3] 
239 - updated to 2.0.3 (change in samba.2.0.3.patch file)
240 - removed kerberos support
241
242 * Tue Jan 26 1999 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
243   [2.2.0-1d]
244 - updated to new version,
245 - added Group(pl),
246 - added patch against GNU libc-2.1 -- prepared by Paul Laufer
247   http://www.cspupomona.edu/~pelaufer/samba,
248 - some other changes ...
249
250 * Wed Aug 05 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
251   [1.9.18p8-1d]
252 - build against glibc-2.1,
253   patch prepared by Paul Laufer <PELaufer@csupomona.edu>
254   http://www.netcom.com/~mlaufer/samba,
255 - translation modified for pl,
256 - build with Kerberos V support,
257 - moved %changelog at the end of spec,
258 - build from non root's acccount,
259 - changed permisions of binaries to 755,
260 - moved config files to /etc/samba instead /etc,
261 - added a sticky bit on /var/spool/samba,
262 - minor modifications of spec.
263
264 * Sat Jul 4 1998 John H Terpstra <jht@samba.anu.edu.au>
265   - changed classification of codepage source files
266   - altered installation of samba system files
267   - modified doc handling (removed attribute setting parameters)
268
269 * Sat Jun 13 1998 John H Terpstra <jht@samba.anu.edu.au>
270   - Added code pages 737 and 861 to files section
271   - Added auto-generation of empty /etc/lmhosts file if not exist
272   - Always zap and create empty /var/lock/samba/STATUS..LCK file
273
274 * Wed Jun 10 1998 John H Terpstra <jht@samba.anu.edu.au>
275   - Updated version info for 1.9.18p8 release
276   - updated codepage support for pages 737 861
277
278 * Sun Apr 26 1998 John H Terpstra <jht@samba.anu.edu.au>
279   - minor tidy up in preparation for release of 1.9.18p5
280   - added findsmb utility from SGI package
281
282 * Wed Mar 18 1998 John H Terpstra <jht@samba.anu.edu.au>
283   - Updated version and codepage info.
284   - Release to test name resolve order
285
286 * Sat Jan 24 1998 John H Terpstra <jht@samba.anu.edu.au>
287  - Many optimisations (some suggested by Manoj Kasichainula <manojk@io.com>
288   - Use of chkconfig in place of individual symlinks to /etc/rc.d/init/smb
289   - Compounded make line
290   - Updated smb.init restart mechanism
291   - Use compound mkdir -p line instead of individual calls to mkdir
292   - Fixed smb.conf file path for log files
293   - Fixed smb.conf file path for incoming smb print spool directory
294   - Added a number of options to smb.conf file
295   - Added smbadduser command (missed from all previous RPMs) - Doooh!
296   - Added smbuser file and smb.conf file updates for username map
This page took 0.053486 seconds and 4 git commands to generate.