]> git.pld-linux.org Git - packages/rygel.git/commitdiff
- updated to 0.38.2 auto/th/rygel-0.38.2-1
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 30 Oct 2019 17:13:41 +0000 (18:13 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Wed, 30 Oct 2019 17:13:41 +0000 (18:13 +0100)
- drop xmls-ns patch, gtk-doc uses non-namespaced stylesheets

git-version-gen [deleted file]
rygel.spec
xmls-ns.patch [deleted file]

diff --git a/git-version-gen b/git-version-gen
deleted file mode 100644 (file)
index 463ad73..0000000
+++ /dev/null
@@ -1,154 +0,0 @@
-#!/bin/sh
-# Print a version string.
-scriptversion=2009-05-11.16
-
-# Copyright (C) 2007-2008 Free Software Foundation
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 3, or (at your option)
-# any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
-# 02110-1301, USA.
-
-# This script is derived from GIT-VERSION-GEN from GIT: http://git.or.cz/.
-# It may be run two ways:
-# - from a git repository in which the "git describe" command below
-#   produces useful output (thus requiring at least one signed tag)
-# - from a non-git-repo directory containing a .tarball-version file, which
-#   presumes this script is invoked like "./git-version-gen .tarball-version".
-
-# In order to use intra-version strings in your project, you will need two
-# separate generated version string files:
-#
-# .tarball-version - present only in a distribution tarball, and not in
-#   a checked-out repository.  Created with contents that were learned at
-#   the last time autoconf was run, and used by git-version-gen.  Must not
-#   be present in either $(srcdir) or $(builddir) for git-version-gen to
-#   give accurate answers during normal development with a checked out tree,
-#   but must be present in a tarball when there is no version control system.
-#   Therefore, it cannot be used in any dependencies.  GNUmakefile has
-#   hooks to force a reconfigure at distribution time to get the value
-#   correct, without penalizing normal development with extra reconfigures.
-#
-# .version - present in a checked-out repository and in a distribution
-#   tarball.  Usable in dependencies, particularly for files that don't
-#   want to depend on config.h but do want to track version changes.
-#   Delete this file prior to any autoconf run where you want to rebuild
-#   files to pick up a version string change; and leave it stale to
-#   minimize rebuild time after unrelated changes to configure sources.
-#
-# It is probably wise to add these two files to .gitignore, so that you
-# don't accidentally commit either generated file.
-#
-# Use the following line in your configure.ac, so that $(VERSION) will
-# automatically be up-to-date each time configure is run (and note that
-# since configure.ac no longer includes a version string, Makefile rules
-# should not depend on configure.ac for version updates).
-#
-# AC_INIT([GNU project],
-#         m4_esyscmd([build-aux/git-version-gen .tarball-version]),
-#         [bug-project@example])
-#
-# Then use the following lines in your Makefile.am, so that .version
-# will be present for dependencies, and so that .tarball-version will
-# exist in distribution tarballs.
-#
-# BUILT_SOURCES = $(top_srcdir)/.version
-# $(top_srcdir)/.version:
-#      echo $(VERSION) > $@-t && mv $@-t $@
-# dist-hook:
-#      echo $(VERSION) > $(distdir)/.tarball-version
-
-case $# in
-    1) ;;
-    *) echo 1>&2 "Usage: $0 \$srcdir/.tarball-version"; exit 1;;
-esac
-
-tarball_version_file=$1
-nl='
-'
-
-# First see if there is a tarball-only version file.
-# then try "git describe", then default.
-if test -f $tarball_version_file
-then
-    v=`cat $tarball_version_file` || exit 1
-    case $v in
-       *$nl*) v= ;; # reject multi-line output
-       [0-9]*) ;;
-       *) v= ;;
-    esac
-    test -z "$v" \
-       && echo "$0: WARNING: $tarball_version_file seems to be damaged" 1>&2
-fi
-
-if test -n "$v"
-then
-    : # use $v
-elif test -d .git \
-    && v=`git describe --abbrev=4 --match='${GNOME_TAG_PATTERN}_*' HEAD 2>/dev/null \
-         || git describe --abbrev=4 HEAD 2>/dev/null` \
-    && case $v in
-        ${GNOME_TAG_PATTERN}_[0-9]*) ;;
-        *) (exit 1) ;;
-       esac
-then
-    # Is this a new git that lists number of commits since the last
-    # tag or the previous older version that did not?
-    #   Newer: v6.10-77-g0f8faeb
-    #   Older: v6.10-g0f8faeb
-    case $v in
-       *-*-*) : git describe is okay three part flavor ;;
-       *-*)
-           : git describe is older two part flavor
-           # Recreate the number of commits and rewrite such that the
-           # result is the same as if we were using the newer version
-           # of git describe.
-           vtag=`echo "$v" | sed 's/-.*//'`
-           numcommits=`git rev-list "$vtag"..HEAD | wc -l`
-           v=`echo "$v" | sed "s/\(.*\)-\(.*\)/\1-$numcommits-\2/"`;
-           ;;
-    esac
-
-    # Change the first '-' to a '.', so version-comparing tools work properly.
-    # Remove the "g" in git describe's output string, to save a byte.
-    v=`echo "$v" | sed 's/-/./;s/\(.*\)-g/\1-/'`;
-else
-    v=UNKNOWN
-fi
-
-#v=`echo "$v" |sed 's/^v//'`
-
-v=`echo "$v" | sed "s/${GNOME_TAG_PATTERN}_//" | tr _ .`
-
-# Don't declare a version "dirty" merely because a time stamp has changed.
-git status > /dev/null 2>&1
-
-dirty=`sh -c 'git diff-index --name-only HEAD' 2>/dev/null` || dirty=
-case "$dirty" in
-    '') ;;
-    *) # Append the suffix only if there isn't one already.
-       case $v in
-         *-dirty) ;;
-         *) v="$v-dirty" ;;
-       esac ;;
-esac
-
-# Omit the trailing newline, so that m4_esyscmd can use the result directly.
-echo "$v" | tr -d '\012'
-
-# Local variables:
-# eval: (add-hook 'write-file-hooks 'time-stamp)
-# time-stamp-start: "scriptversion="
-# time-stamp-format: "%:y-%02m-%02d.%02H"
-# time-stamp-end: "$"
-# End:
index 6cf2135f3b66504247abca916ed1e75fa528cfe4..c31b6330e7941a5208dc6257a0fafa51c8d9f2a9 100644 (file)
@@ -1,30 +1,28 @@
 Summary:       Rygel - collection of DLNA (UPnP AV) services
 Summary(pl.UTF-8):     Rygel - zbiór usług DLNA (UPnP AV)
 Name:          rygel
-Version:       0.36.0
+Version:       0.38.2
 Release:       1
 License:       LGPL v2+
 Group:         X11/Applications
-Source0:       http://ftp.gnome.org/pub/GNOME/sources/rygel/0.36/%{name}-%{version}.tar.xz
-# Source0-md5: 5fb557fcd6635ecb065e3977b99aff89
-Source1:       git-version-gen
+Source0:       http://ftp.gnome.org/pub/GNOME/sources/rygel/0.38/%{name}-%{version}.tar.xz
+# Source0-md5: 1cd6c49da750bd7c28258665ab33084c
 Patch0:                gtk-doc.patch
-Patch1:                xmls-ns.patch
 URL:           https://wiki.gnome.org/Projects/Rygel
 BuildRequires: autoconf >= 2.64
 BuildRequires: automake >= 1:1.11.1
-BuildRequires: docbook-style-xsl
+BuildRequires: docbook-style-xsl-nons
 BuildRequires: gdk-pixbuf2-devel >= 2.0
 BuildRequires: gettext-tools >= 0.19.7
-BuildRequires: glib2-devel >= 1:2.40.0
+BuildRequires: glib2-devel >= 1:2.44.0
 BuildRequires: gobject-introspection-devel >= 1.33.4
-BuildRequires: gssdp-devel >= 0.13.0
-BuildRequires: gstreamer-devel >= 1.0.0
-BuildRequires: gstreamer-plugins-base-devel >= 1.0.0
-BuildRequires: gtk+3-devel >= 3.0.0
+BuildRequires: gssdp-devel >= 1.2.0
+BuildRequires: gstreamer-devel >= 1.12
+BuildRequires: gstreamer-plugins-base-devel >= 1.12
+BuildRequires: gtk+3-devel >= 3.22
 BuildRequires: gtk-doc >= 1.0
 BuildRequires: gupnp-av-devel >= 0.12.8
-BuildRequires: gupnp-devel >= 0.20.14
+BuildRequires: gupnp-devel >= 1.2.0
 BuildRequires: gupnp-dlna-devel >= 0.9.4
 BuildRequires: gupnp-dlna-gst-devel >= 0.9.4
 BuildRequires: libgee-devel >= 0.8.0
@@ -38,9 +36,9 @@ BuildRequires:        libxslt-progs
 BuildRequires: pkgconfig
 BuildRequires: rpmbuild(macros) >= 1.682
 BuildRequires: sqlite3-devel >= 3.5
-BuildRequires: tracker-devel >= 1.0
-BuildRequires: vala >= 2:0.24.0
-BuildRequires: vala-gupnp >= 0.20.14
+BuildRequires: tracker-devel >= 2.0
+BuildRequires: vala >= 2:0.36.0
+BuildRequires: vala-gupnp >= 1.2.0
 BuildRequires: vala-gupnp-av >= 0.12.8
 BuildRequires: vala-libgee >= 0.8.0
 BuildRequires: vala-libmediaart2 >= 0.7.0
@@ -49,13 +47,13 @@ Requires(post,postun):      /sbin/ldconfig
 Requires(post,postun): gtk-update-icon-cache
 Requires(post,postun): hicolor-icon-theme
 Requires:      %{name}-libs = %{version}-%{release}
-Requires:      gstreamer >= 1.0.0
-Requires:      gtk+3 >= 3.0.0
+Requires:      gstreamer >= 1.12
+Requires:      gtk+3 >= 3.22
 Requires:      gupnp-dlna >= 0.9.4
 Requires:      gupnp-dlna-gst >= 0.9.4
 Requires:      libuuid >= 1.41.3
 Requires:      systemd-units >= 38
-Requires:      tracker-libs >= 1.0
+Requires:      tracker-libs >= 2.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -70,9 +68,9 @@ zaimplementowany poprzez mechanizm wtyczek.
 Summary:       Rygel shared libraries
 Summary(pl.UTF-8):     Biblioteki współdzielone Rygela
 Group:         Libraries
-Requires:      glib2 >= 1:2.40.0
-Requires:      gssdp >= 0.13.0
-Requires:      gupnp >= 0.20.14
+Requires:      glib2 >= 1:2.44.0
+Requires:      gssdp >= 1.2.0
+Requires:      gupnp >= 1.2.0
 Requires:      gupnp-av >= 0.12.8
 Requires:      libgee >= 0.8.0
 Requires:      libmediaart2 >= 0.7.0
@@ -92,8 +90,8 @@ Summary:      Rygel header files
 Summary(pl.UTF-8):     Pliki nagłówkowe bibliotek Rygel
 Group:         Development/Libraries
 Requires:      %{name}-libs = %{version}-%{release}
-Requires:      glib2-devel >= 1:2.40.0
-Requires:      gstreamer-devel >= 1.0.0
+Requires:      glib2-devel >= 1:2.44.0
+Requires:      gstreamer-devel >= 1.12
 Requires:      gupnp-av-devel >= 0.12.8
 Requires:      libgee-devel >= 0.8.0
 Requires:      libuuid-devel >= 1.41.3
@@ -123,8 +121,8 @@ Summary:    Vala API for Rygel libraries
 Summary(pl.UTF-8):     API języka Vala do bibliotek Rygel
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}-%{release}
-Requires:      vala >= 2:0.24.0
-Requires:      vala-gupnp >= 0.20.14
+Requires:      vala >= 2:0.36.0
+Requires:      vala-gupnp >= 1.2.0
 Requires:      vala-gupnp-av >= 0.12.8
 Requires:      vala-libgee >= 0.8.0
 %if "%{_rpmversion}" >= "5"
@@ -140,8 +138,6 @@ API języka Vala do bibliotek Rygel.
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
-#install -m755 %{SOURCE1} build-aux/git-version-gen
 
 %build
 %{__gettextize}
@@ -182,7 +178,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog NEWS README TODO
+%doc AUTHORS ChangeLog NEWS README.md TODO
 %attr(755,root,root) %{_bindir}/rygel
 %attr(755,root,root) %{_bindir}/rygel-preferences
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rygel.conf
@@ -261,6 +257,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_pkgconfigdir}/rygel-core-2.6.pc
 %{_pkgconfigdir}/rygel-renderer-2.6.pc
 %{_pkgconfigdir}/rygel-renderer-gst-2.6.pc
+%{_pkgconfigdir}/rygel-ruih-2.0.pc
 %{_pkgconfigdir}/rygel-server-2.6.pc
 
 %files -n vala-rygel
diff --git a/xmls-ns.patch b/xmls-ns.patch
deleted file mode 100644 (file)
index b064c65..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- rygel-0.36.0/configure.ac~ 2017-11-26 12:15:29.000000000 +0100
-+++ rygel-0.36.0/configure.ac  2017-11-26 13:14:02.666952537 +0100
-@@ -464,7 +464,7 @@
- AS_IF([test "x$XSLTPROC" != "x"],
-       [
-        AC_MSG_CHECKING([whether $XSLTPROC can create manpages])
--       $XSLTPROC -nonet http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl >/dev/null 2>&1
-+       $XSLTPROC -nonet http://docbook.sourceforge.net/release/xsl-ns/current/manpages/docbook.xsl >/dev/null 2>&1
-        AS_IF([test "$?" = 0], [AC_MSG_RESULT([yes])], [XSLTPROC=""; AC_MSG_RESULT([no])])
-       ])
- AM_CONDITIONAL([HAVE_XSLTPROC], [test x"$XSLTPROC" != x])
This page took 1.828341 seconds and 4 git commands to generate.