]> git.pld-linux.org Git - packages/rust.git/blob - rust.spec
up to 1.68.0
[packages/rust.git] / rust.spec
1 # TODO
2 # - consider a rust-std package containing .../rustlib/$target
3 #   This might allow multilib cross-compilation to work naturally.
4 # - package additional tools
5 #
6 # Conditional build:
7 %bcond_with     bootstrap       # bootstrap using precompiled binaries
8 %bcond_with     full_debuginfo  # full debuginfo vs only std debuginfo (full takes gigabytes of memory to build)
9 %bcond_without  system_llvm     # system LLVM
10 %bcond_with     tests           # build without tests
11
12 # The channel can be stable, beta, or nightly
13 %define         channel         stable
14
15 %if "%{channel}" == "stable"
16 %define         rustc_package   rustc-%{version}-src
17 %else
18 %define         rustc_package   rustc-%{channel}-src
19 %endif
20
21 # To bootstrap from scratch, set the channel and date from src/stage0.json
22 # e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
23 # or nightly wants some beta-YYYY-MM-DD
24 %define         bootstrap_rust  1.67.1
25 %define         bootstrap_cargo %{bootstrap_rust}
26 %define         bootstrap_date  2023-02-09
27
28 %ifarch x32
29 %define         with_cross      1
30 %endif
31
32 %if %{without full_debuginfo}
33 %define         _enable_debug_packages  0
34 %endif
35
36 Summary:        The Rust Programming Language
37 Summary(pl.UTF-8):      Język programowania Rust
38 Name:           rust
39 Version:        1.68.0
40 Release:        1
41 # Licenses: (rust itself) and (bundled libraries)
42 License:        (Apache v2.0 or MIT) and (BSD and ISC and MIT)
43 Group:          Development/Languages
44 Source0:        https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
45 # Source0-md5:  e0c4908ceb01945930da218d172a21ba
46 Source1:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.xz
47 # Source1-md5:  800e693e0ac317755f8f0e19269540db
48 Source2:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.xz
49 # Source2-md5:  65d86e2c17b1a09df55860a1d8dec9d4
50 Source3:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-aarch64-unknown-linux-gnu.tar.xz
51 # Source3-md5:  127fdf3e824e23808a1fa6a8e92bcf56
52 Source4:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-arm-unknown-linux-gnueabihf.tar.xz
53 # Source4-md5:  70acb1412ca21e288105d86a7d5b975b
54 Source5:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-armv7-unknown-linux-gnueabihf.tar.xz
55 # Source5-md5:  1d917abdc484fd34c1471a931349a2c5
56 Patch0:         llvm-tools-install.patch
57 URL:            https://www.rust-lang.org/
58 # for src/compiler-rt
59 BuildRequires:  cmake >= 3.4.3
60 BuildRequires:  curl
61 %ifarch %{arm} %{mips32} %{ppc}
62 BuildRequires:  libatomic-devel
63 %endif
64 # make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
65 BuildRequires:  procps
66 BuildRequires:  python3
67 BuildRequires:  python3-modules
68 BuildRequires:  rpm-build >= 4.6
69 BuildRequires:  rpmbuild(macros) >= 1.752
70 %if %{without cross}
71 BuildRequires:  curl-devel
72 BuildRequires:  libgit2-devel >= 1.4.0
73 BuildRequires:  libstdc++-devel
74 %if %{with system_llvm}
75 BuildRequires:  llvm >= 13.0
76 BuildRequires:  llvm-devel >= 13.0
77 %endif
78 BuildRequires:  openssl-devel >= 1.0.1
79 BuildRequires:  tar >= 1:1.22
80 BuildRequires:  xz
81 BuildRequires:  xz-devel
82 BuildRequires:  zlib-devel
83 %endif
84 %if %{without bootstrap}
85 BuildRequires:  %{name} >= %{bootstrap_rust}
86 BuildRequires:  cargo >= %{bootstrap_cargo}
87 BuildConflicts: %{name} > %{version}
88 %endif
89 %ifarch x32
90 BuildRequires:  glibc-devel(x86-64)
91 BuildRequires:  glibc-devel(x86-x32)
92 %if "%{_host_cpu}" == "x86_64"
93 # building on x86_64 host with --target x32-pld-linux
94 BuildRequires:  curl-devel
95 BuildRequires:  gcc-multilib-x32
96 BuildRequires:  libgit2-devel >= 1.4.0
97 BuildRequires:  libstdc++-devel
98 %{?with_system_llvm:BuildRequires:      llvm-devel >= 13.0}
99 BuildRequires:  openssl-devel >= 1.0.1
100 BuildRequires:  xz-devel
101 BuildRequires:  zlib-devel
102 %else
103 # building x86_64-hosted crosscompiler on x32 host
104 BuildRequires:  curl-devel(x86-64)
105 BuildRequires:  curl-devel(x86-x32)
106 BuildRequires:  gcc-multilib-64
107 BuildRequires:  libgit2-devel(x86-64) >= 1.4.0
108 BuildRequires:  libgit2-devel(x86-x32) >= 1.4.0
109 BuildRequires:  libstdc++-multilib-64-devel
110 %if %{with system_llvm}
111 BuildRequires:  llvm-devel(x86-64) >= 13.0
112 BuildRequires:  llvm-devel(x86-x32) >= 13.0
113 %endif
114 BuildRequires:  openssl-devel(x86-64)
115 BuildRequires:  openssl-devel(x86-x32)
116 BuildRequires:  xz-devel(x86-64)
117 BuildRequires:  xz-devel(x86-x32)
118 BuildRequires:  zlib-devel(x86-64)
119 BuildRequires:  zlib-devel(x86-x32)
120 %endif
121 %endif
122 # The C compiler is needed at runtime just for linking.  Someday rustc might
123 # invoke the linker directly, and then we'll only need binutils.
124 # https://github.com/rust-lang/rust/issues/11937
125 Requires:       gcc
126 Requires:       %{name}-std%{?_isa} = %{version}-%{release}
127 %ifarch x32
128 Requires:       %{name}-std(x86-64) = %{version}-%{release}
129 Requires:       gcc-multilib-64
130 %endif
131 # Only x86_64 and i686 are Tier 1 platforms at this time.
132 # x32 is Tier 2, only rust-std is available (no rustc or cargo).
133 # https://doc.rust-lang.org/nightly/rustc/platform-support.html
134 ExclusiveArch:  %{x8664} %{ix86} x32 aarch64 armv6hl armv7hl armv7hnl
135 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
136
137 %ifarch x32
138 %define         rust_triple             x86_64-unknown-linux-gnux32
139 %define         rust_host_triple        x86_64-unknown-linux-gnu
140 %define         rust_bootstrap_triple   x86_64-unknown-linux-gnu
141 # libs in _libdir are x86_64 64bit
142 %define         _lib                    lib64
143 %define         _libdir                 %{_prefix}/lib64
144 %else
145 %ifarch armv6hl
146 %define         rust_triple             arm-unknown-linux-gnueabihf
147 %define         rust_host_triple        %{rust_triple}
148 %define         rust_bootstrap_triple   %{rust_triple}
149 %else
150 %ifarch armv7hl armv7hnl
151 %define         rust_triple             armv7-unknown-linux-gnueabihf
152 %define         rust_host_triple        %{rust_triple}
153 %define         rust_bootstrap_triple   %{rust_triple}
154 %define         rust_suppl_targets      thumbv7neon-unknown-linux-gnueabihf
155 %else
156 %define         rust_triple             %{_target_cpu}-unknown-linux-gnu
157 %define         rust_host_triple        %{rust_triple}
158 %define         rust_bootstrap_triple   %{rust_triple}
159 %endif
160 %endif
161 %endif
162
163 %define         rust_targets            %rust_triple %{?rust_suppl_targets}
164
165 %if %{without bootstrap}
166 %define         local_rust_root %{_prefix}
167 %else
168 %define         bootstrap_root  rust-%{bootstrap_rust}-%{rust_bootstrap_triple}
169 %define         local_rust_root %{_builddir}/%{rustc_package}/%{bootstrap_root}
170 %endif
171
172 # We're going to override --libdir when configuring to get rustlib into a
173 # common path, but we'll fix the shared libraries during install.
174 # Without this ugly hack, rust would not be able to build itself
175 # for non-bootstrap build, lib64 is just too complicated for it.
176 %define         common_libdir   %{_prefix}/lib
177 %define         rustlibdir      %{common_libdir}/rustlib
178
179 # once_call/once_callable non-function libstdc++ symbols
180 %define         skip_post_check_so      'librustc.*llvm.*\.so.*'
181
182 # ALL Rust libraries are private, because they don't keep an ABI.
183 %define         _noautoreqfiles         lib.*-[[:xdigit:]]{8}[.]so.*
184 %define         _noautoprovfiles        lib.*-[[:xdigit:]]{8}[.]so.*
185
186 %define         x_py { \
187         x_py() { \
188                 local cmd="$1"; \
189                 shift; \
190                 %{?__jobs:CARGO_BUILD_JOBS=%__jobs }%{__python3} ./x.py "$cmd" %{?__jobs:-j %__jobs} "$@"; \
191         }; x_py }
192
193
194 %description
195 Rust is a systems programming language that runs blazingly fast,
196 prevents segfaults, and guarantees thread safety.
197
198 This package includes the Rust compiler, standard library, and
199 documentation generator.
200
201 %description -l pl.UTF-8
202 Rust to systemowy język programowania działający bardzo szybko,
203 zapobiegający naruszeniom ochrony pamięci i gwarantujący
204 bezpieczną wielowątkowość.
205
206 %package analysis
207 Summary:        Metadata about the standard library
208 Summary(pl.UTF-8):      Metadane o standardowej bibliotece
209 Group:          Development/Tools
210 Requires:       %{name} = %{version}-%{release}
211
212 %description analysis
213 Metadata about the standard library.
214
215 %description analysis -l pl.UTF-8
216 Metadane o standardowej bibliotece.
217
218 %package std
219 Summary:        Standard library for Rust
220 Summary(pl.UTF-8):      Standardowa biblioteka Rusta
221 Group:          Development/Tools
222 Requires:       %{name} = %{version}-%{release}
223
224 %description std
225 Standard library for Rust.
226
227 %description std -l pl.UTF-8
228 Standardowa biblioteka Rusta.
229
230 %package analyzer
231 Summary:        Implementation of Language Server Protocol for Rust
232 Summary(pl.UTF-8):      Implementacja Language Server Protocol dla Rusta
233 Group:          Development/Tools
234 Requires:       %{name} = %{version}-%{release}
235 Obsoletes:      rust-rls < 1.65.0
236
237 %description analyzer
238 Implementation of Language Server Protocol for Rust.
239
240 %description analyzer -l pl.UTF-8
241 Implementacja Language Server Protocol dla Rusta.
242
243 %package debugger-common
244 Summary:        Common debugger pretty printers for Rust
245 Summary(pl.UTF-8):      Narzędzia wypisujące struktury Rusa wspólne dla różnych debuggerów
246 Group:          Development/Debuggers
247 BuildArch:      noarch
248
249 %description debugger-common
250 This package includes the common functionality for rust-gdb and
251 rust-lldb.
252
253 %description debugger-common -l pl.UTF-8
254 Ten pakiet zawiera wspólny kod dla pakietów rust-gdb i rust-lldb.
255
256 %package gdb
257 Summary:        GDB pretty printers for Rust
258 Summary(pl.UTF-8):      Ładne wypisywanie struktur Rusta w GDB
259 Group:          Development/Debuggers
260 Requires:       %{name}-debugger-common = %{version}-%{release}
261 Requires:       gdb
262 BuildArch:      noarch
263
264 %description gdb
265 This package includes the rust-gdb script, which allows easier
266 debugging of Rust programs.
267
268 %description gdb -l pl.UTF-8
269 Ten pakiet zawiera skrypt rust-gdb, pozwalający na łatwiejsze
270 odpluskwianie programów w języku Rust.
271
272 %package lldb
273 Summary:        LLDB pretty printers for Rust
274 Summary(pl.UTF-8):      Ładne wypisywanie struktur Rusta w LLDB
275 Group:          Development/Debuggers
276 Requires:       %{name}-debugger-common = %{version}-%{release}
277 Requires:       lldb
278 BuildArch:      noarch
279
280 %description lldb
281 This package includes the rust-lldb script, which allows easier
282 debugging of Rust programs.
283
284 %description lldb -l pl.UTF-8
285 Ten pakiet zawiera skrypt rust-lldb, pozwalający na łatwiejsze
286 odpluskwianie programów w języku Rust.
287
288 %package doc
289 Summary:        Documentation for Rust
290 Summary(pl.UTF-8):      Dokumentacja do Rusta
291 Group:          Documentation
292 BuildArch:      noarch
293
294 %description doc
295 This package includes HTML documentation for the Rust programming
296 language and its standard library.
297
298 %description doc -l pl.UTF-8
299 Ten pakiet zawiera dokumentację w formacie HTML do języka
300 programowania Rust i jego biblioteki standardowej.
301
302 %package -n cargo
303 Summary:        Rust's package manager and build tool
304 Summary(pl.UTF-8):      Zarządca pakietów i narzędzie do budowania
305 Group:          Development/Tools
306 Requires:       %{name}%{?_isa}
307
308 %description -n cargo
309 Cargo is a tool that allows Rust projects to declare their various
310 dependencies and ensure that you'll always get a repeatable build.
311
312 %description -n cargo -l pl.UTF-8
313 Cargo to narzędzie pozwalające projektom w języku Rust deklarować ich
314 zależności i zapewniające powtarzalność procesu budowania.
315
316 %package -n bash-completion-cargo
317 Summary:        Bash completion for cargo command
318 Summary(pl.UTF-8):      Bashowe dopełnianie parametrów polecenia cargo
319 Group:          Applications/Shells
320 Requires:       %{name} = %{version}-%{release}
321 Requires:       bash-completion
322 BuildArch:      noarch
323
324 %description -n bash-completion-cargo
325 Bash completion for cargo command.
326
327 %description -n bash-completion-cargo -l pl.UTF-8
328 Bashowe dopełnianie parametrów polecenia cargo.
329
330 %package -n zsh-completion-cargo
331 Summary:        Zsh completion for cargo command
332 Summary(pl.UTF-8):      Dopełnianie parametrów polecenia cargo w powłoce Zsh
333 Group:          Applications/Shells
334 Requires:       %{name} = %{version}-%{release}
335 Requires:       zsh
336
337 %description -n zsh-completion-cargo
338 Zsh completion for cargo command.
339
340 %description -n zsh-completion-cargo -l pl.UTF-8
341 Dopełnianie parametrów polecenia cargo w powłoce Zsh.
342
343 %prep
344 %setup -q -n %{rustc_package}
345 %patch0 -p1 -R
346
347 %if %{with bootstrap}
348 %ifarch %{x8664} x32
349 tar xf %{SOURCE1}
350 %endif
351 %ifarch %{ix86}
352 tar xf %{SOURCE2}
353 %endif
354 %ifarch aarch64
355 tar xf %{SOURCE3}
356 %endif
357 %ifarch armv6hl
358 tar xf %{SOURCE4}
359 %endif
360 %ifarch armv7hl armv7hnl
361 tar xf %{SOURCE5}
362 %endif
363 %{__mv} %{bootstrap_root} %{bootstrap_root}-root
364 %{bootstrap_root}-root/install.sh \
365         --components=cargo,rustc,rust-std-%{rust_bootstrap_triple} \
366         --prefix=%{local_rust_root} \
367         --disable-ldconfig
368 test -f %{local_rust_root}/bin/cargo
369 test -f %{local_rust_root}/bin/rustc
370 %endif
371
372 # unbundle
373 # We're disabling jemalloc, but rust-src still wants it.
374 #%{__rm} -r src/jemalloc
375 %if %{with system_llvm}
376 %{__rm} -r src/llvm-project
377 mkdir -p src/llvm-project/libunwind
378 %endif
379
380 # rust-gdb has hardcoded SYSROOT/lib -- let's make it noarch
381 sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
382         src/etc/rust-gdb
383
384 # cargo has hardcoded libexec path - honour rpm _libexecdir
385 %if "%{_libexecdir}" != "%{_prefix}/libexec"
386 suffix="%(echo "%{_libexecdir}" | %{__sed} -e 's,^%{_prefix}/,,')"
387 %{__sed} -i -e 's,"libexec","'${suffix}'",' \
388         src/bootstrap/dist.rs \
389         src/tools/cargo/src/cargo/ops/registry/auth.rs
390 %{__sed} -i -e 's,libexec/,'${suffix}'/,' src/tools/cargo/tests/testsuite/credential_process.rs
391 %endif
392
393 # The configure macro will modify some autoconf-related files, which upsets
394 # cargo when it tries to verify checksums in those files.  If we just truncate
395 # that file list, cargo won't have anything to complain about.
396 find vendor -name .cargo-checksum.json \
397         -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
398
399 %build
400 export CC="%{__cc}"
401 export CXX="%{__cxx}"
402 export AR="%{__ar}"
403 %configure \
404         --build=%{rust_bootstrap_triple} \
405         --host=%{rust_host_triple} \
406         --target="%(echo %rust_targets | tr ' ' ,)" \
407         --libdir=%{common_libdir} \
408         --disable-codegen-tests \
409         --disable-debuginfo-lines \
410 %if %{with full_debuginfo}
411         --disable-debuginfo-only-std \
412         --enable-debuginfo \
413 %else
414         --enable-debuginfo-only-std \
415         --disable-debuginfo \
416 %endif
417         --disable-jemalloc \
418         --disable-option-checking \
419         --disable-rpath \
420         --enable-extended \
421         --enable-llvm-link-shared \
422         --enable-vendor \
423         --local-rust-root=%{local_rust_root} \
424         --llvm-root=%{_prefix} \
425         --release-channel=%{channel} \
426         --set=llvm.static-libstdcpp=false
427
428 export RUST_BACKTRACE=full
429 %x_py dist --verbose
430
431 %{?with_tests:%x_py test}
432
433 %install
434 rm -rf $RPM_BUILD_ROOT
435
436 export CC="%{__cc}"
437 export CXX="%{__cxx}"
438 export AR="%{__ar}"
439 export DESTDIR=$RPM_BUILD_ROOT
440 %x_py install
441
442 # Make sure the shared libraries are in the proper libdir
443 %if "%{_libdir}" != "%{common_libdir}"
444 mkdir -p %{buildroot}%{_libdir}
445 find $RPM_BUILD_ROOT%{common_libdir} -maxdepth 1 -type f -name '*.so' \
446         -exec mv -v -t $RPM_BUILD_ROOT%{_libdir} '{}' '+'
447 %endif
448
449 # The shared libraries should be executable for debuginfo extraction.
450 find $RPM_BUILD_ROOT%{_libdir}/ -type f -name '*.so' -exec chmod -v +x '{}' '+'
451
452 # The libdir libraries are identical to those under rustlib/.  It's easier on
453 # library loading if we keep them in libdir, but we do need them in rustlib/
454 # to support dynamic linking for compiler plugins, so we'll symlink.
455 for rust_target in %rust_targets; do
456         for l in libstd libtest ; do
457                 liblib=$RPM_BUILD_ROOT%{_libdir}/${l}-*.so
458                 libstd=$RPM_BUILD_ROOT%{rustlibdir}/${rust_target}/lib/${l}-*.so
459                 if [ "$(basename ${liblib})" = "$(basename ${libstd})" ]; then
460                         ln -vfsr ${libstd} $RPM_BUILD_ROOT%{_libdir}/
461                 fi
462         done
463 done
464
465 # Remove installer artifacts (manifests, uninstall scripts, etc.)
466 find $RPM_BUILD_ROOT%{rustlibdir}/ -maxdepth 1 -type f -exec rm -v '{}' '+'
467
468 # FIXME: __os_install_post will strip the rlibs
469 # -- should we find a way to preserve debuginfo?
470
471 # Remove unwanted documentation files (we already package them)
472 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/README.md
473 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/COPYRIGHT
474 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-APACHE
475 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-MIT
476
477 # Sanitize the HTML documentation
478 find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -empty -delete
479 find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
480
481 # Move rust-gdb's python scripts so they're noarch
482 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
483 %{__mv} $RPM_BUILD_ROOT%{rustlibdir}/etc $RPM_BUILD_ROOT%{_datadir}/%{name}
484
485 # We don't need stdlib source
486 %{__rm} -r $RPM_BUILD_ROOT%{rustlibdir}/src
487
488 # Create the path for crate-devel packages
489 install -d $RPM_BUILD_ROOT%{_datadir}/cargo/registry
490
491 %clean
492 rm -rf $RPM_BUILD_ROOT
493
494 %post   -p /sbin/ldconfig
495 %postun -p /sbin/ldconfig
496
497 %files
498 %defattr(644,root,root,755)
499 %doc COPYRIGHT LICENSE-APACHE LICENSE-MIT README.md
500 %attr(755,root,root) %{_bindir}/rust-demangler
501 %attr(755,root,root) %{_bindir}/rustc
502 %attr(755,root,root) %{_bindir}/rustdoc
503 %attr(755,root,root) %{_bindir}/rustfmt
504 %attr(755,root,root) %{_libdir}/librustc_driver-*.so
505 %attr(755,root,root) %{_libdir}/libstd-*.so
506 %attr(755,root,root) %{_libdir}/libtest-*.so
507 %{_mandir}/man1/rustc.1*
508 %{_mandir}/man1/rustdoc.1*
509 %dir %{rustlibdir}
510
511 %files analysis
512 %defattr(644,root,root,755)
513 %(for rust_target in %rust_targets; do
514 echo "%{rustlibdir}/$rust_target/analysis"
515 done
516 )
517
518 %files std
519 %defattr(644,root,root,755)
520 %(for rust_target in %rust_targets; do
521 cat <<EOF
522 %dir %{rustlibdir}/$rust_target
523 %dir %{rustlibdir}/$rust_target/lib
524 %attr(755,root,root) %{rustlibdir}/$rust_target/lib/*.so
525 %{rustlibdir}/$rust_target/lib/*.rlib
526 EOF
527 done
528 )
529
530 %files analyzer
531 %defattr(644,root,root,755)
532 %attr(755,root,root) %{_bindir}/rust-analyzer
533 %attr(755,root,root) %{_libexecdir}/rust-analyzer-proc-macro-srv
534
535 %files debugger-common
536 %defattr(644,root,root,755)
537 %dir %{_datadir}/%{name}
538 %dir %{_datadir}/%{name}/etc
539 %{_datadir}/%{name}/etc/lldb_commands
540 %{_datadir}/%{name}/etc/rust_types.py
541
542 %files lldb
543 %defattr(644,root,root,755)
544 %attr(755,root,root) %{_bindir}/rust-lldb
545 %{_datadir}/%{name}/etc/lldb_*.py*
546
547 %files gdb
548 %defattr(644,root,root,755)
549 %attr(755,root,root) %{_bindir}/rust-gdb
550 %attr(755,root,root) %{_bindir}/rust-gdbgui
551 %{_datadir}/%{name}/etc/gdb_*.py*
552
553 %files doc
554 %defattr(644,root,root,755)
555 %dir %{_docdir}/%{name}
556 %doc %{_docdir}/%{name}/html
557
558 %files -n cargo
559 %defattr(644,root,root,755)
560 %attr(755,root,root) %{_bindir}/cargo
561 %attr(755,root,root) %{_bindir}/cargo-clippy
562 %attr(755,root,root) %{_bindir}/cargo-fmt
563 %attr(755,root,root) %{_bindir}/clippy-driver
564 %attr(755,root,root) %{_libexecdir}/cargo-credential-1password
565 %{_mandir}/man1/cargo*.1*
566 %dir %{_datadir}/cargo
567 %dir %{_datadir}/cargo/registry
568
569 %files -n bash-completion-cargo
570 %defattr(644,root,root,755)
571 %{_sysconfdir}/bash_completion.d/cargo
572
573 %files -n zsh-completion-cargo
574 %defattr(644,root,root,755)
575 %{zsh_compdir}/_cargo
This page took 0.098023 seconds and 3 git commands to generate.