]> git.pld-linux.org Git - packages/rust.git/blob - rust.spec
3af82989d96a7f3b8dc1b0e5c534f8c516217d00
[packages/rust.git] / rust.spec
1 # TODO
2 # - consider a rust-std package containing .../rustlib/$target
3 #   This might allow multilib cross-compilation to work naturally.
4 # - package additional tools
5 #
6 # Conditional build:
7 %bcond_with     bootstrap       # bootstrap using precompiled binaries
8 %bcond_with     full_debuginfo  # full debuginfo vs only std debuginfo (full takes gigabytes of memory to build)
9 %bcond_without  system_llvm     # system LLVM
10 %bcond_with     tests           # build without tests
11
12 # The channel can be stable, beta, or nightly
13 %define         channel         stable
14
15 %if "%{channel}" == "stable"
16 %define         rustc_package   rustc-%{version}-src
17 %else
18 %define         rustc_package   rustc-%{channel}-src
19 %endif
20
21 # To bootstrap from scratch, set the channel and date from src/stage0.json
22 # e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
23 # or nightly wants some beta-YYYY-MM-DD
24 %define         bootstrap_rust  1.66.1
25 %define         bootstrap_cargo %{bootstrap_rust}
26 %define         bootstrap_date  2023-01-10
27
28 %ifarch x32
29 %define         with_cross      1
30 %endif
31
32 %if %{without full_debuginfo}
33 %define         _enable_debug_packages  0
34 %endif
35
36 Summary:        The Rust Programming Language
37 Summary(pl.UTF-8):      Język programowania Rust
38 Name:           rust
39 Version:        1.67.1
40 Release:        1
41 # Licenses: (rust itself) and (bundled libraries)
42 License:        (Apache v2.0 or MIT) and (BSD and ISC and MIT)
43 Group:          Development/Languages
44 Source0:        https://static.rust-lang.org/dist/%{rustc_package}.tar.xz
45 # Source0-md5:  e5e47e53c52574ce89ea200e52819f81
46 Source1:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.xz
47 # Source1-md5:  7bdb0591ffdc443f986a3563b5fa5f71
48 Source2:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.xz
49 # Source2-md5:  f6771f700a1c0cafede4f205c1d7c3d9
50 Source3:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-aarch64-unknown-linux-gnu.tar.xz
51 # Source3-md5:  41a059934972af4b327958ce6ee54ac7
52 Source4:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-arm-unknown-linux-gnueabihf.tar.xz
53 # Source4-md5:  3ad4208d29ca809073b43f96767e8b32
54 Source5:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-armv7-unknown-linux-gnueabihf.tar.xz
55 # Source5-md5:  f091919a1e13f71db429b3af957bf361
56 URL:            https://www.rust-lang.org/
57 # for src/compiler-rt
58 BuildRequires:  cmake >= 3.4.3
59 BuildRequires:  curl
60 %ifarch %{arm} %{mips32} %{ppc}
61 BuildRequires:  libatomic-devel
62 %endif
63 # make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
64 BuildRequires:  procps
65 BuildRequires:  python3
66 BuildRequires:  python3-modules
67 BuildRequires:  rpm-build >= 4.6
68 BuildRequires:  rpmbuild(macros) >= 1.752
69 %if %{without cross}
70 BuildRequires:  curl-devel
71 BuildRequires:  libgit2-devel >= 1.4.0
72 BuildRequires:  libstdc++-devel
73 %if %{with system_llvm}
74 BuildRequires:  llvm >= 13.0
75 BuildRequires:  llvm-devel >= 13.0
76 %endif
77 BuildRequires:  openssl-devel >= 1.0.1
78 BuildRequires:  tar >= 1:1.22
79 BuildRequires:  xz
80 BuildRequires:  xz-devel
81 BuildRequires:  zlib-devel
82 %endif
83 %if %{without bootstrap}
84 BuildRequires:  %{name} >= %{bootstrap_rust}
85 BuildRequires:  cargo >= %{bootstrap_cargo}
86 BuildConflicts: %{name} > %{version}
87 %endif
88 %ifarch x32
89 BuildRequires:  glibc-devel(x86-64)
90 BuildRequires:  glibc-devel(x86-x32)
91 %if "%{_host_cpu}" == "x86_64"
92 # building on x86_64 host with --target x32-pld-linux
93 BuildRequires:  curl-devel
94 BuildRequires:  gcc-multilib-x32
95 BuildRequires:  libgit2-devel >= 1.4.0
96 BuildRequires:  libstdc++-devel
97 %{?with_system_llvm:BuildRequires:      llvm-devel >= 13.0}
98 BuildRequires:  openssl-devel >= 1.0.1
99 BuildRequires:  xz-devel
100 BuildRequires:  zlib-devel
101 %else
102 # building x86_64-hosted crosscompiler on x32 host
103 BuildRequires:  curl-devel(x86-64)
104 BuildRequires:  curl-devel(x86-x32)
105 BuildRequires:  gcc-multilib-64
106 BuildRequires:  libgit2-devel(x86-64) >= 1.4.0
107 BuildRequires:  libgit2-devel(x86-x32) >= 1.4.0
108 BuildRequires:  libstdc++-multilib-64-devel
109 %if %{with system_llvm}
110 BuildRequires:  llvm-devel(x86-64) >= 13.0
111 BuildRequires:  llvm-devel(x86-x32) >= 13.0
112 %endif
113 BuildRequires:  openssl-devel(x86-64)
114 BuildRequires:  openssl-devel(x86-x32)
115 BuildRequires:  xz-devel(x86-64)
116 BuildRequires:  xz-devel(x86-x32)
117 BuildRequires:  zlib-devel(x86-64)
118 BuildRequires:  zlib-devel(x86-x32)
119 %endif
120 %endif
121 # The C compiler is needed at runtime just for linking.  Someday rustc might
122 # invoke the linker directly, and then we'll only need binutils.
123 # https://github.com/rust-lang/rust/issues/11937
124 Requires:       gcc
125 Requires:       %{name}-std%{?_isa} = %{version}-%{release}
126 %ifarch x32
127 Requires:       %{name}-std(x86-64) = %{version}-%{release}
128 Requires:       gcc-multilib-64
129 %endif
130 # Only x86_64 and i686 are Tier 1 platforms at this time.
131 # x32 is Tier 2, only rust-std is available (no rustc or cargo).
132 # https://doc.rust-lang.org/nightly/rustc/platform-support.html
133 ExclusiveArch:  %{x8664} %{ix86} x32 aarch64 armv6hl armv7hl armv7hnl
134 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
135
136 %ifarch x32
137 %define         rust_triple             x86_64-unknown-linux-gnux32
138 %define         rust_host_triple        x86_64-unknown-linux-gnu
139 %define         rust_bootstrap_triple   x86_64-unknown-linux-gnu
140 # libs in _libdir are x86_64 64bit
141 %define         _lib                    lib64
142 %define         _libdir                 %{_prefix}/lib64
143 %else
144 %ifarch armv6hl
145 %define         rust_triple             arm-unknown-linux-gnueabihf
146 %define         rust_host_triple        %{rust_triple}
147 %define         rust_bootstrap_triple   %{rust_triple}
148 %else
149 %ifarch armv7hl armv7hnl
150 %define         rust_triple             armv7-unknown-linux-gnueabihf
151 %define         rust_host_triple        %{rust_triple}
152 %define         rust_bootstrap_triple   %{rust_triple}
153 %define         rust_suppl_targets      thumbv7neon-unknown-linux-gnueabihf
154 %else
155 %define         rust_triple             %{_target_cpu}-unknown-linux-gnu
156 %define         rust_host_triple        %{rust_triple}
157 %define         rust_bootstrap_triple   %{rust_triple}
158 %endif
159 %endif
160 %endif
161
162 %define         rust_targets            %rust_triple %{?rust_suppl_targets}
163
164 %if %{without bootstrap}
165 %define         local_rust_root %{_prefix}
166 %else
167 %define         bootstrap_root  rust-%{bootstrap_rust}-%{rust_bootstrap_triple}
168 %define         local_rust_root %{_builddir}/%{rustc_package}/%{bootstrap_root}
169 %endif
170
171 # We're going to override --libdir when configuring to get rustlib into a
172 # common path, but we'll fix the shared libraries during install.
173 # Without this ugly hack, rust would not be able to build itself
174 # for non-bootstrap build, lib64 is just too complicated for it.
175 %define         common_libdir   %{_prefix}/lib
176 %define         rustlibdir      %{common_libdir}/rustlib
177
178 # once_call/once_callable non-function libstdc++ symbols
179 %define         skip_post_check_so      'librustc.*llvm.*\.so.*'
180
181 # ALL Rust libraries are private, because they don't keep an ABI.
182 %define         _noautoreqfiles         lib.*-[[:xdigit:]]{8}[.]so.*
183 %define         _noautoprovfiles        lib.*-[[:xdigit:]]{8}[.]so.*
184
185 %define         x_py { \
186         x_py() { \
187                 local cmd="$1"; \
188                 shift; \
189                 %{?__jobs:CARGO_BUILD_JOBS=%__jobs }%{__python3} ./x.py "$cmd" %{?__jobs:-j %__jobs} "$@"; \
190         }; x_py }
191
192
193 %description
194 Rust is a systems programming language that runs blazingly fast,
195 prevents segfaults, and guarantees thread safety.
196
197 This package includes the Rust compiler, standard library, and
198 documentation generator.
199
200 %description -l pl.UTF-8
201 Rust to systemowy język programowania działający bardzo szybko,
202 zapobiegający naruszeniom ochrony pamięci i gwarantujący
203 bezpieczną wielowątkowość.
204
205 %package analysis
206 Summary:        Metadata about the standard library
207 Summary(pl.UTF-8):      Metadane o standardowej bibliotece
208 Group:          Development/Tools
209 Requires:       %{name} = %{version}-%{release}
210
211 %description analysis
212 Metadata about the standard library.
213
214 %description analysis -l pl.UTF-8
215 Metadane o standardowej bibliotece.
216
217 %package std
218 Summary:        Standard library for Rust
219 Summary(pl.UTF-8):      Standardowa biblioteka Rusta
220 Group:          Development/Tools
221 Requires:       %{name} = %{version}-%{release}
222
223 %description std
224 Standard library for Rust.
225
226 %description std -l pl.UTF-8
227 Standardowa biblioteka Rusta.
228
229 %package analyzer
230 Summary:        Implementation of Language Server Protocol for Rust
231 Summary(pl.UTF-8):      Implementacja Language Server Protocol dla Rusta
232 Group:          Development/Tools
233 Requires:       %{name} = %{version}-%{release}
234 Obsoletes:      rust-rls < 1.65.0
235
236 %description analyzer
237 Implementation of Language Server Protocol for Rust.
238
239 %description analyzer -l pl.UTF-8
240 Implementacja Language Server Protocol dla Rusta.
241
242 %package debugger-common
243 Summary:        Common debugger pretty printers for Rust
244 Summary(pl.UTF-8):      Narzędzia wypisujące struktury Rusa wspólne dla różnych debuggerów
245 Group:          Development/Debuggers
246 BuildArch:      noarch
247
248 %description debugger-common
249 This package includes the common functionality for rust-gdb and
250 rust-lldb.
251
252 %description debugger-common -l pl.UTF-8
253 Ten pakiet zawiera wspólny kod dla pakietów rust-gdb i rust-lldb.
254
255 %package gdb
256 Summary:        GDB pretty printers for Rust
257 Summary(pl.UTF-8):      Ładne wypisywanie struktur Rusta w GDB
258 Group:          Development/Debuggers
259 Requires:       %{name}-debugger-common = %{version}-%{release}
260 Requires:       gdb
261 BuildArch:      noarch
262
263 %description gdb
264 This package includes the rust-gdb script, which allows easier
265 debugging of Rust programs.
266
267 %description gdb -l pl.UTF-8
268 Ten pakiet zawiera skrypt rust-gdb, pozwalający na łatwiejsze
269 odpluskwianie programów w języku Rust.
270
271 %package lldb
272 Summary:        LLDB pretty printers for Rust
273 Summary(pl.UTF-8):      Ładne wypisywanie struktur Rusta w LLDB
274 Group:          Development/Debuggers
275 Requires:       %{name}-debugger-common = %{version}-%{release}
276 Requires:       lldb
277 BuildArch:      noarch
278
279 %description lldb
280 This package includes the rust-lldb script, which allows easier
281 debugging of Rust programs.
282
283 %description lldb -l pl.UTF-8
284 Ten pakiet zawiera skrypt rust-lldb, pozwalający na łatwiejsze
285 odpluskwianie programów w języku Rust.
286
287 %package doc
288 Summary:        Documentation for Rust
289 Summary(pl.UTF-8):      Dokumentacja do Rusta
290 Group:          Documentation
291 BuildArch:      noarch
292
293 %description doc
294 This package includes HTML documentation for the Rust programming
295 language and its standard library.
296
297 %description doc -l pl.UTF-8
298 Ten pakiet zawiera dokumentację w formacie HTML do języka
299 programowania Rust i jego biblioteki standardowej.
300
301 %package -n cargo
302 Summary:        Rust's package manager and build tool
303 Summary(pl.UTF-8):      Zarządca pakietów i narzędzie do budowania
304 Group:          Development/Tools
305 Requires:       %{name}%{?_isa}
306
307 %description -n cargo
308 Cargo is a tool that allows Rust projects to declare their various
309 dependencies and ensure that you'll always get a repeatable build.
310
311 %description -n cargo -l pl.UTF-8
312 Cargo to narzędzie pozwalające projektom w języku Rust deklarować ich
313 zależności i zapewniające powtarzalność procesu budowania.
314
315 %package -n bash-completion-cargo
316 Summary:        Bash completion for cargo command
317 Summary(pl.UTF-8):      Bashowe dopełnianie parametrów polecenia cargo
318 Group:          Applications/Shells
319 Requires:       %{name} = %{version}-%{release}
320 Requires:       bash-completion
321 BuildArch:      noarch
322
323 %description -n bash-completion-cargo
324 Bash completion for cargo command.
325
326 %description -n bash-completion-cargo -l pl.UTF-8
327 Bashowe dopełnianie parametrów polecenia cargo.
328
329 %package -n zsh-completion-cargo
330 Summary:        Zsh completion for cargo command
331 Summary(pl.UTF-8):      Dopełnianie parametrów polecenia cargo w powłoce Zsh
332 Group:          Applications/Shells
333 Requires:       %{name} = %{version}-%{release}
334 Requires:       zsh
335
336 %description -n zsh-completion-cargo
337 Zsh completion for cargo command.
338
339 %description -n zsh-completion-cargo -l pl.UTF-8
340 Dopełnianie parametrów polecenia cargo w powłoce Zsh.
341
342 %prep
343 %setup -q -n %{rustc_package}
344
345 %if %{with bootstrap}
346 %ifarch %{x8664} x32
347 tar xf %{SOURCE1}
348 %endif
349 %ifarch %{ix86}
350 tar xf %{SOURCE2}
351 %endif
352 %ifarch aarch64
353 tar xf %{SOURCE3}
354 %endif
355 %ifarch armv6hl
356 tar xf %{SOURCE4}
357 %endif
358 %ifarch armv7hl armv7hnl
359 tar xf %{SOURCE5}
360 %endif
361 %{__mv} %{bootstrap_root} %{bootstrap_root}-root
362 %{bootstrap_root}-root/install.sh \
363         --components=cargo,rustc,rust-std-%{rust_bootstrap_triple} \
364         --prefix=%{local_rust_root} \
365         --disable-ldconfig
366 test -f %{local_rust_root}/bin/cargo
367 test -f %{local_rust_root}/bin/rustc
368 %endif
369
370 # unbundle
371 # We're disabling jemalloc, but rust-src still wants it.
372 #%{__rm} -r src/jemalloc
373 %if %{with system_llvm}
374 %{__rm} -r src/llvm-project
375 mkdir -p src/llvm-project/libunwind
376 %endif
377
378 # rust-gdb has hardcoded SYSROOT/lib -- let's make it noarch
379 sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
380         src/etc/rust-gdb
381
382 # cargo has hardcoded libexec path - honour rpm _libexecdir
383 %if "%{_libexecdir}" != "%{_prefix}/libexec"
384 suffix="%(echo "%{_libexecdir}" | %{__sed} -e 's,^%{_prefix}/,,')"
385 %{__sed} -i -e 's,"libexec","'${suffix}'",' \
386         src/bootstrap/dist.rs \
387         src/tools/cargo/src/cargo/ops/registry/auth.rs
388 %{__sed} -i -e 's,libexec/,'${suffix}'/,' src/tools/cargo/tests/testsuite/credential_process.rs
389 %endif
390
391 # The configure macro will modify some autoconf-related files, which upsets
392 # cargo when it tries to verify checksums in those files.  If we just truncate
393 # that file list, cargo won't have anything to complain about.
394 find vendor -name .cargo-checksum.json \
395         -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
396
397 %build
398 export CC="%{__cc}"
399 export CXX="%{__cxx}"
400 export AR="%{__ar}"
401 %configure \
402         --build=%{rust_bootstrap_triple} \
403         --host=%{rust_host_triple} \
404         --target="%(echo %rust_targets | tr ' ' ,)" \
405         --libdir=%{common_libdir} \
406         --disable-codegen-tests \
407         --disable-debuginfo-lines \
408 %if %{with full_debuginfo}
409         --disable-debuginfo-only-std \
410         --enable-debuginfo \
411 %else
412         --enable-debuginfo-only-std \
413         --disable-debuginfo \
414 %endif
415         --disable-jemalloc \
416         --disable-option-checking \
417         --disable-rpath \
418         --enable-extended \
419         --enable-llvm-link-shared \
420         --enable-vendor \
421         --local-rust-root=%{local_rust_root} \
422         --llvm-root=%{_prefix} \
423         --release-channel=%{channel} \
424         --set=llvm.static-libstdcpp=false
425
426 export RUST_BACKTRACE=full
427 %x_py dist --verbose
428
429 %{?with_tests:%x_py test}
430
431 %install
432 rm -rf $RPM_BUILD_ROOT
433
434 export CC="%{__cc}"
435 export CXX="%{__cxx}"
436 export AR="%{__ar}"
437 export DESTDIR=$RPM_BUILD_ROOT
438 %x_py install
439
440 # Make sure the shared libraries are in the proper libdir
441 %if "%{_libdir}" != "%{common_libdir}"
442 mkdir -p %{buildroot}%{_libdir}
443 find $RPM_BUILD_ROOT%{common_libdir} -maxdepth 1 -type f -name '*.so' \
444         -exec mv -v -t $RPM_BUILD_ROOT%{_libdir} '{}' '+'
445 %endif
446
447 # The shared libraries should be executable for debuginfo extraction.
448 find $RPM_BUILD_ROOT%{_libdir}/ -type f -name '*.so' -exec chmod -v +x '{}' '+'
449
450 # The libdir libraries are identical to those under rustlib/.  It's easier on
451 # library loading if we keep them in libdir, but we do need them in rustlib/
452 # to support dynamic linking for compiler plugins, so we'll symlink.
453 for rust_target in %rust_targets; do
454         for l in libstd libtest ; do
455                 liblib=$RPM_BUILD_ROOT%{_libdir}/${l}-*.so
456                 libstd=$RPM_BUILD_ROOT%{rustlibdir}/${rust_target}/lib/${l}-*.so
457                 if [ "$(basename ${liblib})" = "$(basename ${libstd})" ]; then
458                         ln -vfsr ${libstd} $RPM_BUILD_ROOT%{_libdir}/
459                 fi
460         done
461 done
462
463 # Remove installer artifacts (manifests, uninstall scripts, etc.)
464 find $RPM_BUILD_ROOT%{rustlibdir}/ -maxdepth 1 -type f -exec rm -v '{}' '+'
465
466 # FIXME: __os_install_post will strip the rlibs
467 # -- should we find a way to preserve debuginfo?
468
469 # Remove unwanted documentation files (we already package them)
470 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/README.md
471 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/COPYRIGHT
472 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-APACHE
473 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-MIT
474
475 # Sanitize the HTML documentation
476 find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -empty -delete
477 find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
478
479 # Move rust-gdb's python scripts so they're noarch
480 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
481 %{__mv} $RPM_BUILD_ROOT%{rustlibdir}/etc $RPM_BUILD_ROOT%{_datadir}/%{name}
482
483 # We don't need stdlib source
484 %{__rm} -r $RPM_BUILD_ROOT%{rustlibdir}/src
485
486 # Create the path for crate-devel packages
487 install -d $RPM_BUILD_ROOT%{_datadir}/cargo/registry
488
489 %clean
490 rm -rf $RPM_BUILD_ROOT
491
492 %post   -p /sbin/ldconfig
493 %postun -p /sbin/ldconfig
494
495 %files
496 %defattr(644,root,root,755)
497 %doc COPYRIGHT LICENSE-APACHE LICENSE-MIT README.md
498 %attr(755,root,root) %{_bindir}/rust-demangler
499 %attr(755,root,root) %{_bindir}/rustc
500 %attr(755,root,root) %{_bindir}/rustdoc
501 %attr(755,root,root) %{_bindir}/rustfmt
502 %attr(755,root,root) %{_libdir}/librustc_driver-*.so
503 %attr(755,root,root) %{_libdir}/libstd-*.so
504 %attr(755,root,root) %{_libdir}/libtest-*.so
505 %{_mandir}/man1/rustc.1*
506 %{_mandir}/man1/rustdoc.1*
507 %dir %{rustlibdir}
508
509 %files analysis
510 %defattr(644,root,root,755)
511 %(for rust_target in %rust_targets; do
512 echo "%{rustlibdir}/$rust_target/analysis"
513 done
514 )
515
516 %files std
517 %defattr(644,root,root,755)
518 %(for rust_target in %rust_targets; do
519 cat <<EOF
520 %dir %{rustlibdir}/$rust_target
521 %dir %{rustlibdir}/$rust_target/lib
522 %attr(755,root,root) %{rustlibdir}/$rust_target/lib/*.so
523 %{rustlibdir}/$rust_target/lib/*.rlib
524 EOF
525 done
526 )
527
528 %files analyzer
529 %defattr(644,root,root,755)
530 %attr(755,root,root) %{_bindir}/rust-analyzer
531 %attr(755,root,root) %{_libexecdir}/rust-analyzer-proc-macro-srv
532
533 %files debugger-common
534 %defattr(644,root,root,755)
535 %dir %{_datadir}/%{name}
536 %dir %{_datadir}/%{name}/etc
537 %{_datadir}/%{name}/etc/lldb_commands
538 %{_datadir}/%{name}/etc/rust_types.py
539
540 %files lldb
541 %defattr(644,root,root,755)
542 %attr(755,root,root) %{_bindir}/rust-lldb
543 %{_datadir}/%{name}/etc/lldb_*.py*
544
545 %files gdb
546 %defattr(644,root,root,755)
547 %attr(755,root,root) %{_bindir}/rust-gdb
548 %attr(755,root,root) %{_bindir}/rust-gdbgui
549 %{_datadir}/%{name}/etc/gdb_*.py*
550
551 %files doc
552 %defattr(644,root,root,755)
553 %dir %{_docdir}/%{name}
554 %doc %{_docdir}/%{name}/html
555
556 %files -n cargo
557 %defattr(644,root,root,755)
558 %attr(755,root,root) %{_bindir}/cargo
559 %attr(755,root,root) %{_bindir}/cargo-clippy
560 %attr(755,root,root) %{_bindir}/cargo-fmt
561 %attr(755,root,root) %{_bindir}/clippy-driver
562 %attr(755,root,root) %{_libexecdir}/cargo-credential-1password
563 %{_mandir}/man1/cargo*.1*
564 %dir %{_datadir}/cargo
565 %dir %{_datadir}/cargo/registry
566
567 %files -n bash-completion-cargo
568 %defattr(644,root,root,755)
569 %{_sysconfdir}/bash_completion.d/cargo
570
571 %files -n zsh-completion-cargo
572 %defattr(644,root,root,755)
573 %{zsh_compdir}/_cargo
This page took 0.236999 seconds and 2 git commands to generate.