]> git.pld-linux.org Git - packages/rust.git/blob - rust.spec
- remove obsolete patch
[packages/rust.git] / rust.spec
1 # TODO
2 # - consider a rust-std package containing .../rustlib/$target
3 #   This might allow multilib cross-compilation to work naturally.
4 #
5 # Conditional build:
6 %bcond_with     bootstrap       # bootstrap using precompiled binaries
7 %bcond_with     tests           # build without tests
8
9 # The channel can be stable, beta, or nightly
10 %define         channel         stable
11
12 %if "%{channel}" == "stable"
13 %define         rustc_package   rustc-%{version}-src
14 %else
15 %define         rustc_package   rustc-%{channel}-src
16 %endif
17
18 # To bootstrap from scratch, set the channel and date from src/stage0.txt
19 # e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
20 # or nightly wants some beta-YYYY-MM-DD
21 %define         bootstrap_rust  1.17.0
22 %define         bootstrap_cargo 0.18.0
23 %define         bootstrap_date  2017-04-27
24
25 Summary:        The Rust Programming Language
26 Summary(pl.UTF-8):      Język programowania Rust
27 Name:           rust
28 Version:        1.19.0
29 Release:        1
30 # Licenses: (rust itself) and (bundled libraries)
31 License:        (Apache v2.0 or MIT) and (BSD and ISC and MIT)
32 Group:          Development/Languages
33 Source0:        https://static.rust-lang.org/dist/%{rustc_package}.tar.gz
34 # Source0-md5:  75e779670ac79edf023497a9c37eb35d
35 Source1:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-x86_64-unknown-linux-gnu.tar.gz
36 # Source1-md5:  98e8f479515969123b4c203191104a54
37 Source2:        https://static.rust-lang.org/dist/%{bootstrap_date}/rust-%{bootstrap_rust}-i686-unknown-linux-gnu.tar.gz
38 # Source2-md5:  2d5de850c32aa8d40c8c21abacf749f8
39 URL:            https://www.rust-lang.org/
40 # for src/compiler-rt
41 BuildRequires:  cmake >= 3.4.3
42 BuildRequires:  curl
43 BuildRequires:  libstdc++-devel
44 BuildRequires:  llvm-devel
45 BuildRequires:  ncurses-devel
46 BuildRequires:  python >= 1:2.7
47 BuildRequires:  zlib-devel
48 %if %{without bootstrap}
49 BuildRequires:  %{name} >= %{bootstrap_rust}
50 BuildRequires:  cargo >= %{bootstrap_cargo}
51 BuildConflicts: %{name} > %{version}
52 %endif
53 # make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
54 BuildRequires:  procps
55 # The C compiler is needed at runtime just for linking.  Someday rustc might
56 # invoke the linker directly, and then we'll only need binutils.
57 # https://github.com/rust-lang/rust/issues/11937
58 Requires:       gcc
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60 # Only x86_64 and i686 are Tier 1 platforms at this time.
61 # https://doc.rust-lang.org/stable/book/getting-started.html#tier-1
62 ExclusiveArch:  %{x8664} %{ix86}
63
64 %define         rust_triple     %{_target_cpu}-unknown-linux-gnu
65
66 %if %{without bootstrap}
67 %define         local_rust_root %{_prefix}
68 %else
69 %define         bootstrap_root  rust-%{bootstrap_rust}-%{rust_triple}
70 %define         local_rust_root %{_builddir}/%{rustc_package}/%{bootstrap_root}
71 %endif
72
73 # We're going to override --libdir when configuring to get rustlib into a
74 # common path, but we'll fix the shared libraries during install.
75 # Without this ugly hack, rust would not be able to buld itself
76 # for non-bootstrap build, lib64 is just too complicated for it.
77 %define         common_libdir   %{_prefix}/lib
78 %define         rustlibdir      %{common_libdir}/rustlib
79
80 # once_call/once_callable non-function libstdc++ symbols
81 %define         skip_post_check_so      'librustc_llvm-.*\.so.*'
82
83 # ALL Rust libraries are private, because they don't keep an ABI.
84 %define         _noautoreqfiles         lib.*-[[:xdigit:]]{8}[.]so.*
85 %define         _noautoprovfiles        lib.*-[[:xdigit:]]{8}[.]so.*
86
87 %description
88 Rust is a systems programming language that runs blazingly fast,
89 prevents segfaults, and guarantees thread safety.
90
91 This package includes the Rust compiler, standard library, and
92 documentation generator.
93
94 %description -l pl.UTF-8
95 Rust to systemowy język programowania działający bardzo szybko,
96 zapobiegający naruszeniom ochrony pamięci i gwarantujący
97 bezpieczną wielowątkowość.
98
99 %package debugger-common
100 Summary:        Common debugger pretty printers for Rust
101 Summary(pl.UTF-8):      Narzędzia wypisujące struktury Rusa wspólne dla różnych debuggerów
102 Group:          Development/Debuggers
103 BuildArch:      noarch
104
105 %description debugger-common
106 This package includes the common functionality for rust-gdb and
107 rust-lldb.
108
109 %description debugger-common -l pl.UTF-8
110 Ten pakiet zawiera wspólny kod dla pakietów rust-gdb i rust-lldb.
111
112 %package gdb
113 Summary:        GDB pretty printers for Rust
114 Summary(pl.UTF-8):      Ładne wypisywanie struktur Rusta w GDB
115 Group:          Development/Debuggers
116 Requires:       %{name}-debugger-common = %{version}-%{release}
117 Requires:       gdb
118 BuildArch:      noarch
119
120 %description gdb
121 This package includes the rust-gdb script, which allows easier
122 debugging of Rust programs.
123
124 %description gdb -l pl.UTF-8
125 Ten pakiet zawiera skrypt rust-gdb, pozwalający na łatwiejsze
126 odpluskwianie programów w języku Rust.
127
128 %package lldb
129 Summary:        LLDB pretty printers for Rust
130 Summary(pl.UTF-8):      Ładne wypisywanie struktur Rusta w LLDB
131 Group:          Development/Debuggers
132 Requires:       %{name}-debugger-common = %{version}-%{release}
133 Requires:       lldb
134 BuildArch:      noarch
135
136 %description lldb
137 This package includes the rust-lldb script, which allows easier
138 debugging of Rust programs.
139
140 %description lldb -l pl.UTF-8
141 Ten pakiet zawiera skrypt rust-lldb, pozwalający na łatwiejsze
142 odpluskwianie programów w języku Rust.
143
144 %package doc
145 Summary:        Documentation for Rust
146 Summary(pl.UTF-8):      Dokumentacja do Rusta
147 Group:          Documentation
148 BuildArch:      noarch
149
150 %description doc
151 This package includes HTML documentation for the Rust programming
152 language and its standard library.
153
154 %description doc -l pl.UTF-8
155 Ten pakiet zawiera dokumentację w formacie HTML do języka
156 programowania Rust i jego biblioteki standardowej.
157
158 %prep
159 %setup -q -n %{rustc_package}
160
161 %if %{with bootstrap}
162 %ifarch %{x8664}
163 tar xf %{SOURCE1}
164 %endif
165 %ifarch %{ix86}
166 tar xf %{SOURCE2}
167 %endif
168 %{__mv} %{bootstrap_root} %{bootstrap_root}-root
169 %{bootstrap_root}-root/install.sh \
170         --components=cargo,rustc,rust-std-%{rust_triple} \
171         --prefix=%{local_rust_root} \
172         --disable-ldconfig
173 test -f %{local_rust_root}/bin/cargo
174 test -f %{local_rust_root}/bin/rustc
175 %endif
176
177 # unbundle
178 %{__rm} -r src/jemalloc/
179 %{__rm} -r src/llvm/
180
181 # extract bundled licenses for packaging
182 cp -p src/rt/hoedown/LICENSE src/rt/hoedown/LICENSE-hoedown
183 sed -e '/*\//q' src/libbacktrace/backtrace.h \
184         >src/libbacktrace/LICENSE-libbacktrace
185
186 # rust-gdb has hardcoded SYSROOT/lib -- let's make it noarch
187 sed -i -e 's#DIRECTORY=".*"#DIRECTORY="%{_datadir}/%{name}/etc"#' \
188         src/etc/rust-gdb
189
190 # These tests assume that alloc_jemalloc is present
191 sed -i -e '1i // ignore-test jemalloc is disabled' \
192         src/test/compile-fail/allocator-dylib-is-system.rs \
193         src/test/compile-fail/allocator-rust-dylib-is-jemalloc.rs \
194         src/test/run-pass/allocator-default.rs
195
196 %build
197 %configure \
198         --build=%{rust_triple} \
199         --host=%{rust_triple} \
200         --target=%{rust_triple} \
201         --libdir=%{common_libdir} \
202         --disable-codegen-tests \
203         --disable-jemalloc \
204         --disable-option-checking \
205         --disable-rpath \
206         --enable-debuginfo \
207         --enable-llvm-link-shared \
208         --enable-local-rust --local-rust-root=%{local_rust_root} \
209         --enable-vendor \
210         --llvm-root=%{_prefix} \
211         --release-channel=%{channel}
212
213 ./x.py dist
214
215 %{?with_tests:./x.py test}
216
217 %install
218 rm -rf $RPM_BUILD_ROOT
219
220 DESTDIR=$RPM_BUILD_ROOT ./x.py dist --install
221
222 # Make sure the shared libraries are in the proper libdir
223 %if "%{_libdir}" != "%{common_libdir}"
224 mkdir -p %{buildroot}%{_libdir}
225 find $RPM_BUILD_ROOT%{common_libdir} -maxdepth 1 -type f -name '*.so' \
226         -exec mv -v -t $RPM_BUILD_ROOT%{_libdir} '{}' '+'
227 %endif
228
229 # The shared libraries should be executable for debuginfo extraction.
230 find $RPM_BUILD_ROOT%{_libdir}/ -type f -name '*.so' -exec chmod -v +x '{}' '+'
231
232 # The libdir libraries are identical to those under rustlib/.  It's easier on
233 # library loading if we keep them in libdir, but we do need them in rustlib/
234 # to support dynamic linking for compiler plugins, so we'll symlink.
235 (cd "$RPM_BUILD_ROOT%{rustlibdir}/%{rust_triple}/lib" &&
236         find ../../../../%{_lib} -maxdepth 1 -name '*.so' \
237         -exec ln -v -f -s -t . '{}' '+')
238
239 # Remove installer artifacts (manifests, uninstall scripts, etc.)
240 find $RPM_BUILD_ROOT%{rustlibdir}/ -maxdepth 1 -type f -exec rm -v '{}' '+'
241
242 # FIXME: __os_install_post will strip the rlibs
243 # -- should we find a way to preserve debuginfo?
244
245 # Remove unwanted documentation files (we already package them)
246 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/README.md
247 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/COPYRIGHT
248 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-APACHE
249 %{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}/LICENSE-MIT
250
251 # Sanitize the HTML documentation
252 find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -empty -delete
253 find $RPM_BUILD_ROOT%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
254
255 # Move rust-gdb's python scripts so they're noarch
256 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
257 %{__mv} $RPM_BUILD_ROOT%{rustlibdir}/etc $RPM_BUILD_ROOT%{_datadir}/%{name}
258
259 %clean
260 rm -rf $RPM_BUILD_ROOT
261
262 %post   -p /sbin/ldconfig
263 %postun -p /sbin/ldconfig
264
265 %files
266 %defattr(644,root,root,755)
267 %doc COPYRIGHT LICENSE-APACHE LICENSE-MIT README.md src/libbacktrace/LICENSE-libbacktrace src/rt/hoedown/LICENSE-hoedown
268 %attr(755,root,root) %{_bindir}/rustc
269 %attr(755,root,root) %{_bindir}/rustdoc
270 %attr(755,root,root) %{_libdir}/libarena-*.so
271 %attr(755,root,root) %{_libdir}/libflate-*.so
272 %attr(755,root,root) %{_libdir}/libfmt_macros-*.so
273 %attr(755,root,root) %{_libdir}/libgetopts-*.so
274 %attr(755,root,root) %{_libdir}/libgraphviz-*.so
275 %attr(755,root,root) %{_libdir}/libproc_macro-*.so
276 %attr(755,root,root) %{_libdir}/libproc_macro_plugin-*.so
277 %attr(755,root,root) %{_libdir}/librustc*-*.so
278 %attr(755,root,root) %{_libdir}/librustdoc-*.so
279 %attr(755,root,root) %{_libdir}/libserialize-*.so
280 %attr(755,root,root) %{_libdir}/libstd-*.so
281 %attr(755,root,root) %{_libdir}/libsyntax-*.so
282 %attr(755,root,root) %{_libdir}/libsyntax_ext-*.so
283 %attr(755,root,root) %{_libdir}/libsyntax_pos-*.so
284 %attr(755,root,root) %{_libdir}/libterm-*.so
285 %attr(755,root,root) %{_libdir}/libtest-*.so
286 %{_mandir}/man1/rustc.1*
287 %{_mandir}/man1/rustdoc.1*
288 %dir %{rustlibdir}
289 %dir %{rustlibdir}/%{rust_triple}
290 %dir %{rustlibdir}/%{rust_triple}/lib
291 %attr(755,root,root) %{rustlibdir}/%{rust_triple}/lib/*.so
292 %{rustlibdir}/%{rust_triple}/lib/*.rlib
293
294 %files debugger-common
295 %defattr(644,root,root,755)
296 %dir %{_datadir}/%{name}
297 %dir %{_datadir}/%{name}/etc
298 %{_datadir}/%{name}/etc/debugger_*.py*
299
300 %files lldb
301 %defattr(644,root,root,755)
302 %attr(755,root,root) %{_bindir}/rust-lldb
303 %{_datadir}/%{name}/etc/lldb_*.py*
304
305 %files gdb
306 %defattr(644,root,root,755)
307 %attr(755,root,root) %{_bindir}/rust-gdb
308 %{_datadir}/%{name}/etc/gdb_*.py*
309
310 %files doc
311 %defattr(644,root,root,755)
312 %dir %{_docdir}/%{name}
313 %doc %{_docdir}/%{name}/html
This page took 0.061596 seconds and 3 git commands to generate.