]> git.pld-linux.org Git - packages/ruby.git/commitdiff
- asm fix for x32
authorJan Rękorajski <baggins@pld-linux.org>
Fri, 2 Jan 2015 14:00:37 +0000 (14:00 +0000)
committerJan Rękorajski <baggins@pld-linux.org>
Fri, 2 Jan 2015 14:00:37 +0000 (14:00 +0000)
ruby.spec
x32-asm.patch [new file with mode: 0644]

index a79ad6e24304ee3590f09f92a31d508317171101..bfc9a2dbb7a8b22cd7fa9a78b7f8327792d39f25 100644 (file)
--- a/ruby.spec
+++ b/ruby.spec
@@ -72,6 +72,7 @@ Patch7:               empty-ruby-version.patch
 Patch8:                rubygems-2.0.0-binary-extensions.patch
 Patch9:                custom-rubygems-location.patch
 Patch10:       %{oname}-posixsh.patch
+Patch11:       x32-asm.patch
 URL:           http://www.ruby-lang.org/
 BuildRequires: autoconf >= 2.60
 BuildRequires: automake
@@ -435,6 +436,7 @@ Biblioteka JSON dla języka Ruby.
 %patch8 -p1
 %patch9 -p1
 %patch10 -p1
+%patch11 -p1
 
 # must be regenerated with new bison
 %{__rm} parse.{c,h}
diff --git a/x32-asm.patch b/x32-asm.patch
new file mode 100644 (file)
index 0000000..9fb8e87
--- /dev/null
@@ -0,0 +1,16 @@
+Index: ruby1.9.1-1.9.3.484/gc.h
+===================================================================
+--- ruby1.9.1-1.9.3.484.orig/gc.h      2014-03-08 07:14:10.672333559 -0800
++++ ruby1.9.1-1.9.3.484/gc.h   2014-03-08 07:17:00.820079593 -0800
+@@ -3,7 +3,11 @@
+ #define RUBY_GC_H 1
+ #if defined(__x86_64__) && defined(__GNUC__) && !defined(__native_client__)
++#ifdef __ILP32__
++#define SET_MACHINE_STACK_END(p) __asm__ volatile ("movl\t%%esp, %0" : "=r" (*(p)))
++#else
+ #define SET_MACHINE_STACK_END(p) __asm__ volatile ("movq\t%%rsp, %0" : "=r" (*(p)))
++#endif
+ #elif defined(__i386) && defined(__GNUC__) && !defined(__native_client__)
+ #define SET_MACHINE_STACK_END(p) __asm__ volatile ("movl\t%%esp, %0" : "=r" (*(p)))
+ #else
This page took 0.115947 seconds and 4 git commands to generate.