dtrace bcond
authorJan Palus <atler@pld-linux.org>
Tue, 15 Jun 2021 12:13:07 +0000 (12:13 +0000)
committerJan Palus <atler@pld-linux.org>
Tue, 15 Jun 2021 12:13:43 +0000 (12:13 +0000)
ruby.spec

index addc701256961126b3b9ae2eb5c3d9c684d7357a..ed9eb9a2d3ff2503a35d1d07bbbe3168cd3a3d30 100644 (file)
--- a/ruby.spec
+++ b/ruby.spec
@@ -8,6 +8,7 @@
 %bcond_without doc             # skip (time-consuming) docs generating; intended for speed up test builds
 %bcond_without batteries       # Don't include rubygems, json, rake, minitest
 %bcond_without default_ruby    # use this Ruby as default system Ruby
+%bcond_without dtrace          # disable tracing with dtrace
 %bcond_with    bootstrap       # build bootstrap version
 %bcond_with    tests           # build without tests
 
@@ -75,12 +76,13 @@ BuildRequires:      openssl-devel >= 0.9.6
 BuildRequires: pkgconfig
 BuildRequires: readline-devel >= 4.2
 BuildRequires: rpm-build >= 5.4.10-49
+BuildRequires: rpmbuild(macros) >= 1.527
 # which version is minimum now? 1.8.7 is not enough, fails with:
 # ./tool/generic_erb.rb:31: syntax error, unexpected ':', expecting ')'
 # ...O.popen("tput smso", "r", err: IO::NULL, &:read) rescue nil)
 BuildRequires: ruby >= 1:1.9
 BuildRequires: sed >= 4.0
-BuildRequires: systemtap-sdt-devel
+%{?with_dtrace:BuildRequires:  systemtap-sdt-devel}
 BuildRequires: tar >= 1:1.22
 BuildRequires: xz
 BuildRequires: yaml-devel
@@ -745,6 +747,7 @@ cp -f /usr/share/automake/config.sub .
        --disable-install-doc \
        --disable-rpath \
        --disable-rubygems \
+       %{__enable_disable dtrace} \
        --with-ruby-version='' \
 
 %{__make} -j1 main \
This page took 0.10912 seconds and 4 git commands to generate.