]> git.pld-linux.org Git - packages/ruby.git/commitdiff
Revert "fix ruby.h header to allow !! which gcc 4.8 is unable to parse"
authorElan Ruusamäe <glen@delfi.ee>
Sat, 26 Jul 2014 20:22:28 +0000 (23:22 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Thu, 28 Aug 2014 18:55:37 +0000 (21:55 +0300)
do the fix in ruby-gnome2, where it's broken

This reverts commit 4fe1ce27707b7bb185b0fb265a63816a8cc80b9b.

gcc-value.patch [deleted file]
ruby.spec

diff --git a/gcc-value.patch b/gcc-value.patch
deleted file mode 100644 (file)
index f0dd9a6..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-fix compiler (gcc 4.8) errors for ruby-gnome2:
-
-rbgtkcalendar.c: In function 'rg_display_options':
-/usr/include/ruby-2.0/ruby/ruby.h:446:18: error: expected '(' before '!' token
- #define NIL_P(v) !((VALUE)(v) != Qnil)
-
-seems same error as here:
-https://github.com/shoes/shoes/issues/246
---- ruby-2.0.0-p481/include/ruby/ruby.h~       2014-07-26 21:30:04.005696992 +0300
-+++ ruby-2.0.0-p481/include/ruby/ruby.h        2014-07-26 21:30:11.189350307 +0300
-@@ -442,8 +442,8 @@
- #endif
- #define SYMBOL_FLAG RUBY_SYMBOL_FLAG
--#define RTEST(v) !(((VALUE)(v) & ~Qnil) == 0)
--#define NIL_P(v) !((VALUE)(v) != Qnil)
-+#define RTEST(v) (!(((VALUE)(v) & ~Qnil) == 0))
-+#define NIL_P(v) (!((VALUE)(v) != Qnil))
- #define CLASS_OF(v) rb_class_of((VALUE)(v))
index 3c455f7c1f745bbd03ff7223e23223eb704412f9..310f755a7150bfa58fa9868ea7e8d25750f67f93 100644 (file)
--- a/ruby.spec
+++ b/ruby.spec
@@ -16,7 +16,7 @@
 %bcond_without default_ruby    # use this Ruby as default system Ruby
 %bcond_with    bootstrap       # build bootstrap version
 
-%define                rel             2
+%define                rel             1
 %define                ruby_version    2.0
 %define                basever         2.0.0
 %define                patchlevel      481
@@ -71,7 +71,6 @@ Patch6:               DESTDIR.patch
 Patch7:                empty-ruby-version.patch
 Patch8:                rubygems-2.0.0-binary-extensions.patch
 Patch9:                custom-rubygems-location.patch
-Patch10:       gcc-value.patch
 URL:           http://www.ruby-lang.org/
 BuildRequires: autoconf >= 2.60
 BuildRequires: automake
@@ -435,7 +434,6 @@ Biblioteka JSON dla języka Ruby.
 %patch7 -p1
 %patch8 -p1
 %patch9 -p1
-%patch10 -p1
 
 # must be regenerated with new bison
 %{__rm} parse.{c,h}
This page took 0.058464 seconds and 4 git commands to generate.