]> git.pld-linux.org Git - packages/ruby.git/blob - ruby.spec
strip ccache from CC and CXX in rbconfig.rb
[packages/ruby.git] / ruby.spec
1 # TODO:
2 #       - include ext/ in docs
3 #       - replace ri with fastri
4 #       - patch ri to search multiple indexes (one per package), so RPMs can install ri docs
5 #   - fix inconsistencies with versioned vs not-versioned dirs (see dirname hacks in configure)
6 #   - custom-rubygems-location.patch
7 #
8 # Conditional build:
9 %bcond_without  doc             # skip (time-consuming) docs generating; intended for speed up test builds
10 %bcond_without  tk              # skip building package with Tk bindings
11 %bcond_without  batteries       # Don't include rubygems, json, rake, minitest
12 %bcond_with     bootstrap       # build bootstrap version
13
14 %define         rel                     4
15 %define         ruby_version    1.9
16 %define         basever         1.9.3
17 %define         patchlevel      429
18 %define         doc_version     1_9_3
19 %define         json_ver        1.5.5
20 %define         rake_ver        0.9.2.2
21 # when increasing rubygems_ver, please remove "11." prefix in rubygems package release
22 %define         rubygems_ver    1.8.11
23 %define         minitest_ver    2.5.1
24 # when increasing rdoc_ver, please remove "11." prefix in rdoc package release
25 %define         rdoc_ver        3.9.5
26 %define         bigdecimal_ver  1.1.0
27 %define         io_console_ver  0.3
28 Summary:        Ruby - interpreted scripting language
29 Summary(ja.UTF-8):      オブジェクト指向言語Rubyインタプリタ
30 Summary(pl.UTF-8):      Ruby - interpretowany język skryptowy
31 Summary(pt_BR.UTF-8):   Linguagem de script orientada a objeto
32 Summary(zh_CN.UTF-8):   ruby - 一种快速高效的面向对象脚本编程语言
33 Name:           ruby
34 Version:        %{basever}.%{patchlevel}
35 Release:        %{rel}
36 Epoch:          1
37 # Public Domain for example for: include/ruby/st.h, strftime.c, ...
38 License:        (Ruby or BSD) and Public Domain
39 Group:          Development/Languages
40 Source0:        ftp://ftp.ruby-lang.org/pub/ruby/1.9/%{name}-%{basever}-p%{patchlevel}.tar.bz2
41 # Source0-md5:  c2b2de5ef15ea9b1aaa3152f9112af1b
42 Source1:        http://www.ruby-doc.org/download/%{name}-doc-bundle.tar.gz
43 # Source1-md5:  ad1af0043be98ba1a4f6d0185df63876
44 Source2:        http://www.ruby-doc.org/downloads/%{name}_%{doc_version}_stdlib_rdocs.tgz
45 # Source2-md5:  ec622612428672c432b6f65dd31a84b5
46 Source3:        http://www.ruby-doc.org/downloads/%{name}_%{doc_version}_core_rdocs.tgz
47 # Source3-md5:  1892aadde51d36106c513bced2193dff
48 Source100:      ftp://ftp.ruby-lang.org/pub/ruby/1.8/%{name}-1.8.7-p330.tar.gz
49 # Source100-md5:        50a49edb787211598d08e756e733e42e
50 Source4:        rdoc.1
51 Source5:        testrb.1
52 Patch0:         %{name}-lib64.patch
53 Patch1:         %{name}-ffs.patch
54 Patch2:         fix-bison-invocation.patch
55 # http://redmine.ruby-lang.org/issues/5231
56 Patch3:         disable-versioned-paths.patch
57 # TODO: Should be submitted upstream?
58 Patch4:         arch-specific-dir.patch
59 # http://redmine.ruby-lang.org/issues/5281
60 Patch5:         site-and-vendor-arch-flags.patch
61 # Make mkmf verbose by default
62 Patch6:         mkmf-verbose.patch
63 Patch7:         strip-ccache.patch
64 URL:            http://www.ruby-lang.org/
65 BuildRequires:  autoconf >= 2.60
66 BuildRequires:  automake
67 BuildRequires:  bison
68 BuildRequires:  db-devel
69 BuildRequires:  gdbm-devel >= 1.8.3
70 BuildRequires:  libffi-devel
71 BuildRequires:  ncurses-devel
72 BuildRequires:  openssl-devel
73 BuildRequires:  pkgconfig
74 BuildRequires:  readline-devel >= 4.2
75 BuildRequires:  rpm-build >= 5.4.10-49
76 # boostrap needs ruby binary, erb module
77 %{!?with_bootstrap:BuildRequires:       ruby-modules}
78 %{!?with_bootstrap:BuildRequires:       ruby}
79 BuildRequires:  sed >= 4.0
80 BuildRequires:  yaml-devel
81 %if %{with tk}
82 BuildRequires:  tk-devel
83 %endif
84 Requires(post,postun):  /sbin/ldconfig
85 Provides:       ruby(ver) = %{ruby_version}
86 Obsoletes:      ruby-REXML <= 2.4.0-2
87 Obsoletes:      ruby-doc < 1.8.4
88 Obsoletes:      ruby-fastthread <= 0.6.3
89 Conflicts:      ruby-activesupport < 2.3.11-2
90 Conflicts:      ruby-activesupport2 < 2.3.11-2
91 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
92
93 %define ruby_ridir              %{_datadir}/ri/%{ruby_version}/system
94 %define gem_dir                 %{_datadir}/%{name}/gems/%{ruby_version}
95
96 # The RubyGems library has to stay out of Ruby directory three, since the
97 # RubyGems should be share by all Ruby implementations.
98 %define rubygems_dir            %{_datadir}/rubygems
99
100 %define ruby_archdir            %{_libdir}/%{name}/%{ruby_version}
101 %define ruby_libdir             %{_datadir}/%{name}/%{ruby_version}
102
103 # This is the local lib/arch and should not be used for packaging.
104 %define sitedir                 site_ruby
105 %define ruby_sitedir            %{_prefix}/local/share/%{name}/%{sitedir}
106 %define ruby_sitearchdir        %{_prefix}/local/%{_lib}/%{name}/%{sitedir}/%{ruby_version}
107 %define ruby_sitelibdir         %{_prefix}/local/share/%{name}/%{sitedir}/%{ruby_version}
108
109 # This is the general location for libs/archs compatible with all
110 # or most of the Ruby versions available in the PLD repositories.
111 %define vendordir               vendor_ruby
112 %define ruby_vendordir          %{_datadir}/%{name}/%{vendordir}
113 %define ruby_vendorarchdir      %{_libdir}/%{name}/%{vendordir}/%{ruby_version}
114 %define ruby_vendorlibdir       %{_datadir}/%{name}/%{vendordir}/%{ruby_version}
115
116 # TODO: drop legacy loadpaths after all ruby modules rebuilt in Th
117 %define legacy_libdir           %{_libdir}/%{name}/%{ruby_version}
118 %define legacy_archdir          %{_libdir}/%{name}/%{ruby_version}/%{_target_cpu}-linux
119 %define legacy_sitedir          %{_libdir}/%{name}/%{sitedir}
120 %define legacy_sitelibdir       %{_libdir}/%{name}/%{sitedir}/%{ruby_version}
121 %define legacy_sitearchdir      %{_libdir}/%{name}/%{sitedir}/%{ruby_version}/%{_target_cpu}-linux
122 %define legacy_vendordir        %{_libdir}/%{name}/%{vendordir}
123 %define legacy_vendorlibdir     %{_libdir}/%{name}/%{vendordir}/%{ruby_version}
124 %define legacy_vendorarchdir    %{_libdir}/%{name}/%{vendordir}/%{ruby_version}/%{_target_cpu}-linux
125
126 %define legacy_siteloadpath     %{legacy_sitelibdir}\\0%{legacy_sitearchdir}\\0%{legacy_sitedir}
127 %define legacy_vendorloadpath   %{legacy_vendorarchdir}
128 %define legacy_loadpath         %{legacy_archdir}
129 %define legacy_loadpaths        %{legacy_siteloadpath}\\0%{legacy_vendorloadpath}\\0%{legacy_loadpath}
130
131 # bleh, some nasty (gcc or ruby) bug still not fixed
132 # (SEGV or "unexpected break" on miniruby run during build)
133 %define         specflags_ia64  -O0
134
135 # ruby needs frame pointers for correct exception handling
136 %define         specflags_ia32  -fno-omit-frame-pointer
137
138 %description
139 Ruby is the interpreted scripting language for quick and easy
140 object-oriented programming. It has many features to process text
141 files and to do system management tasks (as in Perl). It is simple,
142 straight-forward, extensible, and portable.
143
144 This package contains only shared library and ruby interpreter. To get
145 full-functional ruby environment install ruby-modules package.
146
147 %description -l ja.UTF-8
148 Rubyはシンプルかつ強力なオブジェクト指向スクリプト言語です.Rubyは最初
149 から純粋なオブジェクト指向言語として設計されていますから,オブジェクト
150 指向プログラミングを手軽に行う事が出来ます.もちろん通常の手続き型のプ ログラミングも可能です.
151
152 %description -l pl.UTF-8
153 Ruby to interpretowany język skryptowy, w sam raz dla łatwego i
154 szybkiego pisania zorientowanych obiektowo programów. Ma wiele funkcji
155 ułatwiających przetwarzanie plików tekstowych i wykonywanie prac
156 związanych z zarządzaniem systemu (podobnie jak Perl). Jest prosty,
157 rozszerzalny i przenośny.
158
159 Ten pakiet zawiera tylko bibliotekę dzieloną i interpreter ruby.
160 Zainstaluj pakiet ruby-modules, jeżeli potrzebujesz w pełni
161 funkcjonalnego środowiska ruby.
162
163 %description -l pt_BR.UTF-8
164 Ruby é uma linguagem de script interpretada de programação orientada a
165 objeto. Possui diversas características para processamento de texto. É
166 simples, extensível e direta.
167
168 %package modules
169 Summary:        Ruby standard modules and utilities
170 Summary(pl.UTF-8):      Standardowe moduły i narzędzia dla języka Ruby
171 Group:          Development/Languages
172 Requires:       %{name} = %{epoch}:%{version}-%{release}
173 Suggests:       ruby-rubygems
174 Provides:       ruby-bigdecimal = %{bigdecimal_ver}
175 Provides:       ruby-io-console = %{io_console_ver}
176 # ruby-modules deprecated, rpm5 generates ruby(abi) itself
177 Provides:       ruby-modules(ver) = %{ruby_version}
178 %if %{with batteries}
179 Provides:       ruby-minitest = %{minitest_ver}
180 Obsoletes:      ruby-minitest <= 1.5.0
181 %endif
182
183 %description modules
184 Ruby standard modules and utilities:
185 - erb - Tiny eRuby
186 - irb - interactive Ruby
187 - testrb - automatic runner for Test::Unit of Ruby
188
189 %description modules -l pl.UTF-8
190 Standardowe moduły i narzędzia Ruby:
191 - erb - mały eRuby
192 - irb - interaktywny Ruby
193 - testrb - automatyczny runner dla Ruby Test::Unit
194
195 %package tk
196 Summary:        Ruby/Tk bindings
197 Summary(pl.UTF-8):      Wiązania Ruby/Tk
198 Group:          Development/Languages
199 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
200
201 %description tk
202 This pachage contains Ruby/Tk bindings.
203
204 %description tk -l pl.UTF-8
205 Ten pakiet zawiera wiązania Ruby/Tk.
206
207 %package devel
208 Summary:        Ruby development libraries
209 Summary(pl.UTF-8):      Biblioteki programistyczne interpretera języka Ruby
210 Group:          Development/Languages
211 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
212 Requires:       gcc
213 Requires:       glibc-devel
214 Requires:       pkgconfig
215
216 %description devel
217 Ruby development libraries.
218
219 %description devel -l pl.UTF-8
220 Biblioteki programistyczne interpretera języka Ruby.
221
222 %package static
223 Summary:        Ruby static libraries
224 Summary(pl.UTF-8):      Biblioteki statyczne Ruby
225 Group:          Development/Languages
226 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
227
228 %description static
229 Ruby static libraries.
230
231 %description static -l pl.UTF-8
232 Biblioteki statyczne Ruby.
233
234 %package doc
235 Summary:        Ruby HTML documentation
236 Summary(pl.UTF-8):      Dokumentacja HTML do Ruby
237 Group:          Documentation
238 %if "%{_rpmversion}" >= "5"
239 BuildArch:      noarch
240 %endif
241
242 %description doc
243 Ruby HTML documentation: FAQ, guide, core and standard library.
244
245 %description doc -l pl.UTF-8
246 Dokumentacja HTML do Ruby: FAQ, przewodnik, dokumentacja dla core i
247 stdlib.
248
249 %package doc-ri
250 Summary:        Ruby ri documentation
251 Summary(pl.UTF-8):      Dokumentacja Ruby w formacie ri
252 Group:          Documentation
253 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
254 %if "%{_rpmversion}" >= "5"
255 BuildArch:      noarch
256 %endif
257
258 %description doc-ri
259 Ruby ri documentation.
260
261 %description doc-ri -l pl.UTF-8
262 Dokumentacja Ruby w formacie ri.
263
264 %package examples
265 Summary:        Ruby examples
266 Summary(pl.UTF-8):      Przykłady dla języka Ruby
267 Group:          Development/Languages
268 %if "%{_rpmversion}" >= "5"
269 BuildArch:      noarch
270 %endif
271
272 %description examples
273 Ruby examples.
274
275 %description examples -l pl.UTF-8
276 Przykłady programów w języku Ruby.
277
278 # IMPORTANT: keep rdoc, rubygems, rake, json as last packages as we reset epoch/version/release
279 # and %{version},%{release} macros may not be used directly as they take last
280 # subpackage value not main package one what you intend to use
281
282 %package rdoc
283 Summary:        A tool to generate HTML and command-line documentation for Ruby projects
284 Summary(pl.UTF-8):      Narzędzie do generowania dokumentacji HTML i linii poleceń dla projektów w Rubym
285 Version:        %{rdoc_ver}
286 # remove "11." when rdoc_ver is increased
287 Release:        11.%{basever}.%{patchlevel}.%{rel}
288 Epoch:          0
289 License:        GPL v2 and Ruby and MIT
290 Group:          Development/Libraries
291 Requires:       %{name}-modules = 1:%{basever}.%{patchlevel}-%{rel}
292 Obsoletes:      rdoc <= 0.9.0
293 %if "%{_rpmversion}" >= "5"
294 BuildArch:      noarch
295 %endif
296
297 %description rdoc
298 RDoc produces HTML and command-line documentation for Ruby projects.
299 RDoc includes the 'rdoc' and 'ri' tools for generating and displaying
300 online documentation.
301
302 %description rdoc -l pl.UTF-8
303 RDoc tworzy dokumentację HTML i linii poleceń dla projektów w języku
304 Ruby. RDoc zawiera narzędzia 'rdoc' i 'ri' do generowania i
305 wyświetlania dokumentacji online.
306
307 %package rubygems
308 Summary:        RubyGems - the Ruby standard for packaging Ruby libraries
309 Summary(pl.UTF-8):      RubyGems - standard Ruby'ego pakietowania bibliotek
310 Version:        %{rubygems_ver}
311 # remove "11." when rubygems_ver is increased
312 Release:        11.%{basever}.%{patchlevel}.%{rel}
313 Epoch:          0
314 License:        Ruby or MIT
315 Group:          Development/Libraries
316 Requires:       %{name}-modules = 1:%{basever}.%{patchlevel}-%{rel}
317 Requires:       %{name}-rdoc >= %{rdoc_ver}
318 Suggests:       %{name}-devel
319 Provides:       rubygems = %{rubygems_ver}
320 %if "%{_rpmversion}" >= "5"
321 BuildArch:      noarch
322 %endif
323
324 %description rubygems
325 RubyGems is the Ruby standard for publishing and managing third party
326 libraries.
327
328 %description rubygems -l pl.UTF-8
329 RubyGems to standardowe narzędzie języka Ruby do publikowania i
330 zarządzania zewnętrznymi bibliotekami.
331
332 %package rake
333 Summary:        Rake is a Make-like program implemented in Ruby
334 Summary(pl.UTF-8):      Program typu Make dla języka Ruby
335 Version:        %{rake_ver}
336 Release:        %{basever}.%{patchlevel}.%{rel}
337 Epoch:          0
338 License:        MIT
339 Group:          Development/Languages
340 Provides:       rake = %{rake_ver}
341 %if "%{_rpmversion}" >= "5"
342 BuildArch:      noarch
343 %endif
344
345 %description rake
346 Rake is a simple Ruby build program with capabilities similar to make.
347
348 It has the following features:
349 - Rakefiles (rake's version of Makefiles) are completely defined in
350   standard Ruby syntax. No XML files to edit. No quirky Makefile syntax
351   to worry about (is that a tab or a space?)
352 - Users can specify tasks with prerequisites.
353 - Rake supports rule patterns to synthesize implicit tasks.
354 - Rake is lightweight. It can be distributed with other projects as a
355   single file. Projects that depend upon rake do not require that rake
356   be installed on target systems.
357
358 %description rake -l pl.UTF-8
359 Rake to prosty program do budowania w języku Ruby o możliwościach
360 podobnych do make.
361
362 Ma następujące cechy:
363 - Pliki Rakefile (rake'owa odmiana plików Makefile) są definiowane
364   całkowicie w standardowej składni języka Ruby. Nie trzeba modyfikować
365   plików XML. Nie trzeba martwić się kaprysami składni Makefile (czy to
366   tabulacja czy spacja?).
367 - Użytkownicy mogą określać zadania z ich zależnościami.
368 - Rake obsługuje wzorce reguł do tworzenia z nich wynikowych zadań.
369 - Rake jest lekki. Może być rozpowszechniany z innymi projektami jako
370   pojedynczy plik. Projekty używające rake'a nie wymagają go
371   zainstalowanego na systemach docelowych.
372
373 %package json
374 Summary:        JSON library for Ruby
375 Summary(pl.UTF-8):      Biblioteka JSON dla języka Ruby
376 Version:        %{json_ver}
377 Release:        %{basever}.%{patchlevel}.%{rel}
378 Epoch:          0
379 License:        MIT
380 Group:          Development/Languages
381 Obsoletes:      ruby-json-rubyforge
382
383 %description json
384 This is a JSON implementation as a Ruby extension in C.
385
386 %description json -l pl.UTF-8
387 Biblioteka JSON dla języka Ruby.
388
389 %prep
390 %if %{with bootstrap}
391 %setup -q -n %{name}-%{basever}-p%{patchlevel} -a1 -a2 -a3 -a100
392 %else
393 %setup -q -n %{name}-%{basever}-p%{patchlevel} -a1 -a2 -a3
394 %endif
395 %patch0 -p1
396 %patch1 -p1
397 %patch2 -p1
398 %patch3 -p1
399 %patch4 -p1
400 %patch5 -p1
401 %patch6 -p1
402 %patch7 -p1
403
404 # must be regenerated with new bison
405 %{__rm} parse.{c,h}
406
407 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
408
409 find -type f '(' -name '*.rb' -o -name '*.cgi' -o -name '*.test' \
410         -o -name 'ruby.1' -o -name '*.html' -o -name '*.tcl' ')' \
411         | xargs %{__sed} -i 's,/usr/local/bin/,%{_bindir}/,'
412
413 %build
414 cp -f /usr/share/automake/config.sub .
415
416 # build ruby-1.8.7 first
417 %if %{with bootstrap}
418 cd %{name}-1.8.7-p330
419 %configure
420 %{__make}
421 cd ..
422 %endif
423
424 %{__autoconf}
425 %configure \
426         %{?with_bootstrap:--with-baseruby=%{name}-1.8.7-p330/miniruby} \
427         --with-rubylibprefix=%(dirname %{ruby_libdir}) \
428         --with-archdir=%{ruby_archdir} \
429         --with-sitedir=%(dirname %{ruby_sitelibdir}) \
430         --with-sitearchdir=%{ruby_sitearchdir} \
431         --with-vendordir=%(dirname %{ruby_vendorlibdir}) \
432         --with-vendorarchdir=%{ruby_vendorarchdir} \
433         --with-rubygemsdir=%{rubygems_dir} \
434         --with-search-path="%{legacy_loadpaths}" \
435         --enable-shared \
436         --enable-pthread \
437         --disable-rubygems \
438         --disable-install-doc \
439         --with-ruby-version=minor
440
441 %{__make} -j1 main \
442         COPY="cp -p" Q= \
443         %{?with_bootstrap:BASERUBY="ruby-1.8.7-p330/miniruby -I./ruby-1.8.7-p330/lib"}
444
445 %if %{with doc}
446 %{__make} -j1 rdoc
447 %endif
448
449 %install
450 rm -rf $RPM_BUILD_ROOT
451 install -d $RPM_BUILD_ROOT{%{ruby_rdocdir},%{_examplesdir}/%{name}-%{version}} \
452         $RPM_BUILD_ROOT{%{ruby_vendorarchdir},%{ruby_ridir}} \
453         $RPM_BUILD_ROOT%{ruby_vendorlibdir}/net \
454         $RPM_BUILD_ROOT{%{legacy_archdir}/racc,%{legacy_sitelibdir},%{legacy_sitearchdir},%{legacy_vendorarchdir},%{legacy_libdir}/tasks} \
455
456 %{__make} install %{?with_doc:install-doc} \
457         DESTDIR=$RPM_BUILD_ROOT
458
459 cp -Rf sample/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
460 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_mandir}/man1
461 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_mandir}/man1
462
463 %{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}/html
464
465 ln -sf %{gem_dir}/gems/rake-%{rake_ver}/bin/rake $RPM_BUILD_ROOT%{_bindir}/rake
466
467 %if %{without batteries}
468 # packaged separately
469 %{__rm} -r $RPM_BUILD_ROOT%{ruby_libdir}/{rubygems,rake,json,minitest}
470 %{__rm} -r $RPM_BUILD_ROOT%{ruby_archdir}/json
471 %{__rm} -r $RPM_BUILD_ROOT%{gem_dir}/gems/rake-*
472 %{__rm} $RPM_BUILD_ROOT%{ruby_libdir}/{rake,rubygems,json}.rb
473 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{gem,rake}
474 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/rake*
475 %{__rm} $RPM_BUILD_ROOT%{gem_dir}/specifications/{json,minitest,rake}-*.gemspec
476 %{?with_doc:%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/ri/%{ruby_version}/system/JSON}
477 %endif
478
479 %if %{with doc}
480 # too much .ri
481 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/cache.ri
482 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/created.rid
483 %endif
484
485 %clean
486 rm -rf $RPM_BUILD_ROOT
487
488 %post   -p /sbin/ldconfig
489 %postun -p /sbin/ldconfig
490
491 %files
492 %defattr(644,root,root,755)
493 %doc NEWS LEGAL README README.EXT ChangeLog ToDo
494 %attr(755,root,root) %{_bindir}/ruby
495 %attr(755,root,root) %{_libdir}/libruby.so.*.*.*
496 %attr(755,root,root) %ghost %{_libdir}/libruby.so.1.9
497 %{_mandir}/man1/ruby.1*
498
499 %dir %{_libdir}/%{name}
500 %dir %{_libdir}/%{name}/%{vendordir}
501 %dir %{_datadir}/%{name}
502 %dir %{_datadir}/%{name}/%{vendordir}
503
504 %dir %{ruby_libdir}
505 %dir %{ruby_archdir}
506 %dir %{ruby_vendorlibdir}
507 %dir %{ruby_vendorarchdir}
508
509 %dir %{_datadir}/ri
510 %dir %{_datadir}/ri/%{ruby_version}
511 %dir %{ruby_ridir}
512
513 %dir %{ruby_rdocdir}
514
515 # common dirs for ruby vendor modules
516 %dir %{ruby_vendorlibdir}/net
517
518 # legacy dirs. when everything rebuilt in Th not using these dirs. drop them
519 %dir %{legacy_archdir}
520 %dir %{legacy_sitedir}
521 %dir %{legacy_sitelibdir}
522 %dir %{legacy_sitearchdir}
523 %dir %{legacy_vendorarchdir}
524 %dir %{legacy_libdir}/tasks
525 %dir %{legacy_archdir}/racc
526
527 %files devel
528 %defattr(644,root,root,755)
529 %attr(755,root,root) %{_libdir}/libruby.so
530 %{_includedir}/%{name}-%{ruby_version}
531 %{_pkgconfigdir}/ruby-%{ruby_version}.pc
532 %{ruby_libdir}/mkmf.rb
533
534 %files static
535 %defattr(644,root,root,755)
536 %{_libdir}/libruby-static.a
537
538 %if %{with tk}
539 %files tk
540 %defattr(644,root,root,755)
541 %{ruby_libdir}/tcltk.rb
542 %{ruby_libdir}/tk*.rb
543 %{ruby_libdir}/tk
544 %{ruby_libdir}/tkextlib
545 %attr(755,root,root) %{ruby_archdir}/t*.so
546 %endif
547
548 %files rdoc
549 %defattr(644,root,root,755)
550 %attr(755,root,root) %{_bindir}/rdoc
551 %attr(755,root,root) %{_bindir}/ri
552 %{_mandir}/man1/rdoc.1*
553 %{ruby_libdir}/rdoc
554 %dir %{gem_dir}/gems/rdoc-%{rdoc_ver}
555 %dir %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin
556 %attr(755,root,root) %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin/rdoc
557 %{gem_dir}/specifications/rdoc-%{rdoc_ver}.gemspec
558 %attr(755,root,root) %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin/ri
559
560 %if %{with batteries}
561 %files rubygems
562 %defattr(644,root,root,755)
563 %attr(755,root,root) %{_bindir}/gem
564 %{ruby_libdir}/rubygems
565 %{ruby_libdir}/rubygems.rb
566 %{ruby_libdir}/ubygems.rb
567
568 %files rake
569 %defattr(644,root,root,755)
570 %attr(755,root,root) %{_bindir}/rake
571 %{_mandir}/man1/rake.1*
572 %{ruby_libdir}/rake
573 %dir %{gem_dir}/gems/rake-%{rake_ver}
574 %dir %{gem_dir}/gems/rake-%{rake_ver}/bin
575 %attr(755,root,root) %{gem_dir}/gems/rake-%{rake_ver}/bin/rake
576 %{gem_dir}/specifications/rake-%{rake_ver}.gemspec
577
578 %files json
579 %defattr(644,root,root,755)
580 %{ruby_libdir}/json
581 %dir %{ruby_archdir}/json
582 %dir %{ruby_archdir}/json/ext
583 %attr(755,root,root) %{ruby_archdir}/json/ext/*.so
584 %{gem_dir}/specifications/json-%{json_ver}.gemspec
585 %endif
586
587 %files modules
588 %defattr(644,root,root,755)
589 %attr(755,root,root) %{_bindir}/erb
590 %attr(755,root,root) %{_bindir}/irb
591 %attr(755,root,root) %{_bindir}/testrb
592 %{ruby_libdir}/bigdecimal
593 %{ruby_libdir}/cgi
594 %{ruby_libdir}/date
595 %{ruby_libdir}/digest
596 %{ruby_libdir}/dl
597 %{ruby_libdir}/drb
598 %{ruby_libdir}/fiddle
599 %{ruby_libdir}/io
600 %{ruby_libdir}/irb
601 %{ruby_libdir}/matrix
602 %{ruby_libdir}/net
603 %{ruby_libdir}/openssl
604 %{ruby_libdir}/optparse
605 %{ruby_libdir}/psych
606 %{ruby_libdir}/racc
607 %{ruby_libdir}/rbconfig
608 %{ruby_libdir}/rexml
609 %{ruby_libdir}/rinda
610 %{ruby_libdir}/ripper
611 %{ruby_libdir}/rss
612 %{ruby_libdir}/shell
613 %{ruby_libdir}/syck
614 %{ruby_libdir}/test
615 %{ruby_libdir}/uri
616 %{ruby_libdir}/webrick
617 %{ruby_libdir}/xmlrpc
618 %{ruby_libdir}/yaml
619 %{ruby_libdir}/[A-Za-s]*.rb
620 %{ruby_libdir}/tempfile.rb
621 %{ruby_libdir}/thread.rb
622 %{ruby_libdir}/thwait.rb
623 %{ruby_libdir}/time.rb
624 %{ruby_libdir}/timeout.rb
625 %{ruby_libdir}/tmpdir.rb
626 %{ruby_libdir}/tracer.rb
627 %{ruby_libdir}/tsort.rb
628 %{ruby_libdir}/[u-z]*.rb
629 %if %{with batteries}
630 %exclude %{ruby_libdir}/rubygems.rb
631 %exclude %{ruby_libdir}/ubygems.rb
632 %endif
633 %exclude %{ruby_libdir}/mkmf.rb
634 %attr(755,root,root) %{ruby_archdir}/[a-s]*.so
635 %attr(755,root,root) %{ruby_archdir}/[u-z]*.so
636 %dir %{ruby_archdir}/digest
637 %attr(755,root,root) %{ruby_archdir}/digest/*.so
638 %dir %{ruby_archdir}/dl
639 %attr(755,root,root) %{ruby_archdir}/dl/callback.so
640 %dir %{ruby_archdir}/enc
641 %attr(755,root,root) %{ruby_archdir}/enc/*.so
642 %dir %{ruby_archdir}/enc/trans
643 %attr(755,root,root) %{ruby_archdir}/enc/trans/*.so
644 %dir %{ruby_archdir}/io
645 %attr(755,root,root) %{ruby_archdir}/io/*.so
646 %dir %{ruby_archdir}/mathn
647 %attr(755,root,root) %{ruby_archdir}/mathn/*.so
648 %dir %{ruby_archdir}/racc
649 %attr(755,root,root) %{ruby_archdir}/racc/*.so
650 %{ruby_archdir}/rbconfig.rb
651
652 %{gem_dir}/specifications/bigdecimal-%{bigdecimal_ver}.gemspec
653 %{gem_dir}/specifications/io-console-%{io_console_ver}.gemspec
654
655 %if %{with batteries}
656 # minitest
657 %{ruby_libdir}/minitest
658 %{gem_dir}/specifications/minitest-%{minitest_ver}.gemspec
659 %endif
660
661 # parents of gem_dir
662 %dir %{_datadir}/%{name}/gems
663 #%dir %{_datadir}/%{name}/gems/%{ruby_version}
664 %dir %{_datadir}/%{name}/gems/%{ruby_version}/gems
665
666 %dir %{gem_dir}
667 %dir %{gem_dir}/specifications
668 %{_mandir}/man1/erb.1*
669 %{_mandir}/man1/irb.1*
670 %{_mandir}/man1/ri.1*
671 %{_mandir}/man1/testrb.1*
672
673 %files doc
674 %defattr(644,root,root,755)
675 %doc ruby-doc-bundle/*
676 %{?with_doc:%doc ruby_%{doc_version}_stdlib}
677 %{?with_doc:%doc ruby_%{doc_version}_core}
678
679 %if %{with doc}
680 %files doc-ri
681 %defattr(644,root,root,755)
682 %{ruby_ridir}/*
683 %endif
684
685 %files examples
686 %defattr(644,root,root,755)
687 %{_examplesdir}/%{name}-%{version}
This page took 0.291364 seconds and 4 git commands to generate.