]> git.pld-linux.org Git - packages/ruby.git/blob - ruby.spec
package %{ruby_vendordir}/data
[packages/ruby.git] / ruby.spec
1 # TODO:
2 #       - include ext/ in docs
3 #       - replace ri with fastri
4 #       - patch ri to search multiple indexes (one per package), so RPMs can install ri docs
5 #   - fix inconsistencies with versioned vs not-versioned dirs (see dirname hacks in configure)
6 #   - custom-rubygems-location.patch
7 #
8 # Conditional build:
9 %bcond_without  doc             # skip (time-consuming) docs generating; intended for speed up test builds
10 %bcond_without  tk              # skip building package with Tk bindings
11 %bcond_without  batteries       # Don't include rubygems, json, rake, minitest
12 %bcond_with     bootstrap       # build bootstrap version
13
14 %define         rel             2
15 %define         ruby_version    1.9
16 %define         basever         1.9.3
17 %define         patchlevel      448
18 %define         doc_version     1_9_3
19 %define         json_ver        1.5.5
20 %define         rake_ver        0.9.2.2
21 # when increasing rubygems_ver, please remove "11." prefix in rubygems package release
22 %define         rubygems_ver    1.8.11
23 %define         minitest_ver    2.5.1
24 # when increasing rdoc_ver, please remove "11." prefix in rdoc package release
25 %define         rdoc_ver        3.9.5
26 %define         bigdecimal_ver  1.1.0
27 %define         io_console_ver  0.3
28 Summary:        Ruby - interpreted scripting language
29 Summary(ja.UTF-8):      オブジェクト指向言語Rubyインタプリタ
30 Summary(pl.UTF-8):      Ruby - interpretowany język skryptowy
31 Summary(pt_BR.UTF-8):   Linguagem de script orientada a objeto
32 Summary(zh_CN.UTF-8):   ruby - 一种快速高效的面向对象脚本编程语言
33 Name:           ruby
34 Version:        %{basever}.%{patchlevel}
35 Release:        %{rel}
36 Epoch:          1
37 # Public Domain for example for: include/ruby/st.h, strftime.c, ...
38 License:        (Ruby or BSD) and Public Domain
39 Group:          Development/Languages
40 Source0:        ftp://ftp.ruby-lang.org/pub/ruby/1.9/%{name}-%{basever}-p%{patchlevel}.tar.bz2
41 # Source0-md5:  aa710d386e5903f78f0231868255e6af
42 Source1:        http://www.ruby-doc.org/download/%{name}-doc-bundle.tar.gz
43 # Source1-md5:  ad1af0043be98ba1a4f6d0185df63876
44 Source2:        http://www.ruby-doc.org/downloads/%{name}_%{doc_version}_stdlib_rdocs.tgz
45 # Source2-md5:  ec622612428672c432b6f65dd31a84b5
46 Source3:        http://www.ruby-doc.org/downloads/%{name}_%{doc_version}_core_rdocs.tgz
47 # Source3-md5:  1892aadde51d36106c513bced2193dff
48 Source100:      ftp://ftp.ruby-lang.org/pub/ruby/1.8/%{name}-1.8.7-p330.tar.gz
49 # Source100-md5:        50a49edb787211598d08e756e733e42e
50 Source4:        rdoc.1
51 Source5:        testrb.1
52 Patch0:         %{name}-lib64.patch
53 Patch1:         %{name}-ffs.patch
54 Patch2:         fix-bison-invocation.patch
55 # http://redmine.ruby-lang.org/issues/5231
56 Patch3:         disable-versioned-paths.patch
57 # TODO: Should be submitted upstream?
58 Patch4:         arch-specific-dir.patch
59 # http://redmine.ruby-lang.org/issues/5281
60 Patch5:         site-and-vendor-arch-flags.patch
61 # Make mkmf verbose by default
62 Patch6:         mkmf-verbose.patch
63 Patch7:         strip-ccache.patch
64 Patch8:         bison3.patch
65 URL:            http://www.ruby-lang.org/
66 BuildRequires:  autoconf >= 2.60
67 BuildRequires:  automake
68 BuildRequires:  bison >= 1.875
69 BuildRequires:  db-devel
70 BuildRequires:  gdbm-devel >= 1.8.3
71 BuildRequires:  libffi-devel
72 BuildRequires:  ncurses-devel
73 BuildRequires:  openssl-devel
74 BuildRequires:  pkgconfig
75 BuildRequires:  readline-devel >= 4.2
76 BuildRequires:  rpm-build >= 5.4.10-49
77 # boostrap needs ruby binary, erb module
78 %{!?with_bootstrap:BuildRequires:       ruby-modules}
79 %{!?with_bootstrap:BuildRequires:       ruby}
80 BuildRequires:  sed >= 4.0
81 BuildRequires:  yaml-devel
82 %if %{with tk}
83 BuildRequires:  tk-devel
84 %endif
85 Requires(post,postun):  /sbin/ldconfig
86 Provides:       ruby(ver) = %{ruby_version}
87 Obsoletes:      ruby-REXML <= 2.4.0-2
88 Obsoletes:      ruby-doc < 1.8.4
89 Obsoletes:      ruby-fastthread <= 0.6.3
90 Conflicts:      ruby-activesupport < 2.3.11-2
91 Conflicts:      ruby-activesupport2 < 2.3.11-2
92 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
93
94 %define ruby_ridir              %{_datadir}/ri/%{ruby_version}/system
95 %define gem_dir                 %{_datadir}/%{name}/gems/%{ruby_version}
96
97 # The RubyGems library has to stay out of Ruby directory three, since the
98 # RubyGems should be share by all Ruby implementations.
99 %define rubygems_dir            %{_datadir}/rubygems
100
101 %define ruby_archdir            %{_libdir}/%{name}/%{ruby_version}
102 %define ruby_libdir             %{_datadir}/%{name}/%{ruby_version}
103
104 # This is the local lib/arch and should not be used for packaging.
105 %define sitedir                 site_ruby
106 %define ruby_sitedir            %{_prefix}/local/share/%{name}/%{sitedir}
107 %define ruby_sitearchdir        %{_prefix}/local/%{_lib}/%{name}/%{sitedir}/%{ruby_version}
108 %define ruby_sitelibdir         %{_prefix}/local/share/%{name}/%{sitedir}/%{ruby_version}
109
110 # This is the general location for libs/archs compatible with all
111 # or most of the Ruby versions available in the PLD repositories.
112 %define vendordir               vendor_ruby
113 %define ruby_vendordir          %{_datadir}/%{name}/%{vendordir}
114 %define ruby_vendorarchdir      %{_libdir}/%{name}/%{vendordir}/%{ruby_version}
115 %define ruby_vendorlibdir       %{_datadir}/%{name}/%{vendordir}/%{ruby_version}
116
117 # TODO: drop legacy loadpaths after all ruby modules rebuilt in Th
118 %define legacy_libdir           %{_libdir}/%{name}/%{ruby_version}
119 %define legacy_archdir          %{_libdir}/%{name}/%{ruby_version}/%{_target_cpu}-linux
120 %define legacy_sitedir          %{_libdir}/%{name}/%{sitedir}
121 %define legacy_sitelibdir       %{_libdir}/%{name}/%{sitedir}/%{ruby_version}
122 %define legacy_sitearchdir      %{_libdir}/%{name}/%{sitedir}/%{ruby_version}/%{_target_cpu}-linux
123 %define legacy_vendordir        %{_libdir}/%{name}/%{vendordir}
124 %define legacy_vendorlibdir     %{_libdir}/%{name}/%{vendordir}/%{ruby_version}
125 %define legacy_vendorarchdir    %{_libdir}/%{name}/%{vendordir}/%{ruby_version}/%{_target_cpu}-linux
126
127 %define legacy_siteloadpath     %{legacy_sitelibdir}\\0%{legacy_sitearchdir}\\0%{legacy_sitedir}
128 %define legacy_vendorloadpath   %{legacy_vendorarchdir}
129 %define legacy_loadpath         %{legacy_archdir}
130 %define legacy_loadpaths        %{legacy_siteloadpath}\\0%{legacy_vendorloadpath}\\0%{legacy_loadpath}
131
132 # bleh, some nasty (gcc or ruby) bug still not fixed
133 # (SEGV or "unexpected break" on miniruby run during build)
134 %define         specflags_ia64  -O0
135
136 # ruby needs frame pointers for correct exception handling
137 %define         specflags_ia32  -fno-omit-frame-pointer
138
139 %description
140 Ruby is the interpreted scripting language for quick and easy
141 object-oriented programming. It has many features to process text
142 files and to do system management tasks (as in Perl). It is simple,
143 straight-forward, extensible, and portable.
144
145 This package contains only shared library and ruby interpreter. To get
146 full-functional ruby environment install ruby-modules package.
147
148 %description -l ja.UTF-8
149 Rubyはシンプルかつ強力なオブジェクト指向スクリプト言語です.Rubyは最初
150 から純粋なオブジェクト指向言語として設計されていますから,オブジェクト
151 指向プログラミングを手軽に行う事が出来ます.もちろん通常の手続き型のプ ログラミングも可能です.
152
153 %description -l pl.UTF-8
154 Ruby to interpretowany język skryptowy, w sam raz dla łatwego i
155 szybkiego pisania zorientowanych obiektowo programów. Ma wiele funkcji
156 ułatwiających przetwarzanie plików tekstowych i wykonywanie prac
157 związanych z zarządzaniem systemu (podobnie jak Perl). Jest prosty,
158 rozszerzalny i przenośny.
159
160 Ten pakiet zawiera tylko bibliotekę dzieloną i interpreter ruby.
161 Zainstaluj pakiet ruby-modules, jeżeli potrzebujesz w pełni
162 funkcjonalnego środowiska ruby.
163
164 %description -l pt_BR.UTF-8
165 Ruby é uma linguagem de script interpretada de programação orientada a
166 objeto. Possui diversas características para processamento de texto. É
167 simples, extensível e direta.
168
169 %package modules
170 Summary:        Ruby standard modules and utilities
171 Summary(pl.UTF-8):      Standardowe moduły i narzędzia dla języka Ruby
172 Group:          Development/Languages
173 Requires:       %{name} = %{epoch}:%{version}-%{release}
174 Suggests:       ruby-rubygems
175 Provides:       ruby-bigdecimal = %{bigdecimal_ver}
176 Provides:       ruby-io-console = %{io_console_ver}
177 # ruby-modules deprecated, rpm5 generates ruby(abi) itself
178 Provides:       ruby-modules(ver) = %{ruby_version}
179 %if %{with batteries}
180 Provides:       ruby-minitest = %{minitest_ver}
181 Obsoletes:      ruby-minitest <= 1.5.0
182 %endif
183
184 %description modules
185 Ruby standard modules and utilities:
186 - erb - Tiny eRuby
187 - irb - interactive Ruby
188 - testrb - automatic runner for Test::Unit of Ruby
189
190 %description modules -l pl.UTF-8
191 Standardowe moduły i narzędzia Ruby:
192 - erb - mały eRuby
193 - irb - interaktywny Ruby
194 - testrb - automatyczny runner dla Ruby Test::Unit
195
196 %package tk
197 Summary:        Ruby/Tk bindings
198 Summary(pl.UTF-8):      Wiązania Ruby/Tk
199 Group:          Development/Languages
200 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
201
202 %description tk
203 This pachage contains Ruby/Tk bindings.
204
205 %description tk -l pl.UTF-8
206 Ten pakiet zawiera wiązania Ruby/Tk.
207
208 %package devel
209 Summary:        Ruby development libraries
210 Summary(pl.UTF-8):      Biblioteki programistyczne interpretera języka Ruby
211 Group:          Development/Languages
212 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
213 Requires:       gcc
214 Requires:       glibc-devel
215 Requires:       pkgconfig
216
217 %description devel
218 Ruby development libraries.
219
220 %description devel -l pl.UTF-8
221 Biblioteki programistyczne interpretera języka Ruby.
222
223 %package static
224 Summary:        Ruby static libraries
225 Summary(pl.UTF-8):      Biblioteki statyczne Ruby
226 Group:          Development/Languages
227 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
228
229 %description static
230 Ruby static libraries.
231
232 %description static -l pl.UTF-8
233 Biblioteki statyczne Ruby.
234
235 %package doc
236 Summary:        Ruby HTML documentation
237 Summary(pl.UTF-8):      Dokumentacja HTML do Ruby
238 Group:          Documentation
239 %if "%{_rpmversion}" >= "5"
240 BuildArch:      noarch
241 %endif
242
243 %description doc
244 Ruby HTML documentation: FAQ, guide, core and standard library.
245
246 %description doc -l pl.UTF-8
247 Dokumentacja HTML do Ruby: FAQ, przewodnik, dokumentacja dla core i
248 stdlib.
249
250 %package doc-ri
251 Summary:        Ruby ri documentation
252 Summary(pl.UTF-8):      Dokumentacja Ruby w formacie ri
253 Group:          Documentation
254 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
255 %if "%{_rpmversion}" >= "5"
256 BuildArch:      noarch
257 %endif
258
259 %description doc-ri
260 Ruby ri documentation.
261
262 %description doc-ri -l pl.UTF-8
263 Dokumentacja Ruby w formacie ri.
264
265 %package examples
266 Summary:        Ruby examples
267 Summary(pl.UTF-8):      Przykłady dla języka Ruby
268 Group:          Development/Languages
269 %if "%{_rpmversion}" >= "5"
270 BuildArch:      noarch
271 %endif
272
273 %description examples
274 Ruby examples.
275
276 %description examples -l pl.UTF-8
277 Przykłady programów w języku Ruby.
278
279 # IMPORTANT: keep rdoc, rubygems, rake, json as last packages as we reset epoch/version/release
280 # and %{version},%{release} macros may not be used directly as they take last
281 # subpackage value not main package one what you intend to use
282
283 %package rdoc
284 Summary:        A tool to generate HTML and command-line documentation for Ruby projects
285 Summary(pl.UTF-8):      Narzędzie do generowania dokumentacji HTML i linii poleceń dla projektów w Rubym
286 Version:        %{rdoc_ver}
287 # remove "11." when rdoc_ver is increased
288 Release:        11.%{basever}.%{patchlevel}.%{rel}
289 Epoch:          0
290 License:        GPL v2 and Ruby and MIT
291 Group:          Development/Libraries
292 Requires:       %{name}-modules = 1:%{basever}.%{patchlevel}-%{rel}
293 Obsoletes:      rdoc <= 0.9.0
294 %if "%{_rpmversion}" >= "5"
295 BuildArch:      noarch
296 %endif
297
298 %description rdoc
299 RDoc produces HTML and command-line documentation for Ruby projects.
300 RDoc includes the 'rdoc' and 'ri' tools for generating and displaying
301 online documentation.
302
303 %description rdoc -l pl.UTF-8
304 RDoc tworzy dokumentację HTML i linii poleceń dla projektów w języku
305 Ruby. RDoc zawiera narzędzia 'rdoc' i 'ri' do generowania i
306 wyświetlania dokumentacji online.
307
308 %package rubygems
309 Summary:        RubyGems - the Ruby standard for packaging Ruby libraries
310 Summary(pl.UTF-8):      RubyGems - standard Ruby'ego pakietowania bibliotek
311 Version:        %{rubygems_ver}
312 # remove "11." when rubygems_ver is increased
313 Release:        11.%{basever}.%{patchlevel}.%{rel}
314 Epoch:          0
315 License:        Ruby or MIT
316 Group:          Development/Libraries
317 Requires:       %{name}-modules = 1:%{basever}.%{patchlevel}-%{rel}
318 Requires:       %{name}-rdoc >= %{rdoc_ver}
319 Suggests:       %{name}-devel
320 Provides:       rubygems = %{rubygems_ver}
321 %if "%{_rpmversion}" >= "5"
322 BuildArch:      noarch
323 %endif
324
325 %description rubygems
326 RubyGems is the Ruby standard for publishing and managing third party
327 libraries.
328
329 %description rubygems -l pl.UTF-8
330 RubyGems to standardowe narzędzie języka Ruby do publikowania i
331 zarządzania zewnętrznymi bibliotekami.
332
333 %package rake
334 Summary:        Rake is a Make-like program implemented in Ruby
335 Summary(pl.UTF-8):      Program typu Make dla języka Ruby
336 Version:        %{rake_ver}
337 Release:        %{basever}.%{patchlevel}.%{rel}
338 Epoch:          0
339 License:        MIT
340 Group:          Development/Languages
341 Provides:       rake = %{rake_ver}
342 Conflicts:      ruby-modules < 1:1.9.3.429-2
343 %if "%{_rpmversion}" >= "5"
344 BuildArch:      noarch
345 %endif
346
347 %description rake
348 Rake is a simple Ruby build program with capabilities similar to make.
349
350 It has the following features:
351 - Rakefiles (rake's version of Makefiles) are completely defined in
352   standard Ruby syntax. No XML files to edit. No quirky Makefile syntax
353   to worry about (is that a tab or a space?)
354 - Users can specify tasks with prerequisites.
355 - Rake supports rule patterns to synthesize implicit tasks.
356 - Rake is lightweight. It can be distributed with other projects as a
357   single file. Projects that depend upon rake do not require that rake
358   be installed on target systems.
359
360 %description rake -l pl.UTF-8
361 Rake to prosty program do budowania w języku Ruby o możliwościach
362 podobnych do make.
363
364 Ma następujące cechy:
365 - Pliki Rakefile (rake'owa odmiana plików Makefile) są definiowane
366   całkowicie w standardowej składni języka Ruby. Nie trzeba modyfikować
367   plików XML. Nie trzeba martwić się kaprysami składni Makefile (czy to
368   tabulacja czy spacja?).
369 - Użytkownicy mogą określać zadania z ich zależnościami.
370 - Rake obsługuje wzorce reguł do tworzenia z nich wynikowych zadań.
371 - Rake jest lekki. Może być rozpowszechniany z innymi projektami jako
372   pojedynczy plik. Projekty używające rake'a nie wymagają go
373   zainstalowanego na systemach docelowych.
374
375 %package json
376 Summary:        JSON library for Ruby
377 Summary(pl.UTF-8):      Biblioteka JSON dla języka Ruby
378 Version:        %{json_ver}
379 Release:        %{basever}.%{patchlevel}.%{rel}
380 Epoch:          0
381 License:        MIT
382 Group:          Development/Languages
383 Obsoletes:      ruby-json-rubyforge
384 Conflicts:      ruby-modules < 1:1.9.3.429-3
385
386 %description json
387 This is a JSON implementation as a Ruby extension in C.
388
389 %description json -l pl.UTF-8
390 Biblioteka JSON dla języka Ruby.
391
392 %prep
393 %if %{with bootstrap}
394 %setup -q -n %{name}-%{basever}-p%{patchlevel} -a1 -a2 -a3 -a100
395 %else
396 %setup -q -n %{name}-%{basever}-p%{patchlevel} -a1 -a2 -a3
397 %endif
398 %patch0 -p1
399 %patch1 -p1
400 %patch2 -p1
401 %patch3 -p1
402 %patch4 -p1
403 %patch5 -p1
404 %patch6 -p1
405 %patch7 -p1
406 %patch8 -p1
407
408 # must be regenerated with new bison
409 %{__rm} parse.{c,h}
410
411 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
412
413 find -type f '(' -name '*.rb' -o -name '*.cgi' -o -name '*.test' \
414         -o -name 'ruby.1' -o -name '*.html' -o -name '*.tcl' ')' \
415         | xargs %{__sed} -i 's,/usr/local/bin/,%{_bindir}/,'
416
417 %build
418 cp -f /usr/share/automake/config.sub .
419
420 # build ruby-1.8.7 first
421 %if %{with bootstrap}
422 cd %{name}-1.8.7-p330
423 %configure
424 %{__make}
425 cd ..
426 %endif
427
428 %{__autoconf}
429 %configure \
430         %{?with_bootstrap:--with-baseruby=%{name}-1.8.7-p330/miniruby} \
431         --with-rubylibprefix=%(dirname %{ruby_libdir}) \
432         --with-archdir=%{ruby_archdir} \
433         --with-sitedir=%(dirname %{ruby_sitelibdir}) \
434         --with-sitearchdir=%{ruby_sitearchdir} \
435         --with-vendordir=%(dirname %{ruby_vendorlibdir}) \
436         --with-vendorarchdir=%{ruby_vendorarchdir} \
437         --with-rubygemsdir=%{rubygems_dir} \
438         --with-search-path="%{legacy_loadpaths}" \
439         --enable-shared \
440         --enable-pthread \
441         --disable-rubygems \
442         --disable-install-doc \
443         --with-ruby-version=minor
444
445 %{__make} -j1 main \
446         COPY="cp -p" Q= \
447         %{?with_bootstrap:BASERUBY="ruby-1.8.7-p330/miniruby -I./ruby-1.8.7-p330/lib"}
448
449 %if %{with doc}
450 %{__make} -j1 rdoc
451 %endif
452
453 %install
454 rm -rf $RPM_BUILD_ROOT
455 install -d $RPM_BUILD_ROOT{%{ruby_rdocdir},%{_examplesdir}/%{name}-%{version}} \
456         $RPM_BUILD_ROOT{%{ruby_vendorarchdir},%{ruby_ridir}} \
457         $RPM_BUILD_ROOT%{ruby_vendorlibdir}/net \
458         $RPM_BUILD_ROOT%{ruby_vendordir}/data \
459         $RPM_BUILD_ROOT{%{legacy_archdir}/racc,%{legacy_sitelibdir},%{legacy_sitearchdir},%{legacy_vendorarchdir},%{legacy_libdir}/tasks} \
460
461 %{__make} install %{?with_doc:install-doc} \
462         DESTDIR=$RPM_BUILD_ROOT
463
464 cp -Rf sample/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
465 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_mandir}/man1
466 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_mandir}/man1
467
468 %{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}/html
469
470 ln -sf %{gem_dir}/gems/rake-%{rake_ver}/bin/rake $RPM_BUILD_ROOT%{_bindir}/rake
471
472 %if %{without batteries}
473 # packaged separately
474 %{__rm} -r $RPM_BUILD_ROOT%{ruby_libdir}/{rubygems,rake,json,minitest}
475 %{__rm} -r $RPM_BUILD_ROOT%{ruby_archdir}/json
476 %{__rm} -r $RPM_BUILD_ROOT%{gem_dir}/gems/rake-*
477 %{__rm} $RPM_BUILD_ROOT%{ruby_libdir}/{rake,rubygems,json}.rb
478 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{gem,rake}
479 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/rake*
480 %{__rm} $RPM_BUILD_ROOT%{gem_dir}/specifications/{json,minitest,rake}-*.gemspec
481 %{?with_doc:%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/ri/%{ruby_version}/system/JSON}
482 %endif
483
484 %if %{with doc}
485 # too much .ri
486 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/cache.ri
487 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/created.rid
488 %endif
489
490 %clean
491 rm -rf $RPM_BUILD_ROOT
492
493 %post   -p /sbin/ldconfig
494 %postun -p /sbin/ldconfig
495
496 %files
497 %defattr(644,root,root,755)
498 %doc NEWS LEGAL README README.EXT ChangeLog ToDo
499 %attr(755,root,root) %{_bindir}/ruby
500 %attr(755,root,root) %{_libdir}/libruby.so.*.*.*
501 %attr(755,root,root) %ghost %{_libdir}/libruby.so.1.9
502 %{_mandir}/man1/ruby.1*
503
504 %dir %{_libdir}/%{name}
505 %dir %{_libdir}/%{name}/%{vendordir}
506 %dir %{_datadir}/%{name}
507
508 %dir %{ruby_libdir}
509 %dir %{ruby_archdir}
510 %dir %{ruby_vendordir}
511 %dir %{ruby_vendordir}/data
512 %dir %{ruby_vendorlibdir}
513 %dir %{ruby_vendorarchdir}
514
515 %dir %{_datadir}/ri
516 %dir %{_datadir}/ri/%{ruby_version}
517 %dir %{ruby_ridir}
518
519 %dir %{ruby_rdocdir}
520
521 # common dirs for ruby vendor modules
522 %dir %{ruby_vendorlibdir}/net
523
524 # legacy dirs. when everything rebuilt in Th not using these dirs. drop them
525 %dir %{legacy_archdir}
526 %dir %{legacy_sitedir}
527 %dir %{legacy_sitelibdir}
528 %dir %{legacy_sitearchdir}
529 %dir %{legacy_vendorarchdir}
530 %dir %{legacy_libdir}/tasks
531 %dir %{legacy_archdir}/racc
532
533 %files devel
534 %defattr(644,root,root,755)
535 %attr(755,root,root) %{_libdir}/libruby.so
536 %{_includedir}/%{name}-%{ruby_version}
537 %{_pkgconfigdir}/ruby-%{ruby_version}.pc
538 %{ruby_libdir}/mkmf.rb
539
540 %files static
541 %defattr(644,root,root,755)
542 %{_libdir}/libruby-static.a
543
544 %if %{with tk}
545 %files tk
546 %defattr(644,root,root,755)
547 %{ruby_libdir}/tcltk.rb
548 %{ruby_libdir}/tk*.rb
549 %{ruby_libdir}/tk
550 %{ruby_libdir}/tkextlib
551 %attr(755,root,root) %{ruby_archdir}/t*.so
552 %endif
553
554 %files rdoc
555 %defattr(644,root,root,755)
556 %attr(755,root,root) %{_bindir}/rdoc
557 %attr(755,root,root) %{_bindir}/ri
558 %{_mandir}/man1/rdoc.1*
559 %{ruby_libdir}/rdoc
560 %dir %{gem_dir}/gems/rdoc-%{rdoc_ver}
561 %dir %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin
562 %attr(755,root,root) %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin/rdoc
563 %{gem_dir}/specifications/rdoc-%{rdoc_ver}.gemspec
564 %attr(755,root,root) %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin/ri
565
566 %if %{with batteries}
567 %files rubygems
568 %defattr(644,root,root,755)
569 %attr(755,root,root) %{_bindir}/gem
570 %{ruby_libdir}/rubygems
571 %{ruby_libdir}/rubygems.rb
572 %{ruby_libdir}/ubygems.rb
573
574 %files rake
575 %defattr(644,root,root,755)
576 %attr(755,root,root) %{_bindir}/rake
577 %{_mandir}/man1/rake.1*
578 %{ruby_libdir}/rake
579 %dir %{gem_dir}/gems/rake-%{rake_ver}
580 %dir %{gem_dir}/gems/rake-%{rake_ver}/bin
581 %attr(755,root,root) %{gem_dir}/gems/rake-%{rake_ver}/bin/rake
582 %{gem_dir}/specifications/rake-%{rake_ver}.gemspec
583
584 %files json
585 %defattr(644,root,root,755)
586 %{ruby_libdir}/json
587 %dir %{ruby_archdir}/json
588 %dir %{ruby_archdir}/json/ext
589 %attr(755,root,root) %{ruby_archdir}/json/ext/*.so
590 %{gem_dir}/specifications/json-%{json_ver}.gemspec
591 %endif
592
593 %files modules
594 %defattr(644,root,root,755)
595 %attr(755,root,root) %{_bindir}/erb
596 %attr(755,root,root) %{_bindir}/irb
597 %attr(755,root,root) %{_bindir}/testrb
598 %{ruby_libdir}/bigdecimal
599 %{ruby_libdir}/cgi
600 %{ruby_libdir}/date
601 %{ruby_libdir}/digest
602 %{ruby_libdir}/dl
603 %{ruby_libdir}/drb
604 %{ruby_libdir}/fiddle
605 %{ruby_libdir}/io
606 %{ruby_libdir}/irb
607 %{ruby_libdir}/matrix
608 %{ruby_libdir}/net
609 %{ruby_libdir}/openssl
610 %{ruby_libdir}/optparse
611 %{ruby_libdir}/psych
612 %{ruby_libdir}/racc
613 %{ruby_libdir}/rbconfig
614 %{ruby_libdir}/rexml
615 %{ruby_libdir}/rinda
616 %{ruby_libdir}/ripper
617 %{ruby_libdir}/rss
618 %{ruby_libdir}/shell
619 %{ruby_libdir}/syck
620 %{ruby_libdir}/test
621 %{ruby_libdir}/uri
622 %{ruby_libdir}/webrick
623 %{ruby_libdir}/xmlrpc
624 %{ruby_libdir}/yaml
625 %{ruby_libdir}/[A-Za-s]*.rb
626 %{ruby_libdir}/tempfile.rb
627 %{ruby_libdir}/thread.rb
628 %{ruby_libdir}/thwait.rb
629 %{ruby_libdir}/time.rb
630 %{ruby_libdir}/timeout.rb
631 %{ruby_libdir}/tmpdir.rb
632 %{ruby_libdir}/tracer.rb
633 %{ruby_libdir}/tsort.rb
634 %{ruby_libdir}/[u-z]*.rb
635 %if %{with batteries}
636 %exclude %{ruby_libdir}/rubygems.rb
637 %exclude %{ruby_libdir}/ubygems.rb
638 %endif
639 %exclude %{ruby_libdir}/mkmf.rb
640 %attr(755,root,root) %{ruby_archdir}/[a-s]*.so
641 %attr(755,root,root) %{ruby_archdir}/[u-z]*.so
642 %dir %{ruby_archdir}/digest
643 %attr(755,root,root) %{ruby_archdir}/digest/*.so
644 %dir %{ruby_archdir}/dl
645 %attr(755,root,root) %{ruby_archdir}/dl/callback.so
646 %dir %{ruby_archdir}/enc
647 %attr(755,root,root) %{ruby_archdir}/enc/*.so
648 %dir %{ruby_archdir}/enc/trans
649 %attr(755,root,root) %{ruby_archdir}/enc/trans/*.so
650 %dir %{ruby_archdir}/io
651 %attr(755,root,root) %{ruby_archdir}/io/*.so
652 %dir %{ruby_archdir}/mathn
653 %attr(755,root,root) %{ruby_archdir}/mathn/*.so
654 %dir %{ruby_archdir}/racc
655 %attr(755,root,root) %{ruby_archdir}/racc/*.so
656 %{ruby_archdir}/rbconfig.rb
657
658 %{gem_dir}/specifications/bigdecimal-%{bigdecimal_ver}.gemspec
659 %{gem_dir}/specifications/io-console-%{io_console_ver}.gemspec
660
661 %if %{with batteries}
662 # minitest
663 %{ruby_libdir}/minitest
664 %{gem_dir}/specifications/minitest-%{minitest_ver}.gemspec
665 %endif
666
667 # parents of gem_dir
668 %dir %{_datadir}/%{name}/gems
669 #%dir %{_datadir}/%{name}/gems/%{ruby_version}
670 %dir %{_datadir}/%{name}/gems/%{ruby_version}/gems
671
672 %dir %{gem_dir}
673 %dir %{gem_dir}/specifications
674 %{_mandir}/man1/erb.1*
675 %{_mandir}/man1/irb.1*
676 %{_mandir}/man1/ri.1*
677 %{_mandir}/man1/testrb.1*
678
679 %files doc
680 %defattr(644,root,root,755)
681 %doc ruby-doc-bundle/*
682 %{?with_doc:%doc ruby_%{doc_version}_stdlib}
683 %{?with_doc:%doc ruby_%{doc_version}_core}
684
685 %if %{with doc}
686 %files doc-ri
687 %defattr(644,root,root,755)
688 %{ruby_ridir}/*
689 %endif
690
691 %files examples
692 %defattr(644,root,root,755)
693 %{_examplesdir}/%{name}-%{version}
This page took 0.424028 seconds and 4 git commands to generate.