]> git.pld-linux.org Git - packages/ruby.git/blob - ruby.spec
package legacy 'tasks' dir
[packages/ruby.git] / ruby.spec
1 #
2 # TODO:
3 #       - include ext/ in docs
4 #       - replace ri with fastri
5 #       - patch ri to search multiple indexes (one per package), so RPMs can install ri docs
6 #   - fix inconsistencies with versioned vs not-versioned dirs (see dirname hacks in configure)
7 #   - custom-rubygems-location.patch
8 #
9 # Conditional build:
10 %bcond_without  doc             # skip (time-consuming) docs generating; intended for speed up test builds
11 %bcond_without  tk              # skip building package with Tk bindings
12 %bcond_without  batteries       # Don't include rubygems, json or rake
13 %bcond_with     bootstrap       # build bootstrap version
14
15 %define         ruby_version    1.9
16 %define         basever         1.9.3
17 %define         patchlevel      392
18 %define         doc_version     1_9_3
19 %define         json_ver        1.5.5
20 %define         rake_ver        0.9.2.2
21 %define         rubygems_ver    1.8.11
22 %define         minitest_ver    2.5.1
23 %define         rdoc_ver        3.9.5
24 Summary:        Ruby - interpreted scripting language
25 Summary(ja.UTF-8):      オブジェクト指向言語Rubyインタプリタ
26 Summary(pl.UTF-8):      Ruby - interpretowany język skryptowy
27 Summary(pt_BR.UTF-8):   Linguagem de script orientada a objeto
28 Summary(zh_CN.UTF-8):   ruby - 一种快速高效的面向对象脚本编程语言
29 Name:           ruby
30 Version:        %{basever}.%{patchlevel}
31 # NOTE: do not decrease Release, when updating Version,
32 # unless rdoc_ver, rubygems_ver *both* are increased as well
33 Release:        2
34 Epoch:          1
35 # Public Domain for example for: include/ruby/st.h, strftime.c, ...
36 License:        (Ruby or BSD) and Public Domain
37 Group:          Development/Languages
38 Source0:        ftp://ftp.ruby-lang.org/pub/ruby/%{ruby_version}/%{name}-%{basever}-p%{patchlevel}.tar.bz2
39 # Source0-md5:  a810d64e2255179d2f334eb61fb8519c
40 Source1:        http://www.ruby-doc.org/download/%{name}-doc-bundle.tar.gz
41 # Source1-md5:  ad1af0043be98ba1a4f6d0185df63876
42 Source2:        http://www.ruby-doc.org/downloads/%{name}_%{doc_version}_stdlib_rdocs.tgz
43 # Source2-md5:  ec622612428672c432b6f65dd31a84b5
44 Source3:        http://www.ruby-doc.org/downloads/%{name}_%{doc_version}_core_rdocs.tgz
45 # Source3-md5:  1892aadde51d36106c513bced2193dff
46 Source100:      ftp://ftp.ruby-lang.org/pub/ruby/1.8/%{name}-1.8.7-p330.tar.gz
47 # Source100-md5:        50a49edb787211598d08e756e733e42e
48 Source4:        rdoc.1
49 Source5:        testrb.1
50 Patch0:         %{name}-lib64.patch
51 Patch1:         %{name}-ffs.patch
52 Patch2:         fix-bison-invocation.patch
53 # http://redmine.ruby-lang.org/issues/5231
54 Patch3:         disable-versioned-paths.patch
55 # TODO: Should be submitted upstream?
56 Patch4:         arch-specific-dir.patch
57 # http://redmine.ruby-lang.org/issues/5281
58 Patch5:         site-and-vendor-arch-flags.patch
59 URL:            http://www.ruby-lang.org/
60 BuildRequires:  autoconf >= 2.60
61 BuildRequires:  automake
62 BuildRequires:  bison
63 BuildRequires:  db-devel
64 BuildRequires:  gdbm-devel >= 1.8.3
65 BuildRequires:  libffi-devel
66 BuildRequires:  ncurses-devel
67 BuildRequires:  openssl-devel
68 BuildRequires:  pkgconfig
69 BuildRequires:  readline-devel >= 4.2
70 %{!?with_bootstrap:BuildRequires:       ruby-modules}
71 BuildRequires:  sed >= 4.0
72 BuildRequires:  yaml-devel
73 %if %{with tk}
74 BuildRequires:  tk-devel
75 %endif
76 Requires(post,postun):  /sbin/ldconfig
77 Provides:       ruby(ver) = %{ruby_version}
78 Obsoletes:      rdoc
79 Obsoletes:      ruby-REXML
80 Obsoletes:      ruby-doc < 1.8.4
81 Obsoletes:      ruby-fastthread
82 %if %{with batteries}
83 Provides:       json = %{json_ver}
84 Provides:       rake = %{rake_ver}
85 Provides:       ruby-json = %{json_ver}
86 Provides:       ruby-rake = %{rake_ver}
87 Obsoletes:      ruby-json
88 Obsoletes:      ruby-rake
89 %endif
90 Conflicts:      ruby-activesupport < 2.3.11-2
91 Conflicts:      ruby-activesupport2 < 2.3.11-2
92 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
93
94 %define ruby_ridir              %{_datadir}/ri/%{ruby_version}/system
95 %define gem_dir                 %{_datadir}/%{name}/gems/%{ruby_version}
96
97 # The RubyGems library has to stay out of Ruby directory three, since the
98 # RubyGems should be share by all Ruby implementations.
99 %define rubygems_dir            %{_datadir}/rubygems
100
101 %define ruby_archdir            %{_libdir}/%{name}/%{ruby_version}
102 %define ruby_libdir             %{_datadir}/%{name}/%{ruby_version}
103
104 # This is the local lib/arch and should not be used for packaging.
105 %define sitedir                 site_ruby
106 %define ruby_sitedir            %{_prefix}/local/share/%{name}/%{sitedir}
107 %define ruby_sitearchdir        %{_prefix}/local/%{_lib}/%{name}/%{sitedir}/%{ruby_version}
108 %define ruby_sitelibdir         %{_prefix}/local/share/%{name}/%{sitedir}/%{ruby_version}
109
110 # This is the general location for libs/archs compatible with all
111 # or most of the Ruby versions available in the PLD repositories.
112 %define vendordir               vendor_ruby
113 %define ruby_vendordir          %{_datadir}/%{name}/%{vendordir}
114 %define ruby_vendorarchdir      %{_libdir}/%{name}/%{vendordir}/%{ruby_version}
115 %define ruby_vendorlibdir       %{_datadir}/%{name}/%{vendordir}/%{ruby_version}
116
117 # TODO: drop legacy loadpaths after all ruby modules rebuilt in Th
118 %define legacy_libdir           %{_libdir}/%{name}/%{ruby_version}
119 %define legacy_archdir          %{_libdir}/%{name}/%{ruby_version}/%{_arch}-linux
120 %define legacy_sitedir          %{_libdir}/%{name}/%{sitedir}
121 %define legacy_sitelibdir       %{_libdir}/%{name}/%{sitedir}/%{ruby_version}
122 %define legacy_sitearchdir      %{_libdir}/%{name}/%{sitedir}/%{ruby_version}/%{_arch}-linux
123 %define legacy_vendordir        %{_libdir}/%{name}/%{vendordir}
124 %define legacy_vendorlibdir     %{_libdir}/%{name}/%{vendordir}/%{ruby_version}
125 %define legacy_vendorarchdir%{_libdir}/%{name}/%{vendordir}/%{ruby_version}/%{_arch}-linux
126
127 %define legacy_siteloadpath     %{legacy_sitelibdir}\\0%{legacy_sitearchdir}\\0%{legacy_sitedir}
128 %define legacy_vendorloadpath   %{legacy_vendorarchdir}
129 %define legacy_loadpath         %{legacy_archdir}
130 %define legacy_loadpaths        %{legacy_siteloadpath}\\0%{legacy_vendorloadpath}\\0%{legacy_loadpath}
131
132 # bleh, some nasty (gcc or ruby) bug still not fixed
133 # (SEGV or "unexpected break" on miniruby run during build)
134 %define         specflags_ia64  -O0
135
136 # ruby needs frame pointers for correct exception handling
137 %define         specflags_ia32  -fno-omit-frame-pointer
138
139 %description
140 Ruby is the interpreted scripting language for quick and easy
141 object-oriented programming. It has many features to process text
142 files and to do system management tasks (as in Perl). It is simple,
143 straight-forward, extensible, and portable.
144
145 This package contains only shared library and ruby interpreter. To get
146 full-functional ruby environment install ruby-modules package.
147
148 %description -l ja.UTF-8
149 Rubyはシンプルかつ強力なオブジェクト指向スクリプト言語です.Rubyは最初
150 から純粋なオブジェクト指向言語として設計されていますから,オブジェクト
151 指向プログラミングを手軽に行う事が出来ます.もちろん通常の手続き型のプ ログラミングも可能です.
152
153 %description -l pl.UTF-8
154 Ruby to interpretowany język skryptowy, w sam raz dla łatwego i
155 szybkiego pisania zorientowanych obiektowo programów. Ma wiele funkcji
156 ułatwiających przetwarzanie plików tekstowych i wykonywanie prac
157 związanych z zarządzaniem systemu (podobnie jak Perl). Jest prosty,
158 rozszerzalny i przenośny.
159
160 Ten pakiet zawiera tylko bibliotekę dzieloną i interpreter ruby.
161 Zainstaluj pakiet ruby-modules, jeżeli potrzebujesz w pełni
162 funkcjonalnego środowiska ruby.
163
164 %description -l pt_BR.UTF-8
165 Ruby é uma linguagem de script interpretada de programação orientada a
166 objeto. Possui diversas características para processamento de texto. É
167 simples, extensível e direta.
168
169 %package modules
170 Summary:        Ruby standard modules and utilities
171 Summary(pl.UTF-8):      Standardowe moduły i narzędzia dla języka Ruby
172 Group:          Development/Languages
173 Requires:       %{name} = %{epoch}:%{version}-%{release}
174 Suggests:       ruby-rubygems
175 # workaround for autodep generator not getting version properly
176 Provides:       ruby(abi) = %{ruby_version}
177 Provides:       ruby-modules(ver) = %{ruby_version}
178 Obsoletes:      ruby-minitest
179
180 %description modules
181 Ruby standard modules and utilities:
182 - erb - Tiny eRuby
183 - irb - interactive Ruby
184 - testrb - automatic runner for Test::Unit of Ruby
185
186 %description modules -l pl.UTF-8
187 Standardowe moduły i narzędzia Ruby:
188 - erb - mały eRuby
189 - irb - interaktywny Ruby
190 - testrb - automatyczny runner dla Ruby Test::Unit
191
192 %package tk
193 Summary:        Ruby/Tk bindings
194 Summary(pl.UTF-8):      Wiązania Ruby/Tk
195 Group:          Development/Languages
196 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
197
198 %description tk
199 This pachage contains Ruby/Tk bindings.
200
201 %description tk -l pl.UTF-8
202 Ten pakiet zawiera wiązania Ruby/Tk.
203
204 %package devel
205 Summary:        Ruby development libraries
206 Summary(pl.UTF-8):      Biblioteki programistyczne interpretera języka Ruby
207 Group:          Development/Languages
208 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
209
210 %description devel
211 Ruby development libraries.
212
213 %description devel -l pl.UTF-8
214 Biblioteki programistyczne interpretera języka Ruby.
215
216 %package static
217 Summary:        Ruby static libraries
218 Summary(pl.UTF-8):      Biblioteki statyczne Ruby
219 Group:          Development/Languages
220 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
221
222 %description static
223 Ruby static libraries.
224
225 %description static -l pl.UTF-8
226 Biblioteki statyczne Ruby.
227
228 %package doc
229 Summary:        Ruby HTML documentation
230 Summary(pl.UTF-8):      Dokumentacja HTML do Ruby
231 Group:          Documentation
232
233 %description doc
234 Ruby HTML documentation: FAQ, guide, core and standard library.
235
236 %description doc -l pl.UTF-8
237 Dokumentacja HTML do Ruby: FAQ, przewodnik, dokumentacja dla core i
238 stdlib.
239
240 %package doc-ri
241 Summary:        Ruby ri documentation
242 Summary(pl.UTF-8):      Dokumentacja Ruby w formacie ri
243 Group:          Documentation
244 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
245
246 %description doc-ri
247 Ruby ri documentation.
248
249 %description doc-ri -l pl.UTF-8
250 Dokumentacja Ruby w formacie ri.
251
252 %package examples
253 Summary:        Ruby examples
254 Summary(pl.UTF-8):      Przykłady dla języka Ruby
255 Group:          Development/Languages
256
257 %description examples
258 Ruby examples.
259
260 %description examples -l pl.UTF-8
261 Przykłady programów w języku Ruby.
262
263 # IMPORTANT: keep this as last package, as we reset Epoch
264 %package rdoc
265 Summary:        A tool to generate HTML and command-line documentation for Ruby projects
266 Version:        %{rdoc_ver}
267 Epoch:          0
268 License:        GPL v2 and Ruby and MIT
269 Group:          Development/Libraries
270 Requires:       %{name}-modules = 1:%{basever}.%{patchlevel}-%{release}
271
272 %description rdoc
273 RDoc produces HTML and command-line documentation for Ruby projects.
274 RDoc includes the 'rdoc' and 'ri' tools for generating and displaying
275 online documentation.
276
277 %package rubygems
278 Summary:        The Ruby standard for packaging ruby libraries
279 Version:        %{rubygems_ver}
280 License:        Ruby or MIT
281 Group:          Development/Libraries
282 Requires:       %{name}-modules = 1:%{basever}.%{patchlevel}-%{release}
283 Requires:       %{name}-rdoc >= %{rdoc_ver}
284 Provides:       rubygems = %{rubygems_ver}
285 %if "%{_rpmversion}" >= "5"
286 BuildArch:      noarch
287 %endif
288
289 %description rubygems
290 RubyGems is the Ruby standard for publishing and managing third party
291 libraries.
292
293 %prep
294 %if %{with bootstrap}
295 %setup -q -n %{name}-%{basever}-p%{patchlevel} -a1 -a2 -a3 -a100
296 %else
297 %setup -q -n %{name}-%{basever}-p%{patchlevel} -a1 -a2 -a3
298 %endif
299 %patch0 -p1
300 %patch1 -p1
301 %patch2 -p1
302 %patch3 -p1
303 %patch4 -p1
304 %patch5 -p1
305
306 # must be regenerated with new bison
307 %{__rm} parse.{c,h}
308
309 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
310
311 find -type f '(' -name '*.rb' -o -name '*.cgi' -o -name '*.test' \
312         -o -name 'ruby.1' -o -name '*.html' -o -name '*.tcl' ')' \
313         | xargs %{__sed} -i 's,/usr/local/bin/,%{_bindir}/,'
314
315 %build
316 cp -f /usr/share/automake/config.sub .
317
318 # build ruby-1.8.7 first
319 %if %{with bootstrap}
320 cd %{name}-1.8.7-p330
321 %configure
322 %{__make}
323 cd ..
324 %endif
325
326 %{__autoconf}
327 %configure \
328         %{?with_bootstrap:--with-baseruby=%{name}-1.8.7-p330/miniruby} \
329         --with-rubylibprefix=%(dirname %{ruby_libdir}) \
330         --with-archdir=%{ruby_archdir} \
331         --with-sitedir=%(dirname %{ruby_sitelibdir}) \
332         --with-sitearchdir=%{ruby_sitearchdir} \
333         --with-vendordir=%(dirname %{ruby_vendorlibdir}) \
334         --with-vendorarchdir=%{ruby_vendorarchdir} \
335         --with-rubygemsdir=%{rubygems_dir} \
336         --with-search-path="%{legacy_loadpaths}" \
337         --enable-shared \
338         --enable-pthread \
339         --disable-install-doc \
340         --with-ruby-version=minor
341
342 %{__make} -j1 main \
343         COPY="cp -p" Q= \
344         %{?with_bootstrap:BASERUBY="ruby-1.8.7-p330/miniruby -I./ruby-1.8.7-p330/lib"}
345
346 %if %{with doc}
347 %{__make} -j1 rdoc
348 %endif
349
350 %install
351 rm -rf $RPM_BUILD_ROOT
352 install -d $RPM_BUILD_ROOT{%{ruby_rdocdir},%{_examplesdir}/%{name}-%{version}} \
353         $RPM_BUILD_ROOT{%{ruby_vendorarchdir},%{ruby_ridir}} \
354         $RPM_BUILD_ROOT{%{legacy_archdir},%{legacy_sitelibdir},%{legacy_sitearchdir},%{legacy_vendorarchdir},%{legacy_libdir}/tasks} \
355
356 %{__make} install %{?with_doc:install-doc} \
357         DESTDIR=$RPM_BUILD_ROOT
358
359 cp -Rf sample/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
360 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_mandir}/man1
361 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_mandir}/man1
362
363 %{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}/html
364
365 %if %{without batteries}
366 # packaged separately
367 %{__rm} -r $RPM_BUILD_ROOT%{ruby_libdir}/{rubygems,rake,json}
368 %{__rm} -r $RPM_BUILD_ROOT%{ruby_archdir}/json
369 %{__rm} $RPM_BUILD_ROOT%{ruby_libdir}/{rake,rubygems,json}.rb
370 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{gem,rake}
371 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/rake*
372 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/ri/%{ruby_version}/system/JSON
373 %endif
374
375 %if %{with doc}
376 # too much .ri
377 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/cache.ri
378 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/created.rid
379 %endif
380
381 %clean
382 rm -rf $RPM_BUILD_ROOT
383
384 %post   -p /sbin/ldconfig
385 %postun -p /sbin/ldconfig
386
387 %files
388 %defattr(644,root,root,755)
389 %doc NEWS LEGAL README README.EXT ChangeLog ToDo
390 %attr(755,root,root) %{_bindir}/ruby
391 %if %{with batteries}
392 %attr(755,root,root) %{_bindir}/rake
393 %endif
394 %attr(755,root,root) %{_libdir}/libruby.so.*.*.*
395 %attr(755,root,root) %ghost %{_libdir}/libruby.so.1.9
396 %{_mandir}/man1/ruby.1*
397 %if %{with batteries}
398 %{_mandir}/man1/rake.1*
399 %endif
400
401 %dir %{_libdir}/%{name}
402 %dir %{_libdir}/%{name}/%{vendordir}
403 %dir %{_datadir}/%{name}
404 %dir %{_datadir}/%{name}/%{vendordir}
405
406 %dir %{ruby_libdir}
407 %dir %{ruby_archdir}
408 %dir %{ruby_vendorlibdir}
409 %dir %{ruby_vendorarchdir}
410
411 %dir %{_datadir}/ri
412 %dir %{_datadir}/ri/%{ruby_version}
413 %dir %{ruby_ridir}
414
415 %dir %{ruby_rdocdir}
416
417 # legacy dirs. when everything rebuilt in Th not using these dirs. drop them
418 %dir %{legacy_archdir}
419 %dir %{legacy_sitedir}
420 %dir %{legacy_sitelibdir}
421 %dir %{legacy_sitearchdir}
422 %dir %{legacy_vendorarchdir}
423 %dir %{legacy_libdir}/tasks
424
425 %files devel
426 %defattr(644,root,root,755)
427 %attr(755,root,root) %{_libdir}/libruby.so
428 %{_includedir}/%{name}-%{ruby_version}
429 %{_pkgconfigdir}/ruby-%{ruby_version}.pc
430
431 %files static
432 %defattr(644,root,root,755)
433 %{_libdir}/libruby-static.a
434
435 %if %{with tk}
436 %files tk
437 %defattr(644,root,root,755)
438 %{ruby_libdir}/tcltk.rb
439 %{ruby_libdir}/tk*.rb
440 %{ruby_libdir}/tk
441 %{ruby_libdir}/tkextlib
442 %attr(755,root,root) %{ruby_archdir}/t*.so
443 %endif
444
445 %files rdoc
446 %defattr(644,root,root,755)
447 %attr(755,root,root) %{_bindir}/rdoc
448 %attr(755,root,root) %{_bindir}/ri
449 %{_mandir}/man1/rdoc.1*
450 %{ruby_libdir}/rdoc
451 %dir %{gem_dir}/gems/rdoc-%{rdoc_ver}
452 %dir %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin
453 %attr(755,root,root) %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin/rdoc
454 %{gem_dir}/specifications/rdoc-%{rdoc_ver}.gemspec
455 %attr(755,root,root) %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin/ri
456
457 %if %{with batteries}
458 %files rubygems
459 %defattr(644,root,root,755)
460 %attr(755,root,root) %{_bindir}/gem
461 %{ruby_libdir}/rubygems
462 %{ruby_libdir}/rubygems.rb
463 %{ruby_libdir}/ubygems.rb
464
465 %{gem_dir}/specifications/io-console-*.gemspec
466 %{gem_dir}/specifications/bigdecimal-*.gemspec
467 %if %{with batteries}
468 %dir %{gem_dir}/gems/rake-%{rake_ver}
469 %dir %{gem_dir}/gems/rake-%{rake_ver}/bin
470 %attr(755,root,root) %{gem_dir}/gems/rake-%{rake_ver}/bin/rake
471 %{gem_dir}/specifications/minitest-%{minitest_ver}.gemspec
472 %{gem_dir}/specifications/rake-%{rake_ver}.gemspec
473 %{gem_dir}/specifications/json-%{json_ver}.gemspec
474 %endif
475 %endif
476
477 %files modules
478 %defattr(644,root,root,755)
479 %attr(755,root,root) %{_bindir}/erb
480 %attr(755,root,root) %{_bindir}/irb
481 %attr(755,root,root) %{_bindir}/testrb
482 %{ruby_libdir}/bigdecimal
483 %{ruby_libdir}/cgi
484 %{ruby_libdir}/date
485 %{ruby_libdir}/digest
486 %{ruby_libdir}/dl
487 %{ruby_libdir}/drb
488 %{ruby_libdir}/fiddle
489 %{ruby_libdir}/io
490 %{ruby_libdir}/irb
491 %{ruby_libdir}/matrix
492 %{ruby_libdir}/minitest
493 %{ruby_libdir}/net
494 %{ruby_libdir}/openssl
495 %{ruby_libdir}/optparse
496 %if %{with batteries}
497 %{ruby_libdir}/json
498 %{ruby_libdir}/rake
499 %endif
500 %{ruby_libdir}/psych
501 %{ruby_libdir}/racc
502 %{ruby_libdir}/rbconfig
503 %{ruby_libdir}/rexml
504 %{ruby_libdir}/rinda
505 %{ruby_libdir}/ripper
506 %{ruby_libdir}/rss
507 %{ruby_libdir}/shell
508 %{ruby_libdir}/syck
509 %{ruby_libdir}/test
510 %{ruby_libdir}/uri
511 %{ruby_libdir}/webrick
512 %{ruby_libdir}/xmlrpc
513 %{ruby_libdir}/yaml
514 %{ruby_libdir}/[A-Za-s]*.rb
515 %{ruby_libdir}/tempfile.rb
516 %{ruby_libdir}/thread.rb
517 %{ruby_libdir}/thwait.rb
518 %{ruby_libdir}/time.rb
519 %{ruby_libdir}/timeout.rb
520 %{ruby_libdir}/tmpdir.rb
521 %{ruby_libdir}/tracer.rb
522 %{ruby_libdir}/tsort.rb
523 %{ruby_libdir}/[u-z]*.rb
524 %exclude %{ruby_libdir}/rubygems.rb
525 %exclude %{ruby_libdir}/ubygems.rb
526 %attr(755,root,root) %{ruby_archdir}/[a-s]*.so
527 %attr(755,root,root) %{ruby_archdir}/[u-z]*.so
528 %dir %{ruby_archdir}/digest
529 %attr(755,root,root) %{ruby_archdir}/digest/*.so
530 %dir %{ruby_archdir}/dl
531 %attr(755,root,root) %{ruby_archdir}/dl/callback.so
532 %dir %{ruby_archdir}/enc
533 %attr(755,root,root) %{ruby_archdir}/enc/*.so
534 %dir %{ruby_archdir}/enc/trans
535 %attr(755,root,root) %{ruby_archdir}/enc/trans/*.so
536 %dir %{ruby_archdir}/io
537 %attr(755,root,root) %{ruby_archdir}/io/*.so
538 %if %{with batteries}
539 %dir %{ruby_archdir}/json
540 %dir %{ruby_archdir}/json/ext
541 %attr(755,root,root) %{ruby_archdir}/json/ext/*.so
542 %endif
543 %dir %{ruby_archdir}/mathn
544 %attr(755,root,root) %{ruby_archdir}/mathn/*.so
545 %dir %{ruby_archdir}/racc
546 %attr(755,root,root) %{ruby_archdir}/racc/*.so
547 %{ruby_archdir}/rbconfig.rb
548
549 # parents of gem_dir
550 %dir %{_datadir}/%{name}/gems
551 #%dir %{_datadir}/%{name}/gems/%{ruby_version}
552 %dir %{_datadir}/%{name}/gems/%{ruby_version}/gems
553
554 %dir %{gem_dir}
555 %dir %{gem_dir}/specifications
556 %{_mandir}/man1/erb.1*
557 %{_mandir}/man1/irb.1*
558 %{_mandir}/man1/ri.1*
559 %{_mandir}/man1/testrb.1*
560
561 %files doc
562 %defattr(644,root,root,755)
563 %doc ruby-doc-bundle/*
564 %{?with_doc:%doc ruby_%{doc_version}_stdlib}
565 %{?with_doc:%doc ruby_%{doc_version}_core}
566
567 %if %{with doc}
568 %files doc-ri
569 %defattr(644,root,root,755)
570 %{ruby_ridir}/*
571 %endif
572
573 %files examples
574 %defattr(644,root,root,755)
575 %{_examplesdir}/%{name}-%{version}
This page took 0.059655 seconds and 3 git commands to generate.