]> git.pld-linux.org Git - packages/ruby.git/blob - ruby.spec
json ext is not noarch
[packages/ruby.git] / ruby.spec
1 # TODO:
2 #       - include ext/ in docs
3 #       - replace ri with fastri
4 #       - patch ri to search multiple indexes (one per package), so RPMs can install ri docs
5 #   - fix inconsistencies with versioned vs not-versioned dirs (see dirname hacks in configure)
6 #   - custom-rubygems-location.patch
7 #
8 # Conditional build:
9 %bcond_without  doc             # skip (time-consuming) docs generating; intended for speed up test builds
10 %bcond_without  tk              # skip building package with Tk bindings
11 %bcond_without  batteries       # Don't include rubygems, json, rake, minitest
12 %bcond_with     bootstrap       # build bootstrap version
13
14 %define         rel                     4
15 %define         ruby_version    1.9
16 %define         basever         1.9.3
17 %define         patchlevel      429
18 %define         doc_version     1_9_3
19 %define         json_ver        1.5.5
20 %define         rake_ver        0.9.2.2
21 # when increasing rubygems_ver, please remove "11." prefix in rubygems package release
22 %define         rubygems_ver    1.8.11
23 %define         minitest_ver    2.5.1
24 # when increasing rdoc_ver, please remove "11." prefix in rdoc package release
25 %define         rdoc_ver        3.9.5
26 %define         bigdecimal_ver  1.1.0
27 %define         io_console_ver  0.3
28 Summary:        Ruby - interpreted scripting language
29 Summary(ja.UTF-8):      オブジェクト指向言語Rubyインタプリタ
30 Summary(pl.UTF-8):      Ruby - interpretowany język skryptowy
31 Summary(pt_BR.UTF-8):   Linguagem de script orientada a objeto
32 Summary(zh_CN.UTF-8):   ruby - 一种快速高效的面向对象脚本编程语言
33 Name:           ruby
34 Version:        %{basever}.%{patchlevel}
35 Release:        %{rel}
36 Epoch:          1
37 # Public Domain for example for: include/ruby/st.h, strftime.c, ...
38 License:        (Ruby or BSD) and Public Domain
39 Group:          Development/Languages
40 Source0:        ftp://ftp.ruby-lang.org/pub/ruby/1.9/%{name}-%{basever}-p%{patchlevel}.tar.bz2
41 # Source0-md5:  c2b2de5ef15ea9b1aaa3152f9112af1b
42 Source1:        http://www.ruby-doc.org/download/%{name}-doc-bundle.tar.gz
43 # Source1-md5:  ad1af0043be98ba1a4f6d0185df63876
44 Source2:        http://www.ruby-doc.org/downloads/%{name}_%{doc_version}_stdlib_rdocs.tgz
45 # Source2-md5:  ec622612428672c432b6f65dd31a84b5
46 Source3:        http://www.ruby-doc.org/downloads/%{name}_%{doc_version}_core_rdocs.tgz
47 # Source3-md5:  1892aadde51d36106c513bced2193dff
48 Source100:      ftp://ftp.ruby-lang.org/pub/ruby/1.8/%{name}-1.8.7-p330.tar.gz
49 # Source100-md5:        50a49edb787211598d08e756e733e42e
50 Source4:        rdoc.1
51 Source5:        testrb.1
52 Patch0:         %{name}-lib64.patch
53 Patch1:         %{name}-ffs.patch
54 Patch2:         fix-bison-invocation.patch
55 # http://redmine.ruby-lang.org/issues/5231
56 Patch3:         disable-versioned-paths.patch
57 # TODO: Should be submitted upstream?
58 Patch4:         arch-specific-dir.patch
59 # http://redmine.ruby-lang.org/issues/5281
60 Patch5:         site-and-vendor-arch-flags.patch
61 # Make mkmf verbose by default
62 Patch6:         mkmf-verbose.patch
63 URL:            http://www.ruby-lang.org/
64 BuildRequires:  autoconf >= 2.60
65 BuildRequires:  automake
66 BuildRequires:  bison
67 BuildRequires:  db-devel
68 BuildRequires:  gdbm-devel >= 1.8.3
69 BuildRequires:  libffi-devel
70 BuildRequires:  ncurses-devel
71 BuildRequires:  openssl-devel
72 BuildRequires:  pkgconfig
73 BuildRequires:  readline-devel >= 4.2
74 BuildRequires:  rpm-build >= 5.4.10-49
75 # boostrap needs ruby binary, erb module
76 %{!?with_bootstrap:BuildRequires:       ruby-modules}
77 %{!?with_bootstrap:BuildRequires:       ruby}
78 BuildRequires:  sed >= 4.0
79 BuildRequires:  yaml-devel
80 %if %{with tk}
81 BuildRequires:  tk-devel
82 %endif
83 Requires(post,postun):  /sbin/ldconfig
84 Provides:       ruby(ver) = %{ruby_version}
85 Obsoletes:      ruby-REXML <= 2.4.0-2
86 Obsoletes:      ruby-doc < 1.8.4
87 Obsoletes:      ruby-fastthread <= 0.6.3
88 Conflicts:      ruby-activesupport < 2.3.11-2
89 Conflicts:      ruby-activesupport2 < 2.3.11-2
90 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
91
92 %define ruby_ridir              %{_datadir}/ri/%{ruby_version}/system
93 %define gem_dir                 %{_datadir}/%{name}/gems/%{ruby_version}
94
95 # The RubyGems library has to stay out of Ruby directory three, since the
96 # RubyGems should be share by all Ruby implementations.
97 %define rubygems_dir            %{_datadir}/rubygems
98
99 %define ruby_archdir            %{_libdir}/%{name}/%{ruby_version}
100 %define ruby_libdir             %{_datadir}/%{name}/%{ruby_version}
101
102 # This is the local lib/arch and should not be used for packaging.
103 %define sitedir                 site_ruby
104 %define ruby_sitedir            %{_prefix}/local/share/%{name}/%{sitedir}
105 %define ruby_sitearchdir        %{_prefix}/local/%{_lib}/%{name}/%{sitedir}/%{ruby_version}
106 %define ruby_sitelibdir         %{_prefix}/local/share/%{name}/%{sitedir}/%{ruby_version}
107
108 # This is the general location for libs/archs compatible with all
109 # or most of the Ruby versions available in the PLD repositories.
110 %define vendordir               vendor_ruby
111 %define ruby_vendordir          %{_datadir}/%{name}/%{vendordir}
112 %define ruby_vendorarchdir      %{_libdir}/%{name}/%{vendordir}/%{ruby_version}
113 %define ruby_vendorlibdir       %{_datadir}/%{name}/%{vendordir}/%{ruby_version}
114
115 # TODO: drop legacy loadpaths after all ruby modules rebuilt in Th
116 %define legacy_libdir           %{_libdir}/%{name}/%{ruby_version}
117 %define legacy_archdir          %{_libdir}/%{name}/%{ruby_version}/%{_target_cpu}-linux
118 %define legacy_sitedir          %{_libdir}/%{name}/%{sitedir}
119 %define legacy_sitelibdir       %{_libdir}/%{name}/%{sitedir}/%{ruby_version}
120 %define legacy_sitearchdir      %{_libdir}/%{name}/%{sitedir}/%{ruby_version}/%{_target_cpu}-linux
121 %define legacy_vendordir        %{_libdir}/%{name}/%{vendordir}
122 %define legacy_vendorlibdir     %{_libdir}/%{name}/%{vendordir}/%{ruby_version}
123 %define legacy_vendorarchdir    %{_libdir}/%{name}/%{vendordir}/%{ruby_version}/%{_target_cpu}-linux
124
125 %define legacy_siteloadpath     %{legacy_sitelibdir}\\0%{legacy_sitearchdir}\\0%{legacy_sitedir}
126 %define legacy_vendorloadpath   %{legacy_vendorarchdir}
127 %define legacy_loadpath         %{legacy_archdir}
128 %define legacy_loadpaths        %{legacy_siteloadpath}\\0%{legacy_vendorloadpath}\\0%{legacy_loadpath}
129
130 # bleh, some nasty (gcc or ruby) bug still not fixed
131 # (SEGV or "unexpected break" on miniruby run during build)
132 %define         specflags_ia64  -O0
133
134 # ruby needs frame pointers for correct exception handling
135 %define         specflags_ia32  -fno-omit-frame-pointer
136
137 %description
138 Ruby is the interpreted scripting language for quick and easy
139 object-oriented programming. It has many features to process text
140 files and to do system management tasks (as in Perl). It is simple,
141 straight-forward, extensible, and portable.
142
143 This package contains only shared library and ruby interpreter. To get
144 full-functional ruby environment install ruby-modules package.
145
146 %description -l ja.UTF-8
147 Rubyはシンプルかつ強力なオブジェクト指向スクリプト言語です.Rubyは最初
148 から純粋なオブジェクト指向言語として設計されていますから,オブジェクト
149 指向プログラミングを手軽に行う事が出来ます.もちろん通常の手続き型のプ ログラミングも可能です.
150
151 %description -l pl.UTF-8
152 Ruby to interpretowany język skryptowy, w sam raz dla łatwego i
153 szybkiego pisania zorientowanych obiektowo programów. Ma wiele funkcji
154 ułatwiających przetwarzanie plików tekstowych i wykonywanie prac
155 związanych z zarządzaniem systemu (podobnie jak Perl). Jest prosty,
156 rozszerzalny i przenośny.
157
158 Ten pakiet zawiera tylko bibliotekę dzieloną i interpreter ruby.
159 Zainstaluj pakiet ruby-modules, jeżeli potrzebujesz w pełni
160 funkcjonalnego środowiska ruby.
161
162 %description -l pt_BR.UTF-8
163 Ruby é uma linguagem de script interpretada de programação orientada a
164 objeto. Possui diversas características para processamento de texto. É
165 simples, extensível e direta.
166
167 %package modules
168 Summary:        Ruby standard modules and utilities
169 Summary(pl.UTF-8):      Standardowe moduły i narzędzia dla języka Ruby
170 Group:          Development/Languages
171 Requires:       %{name} = %{epoch}:%{version}-%{release}
172 Suggests:       ruby-rubygems
173 Provides:       ruby-bigdecimal = %{bigdecimal_ver}
174 Provides:       ruby-io-console = %{io_console_ver}
175 # ruby-modules deprecated, rpm5 generates ruby(abi) itself
176 Provides:       ruby-modules(ver) = %{ruby_version}
177 %if %{with batteries}
178 Provides:       ruby-minitest = %{minitest_ver}
179 Obsoletes:      ruby-minitest <= 1.5.0
180 %endif
181
182 %description modules
183 Ruby standard modules and utilities:
184 - erb - Tiny eRuby
185 - irb - interactive Ruby
186 - testrb - automatic runner for Test::Unit of Ruby
187
188 %description modules -l pl.UTF-8
189 Standardowe moduły i narzędzia Ruby:
190 - erb - mały eRuby
191 - irb - interaktywny Ruby
192 - testrb - automatyczny runner dla Ruby Test::Unit
193
194 %package tk
195 Summary:        Ruby/Tk bindings
196 Summary(pl.UTF-8):      Wiązania Ruby/Tk
197 Group:          Development/Languages
198 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
199
200 %description tk
201 This pachage contains Ruby/Tk bindings.
202
203 %description tk -l pl.UTF-8
204 Ten pakiet zawiera wiązania Ruby/Tk.
205
206 %package devel
207 Summary:        Ruby development libraries
208 Summary(pl.UTF-8):      Biblioteki programistyczne interpretera języka Ruby
209 Group:          Development/Languages
210 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
211 Requires:       gcc
212 Requires:       glibc-devel
213 Requires:       pkgconfig
214
215 %description devel
216 Ruby development libraries.
217
218 %description devel -l pl.UTF-8
219 Biblioteki programistyczne interpretera języka Ruby.
220
221 %package static
222 Summary:        Ruby static libraries
223 Summary(pl.UTF-8):      Biblioteki statyczne Ruby
224 Group:          Development/Languages
225 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
226
227 %description static
228 Ruby static libraries.
229
230 %description static -l pl.UTF-8
231 Biblioteki statyczne Ruby.
232
233 %package doc
234 Summary:        Ruby HTML documentation
235 Summary(pl.UTF-8):      Dokumentacja HTML do Ruby
236 Group:          Documentation
237 %if "%{_rpmversion}" >= "5"
238 BuildArch:      noarch
239 %endif
240
241 %description doc
242 Ruby HTML documentation: FAQ, guide, core and standard library.
243
244 %description doc -l pl.UTF-8
245 Dokumentacja HTML do Ruby: FAQ, przewodnik, dokumentacja dla core i
246 stdlib.
247
248 %package doc-ri
249 Summary:        Ruby ri documentation
250 Summary(pl.UTF-8):      Dokumentacja Ruby w formacie ri
251 Group:          Documentation
252 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
253 %if "%{_rpmversion}" >= "5"
254 BuildArch:      noarch
255 %endif
256
257 %description doc-ri
258 Ruby ri documentation.
259
260 %description doc-ri -l pl.UTF-8
261 Dokumentacja Ruby w formacie ri.
262
263 %package examples
264 Summary:        Ruby examples
265 Summary(pl.UTF-8):      Przykłady dla języka Ruby
266 Group:          Development/Languages
267 %if "%{_rpmversion}" >= "5"
268 BuildArch:      noarch
269 %endif
270
271 %description examples
272 Ruby examples.
273
274 %description examples -l pl.UTF-8
275 Przykłady programów w języku Ruby.
276
277 # IMPORTANT: keep rdoc, rubygems, rake, json as last packages as we reset epoch/version/release
278 # and %{version},%{release} macros may not be used directly as they take last
279 # subpackage value not main package one what you intend to use
280
281 %package rdoc
282 Summary:        A tool to generate HTML and command-line documentation for Ruby projects
283 Summary(pl.UTF-8):      Narzędzie do generowania dokumentacji HTML i linii poleceń dla projektów w Rubym
284 Version:        %{rdoc_ver}
285 # remove "11." when rdoc_ver is increased
286 Release:        11.%{basever}.%{patchlevel}.%{rel}
287 Epoch:          0
288 License:        GPL v2 and Ruby and MIT
289 Group:          Development/Libraries
290 Requires:       %{name}-modules = 1:%{basever}.%{patchlevel}-%{rel}
291 Obsoletes:      rdoc <= 0.9.0
292 %if "%{_rpmversion}" >= "5"
293 BuildArch:      noarch
294 %endif
295
296 %description rdoc
297 RDoc produces HTML and command-line documentation for Ruby projects.
298 RDoc includes the 'rdoc' and 'ri' tools for generating and displaying
299 online documentation.
300
301 %description rdoc -l pl.UTF-8
302 RDoc tworzy dokumentację HTML i linii poleceń dla projektów w języku
303 Ruby. RDoc zawiera narzędzia 'rdoc' i 'ri' do generowania i
304 wyświetlania dokumentacji online.
305
306 %package rubygems
307 Summary:        RubyGems - the Ruby standard for packaging Ruby libraries
308 Summary(pl.UTF-8):      RubyGems - standard Ruby'ego pakietowania bibliotek
309 Version:        %{rubygems_ver}
310 # remove "11." when rubygems_ver is increased
311 Release:        11.%{basever}.%{patchlevel}.%{rel}
312 Epoch:          0
313 License:        Ruby or MIT
314 Group:          Development/Libraries
315 Requires:       %{name}-modules = 1:%{basever}.%{patchlevel}-%{rel}
316 Requires:       %{name}-rdoc >= %{rdoc_ver}
317 Suggests:       %{name}-devel
318 Provides:       rubygems = %{rubygems_ver}
319 %if "%{_rpmversion}" >= "5"
320 BuildArch:      noarch
321 %endif
322
323 %description rubygems
324 RubyGems is the Ruby standard for publishing and managing third party
325 libraries.
326
327 %description rubygems -l pl.UTF-8
328 RubyGems to standardowe narzędzie języka Ruby do publikowania i
329 zarządzania zewnętrznymi bibliotekami.
330
331 %package rake
332 Summary:        Rake is a Make-like program implemented in Ruby
333 Summary(pl.UTF-8):      Program typu Make dla języka Ruby
334 Version:        %{rake_ver}
335 Release:        %{basever}.%{patchlevel}.%{rel}
336 Epoch:          0
337 License:        MIT
338 Group:          Development/Languages
339 Provides:       rake = %{rake_ver}
340 %if "%{_rpmversion}" >= "5"
341 BuildArch:      noarch
342 %endif
343
344 %description rake
345 Rake is a simple Ruby build program with capabilities similar to make.
346
347 It has the following features:
348 - Rakefiles (rake's version of Makefiles) are completely defined in
349   standard Ruby syntax. No XML files to edit. No quirky Makefile syntax
350   to worry about (is that a tab or a space?)
351 - Users can specify tasks with prerequisites.
352 - Rake supports rule patterns to synthesize implicit tasks.
353 - Rake is lightweight. It can be distributed with other projects as a
354   single file. Projects that depend upon rake do not require that rake
355   be installed on target systems.
356
357 %description rake -l pl.UTF-8
358 Rake to prosty program do budowania w języku Ruby o możliwościach
359 podobnych do make.
360
361 Ma następujące cechy:
362 - Pliki Rakefile (rake'owa odmiana plików Makefile) są definiowane
363   całkowicie w standardowej składni języka Ruby. Nie trzeba modyfikować
364   plików XML. Nie trzeba martwić się kaprysami składni Makefile (czy to
365   tabulacja czy spacja?).
366 - Użytkownicy mogą określać zadania z ich zależnościami.
367 - Rake obsługuje wzorce reguł do tworzenia z nich wynikowych zadań.
368 - Rake jest lekki. Może być rozpowszechniany z innymi projektami jako
369   pojedynczy plik. Projekty używające rake'a nie wymagają go
370   zainstalowanego na systemach docelowych.
371
372 %package json
373 Summary:        JSON library for Ruby
374 Summary(pl.UTF-8):      Biblioteka JSON dla języka Ruby
375 Version:        %{json_ver}
376 Release:        %{basever}.%{patchlevel}.%{rel}
377 Epoch:          0
378 License:        MIT
379 Group:          Development/Languages
380 Obsoletes:      ruby-json-rubyforge
381
382 %description json
383 This is a JSON implementation as a Ruby extension in C.
384
385 %description json -l pl.UTF-8
386 Biblioteka JSON dla języka Ruby.
387
388 %prep
389 %if %{with bootstrap}
390 %setup -q -n %{name}-%{basever}-p%{patchlevel} -a1 -a2 -a3 -a100
391 %else
392 %setup -q -n %{name}-%{basever}-p%{patchlevel} -a1 -a2 -a3
393 %endif
394 %patch0 -p1
395 %patch1 -p1
396 %patch2 -p1
397 %patch3 -p1
398 %patch4 -p1
399 %patch5 -p1
400
401 # must be regenerated with new bison
402 %{__rm} parse.{c,h}
403
404 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
405
406 find -type f '(' -name '*.rb' -o -name '*.cgi' -o -name '*.test' \
407         -o -name 'ruby.1' -o -name '*.html' -o -name '*.tcl' ')' \
408         | xargs %{__sed} -i 's,/usr/local/bin/,%{_bindir}/,'
409
410 %build
411 cp -f /usr/share/automake/config.sub .
412
413 # build ruby-1.8.7 first
414 %if %{with bootstrap}
415 cd %{name}-1.8.7-p330
416 %configure
417 %{__make}
418 cd ..
419 %endif
420
421 %{__autoconf}
422 %configure \
423         %{?with_bootstrap:--with-baseruby=%{name}-1.8.7-p330/miniruby} \
424         --with-rubylibprefix=%(dirname %{ruby_libdir}) \
425         --with-archdir=%{ruby_archdir} \
426         --with-sitedir=%(dirname %{ruby_sitelibdir}) \
427         --with-sitearchdir=%{ruby_sitearchdir} \
428         --with-vendordir=%(dirname %{ruby_vendorlibdir}) \
429         --with-vendorarchdir=%{ruby_vendorarchdir} \
430         --with-rubygemsdir=%{rubygems_dir} \
431         --with-search-path="%{legacy_loadpaths}" \
432         --enable-shared \
433         --enable-pthread \
434         --disable-rubygems \
435         --disable-install-doc \
436         --with-ruby-version=minor
437
438 %{__make} -j1 main \
439         COPY="cp -p" Q= \
440         %{?with_bootstrap:BASERUBY="ruby-1.8.7-p330/miniruby -I./ruby-1.8.7-p330/lib"}
441
442 %if %{with doc}
443 %{__make} -j1 rdoc
444 %endif
445
446 %install
447 rm -rf $RPM_BUILD_ROOT
448 install -d $RPM_BUILD_ROOT{%{ruby_rdocdir},%{_examplesdir}/%{name}-%{version}} \
449         $RPM_BUILD_ROOT{%{ruby_vendorarchdir},%{ruby_ridir}} \
450         $RPM_BUILD_ROOT%{ruby_vendorlibdir}/net \
451         $RPM_BUILD_ROOT{%{legacy_archdir}/racc,%{legacy_sitelibdir},%{legacy_sitearchdir},%{legacy_vendorarchdir},%{legacy_libdir}/tasks} \
452
453 %{__make} install %{?with_doc:install-doc} \
454         DESTDIR=$RPM_BUILD_ROOT
455
456 cp -Rf sample/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
457 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_mandir}/man1
458 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_mandir}/man1
459
460 %{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}/html
461
462 ln -sf %{gem_dir}/gems/rake-%{rake_ver}/bin/rake $RPM_BUILD_ROOT%{_bindir}/rake
463
464 %if %{without batteries}
465 # packaged separately
466 %{__rm} -r $RPM_BUILD_ROOT%{ruby_libdir}/{rubygems,rake,json,minitest}
467 %{__rm} -r $RPM_BUILD_ROOT%{ruby_archdir}/json
468 %{__rm} -r $RPM_BUILD_ROOT%{gem_dir}/gems/rake-*
469 %{__rm} $RPM_BUILD_ROOT%{ruby_libdir}/{rake,rubygems,json}.rb
470 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{gem,rake}
471 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/rake*
472 %{__rm} $RPM_BUILD_ROOT%{gem_dir}/specifications/{json,minitest,rake}-*.gemspec
473 %{?with_doc:%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/ri/%{ruby_version}/system/JSON}
474 %endif
475
476 %if %{with doc}
477 # too much .ri
478 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/cache.ri
479 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/created.rid
480 %endif
481
482 %clean
483 rm -rf $RPM_BUILD_ROOT
484
485 %post   -p /sbin/ldconfig
486 %postun -p /sbin/ldconfig
487
488 %files
489 %defattr(644,root,root,755)
490 %doc NEWS LEGAL README README.EXT ChangeLog ToDo
491 %attr(755,root,root) %{_bindir}/ruby
492 %attr(755,root,root) %{_libdir}/libruby.so.*.*.*
493 %attr(755,root,root) %ghost %{_libdir}/libruby.so.1.9
494 %{_mandir}/man1/ruby.1*
495
496 %dir %{_libdir}/%{name}
497 %dir %{_libdir}/%{name}/%{vendordir}
498 %dir %{_datadir}/%{name}
499 %dir %{_datadir}/%{name}/%{vendordir}
500
501 %dir %{ruby_libdir}
502 %dir %{ruby_archdir}
503 %dir %{ruby_vendorlibdir}
504 %dir %{ruby_vendorarchdir}
505
506 %dir %{_datadir}/ri
507 %dir %{_datadir}/ri/%{ruby_version}
508 %dir %{ruby_ridir}
509
510 %dir %{ruby_rdocdir}
511
512 # common dirs for ruby vendor modules
513 %dir %{ruby_vendorlibdir}/net
514
515 # legacy dirs. when everything rebuilt in Th not using these dirs. drop them
516 %dir %{legacy_archdir}
517 %dir %{legacy_sitedir}
518 %dir %{legacy_sitelibdir}
519 %dir %{legacy_sitearchdir}
520 %dir %{legacy_vendorarchdir}
521 %dir %{legacy_libdir}/tasks
522 %dir %{legacy_archdir}/racc
523
524 %files devel
525 %defattr(644,root,root,755)
526 %attr(755,root,root) %{_libdir}/libruby.so
527 %{_includedir}/%{name}-%{ruby_version}
528 %{_pkgconfigdir}/ruby-%{ruby_version}.pc
529 %{ruby_libdir}/mkmf.rb
530
531 %files static
532 %defattr(644,root,root,755)
533 %{_libdir}/libruby-static.a
534
535 %if %{with tk}
536 %files tk
537 %defattr(644,root,root,755)
538 %{ruby_libdir}/tcltk.rb
539 %{ruby_libdir}/tk*.rb
540 %{ruby_libdir}/tk
541 %{ruby_libdir}/tkextlib
542 %attr(755,root,root) %{ruby_archdir}/t*.so
543 %endif
544
545 %files rdoc
546 %defattr(644,root,root,755)
547 %attr(755,root,root) %{_bindir}/rdoc
548 %attr(755,root,root) %{_bindir}/ri
549 %{_mandir}/man1/rdoc.1*
550 %{ruby_libdir}/rdoc
551 %dir %{gem_dir}/gems/rdoc-%{rdoc_ver}
552 %dir %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin
553 %attr(755,root,root) %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin/rdoc
554 %{gem_dir}/specifications/rdoc-%{rdoc_ver}.gemspec
555 %attr(755,root,root) %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin/ri
556
557 %if %{with batteries}
558 %files rubygems
559 %defattr(644,root,root,755)
560 %attr(755,root,root) %{_bindir}/gem
561 %{ruby_libdir}/rubygems
562 %{ruby_libdir}/rubygems.rb
563 %{ruby_libdir}/ubygems.rb
564
565 %files rake
566 %defattr(644,root,root,755)
567 %attr(755,root,root) %{_bindir}/rake
568 %{_mandir}/man1/rake.1*
569 %{ruby_libdir}/rake
570 %dir %{gem_dir}/gems/rake-%{rake_ver}
571 %dir %{gem_dir}/gems/rake-%{rake_ver}/bin
572 %attr(755,root,root) %{gem_dir}/gems/rake-%{rake_ver}/bin/rake
573 %{gem_dir}/specifications/rake-%{rake_ver}.gemspec
574
575 %files json
576 %defattr(644,root,root,755)
577 %{ruby_libdir}/json
578 %dir %{ruby_archdir}/json
579 %dir %{ruby_archdir}/json/ext
580 %attr(755,root,root) %{ruby_archdir}/json/ext/*.so
581 %{gem_dir}/specifications/json-%{json_ver}.gemspec
582 %endif
583
584 %files modules
585 %defattr(644,root,root,755)
586 %attr(755,root,root) %{_bindir}/erb
587 %attr(755,root,root) %{_bindir}/irb
588 %attr(755,root,root) %{_bindir}/testrb
589 %{ruby_libdir}/bigdecimal
590 %{ruby_libdir}/cgi
591 %{ruby_libdir}/date
592 %{ruby_libdir}/digest
593 %{ruby_libdir}/dl
594 %{ruby_libdir}/drb
595 %{ruby_libdir}/fiddle
596 %{ruby_libdir}/io
597 %{ruby_libdir}/irb
598 %{ruby_libdir}/matrix
599 %{ruby_libdir}/net
600 %{ruby_libdir}/openssl
601 %{ruby_libdir}/optparse
602 %{ruby_libdir}/psych
603 %{ruby_libdir}/racc
604 %{ruby_libdir}/rbconfig
605 %{ruby_libdir}/rexml
606 %{ruby_libdir}/rinda
607 %{ruby_libdir}/ripper
608 %{ruby_libdir}/rss
609 %{ruby_libdir}/shell
610 %{ruby_libdir}/syck
611 %{ruby_libdir}/test
612 %{ruby_libdir}/uri
613 %{ruby_libdir}/webrick
614 %{ruby_libdir}/xmlrpc
615 %{ruby_libdir}/yaml
616 %{ruby_libdir}/[A-Za-s]*.rb
617 %{ruby_libdir}/tempfile.rb
618 %{ruby_libdir}/thread.rb
619 %{ruby_libdir}/thwait.rb
620 %{ruby_libdir}/time.rb
621 %{ruby_libdir}/timeout.rb
622 %{ruby_libdir}/tmpdir.rb
623 %{ruby_libdir}/tracer.rb
624 %{ruby_libdir}/tsort.rb
625 %{ruby_libdir}/[u-z]*.rb
626 %if %{with batteries}
627 %exclude %{ruby_libdir}/rubygems.rb
628 %exclude %{ruby_libdir}/ubygems.rb
629 %endif
630 %exclude %{ruby_libdir}/mkmf.rb
631 %attr(755,root,root) %{ruby_archdir}/[a-s]*.so
632 %attr(755,root,root) %{ruby_archdir}/[u-z]*.so
633 %dir %{ruby_archdir}/digest
634 %attr(755,root,root) %{ruby_archdir}/digest/*.so
635 %dir %{ruby_archdir}/dl
636 %attr(755,root,root) %{ruby_archdir}/dl/callback.so
637 %dir %{ruby_archdir}/enc
638 %attr(755,root,root) %{ruby_archdir}/enc/*.so
639 %dir %{ruby_archdir}/enc/trans
640 %attr(755,root,root) %{ruby_archdir}/enc/trans/*.so
641 %dir %{ruby_archdir}/io
642 %attr(755,root,root) %{ruby_archdir}/io/*.so
643 %dir %{ruby_archdir}/mathn
644 %attr(755,root,root) %{ruby_archdir}/mathn/*.so
645 %dir %{ruby_archdir}/racc
646 %attr(755,root,root) %{ruby_archdir}/racc/*.so
647 %{ruby_archdir}/rbconfig.rb
648
649 %{gem_dir}/specifications/bigdecimal-%{bigdecimal_ver}.gemspec
650 %{gem_dir}/specifications/io-console-%{io_console_ver}.gemspec
651
652 %if %{with batteries}
653 # minitest
654 %{ruby_libdir}/minitest
655 %{gem_dir}/specifications/minitest-%{minitest_ver}.gemspec
656 %endif
657
658 # parents of gem_dir
659 %dir %{_datadir}/%{name}/gems
660 #%dir %{_datadir}/%{name}/gems/%{ruby_version}
661 %dir %{_datadir}/%{name}/gems/%{ruby_version}/gems
662
663 %dir %{gem_dir}
664 %dir %{gem_dir}/specifications
665 %{_mandir}/man1/erb.1*
666 %{_mandir}/man1/irb.1*
667 %{_mandir}/man1/ri.1*
668 %{_mandir}/man1/testrb.1*
669
670 %files doc
671 %defattr(644,root,root,755)
672 %doc ruby-doc-bundle/*
673 %{?with_doc:%doc ruby_%{doc_version}_stdlib}
674 %{?with_doc:%doc ruby_%{doc_version}_core}
675
676 %if %{with doc}
677 %files doc-ri
678 %defattr(644,root,root,755)
679 %{ruby_ridir}/*
680 %endif
681
682 %files examples
683 %defattr(644,root,root,755)
684 %{_examplesdir}/%{name}-%{version}
This page took 0.085506 seconds and 3 git commands to generate.