]> git.pld-linux.org Git - packages/ruby.git/blob - ruby.spec
up to 1.9.3.426 (2013-05-14)
[packages/ruby.git] / ruby.spec
1 #
2 # TODO:
3 #       - include ext/ in docs
4 #       - replace ri with fastri
5 #       - patch ri to search multiple indexes (one per package), so RPMs can install ri docs
6 #   - fix inconsistencies with versioned vs not-versioned dirs (see dirname hacks in configure)
7 #   - custom-rubygems-location.patch
8 #
9 # Conditional build:
10 %bcond_without  doc             # skip (time-consuming) docs generating; intended for speed up test builds
11 %bcond_without  tk              # skip building package with Tk bindings
12 %bcond_without  batteries       # Don't include rubygems, json, rake, minitest
13 %bcond_with     bootstrap       # build bootstrap version
14
15 %define         ruby_version    1.9
16 %define         basever         1.9.3
17 %define         patchlevel      426
18 %define         doc_version     1_9_3
19 %define         json_ver        1.5.5
20 %define         rake_ver        0.9.2.2
21 %define         rubygems_ver    1.8.11
22 %define         minitest_ver    2.5.1
23 %define         rdoc_ver        3.9.5
24 %define         bigdecimal_ver  1.1.0
25 %define         io_console_ver  0.3
26 Summary:        Ruby - interpreted scripting language
27 Summary(ja.UTF-8):      オブジェクト指向言語Rubyインタプリタ
28 Summary(pl.UTF-8):      Ruby - interpretowany język skryptowy
29 Summary(pt_BR.UTF-8):   Linguagem de script orientada a objeto
30 Summary(zh_CN.UTF-8):   ruby - 一种快速高效的面向对象脚本编程语言
31 Name:           ruby
32 Version:        %{basever}.%{patchlevel}
33 # NOTE: do not decrease Release, when updating Version,
34 # unless rdoc_ver, rubygems_ver *both* are increased as well
35 Release:        11
36 Epoch:          1
37 # Public Domain for example for: include/ruby/st.h, strftime.c, ...
38 License:        (Ruby or BSD) and Public Domain
39 Group:          Development/Languages
40 Source0:        ftp://ftp.ruby-lang.org/pub/ruby/1.9/%{name}-%{basever}-p%{patchlevel}.tar.bz2
41 # Source0-md5:  c211205e65d7253fc2a4620a34bc9245
42 Source1:        http://www.ruby-doc.org/download/%{name}-doc-bundle.tar.gz
43 # Source1-md5:  ad1af0043be98ba1a4f6d0185df63876
44 Source2:        http://www.ruby-doc.org/downloads/%{name}_%{doc_version}_stdlib_rdocs.tgz
45 # Source2-md5:  ec622612428672c432b6f65dd31a84b5
46 Source3:        http://www.ruby-doc.org/downloads/%{name}_%{doc_version}_core_rdocs.tgz
47 # Source3-md5:  1892aadde51d36106c513bced2193dff
48 Source100:      ftp://ftp.ruby-lang.org/pub/ruby/1.8/%{name}-1.8.7-p330.tar.gz
49 # Source100-md5:        50a49edb787211598d08e756e733e42e
50 Source4:        rdoc.1
51 Source5:        testrb.1
52 Patch0:         %{name}-lib64.patch
53 Patch1:         %{name}-ffs.patch
54 Patch2:         fix-bison-invocation.patch
55 # http://redmine.ruby-lang.org/issues/5231
56 Patch3:         disable-versioned-paths.patch
57 # TODO: Should be submitted upstream?
58 Patch4:         arch-specific-dir.patch
59 # http://redmine.ruby-lang.org/issues/5281
60 Patch5:         site-and-vendor-arch-flags.patch
61 # Make mkmf verbose by default
62 Patch6:         mkmf-verbose.patch
63 URL:            http://www.ruby-lang.org/
64 BuildRequires:  autoconf >= 2.60
65 BuildRequires:  automake
66 BuildRequires:  bison
67 BuildRequires:  db-devel
68 BuildRequires:  gdbm-devel >= 1.8.3
69 BuildRequires:  libffi-devel
70 BuildRequires:  ncurses-devel
71 BuildRequires:  openssl-devel
72 BuildRequires:  pkgconfig
73 BuildRequires:  readline-devel >= 4.2
74 BuildRequires:  rpm-build >= 5.4.10-49
75 # boostrap needs ruby binary, erb module
76 %{!?with_bootstrap:BuildRequires:       ruby-modules}
77 %{!?with_bootstrap:BuildRequires:       ruby}
78 BuildRequires:  sed >= 4.0
79 BuildRequires:  yaml-devel
80 %if %{with tk}
81 BuildRequires:  tk-devel
82 %endif
83 Requires(post,postun):  /sbin/ldconfig
84 Provides:       ruby(ver) = %{ruby_version}
85 Obsoletes:      ruby-REXML <= 2.4.0-2
86 Obsoletes:      ruby-doc < 1.8.4
87 Obsoletes:      ruby-fastthread <= 0.6.3
88 Conflicts:      ruby-activesupport < 2.3.11-2
89 Conflicts:      ruby-activesupport2 < 2.3.11-2
90 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
91
92 %define ruby_ridir              %{_datadir}/ri/%{ruby_version}/system
93 %define gem_dir                 %{_datadir}/%{name}/gems/%{ruby_version}
94
95 # The RubyGems library has to stay out of Ruby directory three, since the
96 # RubyGems should be share by all Ruby implementations.
97 %define rubygems_dir            %{_datadir}/rubygems
98
99 %define ruby_archdir            %{_libdir}/%{name}/%{ruby_version}
100 %define ruby_libdir             %{_datadir}/%{name}/%{ruby_version}
101
102 # This is the local lib/arch and should not be used for packaging.
103 %define sitedir                 site_ruby
104 %define ruby_sitedir            %{_prefix}/local/share/%{name}/%{sitedir}
105 %define ruby_sitearchdir        %{_prefix}/local/%{_lib}/%{name}/%{sitedir}/%{ruby_version}
106 %define ruby_sitelibdir         %{_prefix}/local/share/%{name}/%{sitedir}/%{ruby_version}
107
108 # This is the general location for libs/archs compatible with all
109 # or most of the Ruby versions available in the PLD repositories.
110 %define vendordir               vendor_ruby
111 %define ruby_vendordir          %{_datadir}/%{name}/%{vendordir}
112 %define ruby_vendorarchdir      %{_libdir}/%{name}/%{vendordir}/%{ruby_version}
113 %define ruby_vendorlibdir       %{_datadir}/%{name}/%{vendordir}/%{ruby_version}
114
115 # TODO: drop legacy loadpaths after all ruby modules rebuilt in Th
116 %define legacy_libdir           %{_libdir}/%{name}/%{ruby_version}
117 %define legacy_archdir          %{_libdir}/%{name}/%{ruby_version}/%{_target_cpu}-linux
118 %define legacy_sitedir          %{_libdir}/%{name}/%{sitedir}
119 %define legacy_sitelibdir       %{_libdir}/%{name}/%{sitedir}/%{ruby_version}
120 %define legacy_sitearchdir      %{_libdir}/%{name}/%{sitedir}/%{ruby_version}/%{_target_cpu}-linux
121 %define legacy_vendordir        %{_libdir}/%{name}/%{vendordir}
122 %define legacy_vendorlibdir     %{_libdir}/%{name}/%{vendordir}/%{ruby_version}
123 %define legacy_vendorarchdir    %{_libdir}/%{name}/%{vendordir}/%{ruby_version}/%{_target_cpu}-linux
124
125 %define legacy_siteloadpath     %{legacy_sitelibdir}\\0%{legacy_sitearchdir}\\0%{legacy_sitedir}
126 %define legacy_vendorloadpath   %{legacy_vendorarchdir}
127 %define legacy_loadpath         %{legacy_archdir}
128 %define legacy_loadpaths        %{legacy_siteloadpath}\\0%{legacy_vendorloadpath}\\0%{legacy_loadpath}
129
130 # bleh, some nasty (gcc or ruby) bug still not fixed
131 # (SEGV or "unexpected break" on miniruby run during build)
132 %define         specflags_ia64  -O0
133
134 # ruby needs frame pointers for correct exception handling
135 %define         specflags_ia32  -fno-omit-frame-pointer
136
137 %description
138 Ruby is the interpreted scripting language for quick and easy
139 object-oriented programming. It has many features to process text
140 files and to do system management tasks (as in Perl). It is simple,
141 straight-forward, extensible, and portable.
142
143 This package contains only shared library and ruby interpreter. To get
144 full-functional ruby environment install ruby-modules package.
145
146 %description -l ja.UTF-8
147 Rubyはシンプルかつ強力なオブジェクト指向スクリプト言語です.Rubyは最初
148 から純粋なオブジェクト指向言語として設計されていますから,オブジェクト
149 指向プログラミングを手軽に行う事が出来ます.もちろん通常の手続き型のプ ログラミングも可能です.
150
151 %description -l pl.UTF-8
152 Ruby to interpretowany język skryptowy, w sam raz dla łatwego i
153 szybkiego pisania zorientowanych obiektowo programów. Ma wiele funkcji
154 ułatwiających przetwarzanie plików tekstowych i wykonywanie prac
155 związanych z zarządzaniem systemu (podobnie jak Perl). Jest prosty,
156 rozszerzalny i przenośny.
157
158 Ten pakiet zawiera tylko bibliotekę dzieloną i interpreter ruby.
159 Zainstaluj pakiet ruby-modules, jeżeli potrzebujesz w pełni
160 funkcjonalnego środowiska ruby.
161
162 %description -l pt_BR.UTF-8
163 Ruby é uma linguagem de script interpretada de programação orientada a
164 objeto. Possui diversas características para processamento de texto. É
165 simples, extensível e direta.
166
167 %package modules
168 Summary:        Ruby standard modules and utilities
169 Summary(pl.UTF-8):      Standardowe moduły i narzędzia dla języka Ruby
170 Group:          Development/Languages
171 Requires:       %{name} = %{epoch}:%{version}-%{release}
172 Suggests:       ruby-rubygems
173 Provides:       ruby-bigdecimal = %{bigdecimal_ver}
174 Provides:       ruby-io-console = %{io_console_ver}
175 # ruby-modules deprecated, rpm5 generates ruby(abi) itself
176 Provides:       ruby-modules(ver) = %{ruby_version}
177 %if %{with batteries}
178 Provides:       rake = %{rake_ver}
179 Provides:       ruby-json = %{json_ver}
180 Provides:       ruby-minitest = %{minitest_ver}
181 Provides:       ruby-rake = %{rake_ver}
182 Obsoletes:      ruby-json <= 1.5.4
183 Obsoletes:      ruby-minitest <= 1.5.0
184 Obsoletes:      ruby-rake < 0.9.2.2
185 %endif
186
187 %description modules
188 Ruby standard modules and utilities:
189 - erb - Tiny eRuby
190 - irb - interactive Ruby
191 - testrb - automatic runner for Test::Unit of Ruby
192
193 %description modules -l pl.UTF-8
194 Standardowe moduły i narzędzia Ruby:
195 - erb - mały eRuby
196 - irb - interaktywny Ruby
197 - testrb - automatyczny runner dla Ruby Test::Unit
198
199 %package tk
200 Summary:        Ruby/Tk bindings
201 Summary(pl.UTF-8):      Wiązania Ruby/Tk
202 Group:          Development/Languages
203 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
204
205 %description tk
206 This pachage contains Ruby/Tk bindings.
207
208 %description tk -l pl.UTF-8
209 Ten pakiet zawiera wiązania Ruby/Tk.
210
211 %package devel
212 Summary:        Ruby development libraries
213 Summary(pl.UTF-8):      Biblioteki programistyczne interpretera języka Ruby
214 Group:          Development/Languages
215 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
216 Requires:       pkgconfig
217
218 %description devel
219 Ruby development libraries.
220
221 %description devel -l pl.UTF-8
222 Biblioteki programistyczne interpretera języka Ruby.
223
224 %package static
225 Summary:        Ruby static libraries
226 Summary(pl.UTF-8):      Biblioteki statyczne Ruby
227 Group:          Development/Languages
228 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
229
230 %description static
231 Ruby static libraries.
232
233 %description static -l pl.UTF-8
234 Biblioteki statyczne Ruby.
235
236 %package doc
237 Summary:        Ruby HTML documentation
238 Summary(pl.UTF-8):      Dokumentacja HTML do Ruby
239 Group:          Documentation
240 %if "%{_rpmversion}" >= "5"
241 BuildArch:      noarch
242 %endif
243
244 %description doc
245 Ruby HTML documentation: FAQ, guide, core and standard library.
246
247 %description doc -l pl.UTF-8
248 Dokumentacja HTML do Ruby: FAQ, przewodnik, dokumentacja dla core i
249 stdlib.
250
251 %package doc-ri
252 Summary:        Ruby ri documentation
253 Summary(pl.UTF-8):      Dokumentacja Ruby w formacie ri
254 Group:          Documentation
255 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
256 %if "%{_rpmversion}" >= "5"
257 BuildArch:      noarch
258 %endif
259
260 %description doc-ri
261 Ruby ri documentation.
262
263 %description doc-ri -l pl.UTF-8
264 Dokumentacja Ruby w formacie ri.
265
266 %package examples
267 Summary:        Ruby examples
268 Summary(pl.UTF-8):      Przykłady dla języka Ruby
269 Group:          Development/Languages
270 %if "%{_rpmversion}" >= "5"
271 BuildArch:      noarch
272 %endif
273
274 %description examples
275 Ruby examples.
276
277 %description examples -l pl.UTF-8
278 Przykłady programów w języku Ruby.
279
280 # IMPORTANT: keep this as last package, as we reset Epoch
281 %package rdoc
282 Summary:        A tool to generate HTML and command-line documentation for Ruby projects
283 Summary(pl.UTF-8):      Narzędzie do generowania dokumentacji HTML i linii poleceń dla projektów w Rubym
284 Version:        %{rdoc_ver}
285 Epoch:          0
286 License:        GPL v2 and Ruby and MIT
287 Group:          Development/Libraries
288 Requires:       %{name}-modules = 1:%{basever}.%{patchlevel}-%{release}
289 Obsoletes:      rdoc <= 0.9.0
290 %if "%{_rpmversion}" >= "5"
291 BuildArch:      noarch
292 %endif
293
294 %description rdoc
295 RDoc produces HTML and command-line documentation for Ruby projects.
296 RDoc includes the 'rdoc' and 'ri' tools for generating and displaying
297 online documentation.
298
299 %description rdoc -l pl.UTF-8
300 RDoc tworzy dokumentację HTML i linii poleceń dla projektów w języku
301 Ruby. RDoc zawiera narzędzia 'rdoc' i 'ri' do generowania i
302 wyświetlania dokumentacji online.
303
304 %package rubygems
305 Summary:        RubyGems - the Ruby standard for packaging Ruby libraries
306 Summary(pl.UTF-8):      RubyGems - standard Ruby'ego pakietowania bibliotek
307 Version:        %{rubygems_ver}
308 Epoch:          0
309 License:        Ruby or MIT
310 Group:          Development/Libraries
311 Requires:       %{name}-modules = 1:%{basever}.%{patchlevel}-%{release}
312 Requires:       %{name}-rdoc >= %{rdoc_ver}
313 Provides:       rubygems = %{rubygems_ver}
314 %if "%{_rpmversion}" >= "5"
315 BuildArch:      noarch
316 %endif
317
318 %description rubygems
319 RubyGems is the Ruby standard for publishing and managing third party
320 libraries.
321
322 %description rubygems -l pl.UTF-8
323 RubyGems to standardowe narzędzie języka Ruby do publikowania i
324 zarządzania zewnętrznymi bibliotekami.
325
326 %prep
327 %if %{with bootstrap}
328 %setup -q -n %{name}-%{basever}-p%{patchlevel} -a1 -a2 -a3 -a100
329 %else
330 %setup -q -n %{name}-%{basever}-p%{patchlevel} -a1 -a2 -a3
331 %endif
332 %patch0 -p1
333 %patch1 -p1
334 %patch2 -p1
335 %patch3 -p1
336 %patch4 -p1
337 %patch5 -p1
338
339 # must be regenerated with new bison
340 %{__rm} parse.{c,h}
341
342 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
343
344 find -type f '(' -name '*.rb' -o -name '*.cgi' -o -name '*.test' \
345         -o -name 'ruby.1' -o -name '*.html' -o -name '*.tcl' ')' \
346         | xargs %{__sed} -i 's,/usr/local/bin/,%{_bindir}/,'
347
348 %build
349 cp -f /usr/share/automake/config.sub .
350
351 # build ruby-1.8.7 first
352 %if %{with bootstrap}
353 cd %{name}-1.8.7-p330
354 %configure
355 %{__make}
356 cd ..
357 %endif
358
359 %{__autoconf}
360 %configure \
361         %{?with_bootstrap:--with-baseruby=%{name}-1.8.7-p330/miniruby} \
362         --with-rubylibprefix=%(dirname %{ruby_libdir}) \
363         --with-archdir=%{ruby_archdir} \
364         --with-sitedir=%(dirname %{ruby_sitelibdir}) \
365         --with-sitearchdir=%{ruby_sitearchdir} \
366         --with-vendordir=%(dirname %{ruby_vendorlibdir}) \
367         --with-vendorarchdir=%{ruby_vendorarchdir} \
368         --with-rubygemsdir=%{rubygems_dir} \
369         --with-search-path="%{legacy_loadpaths}" \
370         --enable-shared \
371         --enable-pthread \
372         --disable-rubygems \
373         --disable-install-doc \
374         --with-ruby-version=minor
375
376 %{__make} -j1 main \
377         COPY="cp -p" Q= \
378         %{?with_bootstrap:BASERUBY="ruby-1.8.7-p330/miniruby -I./ruby-1.8.7-p330/lib"}
379
380 %if %{with doc}
381 %{__make} -j1 rdoc
382 %endif
383
384 %install
385 rm -rf $RPM_BUILD_ROOT
386 install -d $RPM_BUILD_ROOT{%{ruby_rdocdir},%{_examplesdir}/%{name}-%{version}} \
387         $RPM_BUILD_ROOT{%{ruby_vendorarchdir},%{ruby_ridir}} \
388         $RPM_BUILD_ROOT%{ruby_vendorlibdir}/net \
389         $RPM_BUILD_ROOT{%{legacy_archdir}/racc,%{legacy_sitelibdir},%{legacy_sitearchdir},%{legacy_vendorarchdir},%{legacy_libdir}/tasks} \
390
391 %{__make} install %{?with_doc:install-doc} \
392         DESTDIR=$RPM_BUILD_ROOT
393
394 cp -Rf sample/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
395 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_mandir}/man1
396 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_mandir}/man1
397
398 %{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}/html
399
400 %if %{without batteries}
401 # packaged separately
402 %{__rm} -r $RPM_BUILD_ROOT%{ruby_libdir}/{rubygems,rake,json,minitest}
403 %{__rm} -r $RPM_BUILD_ROOT%{ruby_archdir}/json
404 %{__rm} -r $RPM_BUILD_ROOT%{gem_dir}/gems/rake-*
405 %{__rm} $RPM_BUILD_ROOT%{ruby_libdir}/{rake,rubygems,json}.rb
406 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{gem,rake}
407 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/rake*
408 %{__rm} $RPM_BUILD_ROOT%{gem_dir}/specifications/{json,minitest,rake}-*.gemspec
409 %{?with_doc:%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/ri/%{ruby_version}/system/JSON}
410 %endif
411
412 %if %{with doc}
413 # too much .ri
414 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/cache.ri
415 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/created.rid
416 %endif
417
418 %clean
419 rm -rf $RPM_BUILD_ROOT
420
421 %post   -p /sbin/ldconfig
422 %postun -p /sbin/ldconfig
423
424 %files
425 %defattr(644,root,root,755)
426 %doc NEWS LEGAL README README.EXT ChangeLog ToDo
427 %attr(755,root,root) %{_bindir}/ruby
428 %attr(755,root,root) %{_libdir}/libruby.so.*.*.*
429 %attr(755,root,root) %ghost %{_libdir}/libruby.so.1.9
430 %{_mandir}/man1/ruby.1*
431
432 %if %{with batteries}
433 # rake
434 %attr(755,root,root) %{_bindir}/rake
435 %{_mandir}/man1/rake.1*
436 %endif
437
438 %dir %{_libdir}/%{name}
439 %dir %{_libdir}/%{name}/%{vendordir}
440 %dir %{_datadir}/%{name}
441 %dir %{_datadir}/%{name}/%{vendordir}
442
443 %dir %{ruby_libdir}
444 %dir %{ruby_archdir}
445 %dir %{ruby_vendorlibdir}
446 %dir %{ruby_vendorarchdir}
447
448 %dir %{_datadir}/ri
449 %dir %{_datadir}/ri/%{ruby_version}
450 %dir %{ruby_ridir}
451
452 %dir %{ruby_rdocdir}
453
454 # common dirs for ruby vendor modules
455 %dir %{ruby_vendorlibdir}/net
456
457 # legacy dirs. when everything rebuilt in Th not using these dirs. drop them
458 %dir %{legacy_archdir}
459 %dir %{legacy_sitedir}
460 %dir %{legacy_sitelibdir}
461 %dir %{legacy_sitearchdir}
462 %dir %{legacy_vendorarchdir}
463 %dir %{legacy_libdir}/tasks
464 %dir %{legacy_archdir}/racc
465
466 %files devel
467 %defattr(644,root,root,755)
468 %attr(755,root,root) %{_libdir}/libruby.so
469 %{_includedir}/%{name}-%{ruby_version}
470 %{_pkgconfigdir}/ruby-%{ruby_version}.pc
471 %{ruby_libdir}/mkmf.rb
472
473 %files static
474 %defattr(644,root,root,755)
475 %{_libdir}/libruby-static.a
476
477 %if %{with tk}
478 %files tk
479 %defattr(644,root,root,755)
480 %{ruby_libdir}/tcltk.rb
481 %{ruby_libdir}/tk*.rb
482 %{ruby_libdir}/tk
483 %{ruby_libdir}/tkextlib
484 %attr(755,root,root) %{ruby_archdir}/t*.so
485 %endif
486
487 %files rdoc
488 %defattr(644,root,root,755)
489 %attr(755,root,root) %{_bindir}/rdoc
490 %attr(755,root,root) %{_bindir}/ri
491 %{_mandir}/man1/rdoc.1*
492 %{ruby_libdir}/rdoc
493 %dir %{gem_dir}/gems/rdoc-%{rdoc_ver}
494 %dir %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin
495 %attr(755,root,root) %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin/rdoc
496 %{gem_dir}/specifications/rdoc-%{rdoc_ver}.gemspec
497 %attr(755,root,root) %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin/ri
498
499 %if %{with batteries}
500 %files rubygems
501 %defattr(644,root,root,755)
502 %attr(755,root,root) %{_bindir}/gem
503 %{ruby_libdir}/rubygems
504 %{ruby_libdir}/rubygems.rb
505 %{ruby_libdir}/ubygems.rb
506 %endif
507
508 %files modules
509 %defattr(644,root,root,755)
510 %attr(755,root,root) %{_bindir}/erb
511 %attr(755,root,root) %{_bindir}/irb
512 %attr(755,root,root) %{_bindir}/testrb
513 %{ruby_libdir}/bigdecimal
514 %{ruby_libdir}/cgi
515 %{ruby_libdir}/date
516 %{ruby_libdir}/digest
517 %{ruby_libdir}/dl
518 %{ruby_libdir}/drb
519 %{ruby_libdir}/fiddle
520 %{ruby_libdir}/io
521 %{ruby_libdir}/irb
522 %{ruby_libdir}/matrix
523 %{ruby_libdir}/net
524 %{ruby_libdir}/openssl
525 %{ruby_libdir}/optparse
526 %{ruby_libdir}/psych
527 %{ruby_libdir}/racc
528 %{ruby_libdir}/rbconfig
529 %{ruby_libdir}/rexml
530 %{ruby_libdir}/rinda
531 %{ruby_libdir}/ripper
532 %{ruby_libdir}/rss
533 %{ruby_libdir}/shell
534 %{ruby_libdir}/syck
535 %{ruby_libdir}/test
536 %{ruby_libdir}/uri
537 %{ruby_libdir}/webrick
538 %{ruby_libdir}/xmlrpc
539 %{ruby_libdir}/yaml
540 %{ruby_libdir}/[A-Za-s]*.rb
541 %{ruby_libdir}/tempfile.rb
542 %{ruby_libdir}/thread.rb
543 %{ruby_libdir}/thwait.rb
544 %{ruby_libdir}/time.rb
545 %{ruby_libdir}/timeout.rb
546 %{ruby_libdir}/tmpdir.rb
547 %{ruby_libdir}/tracer.rb
548 %{ruby_libdir}/tsort.rb
549 %{ruby_libdir}/[u-z]*.rb
550 %if %{with batteries}
551 %exclude %{ruby_libdir}/rubygems.rb
552 %exclude %{ruby_libdir}/ubygems.rb
553 %endif
554 %exclude %{ruby_libdir}/mkmf.rb
555 %attr(755,root,root) %{ruby_archdir}/[a-s]*.so
556 %attr(755,root,root) %{ruby_archdir}/[u-z]*.so
557 %dir %{ruby_archdir}/digest
558 %attr(755,root,root) %{ruby_archdir}/digest/*.so
559 %dir %{ruby_archdir}/dl
560 %attr(755,root,root) %{ruby_archdir}/dl/callback.so
561 %dir %{ruby_archdir}/enc
562 %attr(755,root,root) %{ruby_archdir}/enc/*.so
563 %dir %{ruby_archdir}/enc/trans
564 %attr(755,root,root) %{ruby_archdir}/enc/trans/*.so
565 %dir %{ruby_archdir}/io
566 %attr(755,root,root) %{ruby_archdir}/io/*.so
567 %dir %{ruby_archdir}/mathn
568 %attr(755,root,root) %{ruby_archdir}/mathn/*.so
569 %dir %{ruby_archdir}/racc
570 %attr(755,root,root) %{ruby_archdir}/racc/*.so
571 %{ruby_archdir}/rbconfig.rb
572
573 %{gem_dir}/specifications/bigdecimal-%{bigdecimal_ver}.gemspec
574 %{gem_dir}/specifications/io-console-%{io_console_ver}.gemspec
575
576 %if %{with batteries}
577 # json
578 %{ruby_libdir}/json
579 %dir %{ruby_archdir}/json
580 %dir %{ruby_archdir}/json/ext
581 %attr(755,root,root) %{ruby_archdir}/json/ext/*.so
582 %{gem_dir}/specifications/json-%{json_ver}.gemspec
583
584 # minitest
585 %{ruby_libdir}/minitest
586 %{gem_dir}/specifications/minitest-%{minitest_ver}.gemspec
587
588 # rake
589 %{ruby_libdir}/rake
590 %dir %{gem_dir}/gems/rake-%{rake_ver}
591 %dir %{gem_dir}/gems/rake-%{rake_ver}/bin
592 %attr(755,root,root) %{gem_dir}/gems/rake-%{rake_ver}/bin/rake
593 %{gem_dir}/specifications/rake-%{rake_ver}.gemspec
594 %endif
595
596 # parents of gem_dir
597 %dir %{_datadir}/%{name}/gems
598 #%dir %{_datadir}/%{name}/gems/%{ruby_version}
599 %dir %{_datadir}/%{name}/gems/%{ruby_version}/gems
600
601 %dir %{gem_dir}
602 %dir %{gem_dir}/specifications
603 %{_mandir}/man1/erb.1*
604 %{_mandir}/man1/irb.1*
605 %{_mandir}/man1/ri.1*
606 %{_mandir}/man1/testrb.1*
607
608 %files doc
609 %defattr(644,root,root,755)
610 %doc ruby-doc-bundle/*
611 %{?with_doc:%doc ruby_%{doc_version}_stdlib}
612 %{?with_doc:%doc ruby_%{doc_version}_core}
613
614 %if %{with doc}
615 %files doc-ri
616 %defattr(644,root,root,755)
617 %{ruby_ridir}/*
618 %endif
619
620 %files examples
621 %defattr(644,root,root,755)
622 %{_examplesdir}/%{name}-%{version}
This page took 0.075796 seconds and 3 git commands to generate.