]> git.pld-linux.org Git - packages/ruby.git/blob - ruby.spec
- updated ia64 patch
[packages/ruby.git] / ruby.spec
1 # TODO:
2 # - SECURITY: http://securitytracker.com/alerts/2004/Aug/1010955.html
3 %define         ruby_ridir      %{_datadir}/ri/1.8/system
4
5 %define         pre             preview2
6
7 Summary:        Ruby - interpreted scripting language
8 Summary(ja):    ¥ª¥Ö¥¸¥§¥¯¥È»Ø¸þ¸À¸ìRuby¥¤¥ó¥¿¥×¥ê¥¿
9 Summary(pl):    Ruby - interpretowany jêzyk skryptowy
10 Summary(pt_BR): Linguagem de script orientada a objeto
11 Summary(zh_CN): ruby - Ò»ÖÖ¿ìËÙ¸ßЧµÄÃæÏò¶ÔÏó½Å±¾±à³ÌÓïÑÔ
12 Name:           ruby
13 Version:        1.8.2
14 Release:        1.%{pre}.1
15 Epoch:          1
16 License:        The Ruby License
17 Group:          Development/Languages
18 Source0:        ftp://ftp.ruby-lang.org/pub/ruby/1.8/%{name}-%{version}-%{pre}.tar.gz
19 # Source0-md5:  f40dae2bd20fd41d681197f1229f25e0
20 Source1:        http://www.ibiblio.org/pub/languages/ruby/doc/%{name}-texi-1.4-en.tar.gz
21 # Source1-md5:  839fda4af52b5c5c6d21f879f7fc62bf
22 Source2:        http://www.math.sci.hokudai.ac.jp/~gotoken/ruby/%{name}-uguide-981227.tar.gz
23 # Source2-md5:  24eadcd067278901da9ad70efb146b07
24 Source3:        http://www.ibiblio.org/pub/languages/ruby/doc/%{name}faq-990927.tar.gz
25 # Source3-md5:  634c25b14e19925d10af3720d72e8741
26 Source4:        irb.1
27 Source5:        http://www.geocities.jp/kosako1/oniguruma/archive/onigd20040821.tar.gz
28 # Source5-md5:  ed8e12118b0d39d6d8581128ad36276f
29 Patch0:         %{name}-info.patch
30 Patch1:         %{name}-LIB_PREFIX.patch
31 Patch2:         %{name}-ia64.patch
32 Patch3:         %{name}-onig-types.patch
33 URL:            http://www.ruby-lang.org/
34 BuildRequires:  autoconf
35 BuildRequires:  automake
36 BuildRequires:  gdbm-devel >= 1.8.3
37 BuildRequires:  ncurses-devel
38 BuildRequires:  readline-devel >= 4.2
39 BuildRequires:  texinfo
40 BuildRequires:  tk-devel
41 Requires(post,postun): /sbin/ldconfig
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43 Obsoletes:      ruby-doc
44 Obsoletes:      rdoc
45 Obsoletes:      ruby-REXML
46
47 %define         _ulibdir        %{_prefix}/lib
48
49 # bleh, some nasty (gcc or ruby) bug still not fixed
50 # (SEGV or "unexpected break" on miniruby run during build)
51 %define         specflags_ia64  -O0
52
53 %description
54 Ruby is the interpreted scripting language for quick and easy
55 object-oriented programming. It has many features to process text
56 files and to do system management tasks (as in Perl). It is simple,
57 straight-forward, extensible, and portable.
58
59 %description -l ja
60 Ruby¤Ï¥·¥ó¥×¥ë¤«¤Ä¶¯ÎϤʥª¥Ö¥¸¥§¥¯¥È»Ø¸þ¥¹¥¯¥ê¥×¥È¸À¸ì¤Ç¤¹¡¥Ruby¤ÏºÇ½é
61 ¤«¤é½ã¿è¤Ê¥ª¥Ö¥¸¥§¥¯¥È»Ø¸þ¸À¸ì¤È¤·¤ÆÀ߷פµ¤ì¤Æ¤¤¤Þ¤¹¤«¤é¡¤¥ª¥Ö¥¸¥§¥¯¥È
62 »Ø¸þ¥×¥í¥°¥é¥ß¥ó¥°¤ò¼ê·Ú¤Ë¹Ô¤¦»ö¤¬½ÐÍè¤Þ¤¹¡¥¤â¤Á¤í¤óÄ̾ï¤Î¼ê³¤­·¿¤Î¥×
63 ¥í¥°¥é¥ß¥ó¥°¤â²Äǽ¤Ç¤¹¡¥
64
65 Ruby¤Ï¥Æ¥­¥¹¥È½èÍý´Ø·¸¤ÎǽÎϤʤɤËÍ¥¤ì¡¤Perl¤ÈƱ¤¸¤¯¤é¤¤¶¯ÎϤǤ¹¡¥¤µ¤é
66 ¤Ë¥·¥ó¥×¥ë¤Êʸˡ¤È¡¤Îã³°½èÍý¤ä¥¤¥Æ¥ì¡¼¥¿¤Ê¤É¤Îµ¡¹½¤Ë¤è¤Ã¤Æ¡¤¤è¤êʬ¤«¤ê
67 ¤ä¤¹¤¤¥×¥í¥°¥é¥ß¥ó¥°¤¬½ÐÍè¤Þ¤¹¡¥
68
69 %description -l pl
70 Ruby to interpretowany jêzyk skryptowy, w sam raz dla ³atwego i
71 szybkiego pisania zorientowanych obiektowo programów. Ma wiele funkcji
72 u³atwiaj±cych przetwarzanie plików tekstowych i wykonywanie prac
73 zwi±zanych z zarz±dzaniem systemu (podobnie jak Perl). Jest prosty,
74 rozszerzalny i przeno¶ny.
75
76 %description -l pt_BR
77 Ruby é uma linguagem de script interpretada de programação
78 orientada a objeto. Possui diversas características para
79 processamento de texto. É simples, extensível e direta.
80
81 %package tk
82 Summary:        Ruby/Tk bindings
83 Summary(pl):    Wi±zania Ruby/Tk
84 Group:          Development/Languages
85 Requires:       %{name} = %{epoch}:%{version}-%{release}
86
87 %description tk
88 This pachage contains Ruby/Tk bindings.
89
90 %description tk -l pl
91 Ten pakiet zawiera wi±zania Ruby/Tk.
92
93 %package devel
94 Summary:        Ruby development libraries
95 Summary(pl):    Biblioteki programistyczne interpretera jêzyka Ruby
96 Group:          Development/Languages
97 Requires:       %{name} = %{epoch}:%{version}-%{release}
98
99 %description devel
100 Ruby development libraries.
101
102 %description devel -l pl
103 Biblioteki programistyczne interpretera jêzyka Ruby.
104
105 %package static
106 Summary:        Ruby static libraries
107 Summary(pl):    Biblioteki statyczne Ruby
108 Group:          Development/Languages
109 Requires:       %{name} = %{epoch}:%{version}-%{release}
110
111 %description static
112 Ruby static libraries.
113
114 %description devel -l pl
115 Biblioteki statyczne Ruby.
116
117 %prep
118 %setup -q -a1 -a2 -a3 -a5
119 %patch0 -p1
120 %patch1 -p1
121 %patch2 -p1
122 %patch3 -p1
123
124 find . -name '*.rb' -or -name '*.cgi' -or -name '*.test' | xargs perl -pi -e "s#/usr/local/bin#bin#"
125
126 %build
127 cp -f /usr/share/automake/config.sub .
128
129 cd oniguruma
130 %configure \
131         --with-rubydir=..
132 %{__make} 18
133 cd ..
134
135 %{__autoconf}
136 %configure \
137         --enable-shared \
138         --enable-pthread \
139         --with-X11-lib=/usr/X11R6/%{_lib}
140 %{__make}
141
142 %{__make} info -C %{name}-texi-1.4-en
143
144 mkdir rdoc
145
146 ./miniruby -I lib bin/rdoc -o rdoc/core .
147 ./miniruby -I lib bin/rdoc -o rdoc/stdlib lib ext/*/
148 ./miniruby -I lib -I ext/syck bin/rdoc --ri -o ri lib ext/*/
149
150 %install
151 rm -rf $RPM_BUILD_ROOT
152 install -d $RPM_BUILD_ROOT{%{_infodir},%{_mandir}/man1,%{_examplesdir}/%{name}-%{version},%{ruby_ridir}}
153
154 %{__make} install \
155         DESTDIR=$RPM_BUILD_ROOT
156
157 cp -a sample/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
158 install %{name}-texi-1.4-en/ruby.info* $RPM_BUILD_ROOT%{_infodir}
159 install %{SOURCE4} $RPM_BUILD_ROOT%{_mandir}/man1
160
161 mv -f ruby-uguide guide
162 mv -f rubyfaq faq
163
164 cp -a ri/ri/* $RPM_BUILD_ROOT%{ruby_ridir}
165
166 %clean
167 rm -rf $RPM_BUILD_ROOT
168
169 %post
170 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
171 /sbin/ldconfig
172
173 %postun
174 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
175 /sbin/ldconfig
176
177 %files
178 %defattr(644,root,root,755)
179 %doc guide faq misc README README.EXT ChangeLog ToDo
180 %doc rdoc
181 %attr(755,root,root) %{_bindir}/*
182 %attr(755,root,root) %{_libdir}/lib*.so.*.*
183 %dir %{_libdir}/%{name}
184 %dir %{_libdir}/%{name}/1.8
185 %{_libdir}/%{name}/1.8/bigdecimal
186 %{_libdir}/%{name}/1.8/cgi
187 %{_libdir}/%{name}/1.8/date
188 %{_libdir}/%{name}/1.8/dl
189 %{_libdir}/%{name}/1.8/drb
190 %{_libdir}/%{name}/1.8/io
191 %{_libdir}/%{name}/1.8/irb
192 %{_libdir}/%{name}/1.8/net
193 %{_libdir}/%{name}/1.8/openssl
194 %{_libdir}/%{name}/1.8/optparse
195 %{_libdir}/%{name}/1.8/racc
196 %{_libdir}/%{name}/1.8/rdoc
197 %{_libdir}/%{name}/1.8/rexml
198 %{_libdir}/%{name}/1.8/rinda
199 %{_libdir}/%{name}/1.8/rss
200 %{_libdir}/%{name}/1.8/runit
201 %{_libdir}/%{name}/1.8/shell
202 %{_libdir}/%{name}/1.8/soap
203 %{_libdir}/%{name}/1.8/test
204 %{_libdir}/%{name}/1.8/uri
205 %{_libdir}/%{name}/1.8/webrick
206 %{_libdir}/%{name}/1.8/wsdl
207 %{_libdir}/%{name}/1.8/xmlrpc
208 %{_libdir}/%{name}/1.8/xsd
209 %{_libdir}/%{name}/1.8/yaml
210 %{_libdir}/%{name}/1.8/[A-Za-s]*.rb
211 %{_libdir}/%{name}/1.8/tempfile.rb
212 %{_libdir}/%{name}/1.8/thread.rb
213 %{_libdir}/%{name}/1.8/thwait.rb
214 %{_libdir}/%{name}/1.8/time.rb
215 %{_libdir}/%{name}/1.8/timeout.rb
216 %{_libdir}/%{name}/1.8/tmpdir.rb
217 %{_libdir}/%{name}/1.8/tracer.rb
218 %{_libdir}/%{name}/1.8/tsort.rb
219 %{_libdir}/%{name}/1.8/[u-z]*.rb
220 %dir %{_libdir}/%{name}/1.8/*-linux*
221 %attr(755,root,root) %{_libdir}/%{name}/1.8/*-linux*/[a-s]*.so
222 %attr(755,root,root) %{_libdir}/%{name}/1.8/*-linux*/[u-z]*.so
223 %attr(755,root,root) %{_libdir}/%{name}/1.8/*-linux*/digest/*.so
224 %attr(755,root,root) %{_libdir}/%{name}/1.8/*-linux*/io/*.so
225 %attr(755,root,root) %{_libdir}/%{name}/1.8/*-linux*/racc/*.so
226 %{_libdir}/%{name}/1.8/*-linux*/rbconfig.rb
227 %dir %{_ulibdir}/%{name}/site_ruby
228 %dir %{_ulibdir}/%{name}/site_ruby/1.8
229 %dir %{_ulibdir}/%{name}/site_ruby/1.8/*-linux*
230 %dir %{ruby_ridir}
231 %{ruby_ridir}/*
232 %{_mandir}/*/*
233 %{_infodir}/*.info*
234 %{_examplesdir}/%{name}-%{version}
235
236 %files devel
237 %defattr(644,root,root,755)
238 %attr(755,root,root) %{_libdir}/lib*.so
239 %{_libdir}/%{name}/1.8/*/*.h
240
241 %files static
242 %defattr(644,root,root,755)
243 %{_libdir}/lib*.a
244
245 %files tk
246 %defattr(644,root,root,755)
247 %{_libdir}/%{name}/1.8/tcltk.rb
248 %{_libdir}/%{name}/1.8/tk*.rb
249 %{_libdir}/%{name}/1.8/tk
250 %{_libdir}/%{name}/1.8/tkextlib
251 %attr(755,root,root) %{_libdir}/%{name}/1.8/*-linux*/t*.so
This page took 0.080679 seconds and 3 git commands to generate.