]> git.pld-linux.org Git - packages/ruby.git/blob - ruby.spec
Merge branch 'new-paths': adds vendor and noarch LOAD_PATHS
[packages/ruby.git] / ruby.spec
1 #
2 # TODO:
3 #       - include ext/ in docs
4 #       - replace ri with fastri
5 #       - patch ri to search multiple indexes (one per package), so RPMs can install ri docs
6 #   - fix inconsistencies with versioned vs not-versioned dirs (see dirname hacks in configure)
7 #   - custom-rubygems-location.patch
8 #
9 # Conditional build:
10 %bcond_without  doc             # skip (time-consuming) docs generating; intended for speed up test builds
11 %bcond_without  tk              # skip building package with Tk bindings
12 %bcond_without  batteries       # Don't include rubygems, json or rake
13 %bcond_with     bootstrap       # build bootstrap version
14
15 %define         ruby_version    1.9
16 %define         basever         1.9.3
17 %define         patchlevel      392
18 %define         doc_version     1_9_3
19 %define         json_ver        1.5.5
20 %define         rake_ver        0.9.2.2
21 %define         rubygems_ver    1.8.11
22 %define         minitest_ver    2.5.1
23 %define         rdoc_ver        3.9.5
24 Summary:        Ruby - interpreted scripting language
25 Summary(ja.UTF-8):      オブジェクト指向言語Rubyインタプリタ
26 Summary(pl.UTF-8):      Ruby - interpretowany język skryptowy
27 Summary(pt_BR.UTF-8):   Linguagem de script orientada a objeto
28 Summary(zh_CN.UTF-8):   ruby - 一种快速高效的面向对象脚本编程语言
29 Name:           ruby
30 Version:        %{basever}.%{patchlevel}
31 # NOTE: do not decrease Release, when updating Version,
32 # unless rdoc_ver, rubygems_ver *both* are increased as well
33 Release:        2
34 Epoch:          1
35 # Public Domain for example for: include/ruby/st.h, strftime.c, ...
36 License:        (Ruby or BSD) and Public Domain
37 Group:          Development/Languages
38 Source0:        ftp://ftp.ruby-lang.org/pub/ruby/%{ruby_version}/%{name}-%{basever}-p%{patchlevel}.tar.bz2
39 # Source0-md5:  a810d64e2255179d2f334eb61fb8519c
40 Source1:        http://www.ruby-doc.org/download/%{name}-doc-bundle.tar.gz
41 # Source1-md5:  ad1af0043be98ba1a4f6d0185df63876
42 Source2:        http://www.ruby-doc.org/downloads/%{name}_%{doc_version}_stdlib_rdocs.tgz
43 # Source2-md5:  ec622612428672c432b6f65dd31a84b5
44 Source3:        http://www.ruby-doc.org/downloads/%{name}_%{doc_version}_core_rdocs.tgz
45 # Source3-md5:  1892aadde51d36106c513bced2193dff
46 Source100:      ftp://ftp.ruby-lang.org/pub/ruby/1.8/%{name}-1.8.7-p330.tar.gz
47 # Source100-md5:        50a49edb787211598d08e756e733e42e
48 Source4:        rdoc.1
49 Source5:        testrb.1
50 Source6:        %{name}-mode-init.el
51 Patch0:         %{name}-lib64.patch
52 Patch1:         %{name}-ffs.patch
53 Patch2:         fix-bison-invocation.patch
54 # http://redmine.ruby-lang.org/issues/5231
55 Patch3:         disable-versioned-paths.patch
56 # TODO: Should be submitted upstream?
57 Patch4:         arch-specific-dir.patch
58 # http://redmine.ruby-lang.org/issues/5281
59 Patch5:         site-and-vendor-arch-flags.patch
60 URL:            http://www.ruby-lang.org/
61 BuildRequires:  autoconf >= 2.60
62 BuildRequires:  automake
63 BuildRequires:  bison
64 BuildRequires:  db-devel
65 BuildRequires:  gdbm-devel >= 1.8.3
66 BuildRequires:  libffi-devel
67 BuildRequires:  ncurses-devel
68 BuildRequires:  openssl-devel
69 BuildRequires:  pkgconfig
70 BuildRequires:  readline-devel >= 4.2
71 %{!?with_bootstrap:BuildRequires:       ruby-modules}
72 BuildRequires:  sed >= 4.0
73 BuildRequires:  yaml-devel
74 %if %{with tk}
75 BuildRequires:  tk-devel
76 %endif
77 Requires(post,postun):  /sbin/ldconfig
78 Provides:       ruby(ver) = %{ruby_version}
79 Obsoletes:      rdoc
80 Obsoletes:      ruby-REXML
81 Obsoletes:      ruby-doc < 1.8.4
82 Obsoletes:      ruby-fastthread
83 %if %{with batteries}
84 Provides:       json = %{json_ver}
85 Provides:       rake = %{rake_ver}
86 Provides:       ruby-json = %{json_ver}
87 Provides:       ruby-rake = %{rake_ver}
88 Obsoletes:      ruby-json
89 Obsoletes:      ruby-rake
90 %endif
91 Conflicts:      ruby-activesupport < 2.3.11-2
92 Conflicts:      ruby-activesupport2 < 2.3.11-2
93 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
94
95 %define ruby_ridir              %{_datadir}/ri/%{ruby_version}/system
96 %define gem_dir                 %{_datadir}/%{name}/gems/%{ruby_version}
97
98 # The RubyGems library has to stay out of Ruby directory three, since the
99 # RubyGems should be share by all Ruby implementations.
100 %define rubygems_dir            %{_datadir}/rubygems
101
102 %define ruby_archdir            %{_libdir}/%{name}/%{ruby_version}
103 %define ruby_libdir             %{_datadir}/%{name}/%{ruby_version}
104
105 # This is the local lib/arch and should not be used for packaging.
106 %define sitedir                 site_ruby
107 %define ruby_sitedir            %{_prefix}/local/share/%{name}/%{sitedir}
108 %define ruby_sitearchdir        %{_prefix}/local/%{_lib}/%{name}/%{sitedir}/%{ruby_version}
109 %define ruby_sitelibdir         %{_prefix}/local/share/%{name}/%{sitedir}/%{ruby_version}
110
111 # This is the general location for libs/archs compatible with all
112 # or most of the Ruby versions available in the PLD repositories.
113 %define vendordir               vendor_ruby
114 %define ruby_vendordir          %{_datadir}/%{name}/%{vendordir}
115 %define ruby_vendorarchdir      %{_libdir}/%{name}/%{vendordir}/%{ruby_version}
116 %define ruby_vendorlibdir       %{_datadir}/%{name}/%{vendordir}/%{ruby_version}
117
118 # TODO: drop legacy loadpaths after all ruby modules rebuilt in Th
119 %define legacy_libdir           %{_libdir}/%{name}/%{ruby_version}
120 %define legacy_archdir          %{_libdir}/%{name}/%{ruby_version}/%{_arch}-linux
121 %define legacy_sitedir          %{_libdir}/%{name}/%{sitedir}
122 %define legacy_sitelibdir       %{_libdir}/%{name}/%{sitedir}/%{ruby_version}
123 %define legacy_sitearchdir      %{_libdir}/%{name}/%{sitedir}/%{ruby_version}/%{_arch}-linux
124 %define legacy_vendordir        %{_libdir}/%{name}/%{vendordir}
125 %define legacy_vendorlibdir     %{_libdir}/%{name}/%{vendordir}/%{ruby_version}
126 %define legacy_vendorarchdir%{_libdir}/%{name}/%{vendordir}/%{ruby_version}/%{_arch}-linux
127
128 %define legacy_siteloadpath     %{legacy_sitelibdir}\\0%{legacy_sitearchdir}\\0%{legacy_sitedir}
129 %define legacy_vendorloadpath   %{legacy_vendorarchdir}
130 %define legacy_loadpath         %{legacy_archdir}
131 %define legacy_loadpaths        %{legacy_siteloadpath}\\0%{legacy_vendorloadpath}\\0%{legacy_loadpath}
132
133 # bleh, some nasty (gcc or ruby) bug still not fixed
134 # (SEGV or "unexpected break" on miniruby run during build)
135 %define         specflags_ia64  -O0
136
137 # ruby needs frame pointers for correct exception handling
138 %define         specflags_ia32  -fno-omit-frame-pointer
139
140 %description
141 Ruby is the interpreted scripting language for quick and easy
142 object-oriented programming. It has many features to process text
143 files and to do system management tasks (as in Perl). It is simple,
144 straight-forward, extensible, and portable.
145
146 This package contains only shared library and ruby interpreter. To get
147 full-functional ruby environment install ruby-modules package.
148
149 %description -l ja.UTF-8
150 Rubyはシンプルかつ強力なオブジェクト指向スクリプト言語です.Rubyは最初
151 から純粋なオブジェクト指向言語として設計されていますから,オブジェクト
152 指向プログラミングを手軽に行う事が出来ます.もちろん通常の手続き型のプ ログラミングも可能です.
153
154 %description -l pl.UTF-8
155 Ruby to interpretowany język skryptowy, w sam raz dla łatwego i
156 szybkiego pisania zorientowanych obiektowo programów. Ma wiele funkcji
157 ułatwiających przetwarzanie plików tekstowych i wykonywanie prac
158 związanych z zarządzaniem systemu (podobnie jak Perl). Jest prosty,
159 rozszerzalny i przenośny.
160
161 Ten pakiet zawiera tylko bibliotekę dzieloną i interpreter ruby.
162 Zainstaluj pakiet ruby-modules, jeżeli potrzebujesz w pełni
163 funkcjonalnego środowiska ruby.
164
165 %description -l pt_BR.UTF-8
166 Ruby é uma linguagem de script interpretada de programação orientada a
167 objeto. Possui diversas características para processamento de texto. É
168 simples, extensível e direta.
169
170 %package modules
171 Summary:        Ruby standard modules and utilities
172 Summary(pl.UTF-8):      Standardowe moduły i narzędzia dla języka Ruby
173 Group:          Development/Languages
174 Requires:       %{name} = %{epoch}:%{version}-%{release}
175 Suggests:       ruby-rubygems
176 # workaround for autodep generator not getting version properly
177 Provides:       ruby(abi) = %{ruby_version}
178 Provides:       ruby-modules(ver) = %{ruby_version}
179 Obsoletes:      ruby-minitest
180
181 %description modules
182 Ruby standard modules and utilities:
183 - erb - Tiny eRuby
184 - irb - interactive Ruby
185 - testrb - automatic runner for Test::Unit of Ruby
186
187 %description modules -l pl.UTF-8
188 Standardowe moduły i narzędzia Ruby:
189 - erb - mały eRuby
190 - irb - interaktywny Ruby
191 - testrb - automatyczny runner dla Ruby Test::Unit
192
193 %package tk
194 Summary:        Ruby/Tk bindings
195 Summary(pl.UTF-8):      Wiązania Ruby/Tk
196 Group:          Development/Languages
197 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
198
199 %description tk
200 This pachage contains Ruby/Tk bindings.
201
202 %description tk -l pl.UTF-8
203 Ten pakiet zawiera wiązania Ruby/Tk.
204
205 %package devel
206 Summary:        Ruby development libraries
207 Summary(pl.UTF-8):      Biblioteki programistyczne interpretera języka Ruby
208 Group:          Development/Languages
209 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
210
211 %description devel
212 Ruby development libraries.
213
214 %description devel -l pl.UTF-8
215 Biblioteki programistyczne interpretera języka Ruby.
216
217 %package static
218 Summary:        Ruby static libraries
219 Summary(pl.UTF-8):      Biblioteki statyczne Ruby
220 Group:          Development/Languages
221 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
222
223 %description static
224 Ruby static libraries.
225
226 %description static -l pl.UTF-8
227 Biblioteki statyczne Ruby.
228
229 %package doc
230 Summary:        Ruby HTML documentation
231 Summary(pl.UTF-8):      Dokumentacja HTML do Ruby
232 Group:          Documentation
233
234 %description doc
235 Ruby HTML documentation: FAQ, guide, core and standard library.
236
237 %description doc -l pl.UTF-8
238 Dokumentacja HTML do Ruby: FAQ, przewodnik, dokumentacja dla core i
239 stdlib.
240
241 %package doc-ri
242 Summary:        Ruby ri documentation
243 Summary(pl.UTF-8):      Dokumentacja Ruby w formacie ri
244 Group:          Documentation
245 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
246
247 %description doc-ri
248 Ruby ri documentation.
249
250 %description doc-ri -l pl.UTF-8
251 Dokumentacja Ruby w formacie ri.
252
253 %package examples
254 Summary:        Ruby examples
255 Summary(pl.UTF-8):      Przykłady dla języka Ruby
256 Group:          Development/Languages
257
258 %description examples
259 Ruby examples.
260
261 %description examples -l pl.UTF-8
262 Przykłady programów w języku Ruby.
263
264 # IMPORTANT: keep this as last package, as we reset Epoch
265 %package rdoc
266 Summary:        A tool to generate HTML and command-line documentation for Ruby projects
267 Version:        %{rdoc_ver}
268 Epoch:          0
269 License:        GPL v2 and Ruby and MIT
270 Group:          Development/Libraries
271 Requires:       %{name}-modules = 1:%{basever}.%{patchlevel}-%{release}
272
273 %description rdoc
274 RDoc produces HTML and command-line documentation for Ruby projects.
275 RDoc includes the 'rdoc' and 'ri' tools for generating and displaying
276 online documentation.
277
278 %package rubygems
279 Summary:        The Ruby standard for packaging ruby libraries
280 Version:        %{rubygems_ver}
281 License:        Ruby or MIT
282 Group:          Development/Libraries
283 Requires:       %{name}-modules = 1:%{basever}.%{patchlevel}-%{release}
284 Requires:       %{name}-rdoc >= %{rdoc_ver}
285 Provides:       rubygems = %{rubygems_ver}
286 %if "%{_rpmversion}" >= "5"
287 BuildArch:      noarch
288 %endif
289
290 %description rubygems
291 RubyGems is the Ruby standard for publishing and managing third party
292 libraries.
293
294 %prep
295 %if %{with bootstrap}
296 %setup -q -n %{name}-%{basever}-p%{patchlevel} -a1 -a2 -a3 -a100
297 %else
298 %setup -q -n %{name}-%{basever}-p%{patchlevel} -a1 -a2 -a3
299 %endif
300 %patch0 -p1
301 %patch1 -p1
302 %patch2 -p1
303 %patch3 -p1
304 %patch4 -p1
305 %patch5 -p1
306
307 # must be regenerated with new bison
308 %{__rm} parse.{c,h}
309
310 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
311
312 find -type f '(' -name '*.rb' -o -name '*.cgi' -o -name '*.test' \
313         -o -name 'ruby.1' -o -name '*.html' -o -name '*.tcl' ')' \
314         | xargs %{__sed} -i 's,/usr/local/bin/,%{_bindir}/,'
315
316 %build
317 cp -f /usr/share/automake/config.sub .
318
319 # build ruby-1.8.7 first
320 %if %{with bootstrap}
321 cd %{name}-1.8.7-p330
322 %configure
323 %{__make}
324 cd ..
325 %endif
326
327 %{__autoconf}
328 %configure \
329         %{?with_bootstrap:--with-baseruby=%{name}-1.8.7-p330/miniruby} \
330         --with-rubylibprefix=%(dirname %{ruby_libdir}) \
331         --with-archdir=%{ruby_archdir} \
332         --with-sitedir=%(dirname %{ruby_sitelibdir}) \
333         --with-sitearchdir=%{ruby_sitearchdir} \
334         --with-vendordir=%(dirname %{ruby_vendorlibdir}) \
335         --with-vendorarchdir=%{ruby_vendorarchdir} \
336         --with-rubygemsdir=%{rubygems_dir} \
337         --with-search-path="%{legacy_loadpaths}" \
338         --enable-shared \
339         --enable-pthread \
340         --disable-install-doc \
341         --with-ruby-version=minor
342
343 %{__make} -j1 main \
344         COPY="cp -p" Q= \
345         %{?with_bootstrap:BASERUBY="ruby-1.8.7-p330/miniruby -I./ruby-1.8.7-p330/lib"}
346
347 %if %{with doc}
348 %{__make} -j1 rdoc
349 %endif
350
351 %install
352 rm -rf $RPM_BUILD_ROOT
353 install -d $RPM_BUILD_ROOT{%{ruby_rdocdir},%{_examplesdir}/%{name}-%{version}} \
354         $RPM_BUILD_ROOT%{ruby_libdir}/tasks \
355         $RPM_BUILD_ROOT{%{ruby_vendorarchdir},%{ruby_ridir}} \
356         $RPM_BUILD_ROOT{%{legacy_archdir},%{legacy_sitelibdir},%{legacy_sitearchdir},%{legacy_vendorarchdir}} \
357
358 %{__make} install %{?with_doc:install-doc} \
359         DESTDIR=$RPM_BUILD_ROOT
360
361 cp -Rf sample/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
362 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_mandir}/man1
363 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_mandir}/man1
364
365 %{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}/html
366
367 %if %{without batteries}
368 # packaged separately
369 %{__rm} -r $RPM_BUILD_ROOT%{ruby_libdir}/{rubygems,rake,json,tasks}
370 %{__rm} -r $RPM_BUILD_ROOT%{ruby_archdir}/json
371 %{__rm} $RPM_BUILD_ROOT%{ruby_libdir}/{rake,rubygems,json}.rb
372 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{gem,rake}
373 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/rake*
374 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/ri/%{ruby_version}/system/JSON
375 %endif
376
377 %if %{with doc}
378 # too much .ri
379 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/cache.ri
380 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/created.rid
381 %endif
382
383 %clean
384 rm -rf $RPM_BUILD_ROOT
385
386 %post   -p /sbin/ldconfig
387 %postun -p /sbin/ldconfig
388
389 %files
390 %defattr(644,root,root,755)
391 %doc NEWS LEGAL README README.EXT ChangeLog ToDo
392 %attr(755,root,root) %{_bindir}/ruby
393 %if %{with batteries}
394 %attr(755,root,root) %{_bindir}/rake
395 %endif
396 %attr(755,root,root) %{_libdir}/libruby.so.*.*.*
397 %attr(755,root,root) %ghost %{_libdir}/libruby.so.1.9
398 %{_mandir}/man1/ruby.1*
399 %if %{with batteries}
400 %{_mandir}/man1/rake.1*
401 %endif
402
403 %dir %{_libdir}/%{name}
404 %dir %{_libdir}/%{name}/%{vendordir}
405 %dir %{_datadir}/%{name}
406 %dir %{_datadir}/%{name}/%{vendordir}
407
408 %dir %{ruby_libdir}
409 %dir %{ruby_archdir}
410 %dir %{ruby_vendorlibdir}
411 %dir %{ruby_vendorarchdir}
412
413 %dir %{_datadir}/ri
414 %dir %{_datadir}/ri/%{ruby_version}
415 %dir %{ruby_ridir}
416
417 %dir %{ruby_rdocdir}
418
419 # legacy dirs. when everything rebuilt in Th not using these dirs. drop them
420 %dir %{legacy_archdir}
421 %dir %{legacy_sitedir}
422 %dir %{legacy_sitelibdir}
423 %dir %{legacy_sitearchdir}
424 %dir %{legacy_vendorarchdir}
425
426 %files devel
427 %defattr(644,root,root,755)
428 %attr(755,root,root) %{_libdir}/libruby.so
429 %{_includedir}/%{name}-%{ruby_version}
430 %{_pkgconfigdir}/ruby-%{ruby_version}.pc
431
432 %files static
433 %defattr(644,root,root,755)
434 %{_libdir}/libruby-static.a
435
436 %if %{with tk}
437 %files tk
438 %defattr(644,root,root,755)
439 %{ruby_libdir}/tcltk.rb
440 %{ruby_libdir}/tk*.rb
441 %{ruby_libdir}/tk
442 %{ruby_libdir}/tkextlib
443 %attr(755,root,root) %{ruby_archdir}/t*.so
444 %endif
445
446 %files rdoc
447 %defattr(644,root,root,755)
448 %attr(755,root,root) %{_bindir}/rdoc
449 %attr(755,root,root) %{_bindir}/ri
450 %{_mandir}/man1/rdoc.1*
451 %{ruby_libdir}/rdoc
452 %dir %{gem_dir}/gems/rdoc-%{rdoc_ver}
453 %dir %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin
454 %attr(755,root,root) %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin/rdoc
455 %{gem_dir}/specifications/rdoc-%{rdoc_ver}.gemspec
456 %attr(755,root,root) %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin/ri
457
458 %if %{with batteries}
459 %files rubygems
460 %defattr(644,root,root,755)
461 %attr(755,root,root) %{_bindir}/gem
462 %{ruby_libdir}/rubygems
463 %{ruby_libdir}/rubygems.rb
464 %{ruby_libdir}/ubygems.rb
465
466 %{gem_dir}/specifications/io-console-*.gemspec
467 %{gem_dir}/specifications/bigdecimal-*.gemspec
468 %if %{with batteries}
469 %dir %{gem_dir}/gems/rake-%{rake_ver}
470 %dir %{gem_dir}/gems/rake-%{rake_ver}/bin
471 %attr(755,root,root) %{gem_dir}/gems/rake-%{rake_ver}/bin/rake
472 %{gem_dir}/specifications/minitest-%{minitest_ver}.gemspec
473 %{gem_dir}/specifications/rake-%{rake_ver}.gemspec
474 %{gem_dir}/specifications/json-%{json_ver}.gemspec
475 %endif
476 %endif
477
478 %files modules
479 %defattr(644,root,root,755)
480 %attr(755,root,root) %{_bindir}/erb
481 %attr(755,root,root) %{_bindir}/irb
482 %attr(755,root,root) %{_bindir}/testrb
483 %{ruby_libdir}/bigdecimal
484 %{ruby_libdir}/cgi
485 %{ruby_libdir}/date
486 %{ruby_libdir}/digest
487 %{ruby_libdir}/dl
488 %{ruby_libdir}/drb
489 %{ruby_libdir}/fiddle
490 %{ruby_libdir}/io
491 %{ruby_libdir}/irb
492 %{ruby_libdir}/matrix
493 %{ruby_libdir}/minitest
494 %{ruby_libdir}/net
495 %{ruby_libdir}/openssl
496 %{ruby_libdir}/optparse
497 %if %{with batteries}
498 %{ruby_libdir}/json
499 %{ruby_libdir}/rake
500 %dir %{ruby_libdir}/tasks
501 %endif
502 %{ruby_libdir}/psych
503 %{ruby_libdir}/racc
504 %{ruby_libdir}/rbconfig
505 %{ruby_libdir}/rexml
506 %{ruby_libdir}/rinda
507 %{ruby_libdir}/ripper
508 %{ruby_libdir}/rss
509 %{ruby_libdir}/shell
510 %{ruby_libdir}/syck
511 %{ruby_libdir}/test
512 %{ruby_libdir}/uri
513 %{ruby_libdir}/webrick
514 %{ruby_libdir}/xmlrpc
515 %{ruby_libdir}/yaml
516 %{ruby_libdir}/[A-Za-s]*.rb
517 %{ruby_libdir}/tempfile.rb
518 %{ruby_libdir}/thread.rb
519 %{ruby_libdir}/thwait.rb
520 %{ruby_libdir}/time.rb
521 %{ruby_libdir}/timeout.rb
522 %{ruby_libdir}/tmpdir.rb
523 %{ruby_libdir}/tracer.rb
524 %{ruby_libdir}/tsort.rb
525 %{ruby_libdir}/[u-z]*.rb
526 %exclude %{ruby_libdir}/rubygems.rb
527 %exclude %{ruby_libdir}/ubygems.rb
528 %attr(755,root,root) %{ruby_archdir}/[a-s]*.so
529 %attr(755,root,root) %{ruby_archdir}/[u-z]*.so
530 %dir %{ruby_archdir}/digest
531 %attr(755,root,root) %{ruby_archdir}/digest/*.so
532 %dir %{ruby_archdir}/dl
533 %attr(755,root,root) %{ruby_archdir}/dl/callback.so
534 %dir %{ruby_archdir}/enc
535 %attr(755,root,root) %{ruby_archdir}/enc/*.so
536 %dir %{ruby_archdir}/enc/trans
537 %attr(755,root,root) %{ruby_archdir}/enc/trans/*.so
538 %dir %{ruby_archdir}/io
539 %attr(755,root,root) %{ruby_archdir}/io/*.so
540 %if %{with batteries}
541 %dir %{ruby_archdir}/json
542 %dir %{ruby_archdir}/json/ext
543 %attr(755,root,root) %{ruby_archdir}/json/ext/*.so
544 %endif
545 %dir %{ruby_archdir}/mathn
546 %attr(755,root,root) %{ruby_archdir}/mathn/*.so
547 %dir %{ruby_archdir}/racc
548 %attr(755,root,root) %{ruby_archdir}/racc/*.so
549 %{ruby_archdir}/rbconfig.rb
550
551 # parents of gem_dir
552 %dir %{_datadir}/%{name}/gems
553 #%dir %{_datadir}/%{name}/gems/%{ruby_version}
554 %dir %{_datadir}/%{name}/gems/%{ruby_version}/gems
555
556 %dir %{gem_dir}
557 %dir %{gem_dir}/specifications
558 %{_mandir}/man1/erb.1*
559 %{_mandir}/man1/irb.1*
560 %{_mandir}/man1/ri.1*
561 %{_mandir}/man1/testrb.1*
562
563 %files doc
564 %defattr(644,root,root,755)
565 %doc ruby-doc-bundle/*
566 %{?with_doc:%doc ruby_%{doc_version}_stdlib}
567 %{?with_doc:%doc ruby_%{doc_version}_core}
568
569 %if %{with doc}
570 %files doc-ri
571 %defattr(644,root,root,755)
572 %{ruby_ridir}/*
573 %endif
574
575 %files examples
576 %defattr(644,root,root,755)
577 %{_examplesdir}/%{name}-%{version}
This page took 0.106353 seconds and 3 git commands to generate.