]> git.pld-linux.org Git - packages/ruby.git/blob - ruby.spec
put main package 'version-release' to subpackages 'release' to lift locking main...
[packages/ruby.git] / ruby.spec
1 # TODO:
2 #       - include ext/ in docs
3 #       - replace ri with fastri
4 #       - patch ri to search multiple indexes (one per package), so RPMs can install ri docs
5 #   - fix inconsistencies with versioned vs not-versioned dirs (see dirname hacks in configure)
6 #   - custom-rubygems-location.patch
7 #
8 # Conditional build:
9 %bcond_without  doc             # skip (time-consuming) docs generating; intended for speed up test builds
10 %bcond_without  tk              # skip building package with Tk bindings
11 %bcond_without  batteries       # Don't include rubygems, json, rake, minitest
12 %bcond_with     bootstrap       # build bootstrap version
13
14 %define         rel                     11
15 %define         ruby_version    1.9
16 %define         basever         1.9.3
17 %define         patchlevel      426
18 %define         doc_version     1_9_3
19 %define         json_ver        1.5.5
20 %define         rake_ver        0.9.2.2
21 # when increasing rubygems_ver, please remove "11." prefix in rubygems package release
22 %define         rubygems_ver    1.8.11
23 %define         minitest_ver    2.5.1
24 # when increasing rdoc_ver, please remove "11." prefix in rdoc package release
25 %define         rdoc_ver        3.9.5
26 %define         bigdecimal_ver  1.1.0
27 %define         io_console_ver  0.3
28 Summary:        Ruby - interpreted scripting language
29 Summary(ja.UTF-8):      オブジェクト指向言語Rubyインタプリタ
30 Summary(pl.UTF-8):      Ruby - interpretowany język skryptowy
31 Summary(pt_BR.UTF-8):   Linguagem de script orientada a objeto
32 Summary(zh_CN.UTF-8):   ruby - 一种快速高效的面向对象脚本编程语言
33 Name:           ruby
34 Version:        %{basever}.%{patchlevel}
35 Release:        %{rel}
36 Epoch:          1
37 # Public Domain for example for: include/ruby/st.h, strftime.c, ...
38 License:        (Ruby or BSD) and Public Domain
39 Group:          Development/Languages
40 Source0:        ftp://ftp.ruby-lang.org/pub/ruby/1.9/%{name}-%{basever}-p%{patchlevel}.tar.bz2
41 # Source0-md5:  c211205e65d7253fc2a4620a34bc9245
42 Source1:        http://www.ruby-doc.org/download/%{name}-doc-bundle.tar.gz
43 # Source1-md5:  ad1af0043be98ba1a4f6d0185df63876
44 Source2:        http://www.ruby-doc.org/downloads/%{name}_%{doc_version}_stdlib_rdocs.tgz
45 # Source2-md5:  ec622612428672c432b6f65dd31a84b5
46 Source3:        http://www.ruby-doc.org/downloads/%{name}_%{doc_version}_core_rdocs.tgz
47 # Source3-md5:  1892aadde51d36106c513bced2193dff
48 Source100:      ftp://ftp.ruby-lang.org/pub/ruby/1.8/%{name}-1.8.7-p330.tar.gz
49 # Source100-md5:        50a49edb787211598d08e756e733e42e
50 Source4:        rdoc.1
51 Source5:        testrb.1
52 Patch0:         %{name}-lib64.patch
53 Patch1:         %{name}-ffs.patch
54 Patch2:         fix-bison-invocation.patch
55 # http://redmine.ruby-lang.org/issues/5231
56 Patch3:         disable-versioned-paths.patch
57 # TODO: Should be submitted upstream?
58 Patch4:         arch-specific-dir.patch
59 # http://redmine.ruby-lang.org/issues/5281
60 Patch5:         site-and-vendor-arch-flags.patch
61 # Make mkmf verbose by default
62 Patch6:         mkmf-verbose.patch
63 URL:            http://www.ruby-lang.org/
64 BuildRequires:  autoconf >= 2.60
65 BuildRequires:  automake
66 BuildRequires:  bison
67 BuildRequires:  db-devel
68 BuildRequires:  gdbm-devel >= 1.8.3
69 BuildRequires:  libffi-devel
70 BuildRequires:  ncurses-devel
71 BuildRequires:  openssl-devel
72 BuildRequires:  pkgconfig
73 BuildRequires:  readline-devel >= 4.2
74 BuildRequires:  rpm-build >= 5.4.10-49
75 # boostrap needs ruby binary, erb module
76 %{!?with_bootstrap:BuildRequires:       ruby-modules}
77 %{!?with_bootstrap:BuildRequires:       ruby}
78 BuildRequires:  sed >= 4.0
79 BuildRequires:  yaml-devel
80 %if %{with tk}
81 BuildRequires:  tk-devel
82 %endif
83 Requires(post,postun):  /sbin/ldconfig
84 Provides:       ruby(ver) = %{ruby_version}
85 Obsoletes:      ruby-REXML <= 2.4.0-2
86 Obsoletes:      ruby-doc < 1.8.4
87 Obsoletes:      ruby-fastthread <= 0.6.3
88 Conflicts:      ruby-activesupport < 2.3.11-2
89 Conflicts:      ruby-activesupport2 < 2.3.11-2
90 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
91
92 %define ruby_ridir              %{_datadir}/ri/%{ruby_version}/system
93 %define gem_dir                 %{_datadir}/%{name}/gems/%{ruby_version}
94
95 # The RubyGems library has to stay out of Ruby directory three, since the
96 # RubyGems should be share by all Ruby implementations.
97 %define rubygems_dir            %{_datadir}/rubygems
98
99 %define ruby_archdir            %{_libdir}/%{name}/%{ruby_version}
100 %define ruby_libdir             %{_datadir}/%{name}/%{ruby_version}
101
102 # This is the local lib/arch and should not be used for packaging.
103 %define sitedir                 site_ruby
104 %define ruby_sitedir            %{_prefix}/local/share/%{name}/%{sitedir}
105 %define ruby_sitearchdir        %{_prefix}/local/%{_lib}/%{name}/%{sitedir}/%{ruby_version}
106 %define ruby_sitelibdir         %{_prefix}/local/share/%{name}/%{sitedir}/%{ruby_version}
107
108 # This is the general location for libs/archs compatible with all
109 # or most of the Ruby versions available in the PLD repositories.
110 %define vendordir               vendor_ruby
111 %define ruby_vendordir          %{_datadir}/%{name}/%{vendordir}
112 %define ruby_vendorarchdir      %{_libdir}/%{name}/%{vendordir}/%{ruby_version}
113 %define ruby_vendorlibdir       %{_datadir}/%{name}/%{vendordir}/%{ruby_version}
114
115 # TODO: drop legacy loadpaths after all ruby modules rebuilt in Th
116 %define legacy_libdir           %{_libdir}/%{name}/%{ruby_version}
117 %define legacy_archdir          %{_libdir}/%{name}/%{ruby_version}/%{_target_cpu}-linux
118 %define legacy_sitedir          %{_libdir}/%{name}/%{sitedir}
119 %define legacy_sitelibdir       %{_libdir}/%{name}/%{sitedir}/%{ruby_version}
120 %define legacy_sitearchdir      %{_libdir}/%{name}/%{sitedir}/%{ruby_version}/%{_target_cpu}-linux
121 %define legacy_vendordir        %{_libdir}/%{name}/%{vendordir}
122 %define legacy_vendorlibdir     %{_libdir}/%{name}/%{vendordir}/%{ruby_version}
123 %define legacy_vendorarchdir    %{_libdir}/%{name}/%{vendordir}/%{ruby_version}/%{_target_cpu}-linux
124
125 %define legacy_siteloadpath     %{legacy_sitelibdir}\\0%{legacy_sitearchdir}\\0%{legacy_sitedir}
126 %define legacy_vendorloadpath   %{legacy_vendorarchdir}
127 %define legacy_loadpath         %{legacy_archdir}
128 %define legacy_loadpaths        %{legacy_siteloadpath}\\0%{legacy_vendorloadpath}\\0%{legacy_loadpath}
129
130 # bleh, some nasty (gcc or ruby) bug still not fixed
131 # (SEGV or "unexpected break" on miniruby run during build)
132 %define         specflags_ia64  -O0
133
134 # ruby needs frame pointers for correct exception handling
135 %define         specflags_ia32  -fno-omit-frame-pointer
136
137 %description
138 Ruby is the interpreted scripting language for quick and easy
139 object-oriented programming. It has many features to process text
140 files and to do system management tasks (as in Perl). It is simple,
141 straight-forward, extensible, and portable.
142
143 This package contains only shared library and ruby interpreter. To get
144 full-functional ruby environment install ruby-modules package.
145
146 %description -l ja.UTF-8
147 Rubyはシンプルかつ強力なオブジェクト指向スクリプト言語です.Rubyは最初
148 から純粋なオブジェクト指向言語として設計されていますから,オブジェクト
149 指向プログラミングを手軽に行う事が出来ます.もちろん通常の手続き型のプ ログラミングも可能です.
150
151 %description -l pl.UTF-8
152 Ruby to interpretowany język skryptowy, w sam raz dla łatwego i
153 szybkiego pisania zorientowanych obiektowo programów. Ma wiele funkcji
154 ułatwiających przetwarzanie plików tekstowych i wykonywanie prac
155 związanych z zarządzaniem systemu (podobnie jak Perl). Jest prosty,
156 rozszerzalny i przenośny.
157
158 Ten pakiet zawiera tylko bibliotekę dzieloną i interpreter ruby.
159 Zainstaluj pakiet ruby-modules, jeżeli potrzebujesz w pełni
160 funkcjonalnego środowiska ruby.
161
162 %description -l pt_BR.UTF-8
163 Ruby é uma linguagem de script interpretada de programação orientada a
164 objeto. Possui diversas características para processamento de texto. É
165 simples, extensível e direta.
166
167 %package modules
168 Summary:        Ruby standard modules and utilities
169 Summary(pl.UTF-8):      Standardowe moduły i narzędzia dla języka Ruby
170 Group:          Development/Languages
171 Requires:       %{name} = %{epoch}:%{version}-%{release}
172 Suggests:       ruby-rubygems
173 Provides:       ruby-bigdecimal = %{bigdecimal_ver}
174 Provides:       ruby-io-console = %{io_console_ver}
175 # ruby-modules deprecated, rpm5 generates ruby(abi) itself
176 Provides:       ruby-modules(ver) = %{ruby_version}
177 %if %{with batteries}
178 Provides:       rake = %{rake_ver}
179 Provides:       ruby-json = %{json_ver}
180 Provides:       ruby-minitest = %{minitest_ver}
181 Provides:       ruby-rake = %{rake_ver}
182 Obsoletes:      ruby-json <= 1.5.4
183 Obsoletes:      ruby-minitest <= 1.5.0
184 Obsoletes:      ruby-rake < 0.9.2.2
185 %endif
186
187 %description modules
188 Ruby standard modules and utilities:
189 - erb - Tiny eRuby
190 - irb - interactive Ruby
191 - testrb - automatic runner for Test::Unit of Ruby
192
193 %description modules -l pl.UTF-8
194 Standardowe moduły i narzędzia Ruby:
195 - erb - mały eRuby
196 - irb - interaktywny Ruby
197 - testrb - automatyczny runner dla Ruby Test::Unit
198
199 %package tk
200 Summary:        Ruby/Tk bindings
201 Summary(pl.UTF-8):      Wiązania Ruby/Tk
202 Group:          Development/Languages
203 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
204
205 %description tk
206 This pachage contains Ruby/Tk bindings.
207
208 %description tk -l pl.UTF-8
209 Ten pakiet zawiera wiązania Ruby/Tk.
210
211 %package devel
212 Summary:        Ruby development libraries
213 Summary(pl.UTF-8):      Biblioteki programistyczne interpretera języka Ruby
214 Group:          Development/Languages
215 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
216 Requires:       gcc
217 Requires:       glibc-devel
218 Requires:       pkgconfig
219
220 %description devel
221 Ruby development libraries.
222
223 %description devel -l pl.UTF-8
224 Biblioteki programistyczne interpretera języka Ruby.
225
226 %package static
227 Summary:        Ruby static libraries
228 Summary(pl.UTF-8):      Biblioteki statyczne Ruby
229 Group:          Development/Languages
230 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
231
232 %description static
233 Ruby static libraries.
234
235 %description static -l pl.UTF-8
236 Biblioteki statyczne Ruby.
237
238 %package doc
239 Summary:        Ruby HTML documentation
240 Summary(pl.UTF-8):      Dokumentacja HTML do Ruby
241 Group:          Documentation
242 %if "%{_rpmversion}" >= "5"
243 BuildArch:      noarch
244 %endif
245
246 %description doc
247 Ruby HTML documentation: FAQ, guide, core and standard library.
248
249 %description doc -l pl.UTF-8
250 Dokumentacja HTML do Ruby: FAQ, przewodnik, dokumentacja dla core i
251 stdlib.
252
253 %package doc-ri
254 Summary:        Ruby ri documentation
255 Summary(pl.UTF-8):      Dokumentacja Ruby w formacie ri
256 Group:          Documentation
257 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
258 %if "%{_rpmversion}" >= "5"
259 BuildArch:      noarch
260 %endif
261
262 %description doc-ri
263 Ruby ri documentation.
264
265 %description doc-ri -l pl.UTF-8
266 Dokumentacja Ruby w formacie ri.
267
268 %package examples
269 Summary:        Ruby examples
270 Summary(pl.UTF-8):      Przykłady dla języka Ruby
271 Group:          Development/Languages
272 %if "%{_rpmversion}" >= "5"
273 BuildArch:      noarch
274 %endif
275
276 %description examples
277 Ruby examples.
278
279 %description examples -l pl.UTF-8
280 Przykłady programów w języku Ruby.
281
282 # IMPORTANT: keep rdoc and rubygems as last packages as we reset epoch/version/release
283 # and %{version},%{release} macros may not be used directly as they take last
284 # subpackage value not main package one what you intend to use
285 %package rdoc
286 Summary:        A tool to generate HTML and command-line documentation for Ruby projects
287 Summary(pl.UTF-8):      Narzędzie do generowania dokumentacji HTML i linii poleceń dla projektów w Rubym
288 Version:        %{rdoc_ver}
289 # remove "11." when rdoc_ver is increased
290 Release:        11.%{basever}.%{patchlevel}.%{rel}
291 Epoch:          0
292 License:        GPL v2 and Ruby and MIT
293 Group:          Development/Libraries
294 Requires:       %{name}-modules = 1:%{basever}.%{patchlevel}-%{rel}
295 Obsoletes:      rdoc <= 0.9.0
296 %if "%{_rpmversion}" >= "5"
297 BuildArch:      noarch
298 %endif
299
300 %description rdoc
301 RDoc produces HTML and command-line documentation for Ruby projects.
302 RDoc includes the 'rdoc' and 'ri' tools for generating and displaying
303 online documentation.
304
305 %description rdoc -l pl.UTF-8
306 RDoc tworzy dokumentację HTML i linii poleceń dla projektów w języku
307 Ruby. RDoc zawiera narzędzia 'rdoc' i 'ri' do generowania i
308 wyświetlania dokumentacji online.
309
310 %package rubygems
311 Summary:        RubyGems - the Ruby standard for packaging Ruby libraries
312 Summary(pl.UTF-8):      RubyGems - standard Ruby'ego pakietowania bibliotek
313 Version:        %{rubygems_ver}
314 # remove "11." when rubygems_ver is increased
315 Release:        11.%{basever}.%{patchlevel}.%{rel}
316 Epoch:          0
317 License:        Ruby or MIT
318 Group:          Development/Libraries
319 Requires:       %{name}-modules = 1:%{basever}.%{patchlevel}-%{rel}
320 Requires:       %{name}-rdoc >= %{rdoc_ver}
321 Suggests:       %{name}-devel
322 Provides:       rubygems = %{rubygems_ver}
323 %if "%{_rpmversion}" >= "5"
324 BuildArch:      noarch
325 %endif
326
327 %description rubygems
328 RubyGems is the Ruby standard for publishing and managing third party
329 libraries.
330
331 %description rubygems -l pl.UTF-8
332 RubyGems to standardowe narzędzie języka Ruby do publikowania i
333 zarządzania zewnętrznymi bibliotekami.
334
335 %prep
336 %if %{with bootstrap}
337 %setup -q -n %{name}-%{basever}-p%{patchlevel} -a1 -a2 -a3 -a100
338 %else
339 %setup -q -n %{name}-%{basever}-p%{patchlevel} -a1 -a2 -a3
340 %endif
341 %patch0 -p1
342 %patch1 -p1
343 %patch2 -p1
344 %patch3 -p1
345 %patch4 -p1
346 %patch5 -p1
347
348 # must be regenerated with new bison
349 %{__rm} parse.{c,h}
350
351 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
352
353 find -type f '(' -name '*.rb' -o -name '*.cgi' -o -name '*.test' \
354         -o -name 'ruby.1' -o -name '*.html' -o -name '*.tcl' ')' \
355         | xargs %{__sed} -i 's,/usr/local/bin/,%{_bindir}/,'
356
357 %build
358 cp -f /usr/share/automake/config.sub .
359
360 # build ruby-1.8.7 first
361 %if %{with bootstrap}
362 cd %{name}-1.8.7-p330
363 %configure
364 %{__make}
365 cd ..
366 %endif
367
368 %{__autoconf}
369 %configure \
370         %{?with_bootstrap:--with-baseruby=%{name}-1.8.7-p330/miniruby} \
371         --with-rubylibprefix=%(dirname %{ruby_libdir}) \
372         --with-archdir=%{ruby_archdir} \
373         --with-sitedir=%(dirname %{ruby_sitelibdir}) \
374         --with-sitearchdir=%{ruby_sitearchdir} \
375         --with-vendordir=%(dirname %{ruby_vendorlibdir}) \
376         --with-vendorarchdir=%{ruby_vendorarchdir} \
377         --with-rubygemsdir=%{rubygems_dir} \
378         --with-search-path="%{legacy_loadpaths}" \
379         --enable-shared \
380         --enable-pthread \
381         --disable-rubygems \
382         --disable-install-doc \
383         --with-ruby-version=minor
384
385 %{__make} -j1 main \
386         COPY="cp -p" Q= \
387         %{?with_bootstrap:BASERUBY="ruby-1.8.7-p330/miniruby -I./ruby-1.8.7-p330/lib"}
388
389 %if %{with doc}
390 %{__make} -j1 rdoc
391 %endif
392
393 %install
394 rm -rf $RPM_BUILD_ROOT
395 install -d $RPM_BUILD_ROOT{%{ruby_rdocdir},%{_examplesdir}/%{name}-%{version}} \
396         $RPM_BUILD_ROOT{%{ruby_vendorarchdir},%{ruby_ridir}} \
397         $RPM_BUILD_ROOT%{ruby_vendorlibdir}/net \
398         $RPM_BUILD_ROOT{%{legacy_archdir}/racc,%{legacy_sitelibdir},%{legacy_sitearchdir},%{legacy_vendorarchdir},%{legacy_libdir}/tasks} \
399
400 %{__make} install %{?with_doc:install-doc} \
401         DESTDIR=$RPM_BUILD_ROOT
402
403 cp -Rf sample/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
404 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_mandir}/man1
405 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_mandir}/man1
406
407 %{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}/html
408
409 %if %{without batteries}
410 # packaged separately
411 %{__rm} -r $RPM_BUILD_ROOT%{ruby_libdir}/{rubygems,rake,json,minitest}
412 %{__rm} -r $RPM_BUILD_ROOT%{ruby_archdir}/json
413 %{__rm} -r $RPM_BUILD_ROOT%{gem_dir}/gems/rake-*
414 %{__rm} $RPM_BUILD_ROOT%{ruby_libdir}/{rake,rubygems,json}.rb
415 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{gem,rake}
416 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/rake*
417 %{__rm} $RPM_BUILD_ROOT%{gem_dir}/specifications/{json,minitest,rake}-*.gemspec
418 %{?with_doc:%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/ri/%{ruby_version}/system/JSON}
419 %endif
420
421 %if %{with doc}
422 # too much .ri
423 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/cache.ri
424 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/created.rid
425 %endif
426
427 %clean
428 rm -rf $RPM_BUILD_ROOT
429
430 %post   -p /sbin/ldconfig
431 %postun -p /sbin/ldconfig
432
433 %files
434 %defattr(644,root,root,755)
435 %doc NEWS LEGAL README README.EXT ChangeLog ToDo
436 %attr(755,root,root) %{_bindir}/ruby
437 %attr(755,root,root) %{_libdir}/libruby.so.*.*.*
438 %attr(755,root,root) %ghost %{_libdir}/libruby.so.1.9
439 %{_mandir}/man1/ruby.1*
440
441 %if %{with batteries}
442 # rake
443 %attr(755,root,root) %{_bindir}/rake
444 %{_mandir}/man1/rake.1*
445 %endif
446
447 %dir %{_libdir}/%{name}
448 %dir %{_libdir}/%{name}/%{vendordir}
449 %dir %{_datadir}/%{name}
450 %dir %{_datadir}/%{name}/%{vendordir}
451
452 %dir %{ruby_libdir}
453 %dir %{ruby_archdir}
454 %dir %{ruby_vendorlibdir}
455 %dir %{ruby_vendorarchdir}
456
457 %dir %{_datadir}/ri
458 %dir %{_datadir}/ri/%{ruby_version}
459 %dir %{ruby_ridir}
460
461 %dir %{ruby_rdocdir}
462
463 # common dirs for ruby vendor modules
464 %dir %{ruby_vendorlibdir}/net
465
466 # legacy dirs. when everything rebuilt in Th not using these dirs. drop them
467 %dir %{legacy_archdir}
468 %dir %{legacy_sitedir}
469 %dir %{legacy_sitelibdir}
470 %dir %{legacy_sitearchdir}
471 %dir %{legacy_vendorarchdir}
472 %dir %{legacy_libdir}/tasks
473 %dir %{legacy_archdir}/racc
474
475 %files devel
476 %defattr(644,root,root,755)
477 %attr(755,root,root) %{_libdir}/libruby.so
478 %{_includedir}/%{name}-%{ruby_version}
479 %{_pkgconfigdir}/ruby-%{ruby_version}.pc
480 %{ruby_libdir}/mkmf.rb
481
482 %files static
483 %defattr(644,root,root,755)
484 %{_libdir}/libruby-static.a
485
486 %if %{with tk}
487 %files tk
488 %defattr(644,root,root,755)
489 %{ruby_libdir}/tcltk.rb
490 %{ruby_libdir}/tk*.rb
491 %{ruby_libdir}/tk
492 %{ruby_libdir}/tkextlib
493 %attr(755,root,root) %{ruby_archdir}/t*.so
494 %endif
495
496 %files rdoc
497 %defattr(644,root,root,755)
498 %attr(755,root,root) %{_bindir}/rdoc
499 %attr(755,root,root) %{_bindir}/ri
500 %{_mandir}/man1/rdoc.1*
501 %{ruby_libdir}/rdoc
502 %dir %{gem_dir}/gems/rdoc-%{rdoc_ver}
503 %dir %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin
504 %attr(755,root,root) %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin/rdoc
505 %{gem_dir}/specifications/rdoc-%{rdoc_ver}.gemspec
506 %attr(755,root,root) %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin/ri
507
508 %if %{with batteries}
509 %files rubygems
510 %defattr(644,root,root,755)
511 %attr(755,root,root) %{_bindir}/gem
512 %{ruby_libdir}/rubygems
513 %{ruby_libdir}/rubygems.rb
514 %{ruby_libdir}/ubygems.rb
515 %endif
516
517 %files modules
518 %defattr(644,root,root,755)
519 %attr(755,root,root) %{_bindir}/erb
520 %attr(755,root,root) %{_bindir}/irb
521 %attr(755,root,root) %{_bindir}/testrb
522 %{ruby_libdir}/bigdecimal
523 %{ruby_libdir}/cgi
524 %{ruby_libdir}/date
525 %{ruby_libdir}/digest
526 %{ruby_libdir}/dl
527 %{ruby_libdir}/drb
528 %{ruby_libdir}/fiddle
529 %{ruby_libdir}/io
530 %{ruby_libdir}/irb
531 %{ruby_libdir}/matrix
532 %{ruby_libdir}/net
533 %{ruby_libdir}/openssl
534 %{ruby_libdir}/optparse
535 %{ruby_libdir}/psych
536 %{ruby_libdir}/racc
537 %{ruby_libdir}/rbconfig
538 %{ruby_libdir}/rexml
539 %{ruby_libdir}/rinda
540 %{ruby_libdir}/ripper
541 %{ruby_libdir}/rss
542 %{ruby_libdir}/shell
543 %{ruby_libdir}/syck
544 %{ruby_libdir}/test
545 %{ruby_libdir}/uri
546 %{ruby_libdir}/webrick
547 %{ruby_libdir}/xmlrpc
548 %{ruby_libdir}/yaml
549 %{ruby_libdir}/[A-Za-s]*.rb
550 %{ruby_libdir}/tempfile.rb
551 %{ruby_libdir}/thread.rb
552 %{ruby_libdir}/thwait.rb
553 %{ruby_libdir}/time.rb
554 %{ruby_libdir}/timeout.rb
555 %{ruby_libdir}/tmpdir.rb
556 %{ruby_libdir}/tracer.rb
557 %{ruby_libdir}/tsort.rb
558 %{ruby_libdir}/[u-z]*.rb
559 %if %{with batteries}
560 %exclude %{ruby_libdir}/rubygems.rb
561 %exclude %{ruby_libdir}/ubygems.rb
562 %endif
563 %exclude %{ruby_libdir}/mkmf.rb
564 %attr(755,root,root) %{ruby_archdir}/[a-s]*.so
565 %attr(755,root,root) %{ruby_archdir}/[u-z]*.so
566 %dir %{ruby_archdir}/digest
567 %attr(755,root,root) %{ruby_archdir}/digest/*.so
568 %dir %{ruby_archdir}/dl
569 %attr(755,root,root) %{ruby_archdir}/dl/callback.so
570 %dir %{ruby_archdir}/enc
571 %attr(755,root,root) %{ruby_archdir}/enc/*.so
572 %dir %{ruby_archdir}/enc/trans
573 %attr(755,root,root) %{ruby_archdir}/enc/trans/*.so
574 %dir %{ruby_archdir}/io
575 %attr(755,root,root) %{ruby_archdir}/io/*.so
576 %dir %{ruby_archdir}/mathn
577 %attr(755,root,root) %{ruby_archdir}/mathn/*.so
578 %dir %{ruby_archdir}/racc
579 %attr(755,root,root) %{ruby_archdir}/racc/*.so
580 %{ruby_archdir}/rbconfig.rb
581
582 %{gem_dir}/specifications/bigdecimal-%{bigdecimal_ver}.gemspec
583 %{gem_dir}/specifications/io-console-%{io_console_ver}.gemspec
584
585 %if %{with batteries}
586 # json
587 %{ruby_libdir}/json
588 %dir %{ruby_archdir}/json
589 %dir %{ruby_archdir}/json/ext
590 %attr(755,root,root) %{ruby_archdir}/json/ext/*.so
591 %{gem_dir}/specifications/json-%{json_ver}.gemspec
592
593 # minitest
594 %{ruby_libdir}/minitest
595 %{gem_dir}/specifications/minitest-%{minitest_ver}.gemspec
596
597 # rake
598 %{ruby_libdir}/rake
599 %dir %{gem_dir}/gems/rake-%{rake_ver}
600 %dir %{gem_dir}/gems/rake-%{rake_ver}/bin
601 %attr(755,root,root) %{gem_dir}/gems/rake-%{rake_ver}/bin/rake
602 %{gem_dir}/specifications/rake-%{rake_ver}.gemspec
603 %endif
604
605 # parents of gem_dir
606 %dir %{_datadir}/%{name}/gems
607 #%dir %{_datadir}/%{name}/gems/%{ruby_version}
608 %dir %{_datadir}/%{name}/gems/%{ruby_version}/gems
609
610 %dir %{gem_dir}
611 %dir %{gem_dir}/specifications
612 %{_mandir}/man1/erb.1*
613 %{_mandir}/man1/irb.1*
614 %{_mandir}/man1/ri.1*
615 %{_mandir}/man1/testrb.1*
616
617 %files doc
618 %defattr(644,root,root,755)
619 %doc ruby-doc-bundle/*
620 %{?with_doc:%doc ruby_%{doc_version}_stdlib}
621 %{?with_doc:%doc ruby_%{doc_version}_core}
622
623 %if %{with doc}
624 %files doc-ri
625 %defattr(644,root,root,755)
626 %{ruby_ridir}/*
627 %endif
628
629 %files examples
630 %defattr(644,root,root,755)
631 %{_examplesdir}/%{name}-%{version}
This page took 1.007976 seconds and 3 git commands to generate.